ATLASSIAN

Documentation for Confluence 8.6
Contents

Confluence Data Center documentation ........................................... 6
Get started .................................................................................. 7
Tutorial: Navigate Confluence ...................................................... 8
  The dashboard ........................................................................... 9
  The space directory .................................................................... 11
  The space sidebar ...................................................................... 12
  Keyboard shortcuts ..................................................................... 15
  Complete your mission ............................................................... 19
Tutorial: Space ace ........................................................................ 20
  Create a project space ............................................................... 21
  Create your personal space ...................................................... 23
  Create the team's PR space ...................................................... 24
  Delete and archive spaces ....................................................... 26
Spaces ........................................................................................ 27
  Create a Space .......................................................................... 30
  Create a Space From a Template ............................................. 33
  Space Keys ............................................................................... 35
Navigate Spaces ........................................................................ 36
Space Permissions Overview .......................................................... 38
  Assign Space Permissions ....................................................... 41
  Make a Space Public .................................................................. 44
  Give Access to Unlicensed Users from Jira Service Management ... 46
Organize your Space .................................................................... 47
  Set up a Space Home Page .................................................... 52
  Use Labels to Categorize Spaces .............................................. 56
Customize your Space .................................................................. 58
  Configure the Sidebar ............................................................. 60
  Edit a Space's Color Scheme ................................................... 62
  Apply a Theme to a Space ....................................................... 64
    Documentation theme migration FAQ .................................... 65
  Customize Space Layouts .......................................................... 71
  Change the Space Logo ........................................................... 73
Copy a Space ................................................................................ 74
Archive a Space .......................................................................... 84
Delete a Space ............................................................................ 86
Export Content to Word, PDF, HTML and XML ......................... 87
  Customize Exports to PDF ...................................................... 90
    Advanced PDF Export Customizations .................................. 97
  Create a PDF in Another Language ......................................... 101
Pages and blogs ........................................................................... 102
  Create and Edit Pages ............................................................. 103
Blog Posts .................................................................................... 106
The Editor ................................................................................... 108
  Symbols, emojis and special characters ................................... 113
  Collaborative editing .............................................................. 118
Move and Reorder Pages .............................................................. 121
Copy a Page ................................................................................ 123
Delete or Restore a Page ............................................................ 126
Add, Remove and Search for Labels ........................................... 128
  Display Pages with Label Macros ............................................. 131
Drafts ......................................................................................... 132
  Concurrent Editing and Merging Changes ............................... 134
Page Restrictions ......................................................................... 135
Links ........................................................................................ 137
Anchors ...................................................................................... 140
Tables ......................................................................................... 146
Add, Assign, and View Tasks ....................................................... 149
  Autocomplete for links, files, macros, mentions and emojis ..... 155
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Layouts, Columns and Sections</td>
<td>160</td>
</tr>
<tr>
<td>Create Beautiful and Dynamic Pages</td>
<td>163</td>
</tr>
<tr>
<td>Page Templates</td>
<td>167</td>
</tr>
<tr>
<td>Create a Template</td>
<td>169</td>
</tr>
<tr>
<td>Create a Page from a Template</td>
<td>173</td>
</tr>
<tr>
<td>Blueprints</td>
<td>175</td>
</tr>
<tr>
<td>Decisions Blueprint</td>
<td>178</td>
</tr>
<tr>
<td>File List Blueprint</td>
<td>180</td>
</tr>
<tr>
<td>Meeting Notes Blueprint</td>
<td>183</td>
</tr>
<tr>
<td>Product Requirements Blueprint</td>
<td>185</td>
</tr>
<tr>
<td>Shared Links Blueprint</td>
<td>187</td>
</tr>
<tr>
<td>Jira Report Blueprint</td>
<td>189</td>
</tr>
<tr>
<td>Retrospective Blueprint</td>
<td>192</td>
</tr>
<tr>
<td>How-To Article Blueprint</td>
<td>194</td>
</tr>
<tr>
<td>Troubleshooting Article Blueprint</td>
<td>196</td>
</tr>
<tr>
<td>Create a Blueprint-Style Report</td>
<td>198</td>
</tr>
<tr>
<td>Import Content Into Confluence</td>
<td>205</td>
</tr>
<tr>
<td>Import a Word Document into Confluence</td>
<td>206</td>
</tr>
<tr>
<td>Undefined Page Links</td>
<td>208</td>
</tr>
<tr>
<td>View Page Information</td>
<td>209</td>
</tr>
<tr>
<td>Page History and Page Comparison Views</td>
<td>210</td>
</tr>
<tr>
<td>Confluence Markup</td>
<td>213</td>
</tr>
<tr>
<td>Confluence Storage Format</td>
<td>214</td>
</tr>
<tr>
<td>Confluence Wiki Markup</td>
<td>226</td>
</tr>
<tr>
<td>Files</td>
<td>235</td>
</tr>
<tr>
<td>Upload Files</td>
<td>236</td>
</tr>
<tr>
<td>Display Files and Images</td>
<td>238</td>
</tr>
<tr>
<td>Manage Files</td>
<td>243</td>
</tr>
<tr>
<td>Share and Comment on Files</td>
<td>246</td>
</tr>
<tr>
<td>Edit Files</td>
<td>248</td>
</tr>
<tr>
<td>Edit in Office using the Office Connector</td>
<td>252</td>
</tr>
<tr>
<td>Install Atlassian Companion</td>
<td>256</td>
</tr>
<tr>
<td>Confluence Mobile</td>
<td>259</td>
</tr>
<tr>
<td>Using the Confluence Data Center and Server mobile app</td>
<td>263</td>
</tr>
<tr>
<td>Using Confluence via your mobile browser</td>
<td>267</td>
</tr>
<tr>
<td>Mobile Device Management (MDM)</td>
<td>270</td>
</tr>
<tr>
<td>Macros</td>
<td>274</td>
</tr>
<tr>
<td>Advanced Roadmaps Macro</td>
<td>278</td>
</tr>
<tr>
<td>Anchor Macro</td>
<td>280</td>
</tr>
<tr>
<td>Attachments Macro</td>
<td>283</td>
</tr>
<tr>
<td>Blog Posts Macro</td>
<td>287</td>
</tr>
<tr>
<td>Change History Macro</td>
<td>291</td>
</tr>
<tr>
<td>ChartMacro</td>
<td>294</td>
</tr>
<tr>
<td>Wiki Markup Examples for Chart Macro</td>
<td>314</td>
</tr>
<tr>
<td>Cheese Macro</td>
<td>317</td>
</tr>
<tr>
<td>Children Display Macro</td>
<td>318</td>
</tr>
<tr>
<td>Code Block Macro</td>
<td>322</td>
</tr>
<tr>
<td>Column Macro</td>
<td>327</td>
</tr>
<tr>
<td>Content by Label Macro</td>
<td>330</td>
</tr>
<tr>
<td>Content by User Macro</td>
<td>334</td>
</tr>
<tr>
<td>Content Report Table Macro</td>
<td>336</td>
</tr>
<tr>
<td>Contributors Macro</td>
<td>339</td>
</tr>
<tr>
<td>Contributors Summary Macro</td>
<td>343</td>
</tr>
<tr>
<td>Create from Template Macro</td>
<td>348</td>
</tr>
<tr>
<td>Create Space Button Macro</td>
<td>351</td>
</tr>
<tr>
<td>Excerpt Include Macro</td>
<td>353</td>
</tr>
<tr>
<td>Excerpt Macro</td>
<td>355</td>
</tr>
<tr>
<td>Expand Macro</td>
<td>358</td>
</tr>
<tr>
<td>Favorite Pages Macro</td>
<td>361</td>
</tr>
<tr>
<td>Gallery Macro</td>
<td>363</td>
</tr>
<tr>
<td>Global Reports Macro</td>
<td>367</td>
</tr>
<tr>
<td>HTML Include Macro</td>
<td>369</td>
</tr>
<tr>
<td>HTML Macro</td>
<td>371</td>
</tr>
<tr>
<td>IM Presence Macro</td>
<td>373</td>
</tr>
<tr>
<td>Macro Name</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Collaboration</td>
<td>526</td>
</tr>
<tr>
<td>Like and Popular Content</td>
<td>527</td>
</tr>
<tr>
<td>Mentions</td>
<td>529</td>
</tr>
<tr>
<td>Share a Page or Blog Post</td>
<td>530</td>
</tr>
<tr>
<td>Comment on pages and blog posts</td>
<td>531</td>
</tr>
<tr>
<td>Watch Pages, Spaces and Blogs</td>
<td>532</td>
</tr>
<tr>
<td>Manage Watchers</td>
<td>533</td>
</tr>
<tr>
<td>Email Notifications</td>
<td>534</td>
</tr>
<tr>
<td>Subscribe to RSS Feeds within Confluence</td>
<td>544</td>
</tr>
<tr>
<td>The RSS Feed Builder</td>
<td>545</td>
</tr>
<tr>
<td>Subscribe to pre-specified RSS feeds</td>
<td>546</td>
</tr>
<tr>
<td>Subscribe to a Network RSS Feed</td>
<td>548</td>
</tr>
<tr>
<td>Your profile and settings</td>
<td>513</td>
</tr>
<tr>
<td>Your User Profile</td>
<td>514</td>
</tr>
<tr>
<td>Change Your Password</td>
<td>517</td>
</tr>
<tr>
<td>Edit Your User Settings</td>
<td>518</td>
</tr>
<tr>
<td>Set Your Profile Picture</td>
<td>519</td>
</tr>
<tr>
<td>Choose Your Home Page</td>
<td>520</td>
</tr>
<tr>
<td>Save for later</td>
<td>521</td>
</tr>
<tr>
<td>View and Revoke OAuth Access Tokens</td>
<td>522</td>
</tr>
<tr>
<td>Network Overview</td>
<td>523</td>
</tr>
<tr>
<td>Office Macro</td>
<td>436</td>
</tr>
<tr>
<td>Popular Labels Macro</td>
<td>442</td>
</tr>
<tr>
<td>Profile Picture Macro</td>
<td>445</td>
</tr>
<tr>
<td>Recently Updated Dashboard Macro</td>
<td>448</td>
</tr>
<tr>
<td>Recently Updated Macro</td>
<td>451</td>
</tr>
<tr>
<td>Recently Used Labels Macro</td>
<td>456</td>
</tr>
<tr>
<td>Related Labels Macro</td>
<td>459</td>
</tr>
<tr>
<td>Roadmap Planner Macro</td>
<td>462</td>
</tr>
<tr>
<td>RSS Feed Macro</td>
<td>464</td>
</tr>
<tr>
<td>Search Results Macro</td>
<td>467</td>
</tr>
<tr>
<td>Section Macro</td>
<td>469</td>
</tr>
<tr>
<td>Space Attachments Macro</td>
<td>472</td>
</tr>
<tr>
<td>Space Details Macro</td>
<td>475</td>
</tr>
<tr>
<td>Spaces List Macro</td>
<td>476</td>
</tr>
<tr>
<td>Status Macro</td>
<td>479</td>
</tr>
<tr>
<td>Table of Contents Macro</td>
<td>482</td>
</tr>
<tr>
<td>Table of Content Zone Macro</td>
<td>488</td>
</tr>
<tr>
<td>Task Report Macro</td>
<td>493</td>
</tr>
<tr>
<td>Team Calendar Macro</td>
<td>496</td>
</tr>
<tr>
<td>User List Macro</td>
<td>499</td>
</tr>
<tr>
<td>User Profile Macro</td>
<td>502</td>
</tr>
<tr>
<td>View File Macro</td>
<td>505</td>
</tr>
<tr>
<td>Widget Connector Macro</td>
<td>506</td>
</tr>
<tr>
<td>Web Page</td>
<td>402</td>
</tr>
<tr>
<td>Network Macro</td>
<td>405</td>
</tr>
<tr>
<td>Noformat Macro</td>
<td>407</td>
</tr>
<tr>
<td>Office Excel Macro</td>
<td>409</td>
</tr>
<tr>
<td>Office PowerPoint Macro</td>
<td>413</td>
</tr>
<tr>
<td>Office Word Macro</td>
<td>416</td>
</tr>
<tr>
<td>Page Index Macro</td>
<td>419</td>
</tr>
<tr>
<td>Page Properties Macro</td>
<td>421</td>
</tr>
<tr>
<td>Page Properties Report Macro</td>
<td>426</td>
</tr>
<tr>
<td>Page Tree Macro</td>
<td>430</td>
</tr>
<tr>
<td>Page Tree Search Macro</td>
<td>434</td>
</tr>
<tr>
<td>Panel Macro</td>
<td>436</td>
</tr>
<tr>
<td>PDF Macro</td>
<td>439</td>
</tr>
<tr>
<td>Popular Labels Macro</td>
<td>442</td>
</tr>
<tr>
<td>Profile Picture Macro</td>
<td>445</td>
</tr>
<tr>
<td>Recently Updated Dashboard Macro</td>
<td>448</td>
</tr>
<tr>
<td>Recently Updated Macro</td>
<td>451</td>
</tr>
<tr>
<td>Recently Used Labels Macro</td>
<td>456</td>
</tr>
<tr>
<td>Related Labels Macro</td>
<td>459</td>
</tr>
<tr>
<td>Roadmap Planner Macro</td>
<td>462</td>
</tr>
<tr>
<td>RSS Feed Macro</td>
<td>464</td>
</tr>
<tr>
<td>Search Results Macro</td>
<td>467</td>
</tr>
<tr>
<td>Section Macro</td>
<td>469</td>
</tr>
<tr>
<td>Space Attachments Macro</td>
<td>472</td>
</tr>
<tr>
<td>Space Details Macro</td>
<td>475</td>
</tr>
<tr>
<td>Spaces List Macro</td>
<td>476</td>
</tr>
<tr>
<td>Status Macro</td>
<td>479</td>
</tr>
<tr>
<td>Table of Contents Macro</td>
<td>482</td>
</tr>
<tr>
<td>Table of Content Zone Macro</td>
<td>488</td>
</tr>
<tr>
<td>Task Report Macro</td>
<td>493</td>
</tr>
<tr>
<td>Team Calendar Macro</td>
<td>496</td>
</tr>
<tr>
<td>User List Macro</td>
<td>499</td>
</tr>
<tr>
<td>User Profile Macro</td>
<td>502</td>
</tr>
<tr>
<td>View File Macro</td>
<td>505</td>
</tr>
<tr>
<td>Widget Connector Macro</td>
<td>506</td>
</tr>
<tr>
<td>Your profile and settings</td>
<td>513</td>
</tr>
<tr>
<td>Your User Profile</td>
<td>514</td>
</tr>
<tr>
<td>Change Your Password</td>
<td>517</td>
</tr>
<tr>
<td>Edit Your User Settings</td>
<td>518</td>
</tr>
<tr>
<td>Set Your Profile Picture</td>
<td>519</td>
</tr>
<tr>
<td>Choose Your Home Page</td>
<td>520</td>
</tr>
<tr>
<td>Save for later</td>
<td>521</td>
</tr>
<tr>
<td>View and Revoke OAuth Access Tokens</td>
<td>522</td>
</tr>
<tr>
<td>Collaboration</td>
<td>526</td>
</tr>
<tr>
<td>Like and Popular Content</td>
<td>527</td>
</tr>
<tr>
<td>Mentions</td>
<td>529</td>
</tr>
<tr>
<td>Share a Page or Blog Post</td>
<td>530</td>
</tr>
<tr>
<td>Comment on pages and blog posts</td>
<td>531</td>
</tr>
<tr>
<td>Watch Pages, Spaces and Blogs</td>
<td>532</td>
</tr>
<tr>
<td>Manage Watchers</td>
<td>533</td>
</tr>
<tr>
<td>Email Notifications</td>
<td>534</td>
</tr>
<tr>
<td>Subscribe to RSS Feeds within Confluence</td>
<td>544</td>
</tr>
<tr>
<td>The RSS Feed Builder</td>
<td>545</td>
</tr>
<tr>
<td>Subscribe to pre-specified RSS feeds</td>
<td>546</td>
</tr>
<tr>
<td>Subscribe to a Network RSS Feed</td>
<td>548</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Workbox Notifications</td>
<td>550</td>
</tr>
<tr>
<td>Analytics</td>
<td>553</td>
</tr>
<tr>
<td>View insights on your site</td>
<td>555</td>
</tr>
<tr>
<td>View insights on spaces</td>
<td>557</td>
</tr>
<tr>
<td>View insights on pages</td>
<td>559</td>
</tr>
<tr>
<td>Search</td>
<td>561</td>
</tr>
<tr>
<td>Confluence Search Syntax</td>
<td>565</td>
</tr>
<tr>
<td>Confluence Search Fields</td>
<td>570</td>
</tr>
<tr>
<td>Search the People Directory</td>
<td>575</td>
</tr>
<tr>
<td>Recently Viewed Pages and Blog Posts</td>
<td>577</td>
</tr>
<tr>
<td>Ranking of Search Results</td>
<td>578</td>
</tr>
<tr>
<td>Permissions and restrictions</td>
<td>581</td>
</tr>
<tr>
<td>Confluence Groups</td>
<td>583</td>
</tr>
<tr>
<td>Check who can view a page</td>
<td>584</td>
</tr>
<tr>
<td>Inspect permissions</td>
<td>587</td>
</tr>
<tr>
<td>Permissions best practices</td>
<td>599</td>
</tr>
<tr>
<td>Team Calendars</td>
<td>604</td>
</tr>
<tr>
<td>Team Calendars Quick Tour</td>
<td>605</td>
</tr>
<tr>
<td>Create, Add, and Edit Calendars</td>
<td>607</td>
</tr>
<tr>
<td>Restrict a Calendar</td>
<td>610</td>
</tr>
<tr>
<td>Add Events</td>
<td>612</td>
</tr>
<tr>
<td>Add Jira Events</td>
<td>614</td>
</tr>
<tr>
<td>Event Types</td>
<td>618</td>
</tr>
<tr>
<td>Custom Event Types</td>
<td>620</td>
</tr>
<tr>
<td>Reminders</td>
<td>622</td>
</tr>
<tr>
<td>Embed Calendars on Confluence Pages</td>
<td>624</td>
</tr>
<tr>
<td>Watch a Calendar</td>
<td>625</td>
</tr>
<tr>
<td>Share Calendars</td>
<td>627</td>
</tr>
<tr>
<td>Subscribe to Team Calendars from Third-Party Calendars</td>
<td>629</td>
</tr>
<tr>
<td>Subscribe to Team Calendars from Microsoft Outlook</td>
<td>632</td>
</tr>
<tr>
<td>Subscribe to Team Calendars from Outlook on the web</td>
<td>636</td>
</tr>
<tr>
<td>Subscribe to Team Calendars from Apple Calendar</td>
<td>637</td>
</tr>
<tr>
<td>Subscribe to Team Calendars from Apple iOS Calendar</td>
<td>639</td>
</tr>
<tr>
<td>Subscribe to Team Calendars from Google Calendar</td>
<td>641</td>
</tr>
<tr>
<td>Subscribe to Team Calendars from Android Calendar</td>
<td>643</td>
</tr>
<tr>
<td>Subscribe to Team Calendars from Thunderbird</td>
<td>645</td>
</tr>
<tr>
<td>Subscribe to Third-Party Calendars from Team Calendars</td>
<td>647</td>
</tr>
<tr>
<td>Subscribe to Outlook Calendar from Team Calendars</td>
<td>648</td>
</tr>
<tr>
<td>Subscribe to Apple Calendar from Team Calendars</td>
<td>649</td>
</tr>
<tr>
<td>Subscribe to Google Calendar from Team Calendars</td>
<td>650</td>
</tr>
<tr>
<td>Subscribe to Opsgenie Calendars from Team Calendars</td>
<td>651</td>
</tr>
<tr>
<td>Subscribe to PagerDuty Schedules from Team Calendars</td>
<td>652</td>
</tr>
<tr>
<td>Subscribe to Teamup Calendars from Team Calendars</td>
<td>653</td>
</tr>
<tr>
<td>Export Team Calendars Content to Other Calendars</td>
<td>654</td>
</tr>
<tr>
<td>Delete or Remove a Calendar</td>
<td>656</td>
</tr>
<tr>
<td>Team Calendars FAQ</td>
<td>658</td>
</tr>
<tr>
<td>Add-ons and integrations</td>
<td>659</td>
</tr>
<tr>
<td>Use Jira applications and Confluence together</td>
<td>660</td>
</tr>
<tr>
<td>Request Marketplace Apps</td>
<td>666</td>
</tr>
<tr>
<td>Use a WebDAV Client to Work with Pages</td>
<td>668</td>
</tr>
<tr>
<td>Mail Archives</td>
<td>670</td>
</tr>
<tr>
<td>Add a Mail Account</td>
<td>672</td>
</tr>
<tr>
<td>Delete and Restore Mail</td>
<td>674</td>
</tr>
<tr>
<td>Import Mail from an mbox</td>
<td>675</td>
</tr>
<tr>
<td>Create content with email</td>
<td>676</td>
</tr>
<tr>
<td>Gadgets</td>
<td>679</td>
</tr>
<tr>
<td>Activity Stream Gadget</td>
<td>681</td>
</tr>
<tr>
<td>Confluence Page Gadget</td>
<td>682</td>
</tr>
<tr>
<td>Confluence QuickNav Gadget</td>
<td>685</td>
</tr>
<tr>
<td>Confluence use-cases</td>
<td>686</td>
</tr>
<tr>
<td>Develop Technical Documentation in Confluence</td>
<td>687</td>
</tr>
<tr>
<td>Use Confluence as a Knowledge Base</td>
<td>693</td>
</tr>
<tr>
<td>Use Confluence as your Intranet</td>
<td>695</td>
</tr>
<tr>
<td>Confluence for Software Teams</td>
<td>697</td>
</tr>
</tbody>
</table>
Confluence Data Center documentation

Confluence is where you create, organize, and discuss work with your team.

Get started

Kick start your Confluence journey with our navigation and space tutorials.

View guide

What’s new in 8.6

Time to upgrade? Get the low down on the latest and greatest changes in Confluence.

View release notes
Get started

Welcome to the Confluence getting started documentation. In this section, you'll find tutorials and other information that'll be useful for evaluating Confluence, and getting to know it when you're starting out.

Teams in Space

"Perform flight research and technology integration to revolutionize aviation and pioneer aerospace technology. Also, land the first humans on Mars by 2020."

You're an astronaut in the 'See Space EZ' team, which is working on the upcoming colonization of Mars.

Go ahead – dive into the tutorials, and let us show you around Confluence and some of its handy features.

- **Tutorial: Navigate Confluence**
  - The dashboard
  - The space directory
  - The space sidebar
  - Keyboard shortcuts
  - Complete your mission
- **Tutorial: Space ace**
  - Create a project space
  - Create your personal space
  - Create the team's PR space
  - Delete and archive spaces
Tutorial: Navigate Confluence

Confluence is pretty simple to use, once you get to know it. This tutorial aims to get you acquainted with the Confluence user interface, and show you how and where to perform some common tasks.

Teams in Space

In this tutorial, you’ll be working with some new Teams in Space recruits. Let's get to know them.

Alana Baczewski  
Tech Lead

Emma Silvetti  
Launch Specialist

William Vladinov  
Aerospace Engineer

Now that you’ve met your team, let’s take a look at your mission.

Mission brief

Your mission commander has thrown you a curveball: this week you’ll be training new recruits at Teams in Space HQ on your collaboration tool – Confluence. You just need to know the basics, so we’ll go through the main things you need to know to complete your mission.

Your mission is broken up into the following components:

- Get to know the dashboard
- Find your way in the space directory
- Master the space sidebar
- Impress everyone with keyboard shortcuts

Those new recruits will be here tomorrow; we better get started!

Let's go!
The dashboard

1. The dashboard
2. The space directory
3. The space sidebar
4. Keyboard shortcuts
5. Complete your mission

The dashboard is the hub of your Confluence site, providing you with access to information and updates that are important to you. It's also the first thing your new recruits will see, so you need to make a good impression on this one.

You can get to the dashboard from anywhere in Confluence by choosing the site logo at the left of the Confluence header.

The dashboard has a collapsible sidebar that helps you get around:

- **Discover**
  Watch the action unfold in real time with **All updates or** check out pages with lots of likes and activity in the **Popular** feed.

- **My Work**
  Get lightning fast access to your recently created and edited pages in **Recently worked on**, get back to that page you stumbled across yesterday in **Recently viewed**, and have mission critical pages on speed dial under **Saved for later**.

- **My Spaces**
  This is where you can keep links to the spaces that you hop in and out of several times a day.

If you're a Confluence admin you can give the dashboard some personality by adding useful announcements, links, or a photo from your last mission (or office party). The whole right hand column is ready and waiting for you to customize.

Try clicking one of the spaces on the sidebar, then return to the dashboard by clicking the site logo. Even when your shuttle is spinning out of control, the dashboard is there to orient you.

You'll discover more about the dashboard as you get to know Confluence, but, for now, let's move on to the space directory.
Pro tips

- You can choose to set any page as your personal home page
- You can always get to the dashboard at https://yoursite.com/wiki/dashboard.
- Your Confluence admin can customize the global dashboard that all users see
The space directory

1. The dashboard
2. The space directory
3. The space sidebar
4. Keyboard shortcuts
5. Complete your mission

The space directory won't let you look up ET in the intergalactic phone book, but it will let you see and filter all the spaces in your Confluence site. Spaces are places to collect pages with a common theme – you can create as many spaces as you like – and you can find them all in the space directory.

Here are some tasks to get you comfortable using the space directory:

1. **Visit the space directory** – To get to the space directory, choose **Spaces > Space directory** in the Confluence header.
2. **Choose the spaces you'll use the most** – No doubt there'll be a space or two that you'll use on a regular basis. Click the star to the right of a space to make it appear under **My Spaces** on the dashboard.
3. **Choose space categories** – Once you're there, you'll see a list of all the spaces in your Confluence site. Choose the 'My Spaces' category on the left to see only the spaces you marked with a star. Then choose all spaces again.
4. **Filter the list of spaces** – Type part of a space name in the **Filter** field at the top right. That'll quickly narrow down the list of spaces if there are a lot of them.

Understanding and using the space directory will make it much easier to find pages and blog posts that are relevant to you.

You're ready to impress those new recruits with your knowledge of Confluence's space directory; now it's time to sneak a peek at the space sidebar.

Next
The space sidebar

1. The dashboard
2. The space directory
3. The space sidebar
4. Keyboard shortcuts
5. Complete your mission

What's in the sidebar?

The sidebar is a feature of every Confluence space; it's where you'll find the page tree (a hierarchical list of pages in the space), customizable space shortcuts, and a link to the space's blog.

The See Space EZ team will find their meeting notes, decisions, requirements, and other pages in the sidebar. Basically any page you create in the space will appear in the sidebar by default.

When you use certain page templates, like meeting notes, Confluence will automatically add an index page to your space shortcuts. The index page is just a place where you can view all pages of the same type – meeting notes in this example – in one place.

The space's blog is great for announcements and what's new-type updates.
1. **Space shortcuts**: link to Confluence pages or other pages on the web
2. **Page tree**: hierarchical view of pages in this space.

The page tree in the sidebar shows the 200 pages closest to where you are. Hit Show all pages, if you want to see all the pages in a space.

**Configure the sidebar**

You can expand or collapse the sidebar using the left square bracket ([ ] ) on your keyboard, or by dragging it with your mouse.

There are lots of things you can change in the sidebar, but we'll stick to the basics – just enough to train your new recruits.

You need to be a space admin to complete this task. Take a look, but feel free to skip it if you're not an admin of any space.

Try this out:
1. Choose **Space tools > Configure sidebar** from the bottom of the sidebar (or the cog menu if your sidebar is collapsed)

2. Add a space shortcut by clicking **Add link**
   Shortcuts can be to Confluence pages or spaces, or to any other content on the web. Try linking to this blog post, which mentions Teams in Space (we're always after a plug at Teams in Space HQ!)

You can also hide things – like the space's blog – in the sidebar, if they’re of no use in the space.

The sidebar is pretty easy, right? You'll be schooling those recruits in no time. Next up: Impress them with your knowledge of keyboard shortcuts.
Keyboard shortcuts

1. The dashboard
2. The space directory
3. The space sidebar
4. Keyboard shortcuts
5. Complete your mission

Give a person some space food, and they'll eat for a day; teach a person to rehydrate their own space food, and they're set for the whole mission. Or something like that. Keyboard shortcuts fall into this basket. We could give you a list here, but then you'd need to keep referring to this page. The best way to go is to show you how to find the list of keyboard shortcuts within Confluence.

Your recruits also need to work fast, so you'll need to pass this wisdom on to them.

Find the keyboard shortcuts

To open the list of keyboard shortcuts in Confluence, do any of the following:

- Choose the help icon at top right of the screen, then choose Keyboard Shortcuts
- When viewing a page, press Shift+?
- While editing a page, choose the question mark icon in the editor toolbar

What you'll see is a dialog listing the available keyboard shortcuts in Confluence for your specific operating system and browser. Expand the menus below to see the full list.

**Screenshot: Keyboard shortcuts menu for Google Chrome on macOS.**

The keyboard shortcuts are broken up into 3 categories:

- General – Global, page and blog post shortcuts.
- Editor – Text editing and formatting shortcuts.
- Editor Autoformatting – Wiki markup and autoformatting shortcuts.

Expand the menu below to see an overview of the shortcuts in this version of Confluence.
## All screens

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>c</td>
<td>Add page</td>
<td>c</td>
</tr>
<tr>
<td>g then d</td>
<td>Go to dashboard</td>
<td>g then d</td>
</tr>
<tr>
<td>g then n</td>
<td>Open notifications</td>
<td>g then n</td>
</tr>
<tr>
<td>g then r</td>
<td>Open recently viewed</td>
<td>g then r</td>
</tr>
<tr>
<td>g then s</td>
<td>Browse current space</td>
<td>g then s</td>
</tr>
<tr>
<td>?</td>
<td>Open shortcut help</td>
<td>?</td>
</tr>
<tr>
<td>u then 8</td>
<td>Show skip links</td>
<td>u then 8</td>
</tr>
<tr>
<td>g then g/</td>
<td>Quick search</td>
<td>g then g</td>
</tr>
<tr>
<td>[</td>
<td>Toggle space sidebar</td>
<td>[</td>
</tr>
<tr>
<td>e</td>
<td>Edit</td>
<td>e</td>
</tr>
<tr>
<td>s</td>
<td>Share</td>
<td>s</td>
</tr>
<tr>
<td>b</td>
<td>Add blog</td>
<td>b</td>
</tr>
<tr>
<td>e</td>
<td>Edit</td>
<td>e</td>
</tr>
<tr>
<td>m</td>
<td>Comment</td>
<td>m</td>
</tr>
<tr>
<td>v</td>
<td>View inline comment</td>
<td>v</td>
</tr>
<tr>
<td>]</td>
<td>Close inline comment</td>
<td>]</td>
</tr>
<tr>
<td>w</td>
<td>Watch page</td>
<td>w</td>
</tr>
<tr>
<td>l</td>
<td>Edit labels</td>
<td>l</td>
</tr>
<tr>
<td>s or k</td>
<td>Share</td>
<td>s or k</td>
</tr>
<tr>
<td>t</td>
<td>View attachments</td>
<td>t</td>
</tr>
<tr>
<td>f</td>
<td>Favorite page</td>
<td>f</td>
</tr>
</tbody>
</table>

## Editor

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + 0</td>
<td>Paragraph</td>
<td>+ 0</td>
</tr>
<tr>
<td>Ctr+(1–6)</td>
<td>Heading level (of the number chosen)</td>
<td>+(1–6)</td>
</tr>
<tr>
<td>Ctrl + 7</td>
<td>Preformatted</td>
<td>+ 7</td>
</tr>
<tr>
<td>Ctrl + 8</td>
<td>Quote</td>
<td>+ 8</td>
</tr>
<tr>
<td><em>bold</em></td>
<td>Bold text</td>
<td><em>bold</em></td>
</tr>
<tr>
<td>+underline+</td>
<td>Underline text</td>
<td>+underline+</td>
</tr>
<tr>
<td><em>italic</em></td>
<td>Italic text</td>
<td><em>italic</em></td>
</tr>
<tr>
<td>{{monospace}}</td>
<td>Monospace text</td>
<td>{{monospace}}</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Ctrl + Shift + V</td>
<td>Paste text without formatting</td>
<td>+ Shift + V</td>
</tr>
<tr>
<td><strong>For Safari only:</strong> Ctrl + Shift + Alt + V</td>
<td></td>
<td><strong>For Safari only:</strong> + Shift + Option + V</td>
</tr>
<tr>
<td>Ctrl + Shift + B, or * + Space</td>
<td>Add a bullet list</td>
<td>+ Shift + B, or * + Space</td>
</tr>
<tr>
<td>Ctrl + Shift + N, or # + space</td>
<td>Add a numbered list</td>
<td>+ Shift + N, or # + space</td>
</tr>
<tr>
<td>[]</td>
<td>Add a task</td>
<td>[]</td>
</tr>
<tr>
<td>Ctrl + K</td>
<td>Link (opens Insert link dialog)</td>
<td>+ K</td>
</tr>
<tr>
<td>Ctrl + Shift + D</td>
<td>Insert markup (opens Insert markup dialog)</td>
<td>+ Shift + D</td>
</tr>
<tr>
<td>Ctrl + Shift + A</td>
<td>Macro (opens Select macro dialog)</td>
<td>+ Shift + A</td>
</tr>
<tr>
<td>Ctrl + Shift + O</td>
<td>Toggle to next inline comment</td>
<td>+ Shift + O</td>
</tr>
<tr>
<td>Ctrl + Shift + L</td>
<td>Toggle to previous inline comment</td>
<td>+ Shift + L</td>
</tr>
<tr>
<td>Ctrl + Shift + Z</td>
<td>Close inline comment</td>
<td>+ Shift + Z</td>
</tr>
<tr>
<td>Ctrl + Shift + E</td>
<td>Preview</td>
<td>+ Shift + E</td>
</tr>
<tr>
<td>Ctrl + S</td>
<td>Save / Publish</td>
<td>+ S</td>
</tr>
<tr>
<td>Ctrl + Shift + U + 8</td>
<td>Show skip links</td>
<td>+ Shift + U + 8</td>
</tr>
<tr>
<td>Ctrl + Z</td>
<td>Undo action</td>
<td>+ Z</td>
</tr>
<tr>
<td>Ctrl + Y</td>
<td>Redo action</td>
<td>+ Shift + Y</td>
</tr>
</tbody>
</table>

### Tables

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Shift + i</td>
<td>Add a table (insert a default table with three columns and four rows)</td>
<td>+ Shift + i</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ctrl + Shift + c</td>
<td>Copy the current table row, or the selected rows</td>
<td>+ Shift + c</td>
</tr>
<tr>
<td>Ctrl + Shift + y</td>
<td>Paste the table rows from your clipboard, placing them above the current row</td>
<td>+ Shift + y</td>
</tr>
<tr>
<td>Ctrl + Shift + x</td>
<td>Cut the current table row, or the selected rows</td>
<td>+ Shift + x</td>
</tr>
<tr>
<td>Alt + Up Arrow</td>
<td>Add a row above the current row</td>
<td>Option + Up Arrow</td>
</tr>
<tr>
<td>Alt + Down Arrow</td>
<td>Add a row below the current row</td>
<td>Option + Down Arrow</td>
</tr>
</tbody>
</table>
Autocomplete

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>File or image suggestions</td>
<td>!</td>
</tr>
<tr>
<td>[</td>
<td>Link suggestions</td>
<td>]</td>
</tr>
<tr>
<td>{ or /</td>
<td>Macro suggestions</td>
<td>{ or /</td>
</tr>
<tr>
<td>:</td>
<td>Emoji suggestions</td>
<td>:</td>
</tr>
<tr>
<td>@</td>
<td>Mention users</td>
<td>@</td>
</tr>
</tbody>
</table>

See more about using autocomplete

You can turn the ‘General’ keyboard shortcuts off when you visit the **General** tab in the keyboard shortcuts dialog.

Take some time to open the dialog and take a look at the shortcuts, and maybe find some you’ll use a lot. Then, start practising!

Next, we’ll wrap up this mission and give you some ideas about where to head from here.
Complete your mission

1. The dashboard
2. The space directory
3. The space sidebar
4. Keyboard shortcuts
5. Complete your mission

Well done, astronaut, you’ve acquitted yourself admirably. I’m sure those new recruits will be mightily impressed with your knowledge of Confluence.

In this tutorial, we’ve:

- Explored the anatomy of the dashboard
- Navigated using the space directory and favorited a space
- Taken a look at and customized the space sidebar
- Found a handy list of keyboard shortcuts to help you work faster

Just look at your team’s adoring faces...

If you’d like to take things to the next level, check out our tutorial on becoming a space ace.
Tutorial: Space ace

This tutorial will take you on a journey through Confluence to create and customize spaces, and delete them if you want to, so you can achieve the rank of ‘Space Ace’!

You'll need to have the ‘Create space’ and ‘Create personal space’ permission to complete this tutorial. If you've just set up Confluence, you won't have any trouble; if you're using an existing instance and you're not an admin, speak to your Confluence admin to make sure you have the right permissions.

Teams in Space

In this tutorial you're a new recruit on the Teams in Space crew, but, even though you're new, you'll be given a lot of responsibility. You need the power to go with it.

Mission brief

You're in charge of organizing information and resources for the planned mission to Mars. There's going to be plenty of important information, and it must be readily available to the people who need it. Some information, though, will be sensitive, and may be ‘for your eyes only.’ You'll use the power and flexibility of Confluence spaces to organize information, and make sure it's visible to the right people.

Your mission is broken up into the following components:

- Create a space to house all of the important information related to the mission
- Create your own space to keep yourself organized
- Create a public relations space, where you’ll introduce your team the world

What's a space?

Well, being an astronaut, I hope you know what space is, but what's a Confluence space all about? It's really just a place to put related things, like information pages and files. But spaces also give you a place to collaborate with groups of people, whether that's your team, people working on a common project, or the whole world.

Every space has its own permissions, allowing you to grant access and other privileges to the right people. They also have a blog, so you can post important messages and updates to whoever can see the space. You can have as many Confluence spaces as you like, and you can archive or delete spaces when you no longer need them.

Enough about that; let's begin.

Start the mission!
Create a project space

1. Create a project space
2. Create your personal space
3. Create the team's PR space
4. Delete and archive spaces

The Mars colonization crew needs a place to put all their mission-critical information and resources, and you’re charged with setting it up. This part is going to be easy, because the information needs to be viewable by the entire Teams in Space organization. That means we can set up the project space without any special permissions.

If you haven't done so already, open up Confluence and log in so we can get started.

Create the space

1. Choose Spaces > Create space from the Confluence header
2. Select the Blank space option and choose Next
3. Enter a Space name – for this space, we'll call it ‘Mars Colony’, as it's being used for the Mars colonization project.
4. Change the Space key to ‘MARS’ – this step isn't absolutely necessary, but it helps people if they're navigating to this space by name. The space key forms part of the URL, so making it a word or name makes it much easier to associate with your project.
5. Click Create

You now have a space set up for the Mars colonization project. Because everyone at Teams in Space HQ needs access to the information in this space, you don't need to do anything with the space's default permissions. It's visible to everyone in your organization, but not to the general public.

Every space has a default home page, which you can customize to suit your needs. Add the following image and text to your space's home page to get things started. Just click Edit (or press E on your keyboard) to edit the home page, and copy and paste the text. For the image it's best to drag it to your desktop and save it there, then drag it into your page. That'll make sure the image is attached directly to the page.

Hit Save when you're happy with the home page.

A human mission to Mars has been the subject of science fiction, engineering, and scientific proposals throughout the 20th century and into the 21st century. The plans comprise proposals to land on Mars, eventually settling on and terraforming the planet, while exploiting its moons, Phobos and Deimos.

Exploration of Mars has been a goal of national space programs for decades. Preliminary work for missions that would involve human explorers has been undertaken since the 1950s, with planned missions typically being cited as taking place 10 to 30 years in the future when they are drafted. The list of manned Mars mission plans in the 20th century shows the various mission proposals that have been put forth by multiple organizations and space agencies in this field of space exploration.
Your 'Mars colony' space is ready for your team to add pages to. If you want to find it again, choose **Spaces** in the Confluence header, and select it from the list; to add a page to it, navigate to the space and hit **Create** in the header.

Now it's on to your personal space; a place where you can work in peace, and be sure that no one's looking over your shoulder.
Create your personal space

1. Create a project space
2. Create your personal space
3. Create the team's PR space
4. Delete and archive spaces

As a newbie on the team, you might want to keep some work to yourself until you're ready to present it. There's always the chance your mission commander will also send you some information that's 'for your eyes only,' and you'll need to keep that in a safe place.

For this part of the mission, we'll be creating a special type of space: a personal space. We'll be using your personal space like a sandbox, at least to start with – somewhere you can play around, draft pages, try out features, and generally see what spaces are capable of.

Create your personal space

1. Choose your profile picture at the right side of the Confluence header
2. Select Add Personal Space...
3. Hit Create

You've now got a space that you can call your own. But we still need to lock it down to make sure it's only visible to you.

4. Choose Space tools > Permissions from the bottom of the sidebar
5. Hit Edit Permissions (enter your password if prompted)

You should see the confluence-users group listed under Groups. To the left of the list of permissions is the View permission, which determines whether everyone in that group can see your space.

6. Uncheck View and hit Save all at the bottom of the page

You're now the only one that can view this space. Feel free to try anything in this space, and store super secret stuff here.
Create the team's PR space

1. Create a project space
2. Create your personal space
3. Create the team's PR space
4. Delete and archive spaces

Now it's time to go public; the world needs to know about the mission and its brave participants.

In this step, we'll create a team space and open it up to everyone. That's right – you can open Confluence spaces up to anonymous (not logged in) users.

In order to allow anonymous access to your Confluence site, a site admin needs to grant anonymous users the 'Use Confluence' permission. Don't worry if you can't do that, or if it's not done; it's just something to note if you're opening up your Confluence site for real.

Create a Team space

1. Choose Spaces > Create space from the header
2. Select Team Space and hit Next
3. Enter a Space name (let's call it 'Mars PR')
4. Change the Space key to 'MarsPR'
5. If there are other people using Confluence with you, feel free to add them as Team members (you can remove them later), or just stick with yourself for now
6. Paste this in as the Description: Follow the progress of the brave Teams in Space astronauts as they embark on their mission to colonize Mars.

Great! You now have a team space, again with its own home page. This home page is a little different to the project space and your personal space – you'll see any team members you added, listed on the home page.

Each space you create also has its own blog, so your social media team will be able to create posts in this space and speak directly to all those adoring fans. But none of those fans can see this space. Yet.

Allow anonymous access

It's time to let the world in by changing the permissions on this space.

1. Choose Space tools > Permissions from the bottom of the sidebar
2. Scroll down until you see Anonymous, then hit Edit Permissions
3. Tick the View permission for anonymous users and hit Save all
That's it. You can now share the space's URL, which will be http(s)://<your_confluence_site>/display/MarsPR. Visitors to that space don't need to log in, or have a license for Confluence.
Delete and archive spaces

1. Create a project space
2. Create your personal space
3. Create the team's PR space
4. Delete and archive spaces

We hope you've had a successful mission, and learned a bit about the power and versatility of Confluence spaces. Flash forward 18 months, and just look how well the colony is coming along!

If you need to clean up old spaces (or destroy the evidence of a failed mission!), you can either archive or delete a space. Archiving just means it won't show up in the regular search, whereas deleting is obviously a lot more permanent.

To archive a space:

1. Choose Space tools > Overview from the bottom of the sidebar
2. Click Edit Space Details
3. Change the Status from 'Current' to 'Archived' and hit Save

To delete a space:

1. Choose Space tools > Overview from the bottom of the sidebar
2. Select the Delete Space tab

What next?

If you'd like to know more about spaces and the permissions that govern them, check out Spaces and Permissions and restrictions in the Confluence documentation.

Teams in Space HQ, signing off.
Spaces

What is a space?

Spaces are Confluence’s way of organizing content into meaningful categories. Think of it like having different folders into which you can put your work.

Spaces come in two main varieties:

- **Site spaces** – These spaces are found in the Space Directory and are the areas where you create content and collaborate with others. They are sometimes called global spaces.

- **Personal spaces** – Every Confluence user can set up a personal space which they can keep private or make public so others can view and edit. Personal spaces are listed in the People Directory and found under your personal profile.

How do I use a space?

**Create as many spaces as you need to get things done:**

- **Team spaces** – Give each team (QA, HR, Engineering, Support, ...) their own space so they can focus and make their information easier for everyone to find.

- **Project spaces** – Put all the information related to your project in one place. This allows everyone to work together in Confluence instead of emailing back and forth.

- **Personal space** – Store everything you’re working on individually, keep your to-do lists, and polish any content before you move it into another shared space.

On this page:

- What is a space?
- How do I use a space?

Related pages:

- Create a Space
- Space Permissions Overview
- Navigate Spaces
- Organize your Space
- Customize your Space
- Archive a Space
- Export Content to Word, PDF, HTML and XML
- Delete a Space
Stay up to date with spaces

- Watch a space to stay up-to-date with any changes.
- Add important spaces to your dashboard so that they’re easy to find again.

Administer spaces
If you have admin permissions for a space you can:

- Change the colors, logo, sidebar and homepage of that space.
- Control who can view and edit your space.
- Make your space public to share it with people who don’t have access to Confluence.

Space Permissions
Some things we should make clear about space admin permissions:

- The person who creates a space automatically has admin permissions for that space.
- Space admins can grant admin permissions to others.
- Space admins don’t have to be Confluence admins and can have special permissions for a single space. For example, you are the admin for your personal space, no matter what kind of access you have anywhere else.

Want more ideas for using spaces? Check out our kickass guides on how to:

- Use Confluence as a Knowledge Base
- Develop Technical Documentation in Confluence
- Use Confluence as your Intranet
- Use Confluence for Software Teams
Create a Space

There's no limit to the number of Spaces you can create on Confluence. You can choose to set up a space for each team, project, or a mix of both depending on your needs.

Each space in Confluence functions autonomously, which means that each space:

- Has its own homepage, blog, pages, comments, files, and RSS feeds.
- Can be customized with different color schemes, logo and sidebar.
- Has its own set of permissions, as set by the space admin.

For example, an IT team can create one overarching space with all their roadmaps, details of sub-teams, and a list of all the people and roles within that team. They could then create a new space for each sub-team, such as Quality Assurance, Developers, and Documentation, with guidelines, long term plans, and knowledge articles within them. Each project that these teams work on could also have its own space, which could be linked to the team spaces using labels.

Create a personal space

Your personal space is always owned by you, and you can use it to store your individual work, keep track of tasks, blog about what you've been working on, or just use it to polish your pages before you move them into a site space.

1. Choose your profile picture at top right of the screen, then choose Add Personal Space..
2. Choose Create.

You can change the permissions for your space at any time to determine who can and can't access the content. So if you want it to be a private sanctuary, that's no problem.

To create a personal space you need the 'Personal Space' global permission.

Create a site space

You can create a site space for any team or project that would benefit from having a place where people can work together and store related files. You can create these as blank spaces, or use templates, called space blueprints, to help you create Team spaces, Knowledge Bases spaces, or Documentation spaces quickly and easily.

1. Hit Spaces > Create space in the header.
2. Pick a type of space.
3. Enter the required details and create your space.
Choose your space key carefully as you can't change this later.

Each space you create will automatically have a home page that you can customize to display relevant information for people viewing the space. If you use a space blueprint when creating a space, it will customize your home page for you.

To create a site space you need the 'Create Space' global permission.

Space permissions

Each space is created with a set of default permissions. The user who created a site space is automatically granted 'space admin' permissions for that space, which means that they can then grant permissions to other users and groups. See Space Permissions Overview for more information.

System Administrators can edit the permissions of spaces in their Confluence site at any time.

Linking related spaces

You can link related spaces together using labels. This will create categories in the space directory for each label, grouping all spaces with that label together.

- You can also add a space description to make it easier for visitors to find the right space within each category.
- To help navigate between related spaces, you can use the Spaces List Macro on a page and filter by category. This will let you insert a list of all the other spaces in a certain category into your space. You can use this, for example, to keep a list in your team space of all the project spaces your team is working on.
- If you want to link to only certain pages of related content, rather than whole spaces, you can use the Content Report Table Macro. You can use this, for example, in a space that functions as a workplace directory, to create a list of all the team pages with everyone's roles and contact details across your organization.
Tips

- If your needs change, or your spaces grow too big, it’s easy to copy or move content from one space to another.
- If the content or purpose of your space changes, you can update the space name, logo, colors and description to reflect those changes.
- If you no longer need a space, such as when a project has been completed, you can archive it, which makes it less visible but retains the content on your site so that you can still refer back to it later.
Create a Space From a Template

Confluence comes with a number of templates, known as space blueprints, which have a customized homepage and sidebar, and may contain page blueprints or sample content to help you get started.

Your Confluence administrator can customize or disable particular blueprint templates, so they may be different to the examples shown here.

Types of space blueprints

Team space

A great building block if you are using Confluence as an intranet or to manage teams. Team spaces highlight the members of the team, and grants permissions to those users accordingly.

Knowledge base space

This space blueprint uses search and page labels to make content easier to find, right from the space homepage. It also contains two page blueprints for creating how-to and troubleshooting articles. The templates used in these page blueprints are completely customizable. The Knowledge Base space blueprint also Use Jira applications and Confluence together.

Documentation space

This space blueprint displays the full page tree in the sidebar and hides other sidebar features including blogs and shared links. The homepage uses search and page labels to make content easy to find. Add the 'featured' label to any page you want to highlight on the homepage. This space does not include any page blueprints but you can create and promote templates for your documentation authors to use.

Software project space

This space is designed to help you organize your software project. The purpose-built space home page lets you view and edit your roadmap, see team members, and Use Jira applications and Confluence together#JIRA Software. Create pages in this space for requirements, meeting notes, decisions, retros, and more.

The software project space blueprint will only appear if you have linked Confluence to your Jira Software instance.
Check out our guides for some more tips on how to:

- Use Confluence as a Knowledge Base
- Develop Technical Documentation in Confluence
- Use Confluence as your Intranet
- Confluence for Software Teams
Space Keys

Each Confluence space has a space key, which is a short, unique identifier that forms part of the URL for that space.

When you create a site space, Confluence will suggest a space key or you can enter your own key to make it more memorable.

For example, you might give your marketing team's space a key of MARKETING. You can then navigate directly to the space using a URL like this - http://<yoursite>/display/marketing

Personal spaces always use your username as the space key.

Choosing a space key

Each space key:

- Must be unique.
- Can contain any alphanumeric character (a-z, 0-9).
- Can be up to 255 characters long.

⚠️ You can't change the space key after you create your space, so choose your space key carefully!
Navigate Spaces

How is content arranged in spaces?

Think of a space as the container that holds all the important stuff a team, group, or project needs to work. These are autonomous – that means that each space has its own pages, blogs, files, comments and RSS feeds.

Each space is automatically created with a homepage - the first page you'll see when you navigate to the space. You can edit your homepage and your sidebar to help people navigate their way around your space.

Spaces can't be nested – you can't have a space within a space – but you can Use Labels to Categorize Spaces. Spaces with the same label will appear together in the the space directory and in the recent activity area of the dashboard.

Inside the space, you can nest your pages, and you can create as many levels of hierarchy as you need. Each space also has its own blog, which lets you share news and make announcements. Blog posts are a great way to keep people involved in what's going on in your team or project.

You can set different levels of access for each space, and the pages and blogs within it, using Space Permissions Overview.

View all spaces in Confluence

There are two main ways to view spaces in Confluence:

- **The space directory** – choose Spaces > Space directory in the Confluence header for a list of all the site and personal spaces you have permission to see. Filter the list of spaces by selecting from the categories on the left of the space directory.
- **The dashboard** – you can make your most useful spaces appear under My spaces on the dashboard. Choose the star icon in the space sidebar or space directory to add a space to My spaces.
The **spaces menu** in the header also displays a list of your recently viewed spaces, allowing you to quickly navigate to the things you view most often.

The **Spaces List Macro** allows you to display a list of spaces on a Confluence page, and lets you filter them by category.
Space Permissions Overview

Every Confluence space has its own set of permissions which determine what people can do in the space.

Space permissions are set by the space administrator. The user who created the space is automatically a space administrator, and other users can also be granted Space Admin permission.

Related pages:
- Confluence Groups
- Assign Space Permissions
- Page Restrictions
- Global Permissions Overview

Edit space permissions

To change permissions for a space, choose Space tools > Permissions from the bottom of the sidebar, then choose Edit Permissions to change permission settings.

See Assign Space Permissions for more details.

Permissions Summary

The following permissions can be assigned in a space:

<table>
<thead>
<tr>
<th>Category</th>
<th>Permission</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>View gives you permission to access the content in this space, and see it in the space directory and other places like the dashboard. Delete own gives you permission to delete any pages, blogs, attachments and comments you've created in this space (regardless of whether other users have subsequently edited the content).</td>
</tr>
<tr>
<td>Pages</td>
<td>Add page gives you permission to create new pages and edit existing pages in this space (assuming the page is not restricted for editing). Delete page gives you permission to delete any page in the space.</td>
</tr>
<tr>
<td>Blog</td>
<td>Add blog gives you permission to create new blog posts and edit existing blog posts in this space (assuming the blog post is not restricted for editing). Delete page gives you permission to delete any blog post in the space. Delete permission is also required to move a page or blog to a different space.</td>
</tr>
<tr>
<td>Attachments</td>
<td>Add attachment gives you permission to upload (attach) files to pages and blog posts in this space, and to edit attached files using the Companion app. Delete attachment gives you permission to remove attached files from pages or blog posts in the space. People with only Add page or blog permissions can still insert existing attached files in the editor, and remove files from the editor, so they're not displayed on the page or blog post. They can't however upload a new file, a new version of an existing file, edit an existing file using the Companion app, or delete the attached file itself.</td>
</tr>
</tbody>
</table>
Here's how it looks on the Permissions screen:

<table>
<thead>
<tr>
<th></th>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Attachments</th>
<th>Comments</th>
<th>Restrictions</th>
<th>Mail</th>
<th>Space</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>View</td>
<td>Add</td>
<td>Delete</td>
<td>Add</td>
<td>Delete</td>
<td>Add/Remove</td>
<td>Add</td>
<td>Add</td>
</tr>
<tr>
<td>atlassian-staff</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>confluence-users</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

How space permissions work

Space permissions are additive. If a user is granted permissions as an individual or as a member of one or more groups, Confluence will combine these permissions together. This is sometimes known as their effective permissions.

Sasha is a member of the confluence-users group and the developers group. The confluence-users group has 'export' permission, but does not have 'restrict' permission. The developers group has 'restrict' permission but does not have 'export' permission.

By being a member of these two groups, Sasha can restrict and export content. The permissions do not conflict, they combine to determine what Sasha is allowed to do in this space.

If you have Confluence Data Center, Inspect permissions provides space admins and Confluence administrators a great way to view someone’s effective permissions.

Who is the space admin?

The user who created the space is automatically a space administrator, and other users can also be granted Space Admin permission.

To find out who is an administrators in your space, either:

- Go to Space Tools > Overview in the space.
- Go to Spaces > Space Directory on the header, then choose the Space Details icon beside the space.

If you accidentally deny all admin access to a space, so that nobody has access to administer the space any more, you can ask someone with Confluence Administrator global permission to recover Space Permissions.

Space admin superpowers
Space administrators can do a lot of things in the space such as:

- grant permissions to users and groups (and themselves)
- create templates
- change the look and feel
- delete the space
- manually remove page restrictions (including on pages they can’t see)
- manage watchers, to change who is watching a page
- inspect permissions to see what users can do in the space (Data Center only)

Confluence administrators aren’t necessarily space administrators. If they don’t have the Space Admin permission (as an individual or member of a group), they can recover permissions to the space, which will grant them space admin permission.
Assign Space Permissions

If you are the administrator of a space, you control the permissions for it. You can choose to assign/revoke permissions on either an individual user basis, or using Confluence Groups.

Want to know the best way to set permissions for your team's needs? Check out our Permissions best practices guide.

To view the permissions for a space:

1. Go to the space and choose Space tools > Permissions from the bottom of the sidebar
2. Choose Edit Permissions.

The Edit Space Permissions page is divided into the following sections:

- **Licensed Users** - this is where you grant permissions to groups and individual users.
- **Anonymous Access** - this is where you grant permissions to users who are not logged in (essentially making the space public). Note: allowing anonymous access in a space will allow all logged in users to see that space, even if your site is not Public.

On this page:
- Grant space permission
- Set default space permission for all new spaces
- Revoke space permissions
- Inspect permissions
- Manage and recover space admin permissions

Related pages:
- Space Permissions Overview
- Global Permissions Overview
- Make a Space Public
- Give Access to Unlicensed Users from Jira Service Management
Grant space permission

To add a new user or group to the permissions list:

1. Search for either a group or user in their respective sections and choose Add. The group or user will appear in the list.
2. Select the specific permissions you’d like to apply then choose Save all.

You can bulk assign or revoke permissions by selecting Select All or Deselect All.

Permissions are managed on a space by space basis. Your Confluence Administrator is able to set default space permissions, which will apply to any new spaces.

Set default space permission for all new spaces

If you regularly need to grant permissions to the same groups each time a new space is created, you should consider updating the default space permissions.
To set the default space permissions:

1. Go to Administration > General Configuration > Space Permissions.
2. Choose Edit Permissions.

Default permissions are configurable for groups only, not for individual or anonymous users.

Revoke space permissions

To remove a user or group from the space permissions list, deselect all the checkboxes for that user or group and save the changes. The user or group won't appear in the list once you save.

Inspect permissions

If you need to troubleshoot why someone can or can't do something in your space, and you have a Data Center license, you can inspect permissions. See Inspect permissions for more information.

Manage and recover space admin permissions

If you're a Confluence Administrator you can recover permissions to a space. This is useful when the only person with Space Admin permissions to a space leaves your organisation, for example.

To recover Space Admin permissions:

1. Go to Administration > General Configuration > Space Permissions.
2. Locate the space in the list of individual spaces and choose Recover Permissions.

You can then choose Manage Permissions, and add any other appropriate permissions to the space. Requests to recover permissions are recorded in the Confluence audit log.

People with System Administrator permissions are able to manage permissions for all spaces, they do not need to first recover permissions.

<table>
<thead>
<tr>
<th>Individual Spaces</th>
</tr>
</thead>
<tbody>
<tr>
<td>These are the current wiki spaces.</td>
</tr>
<tr>
<td>Name</td>
</tr>
<tr>
<td>----------------------------------</td>
</tr>
<tr>
<td>Dev team</td>
</tr>
<tr>
<td>IT Knowledge Base</td>
</tr>
<tr>
<td>Marketing Knowledge base</td>
</tr>
<tr>
<td>Social</td>
</tr>
</tbody>
</table>
Make a Space Public

If your site is public, and you want to share your space with people who are not logged in to Confluence (anonymous users), you can make your space public.

Making a space public does not let you choose who you want to share it with – a public space can be viewed by anyone inside or outside of your organization.

To make your space public:

1. Go to the space and choose Space tools > Permissions from the bottom of the sidebar.
2. Choose Edit Permissions.
3. Scroll down to the Anonymous Access section and select the specific permissions you’d like anonymous users to have.
4. Save All to apply the changes.

Related pages:
- Give Access to Unlicensed Users from Jira Service Management

You can’t grant space administration or page restriction rights to anonymous users. You can grant Delete Own, but it will have no effect, as we have no way of knowing who an anonymous user is.

What happens when the site is not public?

If your Confluence administrator turns off anonymous access to your site, users who are not logged in will no longer be able to see any spaces. However, all logged in users (regardless of their group membership) will be able to see all spaces that have granted space permissions to anonymous users.

Auditing considerations

There are some additional things to be aware of if you grant the Add page permission to anonymous users.

You won’t be alerted, when closing the editor or publishing a page, if the only unpublished changes on the page were made by anonymous users. This means a logged in user may inadvertently publish changes they were not aware had been made to the page.

The changes themselves are visible in the page, but the usual warning dialog will not appear if the only people to have made changes were not logged in.
If there are unpublished changes from both logged in users and anonymous users, the warning dialog will appear, but only the logged in users will be listed in the dialog. Changes made by all users (including anonymous) will be included if you view the changes from that dialog.
Give Access to Unlicensed Users from Jira Service Management

If you're using Confluence as a knowledge base for Jira Service Management, you can choose to allow all active users and customers (that is, logged in users who do not have a Confluence license) to view specific spaces. This can only be turned on via JIRA Service Management.

When a space is accessible to all active users, you'll see the following message in the space permission screen.

<table>
<thead>
<tr>
<th>Permissions</th>
<th>Restricted Pages</th>
<th>Inspect Permissions</th>
</tr>
</thead>
</table>

**Any active user can view this space**

Any active user can view pages in this space, including users who don't have a Confluence license. This was enabled through Jira Service Management so people can view knowledge articles when raising a help request.

[Edit this permission]

This permission overrides all existing space permissions, so any logged in Confluence user will also be able to see the space (regardless of their group membership).

You can edit this permission at any time to revoke access to a space, but it can only be re-enabled from Jira Service Management.

Active users who don't hold a Confluence license have very limited access to Confluence. They can view pages, but can't like, comment, edit, view the dashboard, use the space directory, see user profiles or search your full site.

See [Use Jira applications and Confluence together](#) for more information about Jira Service Management integration.
Organize your Space

Here’s a few tips that'll help you organize your space so that everyone can find what they’re looking for and stay on top of what's important to them.

How do I organize content within my space?

**Pages and blogs**

Everything you create in Confluence, from meeting notes to retrospectives and everything in between, takes the form of either pages or blogs.

- Your homepage will be the first thing that visitors to your site see, so to help them find relevant content, start by curating your homepage with useful macros and including information about what is in your space. See [Set up a Space Home Page](#) for more information.
- If you're creating content that is specific mainly to the current time-frame, and isn't going to change over time, create it as a blog post. Your blog displays as an infinite scroll, so it surfaces the latest news and visitors just need to scroll down if they're interested in older content.
- If you're creating content that you want to last, and possibly evolve over time, then create it as a page. Pages nest, so every page can have its own child pages, which lets you organize your content into categories and subcategories.

**Configure the sidebar**

You can [Configure the Sidebar](#) to make it easier to navigate through your space.

The space shortcuts section of the sidebar lets you link to important content. You can use this to highlight pertinent pages within your space, related content from other spaces, or to external content that is relevant to your space.

The navigation display lists the pages in your space in either a page tree or child pages format. If you only want some content to be visible in the sidebar, you can hide the navigation display and put the pages you want to remain visible under Space shortcuts instead.
The page tree in the sidebar shows the 200 pages closest to where you are. Hit Show all pages, if you want to see all the pages in a space.

Using labels

Labels are keywords or tags that you can add to pages, blog posts, and attachments.

- Define your own labels and use them to categorize, identify, or bookmark content in Confluence. For example, if you assign the label 'accounting' to all accounts-related pages on your site, you'll then be able to:
  - Browse all pages with that label in a single space or across the site.
  - Display a list of pages with that label.
  - Search based on that label.
- Use the Content by Label Macro to create a table of contents for your space that is organized by label categories.
- Labels aren’t exclusive, so you can have as many labels as you want on a page. The page will then appear under each of those categories. See Use Labels to Categorize Spaces for more information.

How do I keep my space tidy?

If you have lots of people creating in the same space, things can get messy fast. You can prevent this by taking a few easy steps.

Create a set of guidelines

- Let your collaborators know about what parent pages to create their child pages under, so no content gets lost or misplaced.
- Decide on standard labels to add to pages, blogs, and attachments so all content gets neatly categorized.
- Add a link to this in the Space Shortcuts section of the sidebar so that it’s easy to find.

Use page blueprints
Blueprints are templates that come with formatting, macros and sample content. You can customize these Blueprints for each space. Everything created from a Blueprint will have its own index in the sidebar, so for example if you use the Meeting Notes Blueprint, you can select 'Meeting Notes' in the sidebar to see a list of all the meeting notes in your space.

Create from template macro

Make things simpler for other contributors by using the Create from Template Macro. The Create from Template Macro lets you put a button on a page that links to a specific template of your choice. When the button is clicked, the macro opens the editor, ready to add a new page, and adds content to that page based on the given template.

Create your own page templates

Create your own templates for any content that you want formatted the same way every time. For example, if you have to create a regular report tracking the same criteria, create a template with headings, variable dates, tables, and spaces for any graphics, so that each time all you have to do is input the new data instead of creating the whole report from scratch.

How do I help my team stay on top of what’s important?

If you’ve got a lot of content on Confluence, staying on top of everything may seem a little daunting – but these features will help your team save and track all the content they care about.

My Spaces

Add any spaces that you want to be able to navigate to easily to your list of ‘My Spaces’. This list can be found under your dashboard and in the Space Directory, and you can also use the Spaces List Macro to display it on a page or blog.

To add a space to your list of ‘My Spaces’, either navigate to that space or find it under the Space Directory, and select the star icon next to the Space Name. To remove it from the list, just select the star icon again.
Save for later

If you only want links to certain pages or blogs rather than a whole space, you can choose Save for later and these will appear on your dashboard and under your profile. You can use the Favorite Pages Macro to display a list of all of everything you’ve saved for later.

Watch a page, blog or space

If you want to keep track of all the changes made to a page, blog, or space, you can also watch them. Watching any content means that you will receive email notifications for all edits, deletions, attachments or comments made to that content.

- To watch a page, navigate to the page you want to watch, then choose Watch > Watch page, or if you want to watch the whole space, select Watch all content in this space.
- To watch a blog, navigate to that blog and choose Watch this blog.
- To stop watching something, deselect the relevant checkbox.

You can also manage watchers for your own space. This is useful when, for example, you’re creating a new project, and want the team members on that project to stay notified of its progress. Go to any page in that space and choose Watch > Manage Watchers, then add or delete any names under ‘Watching this space’.

@mentions
Use @mentions for any work where you need someone else's input or want to assign someone a task. Mentioning someone works like a tag; they'll immediately receive a notification that they've been mentioned, and can click through to that page or blog. If you mention someone when creating a task, it'll assign that task to them and they'll also be able to find it under their profile.

You can use this in place of emails – if you want someone to look something over, add in additional information, or approve anything, simply put that work on Confluence and assign it to them as a task. They'll be able to make any changes or comments within Confluence and let you know when they're done by mentioning you back.
Set up a Space Home Page

When you create a space, Confluence automatically creates a home page for that space. Spaces created with a blueprint come with a ready-made home page populated with useful macros and sample content specific to the blueprint's use case.

However, even if you've started with a blank space, you can still customize your home page to make it easier for everyone using that space to navigate their way around and find useful content.

Create a kick-ass home page

- **What is this space about?**
  Your home page is the first page visitors will see when they visit your space, so it helps to include some information about what the space is about, and what you’re working on. You can use the Info, Tip, Note, and Warning Macros to create a colored box in which to put this information.

- **What is in this space?**
  You can use the Content Report Table Macro to create a table of contents for your space. You can also set this macro to only display content with a particular label, so if you would like only some content to display, you can do this by adding that label to only those pages and blogs you want listed on your home page.

- **Organize your space with labels**
  You can organize content in your space with labels, so that for example, if you have a Learning and Development space, you can create different labels for online learning resources, upcoming workshops, and training strategy. You can then use the Labels List Macro to create a list of those labels to make it easy for visitors to your space to find the content relating to each of those topics.

- **Add a search box so that it’s easy to find content within your space**
  The Livesearch Macro allows you to add a search box to a Confluence page, and you can set it to only find content within your space.

- **Keep everyone updated about the latest changes within your space**
  If it's important for your visitors to know about the latest changes to your space, you can use the Recently Updated Macro to display a list of the most recently updated content. You can set the space parameter to show this for just your space, or, if you have related spaces, to show the most recently updated content across all of those spaces as well.

- **Using Jira? Create and display your Jira issues on Confluence**
  If your Confluence site is connected to a Jira application, you can both create and display your Jira issues without having to leave Confluence using the Jira Issues Macro. You can connect Confluence to any Jira application, including Jira Software and Jira Service Management.

On this page:

- Create a kickass home page
- Top macros for common types of spaces
- Set up your personal space home page
- Set another page as your home page

Related pages:

- Organize your Space
Top macros for common types of spaces

**Team Spaces:**

- **Introduce the team:** The User Profile Macro displays a short summary of a given Confluence user's profile with their role, profile photo and contact details.
- **Share news and announcements with your team:** The Blog Posts Macro displays a stream of your latest blog posts so your team can easily see what's been going on.

**Knowledge Base:**

- **Have external content that you need on your page?** Embed online videos, slideshows, photo streams, and more, directly into your page with the Widget Connector Macro.
- **Put your own multimedia content onto the page:** The Multimedia Macro embeds attached video, animation, and other multimedia files on a Confluence page.
- **Create an index of all your content:** The Page Index Macro creates a hyperlinked alphabetical index of all page titles within the current space.

**Planning/Project:**

- **Keep track of everyone's tasks:** Use the Task Report Macro to display a list of tasks on a page. Filter the tasks by space, page, user, label, created date and more.
- **Is your project on track?** The Status Macro displays a colored lozenge (a rounded box) that is useful for reporting project status. You can choose the color of the lozenge and the text that appears inside the lozenge.
- **Let everyone see where you’re going:** The Roadmap Planner Macro creates simple, visual timelines that are useful for planning projects, software releases and much more.
Using Macros

1. From the editor toolbar, select Insert > Other Macros
2. Find and select the required macro

Speed it up with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. In this example, we're inserting the cheese macro.

To edit an existing macro: Select the macro placeholder and choose Edit. This will open the macro details so you can edit the macro parameters.

Set up your personal space home page

Whether you're using your personal space as a sandbox to draft and test content, a portfolio to show off what you're working on, a home base to navigate to your content in other spaces, or something completely different, these are some macros that should help you use your space more effectively.

- Use the Favorite Pages Macro to create a list on your home page of all the pages you've saved for later, so you can easily navigate back to any of them.
- Use the Content by User Macro to keep track of all the current pages, comments and spaces you've created so you can find everything you've been working on in one place.
- Use the Task Report Macro to keep track of all tasks assigned to you, and tick them off as you finish them.
- Use the Recently Updated Dashboard Macro to keep track of all the content across your Confluence site that you're interested in - the Dashboard lets you choose which spaces, users, blogs, pages or files you would like to keep updated about.

Set another page as your home page

If at any point you decide that you would like another page within your space to be your home page, you can easily change this from the Edit Space Details tab.

To edit a space's details:

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar.
2. Choose Edit Space Details.
3. Enter the page you want use in the Home page field then choose Save.
You can change the home page, name and description of your space, but you are not able to change the space key.
Use Labels to Categorize Spaces

If you’ve got lots of related spaces, you can use labels to group them together into categories in the Space Directory.

For example, if you’re in an IT team who work on a number of projects, each in a different space, you could label each space 'IT-projects-open'. Then in the Space Directory you could select IT-projects-open to see all your current IT project spaces.

You can add as many space categories to a space as you need, so that if, for example, two different teams are working on a project together, you can add labels for both teams and space will appear under both categories.

Labels are easy to add or remove, so if your needs change, you can always recategorize your spaces.

Categorize a space

You need space administrator permissions to add categories to a space.

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar
2. Choose Edit next to Space Categories.
3. Under Space Categories, enter your category name and choose Add. Alternatively, choose a category in the list of Suggested Space Categories.
4. Choose Done.

Add a space description

Help make it easier to find the right space within a category by adding a description to your space:

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar.
2. Choose Edit Space Details.
3. Under the Description field, type a short description to tell visitors what your space is about, then choose Save.

View spaces in a category

To see what spaces are in a category, choose Spaces > Space directory in the Confluence header, then select one of the categories from the list.

You can also view spaces by category by using the Spaces List Macro and filtering by category.
Remove a space from a category

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar.
2. Choose Edit next to Space Categories.
3. Under Space Categories, choose the x icon next to each category that you want to remove.

If you remove all spaces from a category, the category will no longer appear in the Space Directory. There's no way to bulk remove a category, but you can choose the category in the Space Directory to find all the spaces it appears on, and then remove it from each space.

Search within a space category

You can search for content within a specific space category using the search filter.

To search within a Confluence space category:

1. Click the search field in the top-right of Confluence to open the search panel.
2. Click the Space category filter on the left.
3. Start typing the category name and choose from the list of possible matches.

Learn more about searching Confluence.
Customize your Space

Make your space stand out from the crowd by customizing its appearance.

If you have space admin privileges, you can change the color scheme for your space, add your own space logo, choose what shows up in your space’s sidebar, or use Atlassian Marketplace themes to change the whole look of your space.

- Configure the Sidebar
- Edit a Space’s Color Scheme
- Apply a Theme to a Space
- Customize Space Layouts
- Change the Space Logo

Related pages:
- Changing the Look and Feel of Confluence
- Styling Confluence with CSS
Welcome to the home of the Workplace Experience Team.
We're here to make your everyday AWESOME. We organise your lunches, fitness classes, special events and activities, keep the office supplied, and are constantly thinking of new ways to make working here even better.
Check out the links below to find out more!

What we're all about
We strongly believe that if we make your day better and more enjoyable, you'll be more productive, creative, and innovative.

Our mission
Make our workplace a safe, collaborative environment where everyone enjoys being in. We want to support you and help you feel both challenged, stimulated, and fulfilled. We think that by coming up with ideas that bring your fully dedicated to work, with a love of work, we can make your life easier and give you time to worry about.

The team

Quick Links
- New Employee?
- Start here!
- Policies
- Funding and Grants
- Workplace Experience
- Social Clubs

Upcoming Events
- 30 May 2015: The Great Morning Tea
- 1 Jun 2015: The Great Lunch
- 30 May 2015: The Great Evening Tea
- 21 May 2015: Bring your own lunch day!
Configure the Sidebar

If you have administration permissions for a space, you can customize the space's sidebar to have its own logo, change the way the hierarchy is displayed, and add shortcut links to help navigate to important content quickly.

To start configuring the sidebar, choose Space tools > Configure sidebar.

Change the space name and logo

To change the space name:

1. Choose next to the space name.
2. Type in a new space name and Save.

1. **Logo** - change the space name and logo  
2. **Reorder** - drag to reorder shortcuts  
3. **Hide** - hide or show pages, blogs, shortcuts or navigation display options.

To change the space logo:

1. Choose the next to the space name.
2. Choose Upload an image.
3. Select an image from your computer.
4. Adjust the size of the image to fit within the highlighted circle.
5. Choose Save.

Things you should know:

- Space logos are 48px x 48px. Logos smaller than these dimensions will be centred with whitespace around them.
- You can only change the space logo for a site space. For your personal space, your profile picture is used as the space icon.

Configure the sidebar links
- Choose the icons to show or hide pages, blogs, shortcuts or navigation options. For example, if you want your space to be used primarily as a blog you can hide the 'Pages' link.
- Add-ons such as Questions for Confluence may add other links in this section of the sidebar and you can also show or hide these.
- Choose Add link to add a shortcut link to the sidebar. This could be a link to an important page for your team, or to an external site.
- Drag links to reorder them within each section (you can't move a link from one section to another).

Change the navigation display options

- Choose Child pages to see the current page and its children in the sidebar.
- Choose Page tree to see the page tree for the entire space, expanded to the current page.
- You can also choose to completely hide the navigation display options and instead add the pages you want to be visible as shortcut links. Alternatively, you can remove the sidebar navigation altogether and use a Page Tree Macro or Children Display Macro on your homepage for navigation instead.

Adding custom content to a sidebar

You can further customize a sidebar using wiki markup to add custom content.

To add custom content to your sidebar:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar.
2. Choose Sidebar, Header and Footer.
3. Enter your custom content in the Sidebar field.

The sidebar, header and footer fields all use wiki markup, check our guide to wiki markup for help, or check out some common customizations below.

To add a search field to the sidebar add the following wiki markup for a search macro in the Sidebar field.

For the Livesearch Macro macro:

{livesearch}

For the Page Tree Search Macro macro:

{pagetreesearch}

To add a panel with some custom content to the sidebar add the following wiki markup for the Panel Macro in the Sidebar field:

{panel}This is some custom content to appear in the sidebar{panel}

To hide the default page tree and add your own, with additional parameters:

1. Add the wiki markup for the Page Tree Macro in the Sidebar field.
   The following example includes parameters to expand the top three levels of the page tree by default and include an Expand All and Collapse All link above the tree.
   
   {pagetree:root=Page Name|startDepth=3|expandCollapseAll=true}

2. Go to Space Tools > Configure sidebar.
3. Use the Show and Hide icons to hide the default page tree from the sidebar.
Edit a Space's Color Scheme

Spaces inherit the global color scheme by default, but if you have admin permissions for a space, you can jazz it up with your very own customizable color scheme.

To change the color scheme for a space:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar
2. Choose Color Scheme
3. Choose Select next to a scheme listed under Custom Color Scheme (if not already selected)
4. Choose Edit
5. Enter standard HTML/CSS2 color codes or use the color-picker to choose a new color from the palette provided

Customizable Elements

The color scheme allows you to edit the colors of UI elements including the top bar, tabs and backgrounds.

Some UI elements below are for specific themes, and color changes may not take effect for other themes.

- **Top Bar** - the top navigation bar background
- **Top Bar Text** - the text on the top navigation bar
- **Header Button Background** - buttons on the top navigation bar (e.g. Create button)
- **Header Button Text** - the text on buttons on the top navigation bar
- **Top Bar Menu Selected Background** - background color of top navigation bar menu items when selected (e.g. spaces)
- **Top Bar Menu Selected Text** - text color of top navigation bar menu items when selected
- **Top Bar Menu Item Text** - text on top navigation bar drop down menus (e.g. help or cog)
- **Menu Item Selected Background** - highlight color on top navigation bar drop down menu items
- **Menu Item Selected Text** - text color on highlighted top navigation bar drop down menu items
- **Search Field Background** - the background color of the search field on the header
- **Search Field Text** - the color of the text in the search field on the header
- **Page Menu Selected Background** - the background color of the drop down page menu when selected
- **Page Menu Item Text** - the text of the menu items in the drop down page menu
- **Heading Text** - all heading tags throughout the space
- **Links** - all links throughout the space
- **Borders and Dividers** - table borders and dividing lines

Related pages:
- Configure the Sidebar
- Apply a Theme to a Space
Handy Hint

If you mess things up, just choose Reset then try again.
Apply a Theme to a Space

Themes are used to change the appearance of your space. Your Administrator can download and install themes from The Atlassian Marketplace.

Once a theme is installed it can be applied to the whole site or to individual spaces.

To apply a theme to a space:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar.
   You'll need Space Admin permissions to do this.
2. Choose Themes and select a theme option.
3. Choose Confirm.

What is the global look and feel?

When a new space is created, whichever theme is applied to the whole site will be applied by default to the new space. This is the global look and feel, and any changes made globally will flow through to all spaces that inherit the global look and feel.

If a space has its own theme applied, or if changes have been made to customize the look and feel of the space, it will no longer inherit changes from the global look and feel.

If you want to go back to inheriting the global look and feel choose Global look and feel from the Themes page.

Related pages:

- Applying a Theme to a Site
- Customize your Space
- Edit a Space's Color Scheme
- Configure the Sidebar
Documentation theme migration FAQ

As previously announced, the documentation theme is not available in Confluence 6.0. We know you'll have a lot of specific questions, so we've created this FAQ to help you prepare for upgrading to Confluence 6.0.

If you have further questions, you can ask them at the bottom of the page and we'll do our best to provide an answer.

- What does the default theme look like?
- How can I check if I am using the documentation theme in my space?
- How can I check if the documentation theme is being used anywhere in my site?
- What will happen to my theme customizations during the upgrade?
- Will my space break after the upgrade?
- Can I add custom content to the sidebar, header and footer globally?
- Can I still use macros in my sidebar, header or footer?
- Where should I add custom content to the sidebar, header or footer?
- How do I turn off the Pages and Blogs shortcuts at the top of the sidebar?
- Can I edit the default theme's sidebar globally?
- I want to see the page tree, not child pages. how do I do this?
- Where is Space Administration and Space Operations?
- Do I have to use wiki markup in the sidebar, header, and footer?
- Can I hide or change the space logo appearance?
- Can I hide the built in page tree and insert my own?
- How can I make my page titles wrap in the sidebar?
- Can I change the order in which things appear in the sidebar?
- Can I still use the space jump macro?
- Why don't child pages appear below the page?
- Can I restrict search to just this space?
- How do I view the pages in my space alphabetically?
- What will happen if I import a space that uses the documentation theme?

What does the default theme look like?

Here's an example of the documentation theme, and default theme with the same custom content side by side:

1. Documentation theme: with custom sidebar content.
2. Default theme: with the same custom content in the sidebar.

How can I check if I am using the documentation theme in my space?
The easiest way to check whether your space is using the documentation theme is to look for a **Browse** menu in the header, near the **Create** button. (If you're using the default theme already, you'll see a Space Tools menu at the bottom of the sidebar instead.)

**How can I check if the documentation theme is being used anywhere in my site?**

There’s no simple way to see a list of spaces using the Documentation theme in Confluence itself, however if you have a very large site, your Confluence Administrator can use the following query to get a list of spaces directly from the database.

```sql
SELECT *
FROM BANDANA B, SPACES S
WHERE B.BANDANAKEY='atlassian.confluence.theme.settings'
AND S.SPACEKEY=B.BANDANACONTEXT
AND B.BANDANAVALUE LIKE ('%documentation%')
ORDER BY S.SPACENAME;
```

This query will only find spaces that are explicitly using the documentation theme. It doesn’t include spaces using the global look and feel (these spaces automatically change when you change the Site Theme, you won’t need to change the theme space by space).

**What will happen to my theme customizations during the upgrade?**

During the upgrade we’ll automatically turn on the default theme for any spaces that currently use the documentation theme. If you’ve customized the documentation theme (by adding wiki markup to the sidebar, header or footer) we’ll take this wiki markup and drop it into the sidebar, header and footer in the default theme.

The default theme adds some new sections to the sidebar, such as links to pages, blogs and space shortcuts. You can choose to hide these - head to **Space Tools > Configure Sidebar** and use the button to hide any items you don’t want to see.

**Will my space break after the upgrade?**

This depends on the amount of customization you have. In most cases your space sidebar may look a little different but the changes shouldn’t be dramatic.

If you’ve used CSS to change the appearance of your space (either in the space stylesheet or by using the Adaptavist Content Formatting macros like `{style}` and `{div}` in the sidebar, header, or footer of the documentation theme), you may need to make a few changes to some class names in your CSS to get your space looking right. For example, if you specified `#splitter-sidebar` in the doc theme, you’ll need to use `.acs-side-bar` for the default theme.

If you have customized default theme layouts through the Confluence UI, you may find that your space looks strange or broken when the default theme is re-applied to spaces previously using the documentation theme.

If you experience problems, you’ll need to reset the broken layouts.

This method will only work if you have more than one theme available in your site. You’ll need System Administrator global permission to do this.

1. **Switch to another theme temporarily.**
   If you’re unable to use the space navigation, use this URL, replacing YOURSPACEKEY with the space key for the space.

   ```
   http://<yoursite>/spaces/choosetheme.action?key=YOURSPACEKEY
   ```

2. **In the space administration options go to Layouts** (if available) or use the following link, replacing YOURSPACEKEY with the space key for the space.

   ```
   http://<yoursite>/spaces/listdecorators.action?key=YOURSPACEKEY
   ```
3. Choose **Reset Default** next to any template that have been customized.
4. Return to the **Themes** page and try applying the default theme again.

Layouts can also be customized for the entire site - head to Administration ➤ General Configuration ➤ Layouts if you need to reset the layout for the entire site. If you’re unable to reset the layouts via the Confluence UI, you can remove the affected layouts directly in the database. Be sure to take a full database backup before you try this.

First, use the following query to identify customized layouts:

```sql
SELECT *
FROM DECORATOR
ORDER BY SPACEKEY
```

Then, you can selectively remove records for spaces that are affected.

**Can I add custom content to the sidebar, header and footer globally?**

Yes. Head to Administration ➤ General Configuration ➤ Sidebar, Header and Footer. All spaces that use the global look and feel will inherit your custom content. Any custom content added to the sidebar, header and footer in a particular space will override any custom content added globally.

**Can I still use macros in my sidebar, header or footer?**

Yes! If a macro worked correctly in the documentation theme it’ll work in the default theme too.

**Where should I add custom content to the sidebar, header and footer?**

You can add custom content to the sidebar, header and footer in each space individually (Space Tools ➤ Look and Feel ➤ Sidebar, Header and Footer) or globally (Administration ➤ General Configuration ➤ Sidebar, Header and Footer).

Confluence displays global custom content in all spaces, except where a space has its own custom content defined (space custom content overrides global custom content). This behavior applies field by field, so a space can display a combination of custom content. For example you could define the content of a footer globally, and content of a header in each space individually, or only in some spaces.

**How do I turn off the Pages and Blogs shortcuts at the top of the sidebar?**

Go to Space Tools ➤ Configure Sidebar and use the ❌ icons to hide any items you don’t want to see.

**Can I edit the default theme’s sidebar globally?**

No. You can add custom content to the sidebar globally, but showing and hiding sections of the sidebar, setting space logos, and adding shortcut links are done on a space by space basis.

**I want to see the page tree, not child pages. how do I do this?**

Head to Space Tools ➤ Configure Sidebar and select Page Tree in the navigation options. The default for all new spaces is Page Tree.

**Where is Space Administration and Space Operations?**

Instead of choosing between Space Operations and Space Administration, the documentation theme has a single Space Tools menu that lets you jump right to Permissions, Content Tools, Look and Feel, or Integrations.

<table>
<thead>
<tr>
<th>Old Space Operations location</th>
<th>New Location in the sidebar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse &gt; Pages</td>
<td>Pages on the sidebar or Space Tools &gt; Reorder pages</td>
</tr>
<tr>
<td>Browse &gt; Blogs</td>
<td>Blogs on the sidebar</td>
</tr>
<tr>
<td>Browse &gt; Labels</td>
<td>Click a label on any page, then use the menu to see all labels, popular labels or pages from other spaces</td>
</tr>
<tr>
<td>Browse &gt; Space Operations &gt; Space Details</td>
<td>Space Tools &gt; Overview</td>
</tr>
<tr>
<td>Browse &gt; Space Operations &gt; Orphaned Pages</td>
<td>Space Tools &gt; Content Tools &gt; Orphaned Pages</td>
</tr>
<tr>
<td>Browse &gt; Space Operations &gt; Undefined Pages</td>
<td>Space Tools &gt; Content Tools &gt; Undefined Pages</td>
</tr>
<tr>
<td>Browse &gt; Space Operations &gt; Attachments</td>
<td>Space Tools &gt; Content Tools &gt; Attachments</td>
</tr>
<tr>
<td>Browse &gt; Space Operations &gt; PDF, HTML, XML Export</td>
<td>Space Tools &gt; Content Tools &gt; Export</td>
</tr>
<tr>
<td>Browse &gt; Space Operations &gt; RSS Feeds</td>
<td>Space Tools &gt; Content Tools &gt; RSS Feeds</td>
</tr>
<tr>
<td>Browse &gt; Space Operations &gt; Watch this space</td>
<td>Pages &gt; Watch this space (or use the Watch button on any page)</td>
</tr>
<tr>
<td>Browse &gt; Space Operations &gt; Watch this blog</td>
<td>Blogs &gt; Watch this blog (or use the Watch button on any blog post)</td>
</tr>
<tr>
<td>Browse &gt; Space Operations &gt; Remove from My Spaces</td>
<td>Use the icon in the sidebar (or in the space directory)</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; Space Details</td>
<td>Space Tools &gt; Overview</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; Space Categories</td>
<td>Space Tools &gt; Overview</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; Templates</td>
<td>Space Tools &gt; Content Tools &gt; Templates</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; Delete Space</td>
<td>Space Tools &gt; Overview &gt; Delete Space</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; Trash</td>
<td>Space Tools &gt; Content Tools &gt; Trash</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; Permissions</td>
<td>Space Tools &gt; Permissions</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; Restricted Pages</td>
<td>Space Tools &gt; Permissions &gt; Restricted Pages</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; Application links</td>
<td>Space Tools &gt; Integrations &gt; Application Links</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; Themes</td>
<td>Space Tools &gt; Look and Feel &gt; Themes</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; Color Scheme</td>
<td>Space Tools &gt; Look and Feel &gt; Color Scheme</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; PDF Layout</td>
<td>Space Tools &gt; Look and Feel &gt; PDF Layout</td>
</tr>
<tr>
<td>Browse &gt; Space Admin &gt; PDF Stylesheet</td>
<td>Space Tools &gt; Look and Feel &gt; PDF Stylesheet</td>
</tr>
</tbody>
</table>
Do I have to use wiki markup in the sidebar, header, and footer?

Yes. Our main focus when adding this feature was to help people move from the documentation theme to the default theme with a minimum of effort. Keeping these fields as wiki markup means that your existing customizations can be pasted straight in.

Can I hide or change the space logo appearance?

You can upload any image to use as your space logo, but you can't change how it appears in the sidebar (it's always round and always at the top).

Can I hide the built in page tree and insert my own?

Yes! If you want to have complete control over how the page tree appears in your sidebar you can hide the built in page tree, and then add a Page Tree macro `{pagetree}` in the sidebar custom content.

How can I make my page titles wrap in the sidebar?

Page titles do not wrap in the sidebar of the default theme (regardless of whether you're using the built in page tree or have added a │macro as custom content). There's no way to change this.

Can I change the order in which things appear in the sidebar?

You can change the order of some items in the sidebar, such as the shortcuts, but the order of the sections themselves can't be changed. Anything that has a │icon can be moved.

Custom content appears above the page tree. You have the option to hide the built in page tree, and then add it back in the custom content area using wiki markup. This can be useful if you want more control over the order of the page tree and your custom content.

Can I still use the space jump macro?

No, the space jump macro was provided by the documentation theme and will not be available once the documentation theme is removed. If you've used this macro on a page or in the header or footer of a space, it will show the following error after the upgrade unknown macro: `{spacejump}`.

To find out whether the Space Jump macro is used on any pages in your site, enter `macroName:spacejump` into the search bar. All pages containing the macro will be returned (it won't search the sidebar, header or footer unfortunately).

Why don't child pages appear below the page?

The default theme does not list child pages below the sidebar, but you can achieve a similar result by adding a │Display macro to the footer.

Can I restrict search to just this space?

No, that is one of the features we removed with the documentation theme.

One workaround is to add a Livesearch macro to the sidebar or space homepage. Use @self in the spaces parameter to restrict the search to the current space.

How do I view the pages in my space alphabetically?

The default theme does not have an option to view all pages in your space alphabetically.

What will happen if I import a space that uses the documentation theme?
You should have no problems importing the space, but it will have the default theme applied and any wiki markup customization in the theme will not be automatically migrated to the default theme. Before exporting the space you should copy the wiki markup contents of the sidebar, header, and footer fields and keep it so that you can add it back in manually after you've successfully imported your space.
Customize Space Layouts

You can modify Confluence's look and feel by editing the layout files. This page tells you how to customize the layout files for a space. You'll need the system administrator global permission plus space administrator permission for that space.

People with system administrator permissions can also customize the layout of the entire Confluence site. For more information, see Customizing Site and Space Layouts. Site layout customizations modify the default layout of all spaces in the Confluence site.

Any space layout customizations will override the equivalent site customizations.

If you modify the look and feel of Confluence by following these instructions, you'll need to update your customizations when you upgrade Confluence. The more dramatic the customizations are, the harder it'll be to reapply your changes when upgrading. Please take this into account before proceeding with any customizations.

For more information on updating your customizations, please refer to Upgrading Customized Site and Space Layouts.

Confluence is built on top of the Open Source SiteMesh library, a web-page layout system that provides a consistent look and feel across a site. SiteMesh works through 'decorators' that define a page's layout and structure.

To edit the layout of Confluence, you will need to modify these decorator files. A decorator file is a .vmd file and is written in a very simple programming language called Velocity. Learn more about Velocity. Once you become familiar with Velocity, you can edit the decorator files to personalize the appearance of Confluence.

The decorator files in Confluence are grouped into the following categories:

- **Site layouts**: These are used to define the controls that surround each page in the site. For example, if you want to make changes to the header and the footer, you will need to modify these layouts.

- **Content layouts**: These control the appearance of content such as pages and blog posts. They do not change the way the pages themselves are displayed, but they allow you to alter the way the surrounding comments or attachments are shown.

- **Export layouts**: These control the appearance of spaces and pages when they are exported to HTML. If you are using Confluence to generate a static website, for example, you will need to modify these layouts.

Learn more about using decorators.

**To edit a decorator file:**

1. Go to the space and choose **Space tools > Look and Feel** from the bottom of the sidebar
2. Choose **Layout** (Layout is displayed only if you are a Confluence system administrator.)
   You'll see a list of the layouts for the space
3. Click **Create Custom** to edit the default vmd file
   This will open up the vmd file in edit mode. If you only want to view the vmd file, click **View Default**.
4. Make any changes and click **Update**
Content Layouts

Content layouts control the appearance of content such as pages and blog posts: they don't change the way the pages themselves are displayed, but they allow you to alter the way the surrounding comments or attachments are shown.

<table>
<thead>
<tr>
<th>Decorator</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space Layout</td>
<td>&lt; default &gt; · Create custom · View Default</td>
</tr>
<tr>
<td>Page Layout</td>
<td>&lt; default &gt; · Create custom · View Default</td>
</tr>
<tr>
<td>Blog Post Layout</td>
<td>&lt; default &gt; · Create custom · View Default</td>
</tr>
</tbody>
</table>
Change the Space Logo

In Confluence, you can replace the default space logo with an image of your choice. If you have team spaces, you can use an icon that represents the team, or if it’s a space for a client, add their company logo to really impress them.

The instructions below apply to site spaces. For your personal space, your profile picture is used as the space icon.

You need to be a space admin to replace a space's logo.

To change a space's logo:

1. Go to the space and select Space tools > Configure sidebar from the bottom of the sidebar
2. Select the edit icon next to the space name to edit space details
3. Select Upload an image
4. Add an image from your computer
5. Adjust the size of the image to fit within the highlighted circle
6. Select Save

Notes

- **Minimum dimensions**: Space logos are set at 48 x 48px. Logos less than these dimensions will be centred with whitespace around them.
- Space logos in the default theme are square. Personal space logos are circular.
- **Dimensions of image when using the Documentation theme**: The documentation theme does not provide an option to resize or crop your image. Uploading a square image will give the best results.
You can copy the content and settings of public and personal spaces across your Confluence instance. The ability to copy spaces provides you with full control, growth, and maintenance of the content that you’re storing in Confluence. Plus, scaling up your instance will become easier and smoother.

You must be a **Confluence administrator** or **space administrator** to copy spaces. Also, you must have the **Create space** permission. Learn more about the Confluence permissions in Permissions and restrictions.

If you want to copy a **personal space**, you must either be its owner or have administrative permissions for it.

### What will be copied from a space?

An existing space is always copied into a new space that Confluence creates automatically. The new space should have a name, a unique space key, and optionally, a description.

Not all the content and settings of your space will be duplicated in the new space. From the following table, you’ll find out what will be copied by default, what won’t be copied, and what’s optional to copy.

<table>
<thead>
<tr>
<th>Content or setting</th>
<th>Will it be copied by default?</th>
<th>Additional notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space description</td>
<td>Yes</td>
<td>You can change the description when configuring the copy.</td>
</tr>
<tr>
<td>Space permissions</td>
<td>Yes</td>
<td>N/A</td>
</tr>
<tr>
<td>Space templates</td>
<td>Yes</td>
<td>N/A</td>
</tr>
<tr>
<td>Space look and feel</td>
<td>Yes</td>
<td>All the look and feel configurations will be copied by default, including the space header, sidebar, footer, and PDF stylesheets.</td>
</tr>
<tr>
<td>Feature</td>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Archived spaces</td>
<td>Yes</td>
<td>N/A</td>
</tr>
<tr>
<td>Restrictions</td>
<td>Yes</td>
<td>N/A</td>
</tr>
<tr>
<td>Sidebar links</td>
<td>Yes</td>
<td>N/A</td>
</tr>
<tr>
<td>Shortcut links</td>
<td>Yes</td>
<td>N/A</td>
</tr>
<tr>
<td>Links in pages, blog posts, and comments</td>
<td>Yes</td>
<td>The following links in the original space will be copied:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To other pages in the space that you’re copying</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To other pages in other spaces</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To blog posts in the space that you’re copying</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To blog posts in other spaces</td>
</tr>
<tr>
<td>Mentions</td>
<td>Yes</td>
<td>All mentions with the @ character will be copied but the mentioned users</td>
</tr>
<tr>
<td></td>
<td></td>
<td>won’t be notified about that in an email. They also won’t see any</td>
</tr>
<tr>
<td></td>
<td></td>
<td>notifications under the notification (bell) icon.</td>
</tr>
<tr>
<td>Pages</td>
<td>Optionally</td>
<td>All current versions from the original hierarchy are copied.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If the original space has a home page, it’ll be copied too.</td>
</tr>
<tr>
<td>Blog posts</td>
<td>Optionally</td>
<td>All current versions from the original hierarchy are copied.</td>
</tr>
</tbody>
</table>

**i** Copying of pages is audited in your Confluence instance. If any other option is selected for copying (for example, comments or attachments), the additional parameters will show this to you in the audit.

**i** Copying of blog posts is audited in your Confluence instance. If any other option is selected for copying (for example, comments or attachments), the additional parameters will show this to you in the audit.
<table>
<thead>
<tr>
<th>Existing authors and dates</th>
<th>Optionally</th>
</tr>
</thead>
<tbody>
<tr>
<td>Here’s how the authors and dates of the content from the original space will be set in the new space depending on whether you select this option or not:</td>
<td></td>
</tr>
</tbody>
</table>

If you copy pages and use existing authors and dates, the original page authors and dates of page creation and last update will be preserved in the new space.

If you copy pages but don’t use existing authors and dates:

- You’ll be assigned as an author to all pages in the new space.
- The current date when you’re copying the space will be set as a creation date for all pages in the new space.

If you copy blog posts, their original authors and dates of creation and last update will always be preserved in the new space, regardless of whether you use existing authors and dates or not.
If you copy comments along with pages or blog posts, the original authors and creation dates of all comments will always be preserved in the new space, regardless of whether you use existing authors and dates or not.

Only page attachments are affected if you choose to copy existing authors and dates:

- If you select the option, the attachments copied to the new space will keep the original users who uploaded them and the original dates of the uploads.
- If you don’t select the option, you’ll be set as a user who attached files to pages. The date when you’re copying the space will be set as a creation date for the attachments.

For blog post and comment attachments, the new space will always display the original users who attached files and the original dates when files were attached, regardless of whether you use existing authors and dates or not.

ℹ️ If you copy attachments but don’t copy comments, comment attachments will still be copied to the new space. You’ll find them in Attachments of a page or blog post.

If you use existing authors and dates:

- The original creator of the space you’re copying will be set as the creator of the new space.
- The original date when the space you’re copying was created will be set at the creation date of the new space.

If you don’t use existing authors and dates:

- You’ll be set as the creator of the new space.
- The date when you’re copying the space will be set as the creation date of the new space.
| **Comments** (page comments, blog post comments, inline comments, resolved comments, pinned comments on attachments) | Optionally | If you copy comments along with pages or blog posts, all comments will be copied to the new space. The original authors and creation dates of all comments are always preserved in the new space, regardless of whether the **Existing authors and dates** option has been selected.

> For both pages and blog posts, if you copy comments but don’t copy attachments, comment attachments won’t be copied. You’ll see the **Unknown Attachment** labels instead of files.

> If you copy comments and attachments, pinned comments on attachments will also be copied. |

| **Attachments** | Optionally | If you copy attachments along with pages or blog posts, all files attached to them will be copied to the new space.

For page attachments, the copy depends on whether you use existing authors and dates along with attachments or not:

- If you use existing authors and dates, the original users who uploaded attachments and the original dates when the files were uploaded will be preserved in the new space.
- If not, in the new space, you’ll be set as a user who uploaded attachments. The date when you’re copying the space will be set as the creation date for these attachments.

For blog post and comment attachments, the new space will always display the original users who attached files and the original dates when files were attached, regardless of whether you use existing authors and dates or not.

> If you copy attachments but don’t copy comments, comment attachments will still be copied to the new space. You’ll find them in Attachments of a page or blog post.

> If you copy attachments with comments, pinned comments on attachments will also be copied. |

| **Space labels** | Optionally | N/A |
| **Labels on pages and blog posts** | Optionally | N/A |
| **Attachment labels** | Optionally | N/A |
| **Watchers** | Optionally | Watchers include users who are watching:
- Existing pages and blog posts in the space you’re copying.
- New blog posts in the space you’re copying.
- The space you’re copying. |
<table>
<thead>
<tr>
<th>Space status favorite</th>
<th>No</th>
<th>A space acquires the favorite status when you star it and it's added to the list of your selected spaces.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drafts</td>
<td>No</td>
<td>N/A</td>
</tr>
<tr>
<td>Page and blog post history</td>
<td>No</td>
<td>N/A</td>
</tr>
<tr>
<td>Page and blog post likes</td>
<td>No</td>
<td>N/A</td>
</tr>
<tr>
<td>Comment likes</td>
<td>No</td>
<td>N/A</td>
</tr>
<tr>
<td>Comments on attachments</td>
<td>No</td>
<td>N/A</td>
</tr>
<tr>
<td>Page and blog post watchers</td>
<td>No</td>
<td>N/A</td>
</tr>
<tr>
<td>Team Calendars</td>
<td>No</td>
<td>N/A</td>
</tr>
<tr>
<td>Confluence Questions</td>
<td>No</td>
<td>N/A</td>
</tr>
</tbody>
</table>

**Known limitations**

The following technical limitations were put in place to prevent errors and failures that may occur otherwise:

- You can copy only one space at a time. You should repeat the procedure for each space that you want to copy.
- You can copy spaces within only one Confluence instance. Copying spaces between different instances isn’t possible.
- A copy is created in one long-running operation. Check the progress bar to find out about the status of the operation.
- From one branch of pages in the original space tree, only 2000 pages can be copied at a time. If the branch contains more than 2000 pages, the rest of the pages won’t be copied and the copying will stop.
  - This limitation doesn’t apply to blog posts as well as to the case where no branch in the original space contains more than 2000 pages.
- Once space copying has started, you can’t cancel it. You should wait until the operation is completed to see the result.
- Other users shouldn’t make changes to a space that is being copied. Making changes to the content while a copy is in progress may cause the operation to fail.
- Only the latest version of a page and blog post is copied.
- Third-party apps, like Scaffolding Forms & Templates, aren’t copied.
- The copy operation can be a few times slower if Confluence uses Amazon S3 storage to store attachments. We recommend using a filesystem (FS) storage if you want to run copies more quickly.

**Copying a space**

⚠️ Before copying a space, make sure you’ve informed other users that they shouldn’t make any changes to this space until you finish copying it. Any changes they make may cause the copying to fail.

We recommend that you notify other users in advance, copy the space when the activity in your instance is low, or temporarily restrict access to the space you want to copy.

The space you’re copying will also display a banner notifying other users about the copy operation and asking them not to make any changes to the space until the copy is completed. As soon as the space is copied, the banner will disappear.

To copy the content and settings of an existing space:

1. Go to the space that you want to copy.
2. Select **Space tools > Overview > Copy Space.**

### Space Tools

**Overview** | Permissions | Content Tools | Look and Feel | Audit log | Integrations

**Copy this space**

Duplicate the content or settings from this space to a new space. Learn more about copying a space.

#### Configuration

Select what you want to copy:

- **Pages and blogs**
- **Include watchers**
  - These include watchers of pages, blogs, and the space
- **Existing authors and dates**
- **Comments**
- **Attachments**
- **Labels**

#### New space details

By default, the following fields use the details of the current space. You can edit them for the new space.

- **Name of new space**
  - Product Documentation Copy
- **New space key**
  - PDC
- **Description**
  - This is a space for our internal product documentation

Click **Copy**

3. Select what you want to copy:
   - **Pages and blogs** – both pages and blog posts will be copied to the new space.

   Page and blog copying is **audited** in your Confluence instance. If any other option is selected for copying (for example, comments or attachments), the additional parameters will show this to you in the audit.

   - **Pages only** – only pages will be copied to the new space.
   - **Blogs only** – only blog posts will be copied to the new space.
   - **Space settings only** – the new space will be created with all the settings from the original space, like permissions, templates, look and feel, etc.
     - **i.** The new space won’t have any pages, including a home page, or blog posts.
     - **ii.** You can also select to copy the original creator of the space, the original date when it was created, and the original space labels.
     - **iii.** If you don’t copy the original space creator and creation date, you’ll be set as a creator of the new space, and the current date when you’re copying the space will be set as the creation date of the new space.

4. If you’re copying pages, blog posts, or both, choose what other content you want to copy.
### Content option | What you should know
---|---
**Include watchers** | If you want to copy watchers, keep the checkbox selected. If not, clear the checkbox.

**Existing authors and dates** | If selected, the option applies only to original authors and dates of pages and page attachments. 

Original authors and dates are always preserved in the new space for blog posts, comments, blog post attachments, and comment attachments.

If you want to keep the original authors of pages and original dates of page creation and last update, keep the checkbox selected.

If you don’t want to keep the original authors and dates, clear the checkbox. In this case:

- You’ll be set as the creator of the new space.
- In the new space, you’ll be assigned as the author of all pages and page attachments (if you choose to copy attachments).
- The current date when you’re copying the space will be set as the creation date for the new space, all pages in it, and all page attachments (if you choose to copy attachments).

**Comments** | If you want to copy comments, keep the checkbox selected. All comments will be copied for pages or blog posts, depending on what you want to copy.

The original authors and creation dates of all comments are always preserved on all pages and blog posts in the new space, regardless of whether the **Existing authors and dates** option has been selected.

If you don’t want to copy comments, clear the checkbox.

**Attachments** | If you want to copy attachments, keep the checkbox selected.

- Only page attachments are affected if you select **Existing authors and dates**:
  
  - If you select the option, the attachments copied to the new space will keep the original users who uploaded them and the original dates of the uploads.
  - If you don’t select the option, you’ll be set as a user who attached files to pages. The date when you’re copying the space will be set as a creation date for the attachments.
  - For blog post and comment attachments, the new space will always display the original users who attached files and the original dates when files were attached, regardless of whether you select **Existing authors and dates** or not.

If you don’t want to copy attachments, clear the checkbox.

- If you copy attachments but don’t copy comments, comment attachments will still be copied to the new space. You’ll find them in **Attachments** of a page or blog post.

**Labels** | If you want to copy labels, keep the checkbox selected. If not, clear the checkbox.

5. In the **Name of new space** field, edit the name of the new space.
6. In the **New space key** field, edit the key of the new space.
7. In the **Description** field, enter the description of the new space.
8. Select **Copy**.

To track the progress and status of the copy operation, check the progress bar.
Yes, you can. The copy operation will continue and the progress bar will display changes even if you leave or refresh the page.

While you’re copying the space, other users can copy it too. At the same time, the space will display a banner notifying other users about the copy operation and asking them not to make any changes to the space until the copy is completed. As soon as the space is copied, the banner will disappear.

As the initiator of the copy, only you can monitor its progress.

When the copy operation is completed, the success message will display on the page. The message will contain a link to the new space.

If something goes wrong, check the reason and solution for the issue in Troubleshooting or reach out to Atlassian Support.

Performance tests

To find out how much time it takes for the copy operation to complete, check our performance test calculations.

<table>
<thead>
<tr>
<th>Number of pages</th>
<th>Number of blog posts</th>
<th>Total quantity/size (Mb) of attachments</th>
<th>Duration (h:mm:ss)</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>100</td>
<td>190/944.3 Mb</td>
<td>0:02:05</td>
</tr>
<tr>
<td>3000</td>
<td>3000</td>
<td>6000/180 Mb</td>
<td>0:16:32</td>
</tr>
</tbody>
</table>

In both tests, copying attachments took about 50% of the total time that the entire space took to copy. This means that if your space has more attachments, copying it might take longer.

The average time for copying one page is up to 1 second. We’re working on improving the performance in future versions.

⚠️ The copy operation can be a few times slower if Confluence uses Amazon S3 storage to store attachments. We recommend using a filesystem (FS) storage if you want to run copies more quickly.

Troubleshooting

Is there anything you can’t copy? Has the space copying failed? Look for answers and solutions here. If we haven’t listed your issue, reach out to Atlassian Support.

After the copy has been created, you can add anything to it without worrying about any issues. The content you add will be available only in the new space.

Yes, you can. In your new space, you can do the same thing you’d do if you created a space from scratch. In this case, creating the copy might fail. Try to contact a person who’s making changes in the space and ask them to wait until you copy it successfully.

We recommend that you notify other users in advance, copy the space when the activity in your instance is low, or temporarily restrict access to the space you want to copy.

Despite the failure, part of the original space might be copied. We recommend that you delete the partial copy and retry copying the original space.

The space you’re copying will also display a banner notifying other users about the copy operation and asking them not to make any changes to the space until the copy is completed. As soon as the space is copied, the banner will disappear.

To solve the issue, check the following causes:

- The space you’ve copied doesn’t have a home page. In this case, the new space won’t have a home page either.
- You’ve selected to copy only the settings of the original space. In this case, the original home page won’t be copied and neither will other original pages and blog posts.
• Something went wrong during the copy operation. In this case, delete the new space and copy the original space again.

Someone might have revoked your **Create space** permission or administrative permissions. Check your permissions and contact your Confluence admin for assistance. The following table lists the reasons why some links don’t work in the new space after the copying. You’ll also find the solutions for some issues that you can fix yourself.

<table>
<thead>
<tr>
<th>#</th>
<th>Case</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Something went wrong during the copy operation.</td>
<td>Delete the new space and copy the original space again.</td>
</tr>
<tr>
<td>2</td>
<td>In the new space, an undefined link on a blog post redirects you to a new empty page.</td>
<td>This is a known issue we’re working on. It occurs when you copy blog posts but not copy pages. In this case, you’ll be redirected to a new empty page in the original space from a link on a blog post in the new space because Confluence detects this link as <strong>undefined</strong>.</td>
</tr>
</tbody>
</table>

The following table lists the reasons and solutions for failures during the copy operation.

<table>
<thead>
<tr>
<th>#</th>
<th>Reason</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Someone has made changes to the space you’re copying.</td>
<td>Despite the failure, part of the original space might be copied. Delete the partial copy and retry copying the original space.</td>
</tr>
<tr>
<td>2</td>
<td>Someone has deleted the space you’re copying.</td>
<td>Search for the original space by its name. If you find the space, try copying it again. If not, a system administrator can restore the deleted space.</td>
</tr>
<tr>
<td>3</td>
<td>A branch of pages in the original page tree contains more than 2000 pages.</td>
<td>This is a known limitation in Confluence. From one branch of pages in the original space tree, only 2000 pages can be copied. If the branch contains more than 2000 pages, the rest of the pages won’t be copied and the copy operation will stop. This limitation doesn’t apply to blog posts as well as to the case where no branch in the original space contains more than 2000 pages.</td>
</tr>
<tr>
<td>4</td>
<td>There’s not enough memory or disk space to complete the copy.</td>
<td>Try clearing the memory or disk space and copy the original space again.</td>
</tr>
</tbody>
</table>

Even if your internet connection has dropped, the copy operation will continue in the background. A notification about this will appear on the page instead of the progress bar. As soon as the connection is restored, the progress bar will update to display the latest status of the copy operation.
You might have not selected the **Attachments** option when copying your space. You can delete the new space and repeat the copy operation with the option selected.

To enable logs, follow the guidelines from the section *Add logging for an additional class or package* of the document on [logging configuration](#).

In the **Class/Package name** field, enter `com.atlassian.confluence.plugin.copyspace`. 
Archive a Space

Archiving a space is useful when you have content that is no longer relevant, but you still want the option of accessing it at a later date. Archived spaces are less visible, but still available on your site. Archiving a space is easy to undo — you can make a space current again at any time.

Archive a space

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar.
2. Choose Edit Space Details.
3. Select Archived in the Status dropdown menu.
4. Choose Save.

The effect of archiving a space

Spaces

If a space is archived, that space:

- Won't appear in the Recent spaces section of the search panel.
- Won't appear in search results, unless you select Search archived spaces.
- Won't appear in advanced search results unless you select Search archived spaces.
- Won't appear on the Spaces dropdown menu.
- Won't appear in the general spaces lists in the Space Directory, but will instead appear under the Archived Spaces list. It will, however, still appear under any categories it was labeled with.
- Won't show up in activity streams when updated.
- Won't appear on your dashboard.

Pages

Pages within an archived space will appear in a few places.

If you view a page within an archived space, that page will appear in:

- The Recently visited section of the search panel.
- The Recently viewed pages menu.

If you edit a page within an archived space, that page will appear in:

- Activity streams
- The Recently updated macro.

Pages within an archived space won't appear in search results, unless you select Search archived spaces.

These functions remain available for archived spaces:

- You can view the content as usual, by following a link or typing in a URL belonging to the archived space.
- You can edit the content as usual, as determined by the space permissions.
- RSS feeds, watches and notifications remain active.
Archiving a space has no effect on search results of external search engines. For example, a public space will still appear in Google search results.

Change a space from archived to current

Through the space directory:

1. Go to **Spaces > Space directory** in the header.
2. Choose **Archived Spaces** on the left.
3. Find your space and click the **i** on the right.
4. Choose **Edit Space Details**.
5. Change the **Status** from 'Archived' to 'Current' and hit **Save**.

Through the archived space:

1. If you know the **space key**, you can navigate straight to the archived space - [http://yoursite/display/SPACEKEY](http://yoursite/display/SPACEKEY)
2. Choose **Space tools > Overview** from the bottom of the sidebar.
3. Choose **Edit Space Details**.
4. Change the **Status** from 'Archived' to 'Current' and hit **Save**.

![Edit Space Details](image)
Delete a Space

Deleting a space permanently removes the space and all of its contents, including any calendars and questions linked to that space. Only someone with space admin permissions can delete that space.

⚠ Deleting a space is permanent – it does not go to the trash and cannot be undone.

If you're unsure about deleting a space, create an XML export of the space as a backup before proceeding. You can then restore the space from the XML export file if you need to.

To delete a space:

1. Go to the space and choose Space Tools > Overview from the bottom of the sidebar.
2. Choose Delete Space.
3. Choose OK.

Related pages:
- Archive a Space
- Export Content to Word, PDF, HTML and XML

Members of the confluence-administrators group can also delete spaces, including personal spaces.
Export Content to Word, PDF, HTML and XML

You can export all or part of a Confluence space to various formats, including Microsoft Word, HTML, PDF and XML.

To use the space export functionality, you need the ‘Export Space’ permission. See the guide to space permissions.

Export single pages to PDF

If you need to send content to people who don't have access to Confluence, you can export a single page or blog post as a PDF.

If you've got permission to view the page in Confluence, you'll be able to export it in this way; go to the page and choose ***(Tools) > Export to PDF***.

Only published content is exported. This means you can create PDF exports even while people are still working on the page.

When you export a single page to PDF, the PDF stylesheet customizations are applied, but any PDF layout customizations are not. To make your PDF layout customizations apply to a single page exported to PDF, you'll need to use the 'multiple page' method described below to export the single page. See Customize Exports to PDF.

Export single pages to Word

You can also choose to export single pages to a .doc file that can be opened in Microsoft Word.

If you've got permission to view the page in Confluence, you'll be able to export it in this way; go to the page and choose **(Tools) > Export to Word**.

Only published content is exported. This means you can create Word exports even while people are still working on the page. Also, only the first 50 attached images will be included in the export. See the notes below for more information.

Note that due to the format of this file, it can only be opened in Microsoft Word and is not compatible with other applications such as Open Office, Libre Office or Google Docs.

Export multiple pages to HTML or PDF

If you want to export a space – or selected pages in a space – to HTML or PDF, Confluence can create a zipped archive of the HTML, or a single, downloadable PDF file.

PDF export is useful you're producing a printable user manual from your documentation space for example. The HTML export can be used to convert your site content to a static website.

To export pages to HTML or PDF:

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Select **Export**
3. Select one of the following formats:
   a. **HTML** – export an HTML file containing only the pages you have permission to view. With this format, you have two options:
      - **Normal Export** – generate an HTML file for each page in the space, except for blogs, comments, and attachments.
      - **Custom Export** – generate an HTML file of only the pages you've selected.
b. **PDF** – export a PDF file containing only the pages you have permission to view. With this format, you have two options:
   - **Normal export** – generate a PDF file for each page in the space, except for blogs, comments, and non-image attachments.
   - **Custom export** – generate a PDF file of selected pages excluding any comments.

For normal export and custom export, you can also choose to **Include Pages Numbers** at the bottom of every page in your PDF.

4. Review your selection, and select **Export**.

You can download the zipped archive or PDF when the export process has finished.

**Export (back up) multiple pages to XML**

If you want to export a space as an XML, Confluence can create a zipped archive of the XML.

XML space exports can be used to import your space content into another Confluence space running the same or newer version of Confluence.

**To export pages to XML:**

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar.
2. Select **Back up** – an XML export contains every page, blog posts, comment, and attachment in the space, but excludes blog posts.
3. Under **Save to restore directory**, you can:
   a. Give your XML export a **file name** (optional).
   b. Select **Save permanently** if you want to keep your file on the server, otherwise, all space backups are only temporarily saved to your `<home-directory>/restore/space`, where `<home-directory>` is `<shared-home-directory>` for Confluence Data Center. You’ll need access to the server to retrieve the file this way.
4. Select **Back up**

You can download the exported XML backup by selecting the file name when the export process has finished.

**What’s included in the export?**

The following content is included in space exports.

<table>
<thead>
<tr>
<th></th>
<th>PDF export</th>
<th>HTML export</th>
<th>XML export (backup)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pages</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Blogs</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Comments</td>
<td>No</td>
<td>Optional</td>
<td>Yes</td>
</tr>
<tr>
<td>Attachments</td>
<td>Images only</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Unpublished changes</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Page numbers</td>
<td>Optional</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>Restricted pages and blog posts</td>
<td>Only those you can view</td>
<td>Only those you can view</td>
<td>Yes, they remain restricted</td>
</tr>
</tbody>
</table>

**Customizing the appearance of PDF exports**

You can add a title page, table of contents, and customized headers and footers to the PDF output. For more advanced customizations, you can apply Cascading Style Sheet (CSS) modifications. These customizations are specific to each space, and you need the ‘Space Administrator’ permission to apply these customizations. For more information, see **Customize Exports to PDF**.
Notes on PDF exporting

- To export a PDF containing international text, see Create a PDF in Another Language
- Confluence's PDF export feature is designed to handle a wide variety of content, but on rare occasions the PDF Export process may fail due to an unrecognized customization. If that happens, the PDF export screen will indicate the title of the page in which the problem occurred, to help you diagnose the cause of the failure.
- Tables that exceed the width of a page, particularly those with images in them, might be cut off in the PDF. See Wide tables are cut off in PDF exports for some suggested workarounds.
- In Confluence Data Center, PDF exports are handled by the external process pool.

Notes on Word exporting

- Only the first 50 images attached to the page are exported to your Word document. This is to prevent out of memory errors affecting your whole Confluence site. See CONFSERVER-34211 - If a page with big number of images Exported to Word, some images are invisible for more information, and to find out how you can temporarily increase this limit using a system property.

Notes on HTML exporting

- In the zip file, page attachments are placed in individual folders with names in the following format: ...\download\attachments\xxxxxx
  where 'xxxxxx' is the page ID of the page containing the attachments.
- To customize the HTML output, you'll need to modify the file confluence-x.y.z-jar/com/atlassian/confluence/pages/Page.htmlexport.vm. To learn how to repackage this file, see How to Edit Files in Confluence JAR Files

Notes on XML exporting (backup)

- When you create a space backup, it doesn't mean it will start immediately. If someone has created another backup task on your Confluence site, your job will be added to a "queue". This will be reflected in your task status. Only one backup is processed at a time; we do this to provide a stable, fast, and reliable backup experience.
- If your task was "queued" and someone restarts Confluence, your task won't lose its place in the queue.
- If your task was "in progress" and someone restarts Confluence, it will fail and you will need to run the backup again.
- The Space backup recent activity table lists XML exports of that space only over a two-week period.
- You can only import a space into the same or later Confluence version. You can't import a space into an earlier version.
- Team Calendars aren't included in XML exports.
- If you're doing the export for backup purposes, consider another means of backup. See Production Backup Strategy.

Migrating content to Confluence Cloud

If you're migrating from Confluence Server to Confluence Cloud, you can use the Confluence Cloud Migration Assistant to migrate your content and spaces.
Customize Exports to PDF

Confluence provides a basic PDF export that you can customize and style to suit your needs.

You need Space Admin permissions to customize PDF exports in a space, and Confluence Administrator global permissions to customize PDF exports for the whole site.

How it works

When someone exports a space to PDF, Confluence will apply any layout and styling directions it finds in the current space or set globally for the whole site.

- The PDF Layout allows you to add a title page to your PDF, and add a header and footer to all pages.
- The PDF Stylesheet allows you to change the look of the PDF. You can change just about anything, including the paper size, fonts and colours, spacing, and control behaviours like page breaks.

Both the PDF Layout and PDF Stylesheet can be customized on a space by space basis, or globally for the whole site. Space customizations will always completely override any global customizations. This means you can't mix and match and set some items globally and others at the space level.

Limitations

There are a few limitations to be aware of:

- Changes to the PDF layout only apply to space exports, not to single page exports (via More options > Export to PDF).
- The way that Confluence Data Center processes space exports means that some options, like adding page numbers via CSS, aren't available in PDFs created with Data Center. We recommend selecting Include page numbers on the export screen if you need to number your pages.
- We provide a number of example customizations to get you started, however Atlassian Support can't help you with styling your PDFs or problems introduced by your customizations. If you're new to CSS, you might want to get help from an Atlassian Solution Partner, or check out a Marketplace app like Scroll PDF Exporter which has a WYSIWYG editor to help you produce beautifully styled PDFs.

Change the PDF layout

The PDF Layout is where you add a title page, header, or footer to your PDF exports. The PDF layout fields accept HTML. You can include inline CSS in the HTML too.
To change the PDF layout for the whole site:

- Go to Administration > General Configuration > PDF Layout. You need Confluence Administrator global permissions to do this. You need
- Choose Edit, then add your customizations in the Title, Header, or Footer fields.

To change the PDF layout for a specific space:

- Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar. You'll need Space Admin permissions to do this.
- Choose PDF Layout.
- Choose Edit, then add your customizations in the Title, Header or Footer fields.

**PDF Layout examples**

Here are some examples of things you can do in the PDF Layout. The PDF layout can accept HTML and inline CSS.

**Title page**

In this example we've added the title "Documentation for Confluence", a logo, and an additional title "Contents" above the table of contents.

```html
<div class="fsTitlePage">
  <img src="/download/attachments/16918009/atlassian_logo.png" />
  <div class="fsDocTitle">Documentation for Confluence</div>
</div>
<div class="tocTitle">Contents</div>
```

The logo image we've used is attached to a Confluence page in the same site. You can find out the attachment ID by right clicking the image on the page, and copying its location.

**Header or footer**

In this example we've added plain text to the footer with some copyright information, and included a link.

```
Created in 2018 by Atlassian. Licensed under a <a href="http://creativecommons.org/licenses/by/2.5/au/" >Creative Commons Attribution 2.5 Australia License</a>.
```

**Change the PDF stylesheet**

The PDF Stylesheet allows you to change the appearance of your PDF. This includes things like paper size, fonts, colours, spacing, and other styling.

To change the PDF stylesheet for the whole site:

- Go to Administration > General Configuration > PDF Stylesheet. You need Confluence Administrator global permissions to do this. You need
- Choose Edit, then add your CSS.

To change the PDF stylesheet for a specific space:

- Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar. You'll need Space Admin permissions to do this.
- Choose PDF Stylesheet.
- Choose Edit, then add your CSS.
PDF Stylesheet examples

Here are some examples of common CSS overrides that you can use in your PDF Stylesheet.

The default CSS rules will apply unless you have specified an override in the PDF Stylesheet.

Page size

The default page size is US Letter (8.5 inches wide by 11 inches long). To override this behaviour and specify a particular size, add a size property to the CSS @page rule.

For example to export your space in A4 size:

```css
@page
{
/*The A4 paper size is 210 mm wide by 297 mm long*/
size: 210mm 297mm;
}
```

Page orientation

To change the page orientation of your PDF document, reverse the order of the values declared in the @page rule's size property. The first and second values of this property represent the width and height of the page, respectively.

For example, to generate an A4 PDF in landscape, your @page rule might look like this:

```css
@page
{
/*A4-sized pages in landscape orientation are 297 mm wide by 210 mm long*/
size: 297mm 210mm;
}
```

Page margins

The default margins are 0.5”. To set all margins to 15 mm, with a paper size of A4, edit the CSS @page rule in the PDF Stylesheet, like this:

```css
@page
{
size: 210mm 297mm;
margin: 15mm;
}
```

To set the margins independently, edit the @page rule like this:

```css
@page
{
margin-top: 2.54cm;
margin-bottom: 2.54cm;
margin-left: 1.27cm;
margin-right: 1.27cm;
}
```

To set margins to include a gutter for binding a printed document, you can use the :left and :right pseudo-classes, as follows:
In the example above we’ve also used the :first pseudo-class to define different margins for the title page.

**Page breaks**

By default, each Confluence page will start on a new page in the PDF. If you don’t want each Confluence page to start on a new page, you can override the default page breaks using the following CSS:

```
.pagetitle {
  page-break-before: auto;
}
```

This behaviour changed in Confluence 6.13. If you’re using Confluence 6.12 or earlier, page breaks are not added before each page title.

> If you’re using Confluence Data Center, you won’t be able to change this behavior, as PDFs are generated page by page in the external process pool, and then combined together once all pages are complete.

**Word wrapping**

Long, unbreakable words or strings (such as a URL) will automatically wrap to fit the page width, or cell width if in a table.

If you don’t want words or long strings to break you can use the following CSS:

```
div {
  word-wrap: normal !important;
}
```

This may mean that the table formatting in your PDF is problematic, and very long content may overflow, and be cut off the page.

**Title page**

If you have added a title page in the PDF layout, you can use the following rules to change the appearance of the title page and title text.
Table of contents

A table of contents is included by default when you export a space to PDF. It will appear at the start of the document, or after the title page, if you've configured a title page in the PDF layout.

To omit the table of contents, use the following override:

```css
div.toc {
  display: none;
}
```

The table of contents uses a leader character to visually connect the page title with its page number. By default this is a dot. Allowed values are dotted, solid and space. You can also use a string, for example `leader(".
.
").`

The example below uses solid line, instead of dots.

```css
span.toclead:before {
  content: leader(solid);
}
```

Tables

When you export a page that contains a table, we'll reduce the width of the table columns as much as possible, so that the whole table fits comfortably on the page. Individual columns are resized to fit the contents of each column.

If you prefer table columns to always be of equal width, you can use the following CSS:

```css
table.fixedTableLayout {
  table-layout: fixed !important;
  width: 98% !important;
}
```

Any images in a table will be exported using the size set in the editor. If your table contains large images, part of the table may be cut off when exported to PDF. To ensure that nothing is cut off, we recommend resizing images in the editor, so that the total width does not exceed about 600px (for an A4 page in portrait orientation).

Alternatively you can use the following CSS to fit images to the available width:

```css
table img.confluence-embedded-image {
  -fs-fit-images-to-width: 100% !important;
}
```
Page numbers

To add page numbers to your document, select Include page numbers on the export screen.

⚠ If you're using Confluence Data Center, you can't add page numbers using these methods, as PDFs are generated page by page in the external process pool, and then combined together once all pages are complete. Use the Include page numbers option on the export screen instead.

To add page numbers in the format "Page x of y" to the bottom of your page, add the following CSS to the PDF stylesheet:

```css
@page
{
  @bottom-center
  {
    content: "Page " counter(page) " of " counter(pages);
    font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
    font-size: 8pt;
  }
}
```

Alternatively you can add page numbers into the footer. This requires making a change in the PDF layout and the stylesheet.

First, add an element in the PDF layout. In this example we'll call it pageNum:

```html
<span id="pageNum"/>
```

Then, in the PDF stylesheet, style the pageNum element as follows:

```css
#pageNum:before
{
  content: counter(page);
}
```

Headings

Heading sizes in the PDF export roughly match the sizes used on Confluence pages. You can easily override them as follows:

```css
h1 {
  /* Custom styling */
}

h2 {
  /* Custom styling */
}
```

This behaviour changed in Confluence 6.13. In Confluence 6.12 and earlier, headings were demoted based on the position of the page in the page tree. Now headings are a consistent size on every page.

Other formatting
You can use the stylesheet to customize the output of just about anything on the page, including fonts, tables, line spacing, macros, etc. The export engine works directly from the HTML output produced by Confluence. Therefore, the first step in customizing something is to find a selector for the HTML element produced by Confluence or the Confluence macro. Then add a CSS rule to the PDF stylesheet.
Advanced PDF Export Customizations

This page provides information about 'advanced' PDF export customizations. These expand upon the regular customizations described in Customize Exports to PDF.

The information below is for advanced users. Be aware that the advanced customizations described below require knowledge of certain parts of Confluence, and of CSS and HTML. Customizations are not supported by Atlassian, so our support engineers won't be able to help you with these modifications.

The code examples shown below are designed to work with Confluence Server.

If you're using Confluence Data Center, the CSS examples may not provide the desired result since the markup used to generate a PDF differs when using an external process pool.

In Confluence Data Center, you'll need to disable the external process pool using a system property to return to the legacy method used in Confluence Server – then, the code will work as expected.

Header and Footer

Adding Headers and Footers to Single Page Exports

Single page exports don't support adding HTML headers and footers via the PDF Layout page, but you can use CSS rules in the PDF Stylesheet page (Space tools > Look and Feel > PDF Stylesheet) to produce headers and/or footers for a single page export.

For custom headers, define any of the following rules within your @page rule: @top-left, @top-center, and @top-right. These rules allow you to define the content of the left-hand side, centre and right-hand side of your page’s header area, respectively.

For custom footers, define @bottom-left, @bottom-center and @bottom-right rules within your @page rule.

For example, the following rules add a document title at the centre of the header and a page number at the centre of the footer:
CSS - PDF Stylesheet

@page
{
  @top-center
  {
    content: "Document Title Goes Here"; /* This is the content that will appear in the header */
    font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
    font-size: 8pt;
  }
  @bottom-center
  {
    content: "Page " counter(page); /* This is the content that will appear in the footer */
    font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
    font-size: 8pt;
  }
  /* Any other page-specific rules */
}

Notes:

- The `font-family` and `font-size` properties ensure that the header and footer text is rendered in the same default font style used for the body text, based on the default CSS rules.
- It is not possible to use this method to insert images (stored as attachments within your Confluence instance) into the headers and footers of single page exports.

Adding Images to Headers and Footers

To insert an image into the header or footer, add HTML to the Header or Footer section of the PDF Layout screen.

The following example uses an HTML `img` element with `src` attribute to add an image to the left of the header. The `src` attribute refers to an image attached to a Confluence page. The image element is usually placed within a `div` element container.

### HTML - PDF Layout: Header Section

```html
<div style="margin-top: 10.0mm;">
  <img src="https://confluence.atlassian.com/download/attachments/12346/header-image.png" />
</div>
```

In the example above, the header includes an image called ‘header-image.png’. The "12346" in the `src` attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page, then right-click the image and copy its location.
3. Paste the link into the appropriate `src=""` attribute in your PDF Stylesheet, as shown above.
4. Edit the image URL so that it is relative, by removing the first part of the URL before `/download/...`

Notes:

- This example uses an inline CSS property `margin-top` in the `style` attribute to force the image away from the top of the page by 10mm. This comes in handy when your header image is large enough to touch or spill over the top of the page.
- Likewise, for footers, you can use the `margin-bottom:XXmm` property to force an image away from the bottom of the page by ‘XX’ mm.
- Very large images can spill over into the body of a page or alter the position of text or other elements used within a header or footer. In such situations, it is recommended that you reduce the size of the image and then attach it to your Confluence page again. If you prefer to keep the image size and want to move the content lower instead, you can do so by configuring the `margin-top` properties in the @page CSS rule.
• By default, a header or footer image is aligned to the left-hand side of the page. However, you can align this image to the centre or right-hand side of a page by adding either the `text-align:center` or `text-align:right` properties to your `style` attribute. For example, to align the header image to the right-hand side of the page, your `style` attribute would look similar to this: `style="margin-top:10mm; text-align:right"`.

Incorporating Other Fonts

By default, Confluence provides Times New Roman, Helvetica or Courier fonts for use in PDF exports. You can use your own fonts for PDF exports by declaring them in a `@font-face` CSS rule in your PDF Stylesheet.

The following CSS rule example shows how to declare the Consolas font and apply it to some elements for your PDF export:

```
@font-face { src: url(file:///usr/share/fonts/Consolas.ttf); -fs-pdf-font-embed: embed; } .code pre, .preformatted pre, tt, kbd, code, samp { font-family: Consolas, monospace; font-size: 9pt; }
```

The font path specified in the CSS must be the path to the font on the Confluence server.

Adding a Dynamic Title to the Title Page

When you export an arbitrary set of pages from Confluence, you may like to have a corresponding title added to the cover (or title) page automatically. This can be done (in a somewhat irregular way) by using the top level item from the default table of contents as the title. This method relies on having the exported pages structured as sub-pages of the top-level page. In other words, the pages to be exported should consist of a page (at the top-level) and all of its child pages. The result is that the title that appears on the cover page changes depending on the top-level page that is used for the export.

The CSS below moves, and styles, the top-level TOC item for use as the title on the cover page, and turns off the leader and page number normally associated with this item in the TOC.

```
.fsTitlePage { position:relative; left:0px; } /* Turn off the default section numbering for this TOC item */ .toclvl0:before { content: " "; counter-reset: chapter 0; } /* Hide the default page numbering for this TOC item */ .toclvl0 .tocnum { display: none; } /* Move and style this TOC item */ .tocvlv0 { position:absolute; top:250px; font-size: 42px; font-weight: bold; margin: 72px 0 4px 0; text-align:center; }
```

Hiding Text from the PDF Output

This section describes a way to hide text from your PDF export. In other words, you can have text on the Confluence page that will not appear in the PDF export.

There are three steps:

1. Follow the instructions to define the NoPrint user macro.
2. Use the NoPrint macro to mark some text on a Confluence page.
3. Add the following CSS to your PDF stylesheet to make the PDF export recognize the NoPrint macro:

```
.noprint { display: none; }
```

Indexing
To obtain an index at the end of the exported PDF file, consider using the Scroll Wiki PDF Exporter plugin that is produced by K15t Software GmbH.

Notes

If styling is not working as expected, it is useful to look at the intermediary HTML source to which the CSS is applied. This intermediary HTML is created whenever you create an HTML export that contains multiple pages, and is stored in the temp directory in Confluence's home directory. For example:

```
/temp/htmlexport-20110308-154047-1/export-intermediate-154047-2.html
```
Create a PDF in Another Language

To export a Confluence page written in a language other than English, you'll need the necessary font for that language.

Upload a Font File to Confluence

1. Find the appropriate font file:
   - **Windows users:** All font files in Windows are stored in a directory called:
     
     C:\WINDOWS\Fonts
   
   - **Unix users:** All font files in Unix are stored in:
     
     /usr/share/fonts
   
   - Microsoft True Type core fonts such as Verdana can be downloaded from this page: [http://corefonts.sourceforge.net/](http://corefonts.sourceforge.net/)

2. Copy the font file into a temporary folder, for example a folder on your desktop.
3. Select Administration, then select General Configuration then choose PDF Export Language Support.
4. Upload the file you copied in step 2.
5. Choose Install.

Notes

- The only font files supported are *true type fonts and true type collections*. The accepted file extensions are *.ttf* and *.ttc*.
- Confluence can only store one font file at any one time. Please create a collection to install more than one *.ttf* files.
- We recommend that you use Unicode font Verdana for correct character encoding and exporting to PDF.
- For symbols, if the other fonts do not work, try Seguisym
- If the font file size is bigger than your current attachment size limit, you will not be able to upload it. Please increase the attachment size limit temporarily and re-upload again. An improvement of the error messaging is tracked at [CONFSERVER-24706](http://CONFSERVER-24706)
- To make use of an installed font in your PDF Export style sheet (CSS) refer to it by the font-family ConfluenceInstalledFont.
Pages and blogs

Pages and blog posts allow you to capture and share information in Confluence.

Whether it's taking down some quick notes from a meeting, writing a requirements page, or letting your teammates know about the company's latest marketing push – you can create it as a Confluence page or blog post.

Pages are great for when you want the information to last and evolve over time. If it's a point-in-time update or one-time communication then a blog post is the way to go. These aren't hard-and-fast rules; they're just pointers to give you a place to start.

Each Confluence space, including your personal space, allows you to create pages in it, and has its own blog where you can create posts. If you're not sure what a space is, or what you can do with spaces, check out our page on Spaces.

Take a look at the below pages to learn more about pages and blog posts in Confluence.

- Create and Edit Pages
- Blog Posts
- The Editor
- Move and Reorder Pages
- Copy a Page
- Delete or Restore a Page
- Add, Remove and Search for Labels
- Drafts
- Page Restrictions
- Links
- Anchors
- Tables
- Add, Assign, and View Tasks
- Autocomplete for links, files, macros, mentions and emojis
- Page Layouts, Columns and Sections
- Create Beautiful and Dynamic Pages
- Page Templates
- Blueprints
- Import Content Into Confluence
- Undefined Page Links
- View Page Information
- Page History and Page Comparison Views
- Confluence Markup

Related pages:
- Create and Edit Pages
- Blog Posts
- The Editor
- Page Templates
- Delete or Restore a Page
- Spaces
Create and Edit Pages

Create a page

You can create a page from anywhere in Confluence; just choose Create in the header and you’re ready to go. Pages are the place to capture all your important (and unimportant) information; start with a blank page and add rich text, tasks, images, macros and links, or use one of the useful blueprints to capture meeting notes, decisions, and more.

On this page:
- Create a page
- Edit together
- Collaborate or restrict
- Organize and move
- Other page actions
  - Notes

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a page from a template, hit the Create from template button.

1. Create blank page
2. Create from template

Once you decide on a blank page or blueprint, you’ll be taken straight into the Confluence editor. The editor is where you’ll name or rename your page, add the content, and format it to look great. When you’ve added some content, choose > Preview to take a peek at what your finished page will look like, and Publish when you’re ready to make it appear in the space.

After you save you’ll see the page in ‘view’ mode. You can re-enter the editor any time by choosing Edit or pressing E on your keyboard.
1. **Confluence header**: create blank pages, pages from templates and visit spaces or your profile.

2. **Space sidebar**: access pages, blogs and administer the space.

3. **Page tools**: edit or share the page, watch it to get updates and perform more actions.

Another useful way to create a page is to use the Create from Template Macro. This macro allows you to choose a page template, and adds a button to the page allowing one-click page creation. If you want others to create pages using this template, this is a great option.

### Edit together

Need input from your team members? Multiple people can edit your page at the same time.

Hit the **Invite** button in the editor and either grab the link, or enter some people or groups to invite by email (they need the appropriate Confluence and space permissions of course).

See [Collaborative editing](#) for all the ins and outs.

### Collaborate or restrict

Once you've created a page, you can decide if you want to keep it private, using restrictions, or collaborate on it with others using @mentions, sharing, and comments.

### Organize and move

You can also organize pages in a hierarchy, with child and/or parent pages for closely related content. When you navigate to a Confluence page and choose the **Create** button in the header, the page you're creating will by default be a child of the page you're viewing. Have as many child pages and levels in the hierarchy as you need to, and move pages if you want to change their location.

If you want to view all pages in a Confluence space, choose **Pages** in the sidebar.

---

Each time you create a page, you’re creating it in a **space**. Spaces are containers used to contain pages with related content, so you can set them up for each team in your organization, for projects, a combination of both, or for any reason you want to group pages together. See [Spaces](#) for more information.

### Other page actions
• Copy a page and its child pages
• Delete a page or remove a specific version of a page
• Monitor page updates and other activity through page notifications
• View page history, and manage and compare versions of a page
• Search page content, including attachments
• Export pages to Word, PDF, HTML or XML
• Like a page

⚠️ We recommend you don't use special characters in page or attachment names, as the page or attachment may not be found by Confluence search, and may cause some Confluence functions to behave unexpectedly.

If you rename a page, Confluence will automatically update all relative links to the page, except in some macros. Links from external sites will be broken, unless they use the permanent URL. See Links for more information.

Notes

You may experience problems saving extremely large pages. Confluence can accept approximately 5mb of content (not including attached files) which is roughly equivalent to 800,000 words. If you do experience errors that indicate the page is too large to save, you should break up the page into several smaller pages.
Blog Posts

Blog posts are an easy way to share announcements, journal entries, status reports, or any other timely information. Others can join in by commenting on and/or liking your blog post and, if you get enough of either, your post might make it to the popular feed on the dashboard!

Each space in Confluence, including your personal space, has its own blog. To view a space's blog, go to a space and choose Blog in the sidebar. You'll see a list of the latest blog posts, and you can click through to earlier posts via the navigation area in the sidebar.

Create a blog post

You can follow the same process to create a blog post as when you create a Confluence page.

1. Navigate to the space where you want to create your blog post
2. Choose Create in the Confluence header and select Blog post
3. Add your content and choose Publish

You can create blog posts from the Dashboard, but you'll need to make sure you choose the space it's going to appear in in the create dialog.

Blog posts can be attractive and engaging in the same way a page can be, so go ahead and add images, YouTube clips (preferably of cats), and tables to your post to really grab your audience.

To create a blog post, you need the 'Add Blog' permission. See Space Permissions.

Move a blog post

If you create a blog post in the wrong space, or want to reorganize your spaces, you can move an individual blog post to another space.

To move a blog post, go to the post and choose More options > Move and select the new destination space.

You'll need the 'Delete blog' permission in the current space, and 'Add blog' permission in the new (destination) space to do this.

Restrict a blog post

You can restrict a blog post so that it is only available to specific users or groups. Blog post restrictions work in the same way as page restrictions.

To restrict a blog post prior to publishing it, choose the Unrestricted button in the footer and apply your restrictions. To restrict a blog post after publishing, choose More options > Restrictions and apply your restrictions.

Notes:

- Notifications are sent at the point a blog post is created - removing restrictions does not trigger a new notification.
- As a blog post has no parent, restrictions aren't inherited.

Delete a blog post

To delete a blog post, choose More options > Delete. Deleting a blog post follows the same rules as deleting a page.

Export a blog post
You can export individual blog posts to PDF. This is useful, for example, if you want to email an internal blog post to people outside your organization.

See Export Content to Word, PDF, HTML and XML for more information on exporting blog pages to PDF.
The Editor

The Confluence editor is what you’ll use to create and edit Confluence pages, blog posts, and comments. You can enter content as you would in a Word document, apply formatting, and embed other content and files on the page.

**Note:** To edit a page, you need the 'Add Pages' permission for the space. See space permissions. Someone may also apply page restrictions that prevent you from editing the page.

**Edit a page or blog post**

You’ll be taken to the editor whenever you create a new page or blog post, or add a comment. To edit an existing page or blog post, choose **Edit** at the top of a page or press **E** on your keyboard.

Confluence automatically saves changes as you type. Changes are only visible when viewing the page after you publish or update. See Collaborative editing for more information on how this works.

---

The editor

The editor allows you to enter or change the title of your page; insert content including text, images, and links; and format your content using the toolbar.

If you’re renaming your page, there are some things you should take into account.
1. **Page content**: add your page title and body text.
2. **Page tools**: add labels, or restrict the page.
3. **Insert**: add files, links, images, tables and macros
4. **Notify**: notify others and leave a comment when you change a page.
5. **Preview or revert**: preview your page, view changes since last published, or revert back to last published version (or delete the draft page, if it has never been published).

**Editor toolbar**

The editor toolbar is where you format your page layout and text, and add links, tables, images, attachments and macros. You can also perform a find and replace, or get help using the editor by choosing the help icon 🤷‍♂️.

**Emoji menu**
Use the emoji menu to preview, search for, and insert an emoji or symbol into your page. You can see the emoji's keyboard shortcut in the preview bar at the bottom of the emoji menu.

Insert menu

The Insert menu is particularly useful. Use the Insert menu to include any of the following content types on your page:

- An image
- A link to another Confluence page or external URL, or a link to an attachment or image
- A horizontal line
- A macro (choose a specific macro, or Other Macros, from the Insert menu)

You can also use keyboard shortcuts to insert links, images, and macros. Try out the shortcuts listed below:

- Type [ (square bracket) to insert a link.
- Type ! (exclamation mark) to insert an image or other media.
- Type { (curly bracket) to insert a macro.

Typing any of the above shortcuts will trigger the autocomplete functionality, prompting you with a list of suggestions to finish off the entry. For more shortcuts, click the help icon on the editor toolbar.

Restrictions, labels, and notifications

When editing a page, you may want to set restrictions on who can view or edit the page, or add labels to the page to make it easily searchable.

Once you're ready to save, you can enter change comments to let others know what you've changed, and, if you like, send an email notification to anyone watching the page.

Things to help you work faster

Auto-formatting

You can type Confluence wiki markup directly into the editor to have Confluence auto-format your text as you type. To learn more, choose help icon in the toolbar, then choose Editor Autoformatting.
Autoconvert for pasted links

When you paste certain URLs into Confluence, the editor will analyze what you’re pasting and automatically convert it into something that will display well in Confluence. Examples include:

- YouTube videos
- Jira issue queries
- Google Maps
- Confluence pages, blog posts, comments, user statuses, user profiles.
- Shared screenshot links from Skitch
- And more.

Drag-and-drop for external images and files

You can drag files, like images, multimedia, Office files and PDFs, from your computer and drop them directly into the editor. The contents of the file will be embedded into the page or blog post.

Drag-and-drop within the editor

In the editor panel, you can drag an image or a macro from one location to another on the page. Hover your cursor over the image or the macro placeholder and your cursor changes to a drag-and-drop icon. Click the image or macro and drag it to a new location.

Keyboard shortcuts

To view the available keyboard shortcuts, choose the help icon in the editor toolbar.

Find and replace text

Click the icon on the toolbar, or use the keyboard shortcut Ctrl+F (Windows) or Cmd+F (Mac OS).

Search matches are highlighted in yellow. You can step through the results one by one, replace the matching text strings one by one, or replace all matching strings at once. Find and replace works only within the current page.

Invite people to edit with you

Speed up your draft and review cycles and get input from the right people by inviting them to edit the page with you. The page does not need to be published.

Hit the button in the editor and either grab the link, or add people, groups or email addresses to invite, just like sharing a page.

Sharing or inviting someone to edit a page or blog post does not automatically grant any permissions - they will still need the appropriate Confluence permissions to access Confluence and view or edit the page.

Up to 12 people can edit the same page at the same time (your administrator can change this limit).

Record change comments and notify watchers

When you finish editing a page, you can add a comment to let others know what you changed. Type a short message in the change comments field in the footer. The comment will be visible in the page history.

If you want to send a notification to people watching the page, select Notify watchers. The change comment will be included in the notification email.

The Notify watchers checkbox remembers your last selection for each page, so if you choose not to notify people, the checkbox will be deselected for you next time you edit that page.
Symbols, emojis and special characters

You can add various symbols, emojis and special characters to Confluence pages. You can also use them in other places that display content, such as pages, blog posts, inline and page comments, and the dashboard welcome message.

Using Confluence Cloud? Check out our info on how to Use symbols, emojis and special characters in the new editor.

Insert symbols and special characters

1. Edit the page (if you're viewing the page, press E on your keyboard)
2. Choose Insert ➤ Symbol
3. Choose a symbol to insert it

On this page:

- Insert symbols and special characters
- Insert emojis
  - Select it from the emoji menu
  - Type the emoji shortcut
  - Trigger the emoji autocomplete
- Add your own emojis
  - View and delete custom emojis
- Prevent emojis from appearing

Related pages:

- The Editor

Insert emojis
There are a few ways you can add an emoji to your page.

**Select it from the emoji menu**

1. Edit the page
2. Select where you want to add the emoji
3. Open the emoji menu from the editor toolbar
4. Select an emoji to insert it.

Tip: Open the emoji menu using Ctrl+Shift+M (Windows) orCmd+Shift+M (Mac).

You can also personalize skin tone for certain emojis. Select the hand emoji (next to the emoji search bar) and it will expand to show the skin tone variations.
Type the emoji shortcut

1. Edit the page
2. Select where you want to insert the emoji
3. Type its keyboard shortcut

Emoji shortcuts start and end with a colon "::", for example :wave:. To learn an emoji's shortcut, hover over an emoji in the emoji menu. The emoji shortcut is visible in the preview panel.

Knowing an emoji shortcut is helpful when the emoji menu isn't available, for example in an inline comment.

You must have autoformatting enabled in the editor for this to work. See Edit Your User Settings

Screenshot: The keyboard shortcuts for our original emoticon set
Trigger the emoji autocomplete

1. Edit the page
2. Select where you want to add the emoji
3. Type a colon “:” to activate the emoji autocomplete menu
4. Type the emoji name, shortcut, or browse the suggestions using your up and down arrows or mouse
5. Select the relevant emoji to insert it

The emoji autocomplete menu will continue to change as you type to predict and match your input.

You must have autocomplete enabled in the editor for this to work. See Edit Your User Settings

Screenshot: The emoji autocomplete feature is activated when you type a colon in the editor

Add your own emojis
You can upload your own emojis using the emoji menu in the editor.

Files must be JPG, PNG, or GIF, and no larger than 1 MB. Regardless of the original file's dimensions, the emoji created will be 36 x 36 pixels.

To upload a custom emoji:

1. Open the emoji menu from the editor toolbar
2. Select +Add your own emoji
3. Select the icon under ‘Select an image’
4. Browse for and select the image file (we accept JPG, PNG, and GIF files up to 1MB)
5. Select Open
6. Give your emoji a name
7. Give your emoji a shortcut (this must be unique)
8. Select Add emoji

Confluence and system admins can view and delete custom emojis uploaded to their site at https://[yourdomain]/admin/emojis/globalsettings.action

Learn about managing emojis

View and delete custom emojis

Custom emojis will appear in the emoji menu under ‘All uploads’ (+).

To see the emojis you’ve uploaded:

1. Open the emoji menu from the editor toolbar
2. Select the + tab
3. Any emojis you've added will appear under ‘Your uploads’

To delete an emoji you’ve uploaded:

1. Open the emoji menu from the editor toolbar
2. Select the + tab
3. Under ‘Your uploads’, select the emoji you want to delete
4. Select the cross (x) to the top right the image or use the backspace keyboard shortcut
5. You will receive a confirmation message, select Remove

Prevent emojis from appearing

To undo the conversion of a character combination or shortcut into an emoticon or emoji, press Ctrl+Z (Windows) or Cmd+Z (Mac).

To prevent Confluence from converting text to emojis automatically, disable ‘Autoformatting’ in your user profile. See Edit Your User Settings.
Collaborative editing

Collaborative editing takes teamwork to the next level by letting you and your team work together in real time on software requirements, meeting notes, retros, and any other Confluence page. See who's editing the page with you, and see changes as they happen. Hit \( + \) to invite more people to edit with you.

Changes save and sync automatically, so everyone editing sees the same thing. And, because we're saving all the time, there's no need to manually save. Publish now or keep the draft and publish it later—you're in control.

Up to 12 people can edit the same page at the same time. Your administrator can change this limit using a system property.

Once you and your team are done editing you can:

- **publish** (or update if the page has previously been published) to make everyone's changes visible
- close the editor and **keep** everyone's work to finish later
- **revert** to the published version of the page, discarding everyone's unpublished changes
- **delete** the draft page entirely, if it has never been published.

We'll warn you if you're about to publish (or discard) other peoples' changes along with your own.

On this page:

- Drafts and unpublished changes
- Things you should know

---

1. **Invite more people**: see who is editing the page and invite others to edit with you.
2. **See what they're doing**: watch others edit the page in real time.

---

Drafts and unpublished changes

**What is a draft?**

A draft is a page that has never been published before. Draft pages have a lozenge that says draft, and are only visible to their author, and to anyone that author shares their draft with. Nobody else will be able to see your draft, as it is only accessible from the Recently worked on list of each of the people who've contributed to it.

**What are unpublished changes?**
A page with **unpublished changes** is a page that has been published, and has then had edits made to it, but which has not yet been republished. Anyone who has unpublished edits will see the page in their **Recently worked on** list, with a lozenge saying **unpublished changes**. People who haven't contributed to the unpublished changes won't see this lozenge.

Those unpublished changes, however, are visible in the editor, and anyone can access them by editing that page. Therefore, if you have unpublished changes and do not want someone else making additional changes before they can be published, you might want to temporarily restrict editing on that page (leaving the published version of the page visible).

**Things you should know**

**Limited content auditing**

We don't yet have the same auditing capabilities with collaborative editing. All page changes are currently attributed to the person that publishes the page, rather than the person who made each specific change.

**Changes in drafts aren't versioned**

We're saving all the time in collaborative editing, but we don't save versions in a draft. When restoring an earlier page version, you can only roll back to published versions (the page draft is deleted when you restore a previous version)

**No more personal drafts**

Collaborative editing introduces a new type of draft, a **shared draft**. Previously, when you edited a page but didn't save it, Confluence would create a draft that was only visible to you (a personal draft). When collaborative editing is turned on, Confluence creates a shared draft whenever anyone edits a page. All page editors work on this same shared draft, and it exists until someone publishes the page.

When you publish a shared draft, you're publishing all the changes you have made and changes made by others. Publishing creates a version in the page history.

If you discard a shared draft, you're discarding all changes, including changes made by others. Because shared drafts aren't versioned, there's no way to get a discarded draft back.

Any existing personal drafts are still available, but are no longer editable. If you edit a page, you'll see the shared draft of the page, not your personal draft (if one exists).

If you need to get content out of your previous personal drafts head to **Profile > Drafts**, locate your page and copy the contents.
Move and Reorder Pages

The easiest way to set a page's location in Confluence is to navigate to the space where you want the page to live and, if necessary, find its parent page and choose Create. Sometimes though, you'll want to change a page's location either while you're creating it, or after it's been created.

You can also move and reorder pages in the page tree (hierarchy).

Set page location or move a page

1. Do either of the following:
   - **While creating a page** — choose the location icon at the top of the page
   - **Once a page is created** — choose More options > Move
2. Use the tabs on the left of the 'Set Page Location' dialog to help you find the new space and/or parent page for your page (the Current location and New location breadcrumbs at the bottom of the dialog indicate the current parent page and new parent page)
3. Select Reorder if you want to move the page to a different position amongst the child pages (when you choose Move in the next step, you'll be able to reorder the page)
4. Choose Move (If you're reordering the child pages, choose the new position for the page and choose Reorder)

The page – along with any attachments, comments, and child pages – is moved to your chosen location. Confluence will automatically adjust all links to the moved pages, to point to the page(s) in its new location.

When completing the New parent page field, you need to select the page suggested by Confluence's autocomplete. Typing or pasting the page name (or using your browser's autocomplete) won't work.

**Screenshot: Setting the location or moving a page**

Reorder pages within a space

On this page:
- Set page location or move a page
- Reorder pages within a space
- Notes about permissions

Related pages:
- Create and Edit Pages
- Copy a Page
- Delete or Restore a Page
You can change the location of a page within its space, and reorder pages in the hierarchy. This allows you to:

- Move a single page, or a family of pages, to a different parent within the space.
- Reorder pages that are children of the same parent.

All links to the page are maintained. When you move a parent page, the entire hierarchy of child pages will move too.

**To move or reorder a page:**

1. Go to the space and choose **Space tools > Reorder pages** from the bottom of the sidebar.
2. Expand the branches to locate the page you want to move.
3. Drag the page to a new position in the tree.

Alternatively, you can choose to order a group of child pages alphabetically by choosing the **Sort Alphabetically (A-Z)** icon. The **Sort Alphabetically (A-Z)** icon only appears next to the parent page if the page family is currently sorted manually.

If you change your mind, you can use the **Undo Sorting** icon to revert back to the previous manual page order. This option is only available immediately after sorting the page, while you're still on the **Reorder Pages** tab, and haven't performed any other action.

![Tree view of a page hierarchy]

1. **Alphabetical**: sort all child pages alphabetically.
2. **Undo**: undo sorting.

**Notes about permissions**

To move a page, you need the following permissions:

- 'Add' permission on the page you're moving, and
- 'View' permission on the page's parent page. If you're moving the page to a different parent, you need 'View' permission on the new parent.

To move a page into a different space, you also need:

- 'Delete' permission on the space you're moving from, and
- 'Add' permission on the space you're moving to.

If the page has restrictions, and you want to keep the page restrictions in the new location, you'll also need 'Restrict' permission on the space you're moving to. Alternatively, remove the page restrictions before performing the move.
Copy a Page

If you need to duplicate the contents of a page, the easiest way is to copy the page. You can copy pages into the same space or to a different space.

When you copy pages into the same space, you'll need to rename them, as two pages with the same name can't live in the same space. We give you some handy tools to help rename your pages during the copy process.

You need the 'Create Page' permission to copy pages. See space permissions for more information.

Copy pages

Single page

To copy a single page:

1. Go to the page and choose More options > Copy.
2. Choose a Location for the new page.
3. Choose whether to include attached files and images.
4. Hit Copy.

Confluence will open the copy of the page in the editor and name it 'Copy of [original page title]'. You can then rename the page and work in the editor like any ordinary page.

Any restrictions are not copied over. If the page contains private information, click the padlock icon in the editor to apply restrictions before you publish.

Page hierarchy

To copy a page and all its child pages:

1. Go to the page and choose More options > Copy.
2. Choose a Location for the new pages.
3. Select Include child pages.
4. Use the options provided to customize your new page titles.
   You can add a prefix, replace a keyword or phrase in existing titles, or both. The preview will give you a good idea of what your new page hierarchy will look like, and warn you if there are any problems.
5. Deselect any items you do not want to copy over (attached files, labels, restrictions)
6. Hit Copy.

You’ll find a link to your newly copied pages in the copy complete message.

⚠️ Note: It’s not possible to selectively copy multiple pages. You will be copying the entire hierarchy.

What’s included when you copy a page?

Here’s some more info on what’s included when you copy a page.

<table>
<thead>
<tr>
<th></th>
<th>Single page</th>
<th>Page and its child pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page contents (text, macros)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Attached files and images</td>
<td>Optional</td>
<td>Optional - if you choose not to include attachments, you may see 'unknown-attachment' errors on the copied pages.</td>
</tr>
<tr>
<td>Comments</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Labels</td>
<td>Yes</td>
<td>Optional</td>
</tr>
<tr>
<td>Restrictions</td>
<td>No</td>
<td>Optional - you may not be able to change this option if you don't have appropriate 'Restrict' space permissions.</td>
</tr>
<tr>
<td>Watchers</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Saved for later info</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>History</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Child pages with view restrictions</td>
<td>-</td>
<td>Yes - if you have permission to see the child pages. No - if you do not have permission to see the child pages.</td>
</tr>
</tbody>
</table>

Space permissions and page restrictions

Your space permissions and any existing page restrictions have an impact on what you can copy:
- To copy pages you need the 'Create' page permission in the destination space.
- To copy pages with restrictions intact, you need the 'Restrict' page permission in the destination space.

When copying a page and its child pages, you also have a choice to copy over any existing page restrictions. This is useful if you need to maintain the current view or edit restrictions. If you don't have 'Restrict' page permission in the destination space, you won't be able to choose this option.

Limitations

You can copy hierarchies containing up to 2000 pages. Administrators can increase or decrease this limit by setting the `confluence.cph.max.entries` system property.
Delete or Restore a Page

When you delete a Confluence page, we'll move it to the space's trash. It's not permanently deleted, and can be restored by a space admin, until the page is permanently deleted from the trash.

Don't see a delete option? Delete only appears if you are allowed to delete the page. Both space permissions and page restrictions can prevent you from deleting.

Delete a single page

When you delete a page in Confluence, you're deleting its page history too. If you only want to delete a specific version of a page, take a look at the instructions below for deleting a specific version.

To delete a page:

1. Go to the page and choose More options *** > Delete.
2. We'll warn you of any issues, such as incoming links that will break. Choose Delete to proceed.

The page will be sent to the trash, where it can be restored by a space admin.

Any child pages (including any restricted pages that you are not allowed to see) will move up to the nearest parent page.

Delete a page hierarchy

Only users with Delete Page permission in a space can delete hierarchies.

When deleting a page that has child pages you have the option to delete the entire page hierarchy.

To delete a page hierarchy:

1. Navigate to the parent page and choose More options *** > Delete.
2. Choose Also delete child pages then hit Next.
3. We'll warn you of any issues, such as incoming links that will break. Choose Delete to proceed.

The pages will be sent to the trash, where they can be restored by a space admin.

Any pages that are restricted (that you are not allowed to see or delete) will not be deleted and will move up to the nearest parent page.

Users who only have Delete Own permission can’t delete hierarchies, even if they created all of the pages in the hierarchy.

Delete an unpublished page

To delete a page that has never been published (a draft), in the editor go to More options *** > Delete unpublished page.

Deleted drafts are not sent to the trash, so cannot be restored. If other people have contributed to the draft, you will be deleting their work as well as your own.

Delete a page version

Space admins can delete specific versions from the page history. This is useful if you need to prevent older versions of a page being restored in future. Deleting a page version is permanent and can't be undone.
To delete a specific version of a page:

1. Go to the page and choose More options ••• > Page History
2. Choose Delete next to the version you want to delete.

The remaining versions are not re-numbered so that other users can see that a version has been removed.

Restore deleted pages

If you're a space admin you can restore deleted pages back into a space. This is useful if someone accidentally deletes a page and needs to get it back.

To restore a deleted page:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Trash.
3. Choose More options ••• > Restore next to the page you wish to restore.

Pages are restored to the root of the space. Head to Space Tools > Reorder Pages to drag your restored page back into the page hierarchy.

Empty the trash or permanently delete a page

If you're a space admin you can permanently delete a page (and all its attached files) by purging it from the trash. Once purged, the page and all its versions and attached files will be gone for good.

To purge deleted pages:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Trash.
3. Choose More options ••• > Purge next to a specific page or you can Purge all to completely empty the trash.

Automatically purge deleted pages and files

Confluence can automatically purge deleted items from the trash when they reach a certain age, based on the date they were deleted.

Deletion dates will not be accurate for any items deleted before Confluence 7.14. This is because we did not store this data in earlier Confluence versions. The date displayed in the trash page is the date your site was first upgraded to Confluence 7.14 or later. Anything deleted after this date has an accurate deletion date.

To find out how to automatically purge items from the trash see Set retention rules to delete unwanted data.
Add, Remove and Search for Labels

Labels are key words or tags that you can add to pages, blog posts and attachments. You can define your own labels and use them to categorize, identify or bookmark content in Confluence.

For example, you could assign the label 'accounting' to all accounts-related pages on your site. You can then browse all pages with that label in a single space or across the site, display a list of pages with that label, or search based on the label.

Because labels are user-defined, you can add any word that helps you identify the content in your site.

You can also apply labels (known as categories) to spaces, to help organize your Confluence spaces. See Use Labels to Categorize Spaces.

Label a page or blog post

Any user with permission to edit a page can add labels to it. Any existing labels appear at the bottom-right of the page, below the page content.

To add a label to a page or blog post:

1. At the bottom of the page, choose Edit labels or hit L on your keyboard
2. Type in a new label (existing labels are suggested as you type)
3. Choose Add

Labels can't contain spaces, are lower case, and can contain a maximum of 255 characters. You can add multiple labels by adding a space between each label, any capitals will be automatically converted to lower case. If you want a label to include more than one word, use an underscore or hyphen (the only two special characters that labels accept). For example this_is_a_label or this-is-a-label.

Label an attachment

1. Do either of the following:
   - Go to the page that contains the attachment and choose Go to More options > Attachments
   - Go to the space and choose Space tools > Content Tools from the bottom of the sidebar, then choose Attachments
     You'll see a list of attachments, with any existing labels listed in the Labels column.
2. Choose the Edit label icon beside the list of labels and type in a new label (existing labels are suggested as you type)
3. Choose Add

You can also add labels in a list of attachments displayed by the Attachments macro, by choosing the edit icon beside each label.

If you add one or more labels to a template, that label will be copied to the page when someone adds a page based on that template. See Creating a Template.

The Labeled content page

If you’re viewing a page or post that has labels or displays the Attachments macro, you can choose any label to go to the Labeled content page for the space. Choose Popular Labels or All Labels from the cog at the top-right – to view the most-used labels or all labels in the space – or choose See content from all spaces from the cog to view labeled content from all spaces in your Confluence site.

Screenshot: The Labeled content page

The Popular Labels option displays a word cloud, where the bigger a label is displayed, the more popular it is. Choose any label to view content tagged with that label.

You can also navigate to the labels view for a space by entering the following URL (replace SPACEKEY with the space’s key):

```
<your.Confluence.site>/labels/listlabels-alphaview.action?key=SPACEKEY
```

Search by label

You can use the 'labelText: ' prefix to search specifically for content that has a specific label. For example, if you’re looking for pages with the label ‘chocolate’, type `labelText:chocolate` into the search field in the Confluence header. For more examples of searching by label, see Confluence Search Syntax.

Search for labeled pages using a URL

Entering a URL with an appended label or labels is another way to search for pages with particular labels.

In your browser's address bar, enter the following URL and press enter: `http://<your.Confluence.site>/label/foo+bar`

The Labeled content page will load, showing search results for pages with the both labels, ‘foo’ and ‘bar’. Replace ‘foo’ and ‘bar’ with the label(s) you want to search for, and separate multiple labels with a + symbol.
Adding a label to your results:

Once you're on the Labeled content page, you can add more labels to your search by choosing them from the Related Labels list at the top-right of the page. Each label is listed with a plus (+) sign.

If you want to remove labels from your search, locate the included labels at the top of the page and choose the label(s) you want to remove. Each included label will be listed with a minus (−) sign.

Remove labels

When viewing page, blog post, or attachment labels, an x appears alongside each label. Choose the x to remove the label.

ℹ️ You can’t remove, consolidate or manage labels directly. A label is created by adding it to a page for the first time, and ceases to exist once it’s been removed from all pages it was added to.

If you have deleted pages that contain a label, you may need to purge the deleted pages from the space’s trash to ensure that the label disappears too.

If you are using the Labels List Macro, the appearance of labels from deleted pages is considered a bug. Track the issue at [CONFSERVER-55441](https://jira.atlassian.com/browse/CONFSERVER-55441) [GATHERING IMPACT](https://jira.atlassian.com/browse/CONFSERVER-55441)
Display Pages with Label Macros

Using labels and macros, you can categorize pages and then display them in Confluence in a number of ways.

As an example, you could label all pages relevant to the marketing team with 'marketing', and then add more specific labels like 'online', 'mobile', and 'physical' to different pages where required.

You could then use the Content by Label Macro to display different combinations of pages with the marketing label. Some combinations you could use would be:

- All pages with the label 'marketing'.
- Pages with all of the following labels: 'marketing', 'mobile', and 'online'.
- Pages with either the 'mobile' or 'online' labels, in the Marketing space.

There are a lot of ways you can filter the content, making it easier for you to find content that's relevant to you.

Other label macros

Here are some other macros that use labels, and can help you categorize and display your content.

**Navigation Map macro**

The Navigation Map macro renders the list of pages associated with a specified label as a navigation map.

**Related Labels macro**

The Related Labels macro lists labels commonly associated with the current page's labels.

**Content by Label macro**

The Content by Label macro displays a list of content marked with specified labels.

**Content Report Table macro**

The Content Report Table macro displays a set of pages and blog posts in tabular format, based on the specified labels.

**Labels List macro**

The Labels List macro lists all labels of a space, grouped alphabetically.

**Recently Used Labels macro**

The Recently Used Labels macro lists labels most recently used in a specified scope - global (site), space, or personal.

**Popular Labels macro**

The Popular Labels macro displays popular labels in a list or in a heatmap (also called a cloud).
Drafts

A draft is a page you've never published. Unpublished changes are edits that you've made to a published page, without republishing them.

Confluence autosaves your drafts and unpublished changes as you work, so if you get interrupted and close your tab or navigate away, your content lives on for you to resume editing when you're ready.

If you're creating or editing, but don't want to publish your changes yet, hit Close at the bottom-right of the editor. This will save those changes in the editor without publishing, and you can return to them at any point. Closing the editor will land you back on the published version of the page, or, if you're working on a draft, on your Recently worked on list.

Find drafts and unpublished changes

Drafts and pages with unpublished changes appear in Recently worked on in the dashboard. You can easily differentiate between these as they'll have a 'draft' or 'unpublished changes' lozenge next to their titles. The 'unpublished changes' lozenge is only visible to people who have contributed to the draft or unpublished changes, so you don't have to worry about it distracting your viewers.

Resume editing a draft

You can find your drafts under Recently worked on or by heading to your profile and clicking on Drafts (only drafts that you created show in your profile). Clicking on a draft will drop you straight into the editor so you can keep editing and/or publish.

If you didn't enter a page title, the draft will be called 'Untitled'.

Resume editing a page with unpublished changes

If you've been editing a page that's already been published, you can find the page again either through the page tree or under your Recently worked on. The 'unpublished changes' lozenge makes them easy to spot.

Edit the page to see the unpublished changes and keep editing, then, when you're ready, hit Publish.

Discarding unpublished changes
If you make changes to a published page, then change your mind, you can discard all changes by reverting to the last published version of the page. This will discard all unpublished changes made by you and any others who have edited the page since the last time it was published.

Before you revert to the last published version you should:

- Check who else has edited the page since last publish - their avatars will be shown at the top of the editor.
- In the editor, go to More options ⚙️ > View changes to see all changes that have been made since last publish. The changes won’t be attributed to individual users.

Once you’ve checked to make sure you aren’t going to inadvertently discard someone else’s changes, go to More options ⚙️ > Revert to last published version to discard all changes.

Delete a draft

To delete a draft go to More options ⚙️ > Delete unpublished page.

Because drafts have never been published, you’ll be deleting the entire page or blog post. Discarded drafts are not sent to the trash.

⚠️ Drafts in Confluence are shared, meaning other people can work on them with you. If you delete a draft that other people have worked on, you’re deleting their changes too.

Personal drafts

When collaborative editing is turned off, drafts work a little differently. Instead of a shared draft, you have a personal draft of a page. See Concurrent Editing and Merging Changes for more information.

You may see some old personal drafts in the Drafts page in your profile. These were created when collaborative editing was turned off.
Concurrent Editing and Merging Changes

Sometimes, another user may edit the same page as you’re editing, at the same time you do. When this happens, Confluence will do its best to ensure nobody’s changes are lost.

How will I know if someone else is editing the same page as I am?

If another user is editing the same page as you, Confluence will display a message above your edit screen letting you know who the other user is and when the last edit was made.

*Screenshot: Concurrent editing notification*

What happens if two of us are editing the same page and the other user saves before I do?

If someone else has saved the page before you, when you click *Save*, Confluence will check if there are any conflicts between your changes and theirs. If there are no conflicting changes, Confluence will merge the changes.

If there are conflicts, Confluence will display them for you and give you the option to:

- **Continue editing** - Continue to edit the page; useful if you want to manually merge the changes.
- **Overwrite** - Replace the other person's edits with yours (their edits will not be included in the latest version).
- **Cancel** - Discard your changes and exit the editor, keeping the other person's edits.

**Example Scenario**

For example, Alice and Bob both edit the same page at the same time.

If Alice clicks save before Bob, Bob is now effectively editing an out-of-date version of the page. When Bob clicks save, Confluence will examine his changes to see if any overlap with Alice’s. If the changes don’t overlap (i.e. Alice and Bob edited different parts of the page), Bob’s changes will be *merged* with Alice's automatically.

If Bob’s changes overlap with Alice’s, Confluence will display an error message to Bob showing where Alice has changed the page, and giving Bob the options to overwrite Alice's changes with his own, to re-edit the document to incorporate Alice's work, or to cancel his own changes entirely, maintaining Alice’s changes.
Page Restrictions

Page restrictions allow you to control who can view and/or edit individual pages in a space. So, if you're working on a page that shouldn't be viewed by just anybody, it's easy to lock it down to the people who need to know. You can add restrictions for individuals or for Confluence groups.

To add or remove page restrictions, you'll need to have permissions to edit the page and 'Restrict' or 'Admin' permission in the space.

Restrict a page or blog post

To restrict who can view or edit a page or blog post:

1. Choose the Restrictions icon at the top of the page.
2. Choose whether you just want to limit only who can Edit, or who can View and / or Edit.
3. Enter users or groups then click Add to add them to the list.
   If you chose Viewing and Editing restricted you can further specify for each person or group whether they can edit or just view the page.
4. Apply the restrictions.

You can add as many users and/or groups as you need. You can apply page restrictions to published and unpublished (draft) pages.

On this page:

- Restrict a page or blog post
- Remove restrictions from a page
- Copy a restricted page
- Get access to a restricted page
- View all restricted pages in a space
- Notes

In this example, some users and groups can view only, others can also edit, plus there are inherited restrictions that might impact who can view the page.
1. **Speed it up**: apply the same restriction to multiple people and groups.
2. **Watch out**: restrictions on other pages can affect this one.
3. **Be specific**: choose exactly what each group or person can do.

**Who is ‘everyone’?**

When we say “everyone can view this page” everyone means all the people who can view the page by default. There are two things that can affect who can view a page - the space permissions, and view restrictions on any parent pages that are being inherited.

Restrictions don’t override a person’s space permission. For example, if you say a person ‘can view’ in the restrictions dialog and they don’t have ‘view’ permissions for the space, they won’t be able to see the page.

**How do inherited restrictions work?**

View restrictions are inherited, which means a restriction applied to one page will cascade down to any child pages. Edit restrictions are not inherited, which means pages need to be restricted individually.

The restrictions dialog will tell you when there are inherited restrictions that might affect who can view your page.

Here’s the basics:

- If you restrict **viewing** to a person or group, only they will be able to see that page and all its child pages (unless there are further restrictions on the child pages).
- If you restrict **editing** to a person or group, they’ll be able to see and edit that page, plus see its child pages.
- Parent pages (higher up in the page hierarchy) can have their own view restrictions that may prevent people from viewing your page.

If the person you’ve listed as a viewer or editor can’t see the page, check to make sure:

- they have **View** space permission for that space, or
- there’s no view restriction on a page higher up the page hierarchy that prevents them seeing any children of that page.

**View current page restrictions**

The restrictions icon at the top of the page gives you a clue that the page has restrictions:

| Viewing this page is not restricted. Everyone can see this page (but editing may be restricted). |
| The page is restricted. Click the icon to see the list of who can view and edit this page. |
Remove restrictions from a page

Removing restrictions is easy. Choose **No restrictions** to remove all restrictions, or click **Remove** next to each person or group in the list if you want to change who can view or edit the page.

Copy a restricted page

When you copy a single page, we don’t automatically copy the restrictions. If the page contains information that should be private, remember to reapply restrictions in the editor *before* you publish, to avoid notifying people who are watching the space.

When you copy a page and all its child pages, you have the option to copy all restrictions, or skip copying restrictions on all pages. See [Copy a Page](#) for more information.

Get access to a restricted page

If you navigate to a page that you’re not able to view or edit because it has page restrictions applied (for example from a link, an invite, or page URL) you may be able to request access to the page.

![Request access image](image)

If the request access message above doesn’t appear, you’re not able to request access for that particular page. This usually is because the page has inherited view restrictions from a parent page, you don’t have adequate space permissions, or there is no mail server set up.

**Request access**

To request access to a restricted page:

1. On the restricted page choose **Request access**.
2. Confluence will send an email to up to 5 people most likely to be able to grant you access.
3. Wait for an email confirming that access has been granted.
Grant access

To grant access to a restricted page:

1. In the request access email, choose **Grant access**.
   You'll be taken to the restricted page, and a dialog will appear with the access request.
2. Choose **Grant access**.
   (We'll let you know if someone else got there before you, and has already granted access)

The user will receive an email confirming that access has been granted.

Who can grant access?

When a user requests access to a restricted page, Confluence will send an email to up to 5 people who are most likely to be able to grant access, in the following order:

1. people who have contributed to the page in the past, can see the page and have 'Restrict' or 'Admin' space permission (sorted by last edit date)
2. space administrators who can see the page (sorted alphabetically).

This means that the request should be actioned quickly, as it prioritizes the people who have been interacting with the page most recently. There's no follow up email if none of the 5 people respond, the user will need to contact a space administrator directly to ask for access.

Disable the ability to request access

If you don't want people to be able to request access to restricted pages, for example if you're using Confluence for public documentation, you can disable the Confluence Request Access Plugin. See **Managing System and Marketplace Apps**.

View all restricted pages in a space

You need space admin permissions to view the list of restricted pages in a space.
To view restricted pages:

1. Go to the space and choose **Space tools > Permissions** from the bottom of the sidebar
2. Choose **Restricted Pages**.

Screenshot: Restricted pages in a space

<table>
<thead>
<tr>
<th>Permissions</th>
<th>Restricted Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title (Space)</td>
<td>Type</td>
</tr>
<tr>
<td>Launch Pil Product Requirements</td>
<td>Edit</td>
</tr>
<tr>
<td>Edit</td>
<td>cassie</td>
</tr>
<tr>
<td>Edit</td>
<td>emma</td>
</tr>
<tr>
<td>Teams in Space Marketing Launch (teams in space)</td>
<td>Edit</td>
</tr>
<tr>
<td>Product Requirements (teams in Space)</td>
<td>View</td>
</tr>
<tr>
<td>Edit</td>
<td>admin</td>
</tr>
</tbody>
</table>

Notes

- **You can't exclude yourself**
  When you apply a restriction, Confluence will automatically add you to the list. You can't remove yourself from this list.
- **Space Admin and System Administrator access to restricted pages**
  Users with 'Admin' permissions in a space, or users with the System Administrator global permission can remove restrictions from pages, even if the page restriction prevents them from viewing the page. Go to **Space Administration > Restricted Pages**.
Links

You can create links to pages, blog posts, anchors, attachments, external websites, Jira issues and more. Links can be text or images, and can be added in many different ways.

Links to pages within your Confluence site are relative, which means that you can move pages and rename pages without breaking links.

This page explains the most common ways to create links.

Insert a text link

To insert a link on a page:

1. In the editor, select some text or position your cursor where you want to insert the link
2. Choose Link on the toolbar or use the keyboard shortcut Ctrl+K
3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular types of content)
4. Enter or modify the link text (this is the text that will appear on the page. If this field is left blank, the page name or URL will be used as the link text.)
5. Select Insert

Other ways to do this

There are a few other ways to insert a link:

- Type ] followed by the page or attachment name. Autocomplete will suggest matching items for you.
- Paste a URL over highlighted text to create link text.
- Paste a URL directly onto your page. Confluence will automatically create the link, and if the URL is for a page in the current site, the page name will be set as the link text.

⚠️ Confluence doesn't provide an option to configure a link to open in a new window or tab. Users can choose to right click / CTRL+click the link if they want to open it in a particular way.

Insert an image link

1. Select an image on your page
2. Choose Link on the Image Properties toolbar
3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular types of content)
4. Choose Insert

Related pages:
- Anchors
- Inserting JIRA Issues
- The Editor
Modify a link

1. Select the link text or image
2. Choose **Edit** from the link properties toolbar
3. Modify the link and choose **Save**

Remove a link

1. Select the link text or image
2. Choose **Unlink** from the properties toolbar

Click to find out more

- Go to link
- Edit
- Unlink

Link to specific types of content

Confluence supports many methods for creating links. Some of the common ones are listed here.

<table>
<thead>
<tr>
<th>Type of link</th>
<th>Ways to do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to a page</td>
<td>Choose <strong>Link &gt; Search</strong> then enter part of the page name.</td>
</tr>
<tr>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td>Choose <strong>Link &gt; Recently viewed</strong> and select a page from the list.</td>
</tr>
<tr>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td>Type [ and enter part of the page name then select the page from the list.</td>
</tr>
<tr>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td>Paste the URL of the page onto your page (Confluence will automatically create the link).</td>
</tr>
</tbody>
</table>
| Link to a page in another space | Choose **Link > Search** enter part of the page name and select **All Spaces** from the drop down.

or

Choose **Link > Advanced** then enter the space key followed by the page name `spacekey:mypage`.

or

Type `[ and enter part of the page name then select the page from the list. (you can hover over each suggestion to see which space the page is from). |

| Link to a blog post | Choose **Link > Search** and enter part of the blog post name.

or

Type `[ and enter part of the blog post name then select the blog post from the list. |

| Link to an attachment or image on this page | Choose **Link > Attachment** then upload or select an attachment from the list.

or

Type `[ and enter part of the attachment file name then select the attachment from the list. |

| Link to an attachment on another page | Choose **Link > Search** and enter part of the attachment name.

or

Type `[ and enter part of the attachment file name then select the attachment from the list (you can hover over each suggestion to see which space the page is from). |

| Link to a website | Choose **Link > Web Link** then enter the website URL.

or

Paste the URL over highlighted text to create link text.

or

Type or paste the URL onto the page (Confluence will automatically create the link). |

| Link to an email address | Choose **Link > Web Link** then enter the email address.

or

Type or paste the email address onto the page (Confluence will automatically create a `mailto:` link). |

| Link to an anchor on a page | Choose **Link > Advanced** then enter the anchor name in one of the formats below.

For an anchor on this page: `#anchor name`.

For an anchor on another page in this space: `page name#anchor name`.

For an Anchor on another page in another space: `spacekey:page name#anchor name`.

See **Anchors** for more information on using anchors. |
| Link to a heading on a page | Choose Link > Advanced then enter the heading in one of the formats below. Heading text is case sensitive and must be entered without spaces.  
For a heading on this page: #MyHeading.  
For a heading on another page in this space: Page Name#MyHeading.  
For a heading on another page in another space: spacekey:Page Name#MyHeading.  
Be aware that these links will break if you edit the heading text. Consider using the Table of Contents macro or an Anchor instead. |
|---|---|
| Link to a comment on a page | Go to the comment, right click the Date at the bottom of the comment and copy the link. Paste the link directly onto your page or choose Link > Web Link and paste in the URL.  
or  
Type [$ then enter the Comment ID ('12345' in this example): [$12345] |
| Link to an undefined page (a page that does not exist yet) | Choose Link > Advanced then enter the new page name (a page will be created on click).  
or  
Type [ then enter the new page name then choose Insert link to create page.  
See Undefined Page Links for more information on undefined pages. |
| Link to a personal space or user profile | Choose Link > Search then enter the user's name and select their personal space homepage or their profile from the list.  
or  
Type [ then enter the user's name and select their personal space homepage or their profile from the list. |
| Link to a Jira issue (where Confluence is connected to Jira) | Paste the Jira issue URL - Confluence will automatically create a Jira Issue macro. |

**Link to Confluence pages from other websites**

The best way to link to a Confluence page from outside Confluence, for example from another site or in an email, is to use the share link which is a permanent URL. This ensures that the link to the page is not broken if the page name changes.

To access the permanent URL for a page:

1. View the page you wish to link to.  
2. Choose Share.  
3. Copy the Share link.

You do not need to use the share link to link to pages within your Confluence site. Confluence automatically updates links when you rename or move a page to another space.

If you want to link to specific content such as anchors, headings or comments you need to use the following link syntax. Note that there are no spaces in the page name, anchor name or heading text.

In the examples below, the anchor name is 'InsertLinkAnchor' and the heading text is 'Insert a link'. Scroll right within the table to see the longer links in full.
### Purpose

<table>
<thead>
<tr>
<th>Link syntax</th>
<th>Example from this page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to an anchor (from an external website)</td>
<td><a href="http://myconfluence.com/display/spacekey/Page+name#pagename-anchorname">http://myconfluence.com/display/spacekey/Page+name#pagename-anchorname</a></td>
</tr>
<tr>
<td>Example from this page:</td>
<td><a href="https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLinks-InsertLinkAnchor">https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLinks-InsertLinkAnchor</a></td>
</tr>
<tr>
<td>Link to a heading (from an external website)</td>
<td><a href="http://myconfluence.com/display/spacekey/Page+name#pagename-headingtext">http://myconfluence.com/display/spacekey/Page+name#pagename-headingtext</a></td>
</tr>
<tr>
<td>Example from this page:</td>
<td><a href="https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLinks-InsertLink">https://confluence.atlassian.com/display/DOC/Working+with+Links#WorkingwithLinks-InsertLink</a></td>
</tr>
<tr>
<td>Link to a comment (from an external website)</td>
<td><a href="http://myconfluence.com/display/spacekey/pagename?focusedCommentId=commentid#comment-commentid">http://myconfluence.com/display/spacekey/pagename?focusedCommentId=commentid#comment-commentid</a></td>
</tr>
<tr>
<td>Example from this page:</td>
<td><a href="https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803">https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803</a></td>
</tr>
</tbody>
</table>

Some things to note when linking to anchors from a website or email message:
- The page name is repeated in the URL, after the # sign. The second occurrence of the page name is concatenated into a single word, with all spaces removed.
- There is a single dash (hyphen) between the concatenated page name and the anchor name.
- The anchor name in the full URL is concatenated into a single word, with all spaces removed.
- The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as you used when creating the anchor.

### Link to a comment

You can add a link to a comment by using the comment URL (a permanent link), or by using wiki markup to link to the Comment ID.

To find out the comment URL and comment ID:

1. Go to the comment you wish to link to
2. Choose the Date at the bottom of the comment and examine the URL

The number after 'comment-' is the Comment ID. An example is shown here.

https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803

You can use wiki markup directly in the editor to link to a comment. Enter [$ followed by the Comment ID, for example [$12345] where '12345' is the Comment ID.

### Using shortcut links

If you have configured shortcut links on your Confluence site, then you can link to an external site using a shortcut link that looks like this:CONF-17025@jira.

Our Confluence site (where this documentation is housed) is configured to allow shortcut links to our Jira site, using the shortcut @jira. So the shortcut link CONF-17025@jira produces this link.
To add a shortcut link using the 'Insert Link' dialog:

1. Select **Link > Advanced** and enter or paste the shortcut link into the **Link** field (shortcut links are case-insensitive)
2. Modify or enter link text (this is the text that will appear on the page)
3. Select **Insert**

You can also type '|' and select **Insert Web Link > Advanced** to enter a shortcut link. See **Configuring Shortcut Links** for more details.
Anchors

You can use anchors to enable linking to specific locations on a page, and they can be especially useful for allowing your readers to navigate to specific parts of a long document. Anchors are invisible to the reader when the page is displayed.

There are two steps to using an anchor:

Step 1: Create the anchor
Step 2: Create a link to the anchor

Step 1: Create the anchor

Add the Anchor Macro to mark the location you want to link to:

1. Do either of the following in the Confluence editor:
   - Choose Insert > Other Macros, then find and select the Anchor macro
   - Type { and the beginning of the macro name, then select the Anchor macro
2. Enter the Anchor Name (For example, 'bottom' or 'important information')
3. Choose Insert

Macro options (parameters)

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anchor Name</td>
<td>None</td>
<td>This is the anchor name that you will use when creating the link.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• The anchor name can include spaces. Confluence will remove the spaces automatically when building a URL that points to this anchor.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• The anchor name is case sensitive. You must use the same pattern of upper and lower case letters when creating the link as you used when creating the Anchor macro.</td>
</tr>
</tbody>
</table>

Step 2: Create a link to the anchor

You can link to an anchor from:

• A page on the same Confluence site. The link may be on the same page as the anchor, another page in the same space, or a page in another space on the same Confluence site.
• Another web page or another Confluence site, using a specifically formatted URL.

Link to an anchor on the same Confluence site:

1. Select some text or position your cursor where you want to insert the link
2. Choose Link in the toolbar or press Ctrl+K
3. Choose Advanced and enter the anchor name in the Link field, following the format below.
4. Enter or modify the Link Text (this is the text that will appear on the page. If this field is left blank, the page name or URL will be used as the link text)

5. Choose Save

- Anchor names are case sensitive.
- Enter page and anchor names with spaces when you link to them in the same Confluence site. A good way to do this is to copy the page title exactly as appears on the page. Don't copy the page URL, as we don't want to include the + symbol).
- If you're linking to an anchor on a different page that has special characters in its name, where the URL displays a page ID rather than a name, you should still enter the page name when linking to it.

**Notes about the full URL:**

- The page name is repeated in the URL, after the # sign. The second occurrence of the page name is concatenated into a single word, with all spaces removed.
- There is a single dash (hyphen) between the concatenated page name and the anchor name.
- The anchor name in the full URL is concatenated into a single word, with all spaces removed.
- The anchor name is case sensitive.
- If the page name contains special characters, where the URL displays a page ID rather than a name, the link to an anchor will look more like this http://myconfluence.com/pages/viewpage.action?pageId=54689987#Test-page1-anchor
  In this example the page title is Test - Page 1! and the anchor name is anchor.
Notes

- **Table of contents on a page**: Consider using the Table of Contents Macro to generate a list of links pointing to the headings on the page. The list of links will appear on the page, and will be automatically updated each time someone changes the wording of a heading.

- **Linking to headings**: You can link directly to the headings of a page. See Links. However, if someone changes the wording of a heading, those direct links will be broken. Use the Anchor macro to ensure a lasting link within the body of a page.

- **Site welcome message**: If you are adding an anchor to a page that you are using in the site welcome message, you can only link to that anchor from another page. Internal links within that page will not work.

- **Templates**: When you are previewing a template, a link to an anchor is displayed as a 'broken' link. However, when you create a page using the template the resulting page will have the correct link.
Tables

Confluence tables allow you to present important information and discuss it with your team. Use familiar table formatting options – resizing columns, coloring cells, rows and columns, aligning content, and sorting the table by clicking the column headers – to view the information the way you like it.

Using Confluence Cloud? Check out our info on the new Confluence Cloud editor if your table looks like this one.

Insert a table

To create a table:

1. Hit the **Table** button in the toolbar
2. Click a cell in the drop-down to set the number of columns and rows in your table

Edit your table

To resize table columns, just click and drag the column's border. To make other changes to your table, click inside it to reveal the table toolbar.

Here's a summary of the table tools:

<table>
<thead>
<tr>
<th>Column width modes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Responsive</strong> – choose this mode if you want the table to expand as you add content. You can drag to resize the columns. It'll also resize itself to fit the page-viewer's window size (within reason).</td>
</tr>
<tr>
<td><strong>Fixed width</strong> – choose this mode if you want to drag column borders to set width. Columns appear at your set size, regardless of content and window size.</td>
</tr>
<tr>
<td>Rows</td>
</tr>
<tr>
<td>----------------------</td>
</tr>
<tr>
<td>• Insert rows before or after the current row</td>
</tr>
<tr>
<td>• Delete the current row</td>
</tr>
<tr>
<td>• Cut, copy and paste the current row</td>
</tr>
<tr>
<td>• Mark a row as a header row (shaded with bold text)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Columns</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Insert columns before or after the current column</td>
<td>Add a table (insert a default table with three columns and four rows)</td>
</tr>
<tr>
<td>• Delete the current column</td>
<td>+ Shift + i</td>
</tr>
<tr>
<td>• Cut, copy and paste the current column</td>
<td>Add a table with a custom number of columns, as specified by the vertical bars (you can't insert a nested table with this shortcut)</td>
</tr>
<tr>
<td>• Mark a column as a header column (shaded with bold text)</td>
<td></td>
</tr>
<tr>
<td>• Add a numbering column to automatically number each row</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cells</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Merge selected cells</td>
<td>Add a table (insert a default table with three columns and four rows)</td>
</tr>
<tr>
<td>• Split selected cells</td>
<td>+ Shift + i</td>
</tr>
<tr>
<td>• Change cell color</td>
<td>Add a table with a custom number of columns, as specified by the vertical bars (you can't insert a nested table with this shortcut)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Alignment</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Align content to top</td>
<td>Add a table (insert a default table with three columns and four rows)</td>
</tr>
<tr>
<td>• Align content to middle</td>
<td>+ Shift + i</td>
</tr>
<tr>
<td>• Align content to bottom</td>
<td>Add a table with a custom number of columns, as specified by the vertical bars (you can't insert a nested table with this shortcut)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Delete entire table</td>
<td>Add a table (insert a default table with three columns and four rows)</td>
</tr>
</tbody>
</table>

Shortcut keys

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Shift + i</td>
<td>Add a table (insert a default table with three columns and four rows)</td>
<td>+ Shift + i</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>**</td>
<td>**</td>
<td>**</td>
</tr>
<tr>
<td>Add a table with custom headings as specified by the text (you can’t insert a nested table with this shortcut)</td>
<td>Ctrl + Shift + c</td>
<td>Copy the current table row, or the selected rows</td>
</tr>
<tr>
<td>Ctrl + Shift + y</td>
<td>Paste the table rows from your clipboard, placing them above the current row</td>
<td>Ctrl + Shift + x</td>
</tr>
<tr>
<td>Alt + Up Arrow</td>
<td>Add a row above the current row</td>
<td>Alt + Down Arrow</td>
</tr>
</tbody>
</table>

For more editor keyboard shortcuts, see [Keyboard shortcuts](#).

**Sort the table in view mode**

When viewing a table on a page, you can sort it by clicking the sort icons in the header row.

*Screenshot: A colorful, sortable table*

<table>
<thead>
<tr>
<th>Document</th>
<th>Author</th>
<th>Reviewer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Get started</td>
<td>Sandy</td>
<td>Pete</td>
</tr>
<tr>
<td>Installation guide</td>
<td>Sandy</td>
<td>Trinh</td>
</tr>
<tr>
<td>Upgrade guide</td>
<td>Juan</td>
<td>Lise</td>
</tr>
</tbody>
</table>

The default sort order is the order the table rows are listed in the editor. You can use the [Cut row](#) and [Paste row](#) icons to move rows around in the editor.

**Sticky table headers in view mode**

In some instances the header rows of your table will stick to the top when you're scrolling down a page, making those really long tables easier to read.

You don’t need to do anything to enable sticky table headers, however there are a lot of situations where headers won’t stick. These include when your table:

- Is inside a page layout, inside another table, or inside a macro.
- Has no header row or there are cells in the top row that aren't marked as headers.
- Has a header column, instead of a header row, and scrolls horizontally.
- Contains another table, that has its own header row.

There's no way to freeze rows or columns in Confluence tables.

See

- [CONFSERVER-54343](#) - Table header with heading column not sticky when scrolling
  
  **LONG TERM BACKLOG**

for issues with sticky table headers.
Add, Assign, and View Tasks

Keep track of the things that need to get done with tasks. With the ability to give each task an assignee and due date, and plenty of ways to see your tasks, you can make sure nothing slips through the cracks.

Add a task

You can add tasks on any page in Confluence. For example, you might add tasks under action items on a meeting notes page, or in a requirements page – anywhere you need a lightweight task management solution.

To create a task:

1. In the editor, choose the Task list button or use the keyboard shortcut [ ]
2. Start typing your task – @mention someone to assign the task to them, and type // and choose a due date

The first person you mention in a task is the assignee; you can even assign tasks to yourself.

Note:

- If you assign a task to someone who doesn’t have permission to view the page or space, they won’t see the task.
- Tasks with no text will not be shown in the Task report macro.

View tasks

There are a number of ways to keep track of tasks assigned to you, or tasks you’ve created for others.

On a page

The simplest way to see a task is on the page it was originally created on. It’s easy to see if a task is complete, who it’s assigned to, and when it’s due. If a task is nearing or passed its due date, the color of the date will change (red for overdue, orange for due in the next 7 days).

In your profile

The tasks page in your profile gives you a place to see all the tasks relevant to you. Easily keep track of the status of tasks assigned to you, and tasks you’ve created and assigned to others.

To view the tasks page, go to Profile > Tasks. Use the filters to show tasks that were assigned to you or created by you in the last 6 months, and toggle between complete or incomplete tasks.
If you need to see more than just your last 6 months of tasks, use a Task Report.

**In a Task Report**

If you're looking for a more custom view of tasks, the Task Report blueprint is a great way to track tasks assigned to a specific team or project.

To create a task report:

1. Choose Create > Task Report
2. Select the type of report:
   - **Assigned to my team** – for tasks assigned to particular people.
   - **In my project** – for tasks that appear in a specific space or parent page.
   - **Custom** – for a wide range of filtering options, including by date or page label.
3. Follow the prompts to create the report.

This blueprint uses the Task Report Macro. You can also choose to use this macro on an existing page, for example, on a project or team space homepage.

### Notes

- The date picker can be triggered by typing // or by typing a date in the format dd/mm/yyyy or dd-mm-yyyy. Typing other date formats in the editor won't trigger the date picker.
- Personal Tasks (created in the Workbox in older versions of Confluence) don't appear in the Tasks view or Task Report. To migrate any incomplete personal tasks, go to Workbox > Personal Tasks and follow the prompts.
- The wiki markup based Tasklist Macro has been removed from the macro browser. If you have a Tasklist macro on a page it will continue to work, but you will be unable to add new Tasklists using this macro.
Do more with Confluence

For even more ways to organize your tasks in Confluence, check out these apps from the Atlassian Marketplace:

- Comala Workflows: Improve document collaboration by assigning users to review, approve, and publish pages
- TodoMe for Confluence: Add, assign, and view tasks from every Confluence page
- Agile Retrospectives for Confluence: Interactively assign action items to team members
Autocomplete for links, files, macros, mentions and emojis

When using the Confluence editor, you can type a trigger character or press a keyboard shortcut to see a list of suggested links, files, emojis, or macros to add to your page, or to mention another user (and automatically notify them of this).

Summary of autocomplete

<table>
<thead>
<tr>
<th>What you want to do</th>
<th>Trigger character</th>
<th>Keyboard shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a link on your page</td>
<td>[</td>
<td>Ctrl+Shift+K</td>
<td>See a list of suggested pages or other locations to link to from your page. More...</td>
</tr>
<tr>
<td>Display an image, video, audio file or document on your page</td>
<td>!</td>
<td>Ctrl+Shift+M</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page. More...</td>
</tr>
<tr>
<td>Add a macro on your page</td>
<td>{ or /</td>
<td>None</td>
<td>See a list of suggestions as you begin typing a macro name. More. ..</td>
</tr>
<tr>
<td>Notify another user by email that you have mentioned them on your page</td>
<td>@</td>
<td>None</td>
<td>See a list of suggested users to mention. More...</td>
</tr>
<tr>
<td>Add an emoji on your page</td>
<td>:</td>
<td>None</td>
<td>See a list of suggested emojis to add to your page More...</td>
</tr>
</tbody>
</table>

On this page:

- Summary of autocomplete
- Using autocomplete for links
- Using autocomplete for images, videos, audio files and documents
- Using autocomplete for macros
- Using autocomplete for mentions
- Using autocomplete for emojis
- Canceling autocomplete
- Enabling and disabling autocomplete
- Ignoring autocomplete

Related pages:

- Links
- Using Images
- Macros
- Keyboard shortcuts
- Your profile and settings

Using autocomplete for links

Type ‘[’, or press Ctrl+Shift+K, to see a list of suggested pages or other locations to link to from your page. You can link to pages, user profiles, images, documents and other file attachments.

To autocomplete a link:

1. Edit the page.
2. Click where you want to insert a link and do one of the following:
   - Type ‘[’ and then the first few characters of the page title, user’s name, image name or file name.
   - Type the first few characters of the page title, user’s name, image name or file name (or select relevant text) and then press Ctrl+Shift+K.
3. Click the relevant link from the list of suggestions.

If the item you need is not in the list, either:

- Choose **Search for ‘xxx’** to continue looking for the page within Confluence, or
- Choose **Insert Web Link** to insert a link to an external web page using the link browser.
Using autocomplete for images, videos, audio files and documents

You can use the autocomplete as a fast way of embedding images, videos, audio files and documents into your page. Type an exclamation mark or press Ctrl (or Cmd)+Shift+M to see a list of suggested images, multimedia files and documents to display on your page. You can use autocomplete to embed the following file types:

- Images – any format that Confluence supports.
- Videos, audio files and all multimedia formats that Confluence supports.
- Office documents supported by the Confluence Office Connector: Word, Excel and PowerPoint.
- PDF files.

Autocomplete works most efficiently for files that are already attached to the Confluence page.

To embed an image, video, audio file or document:

1. Edit the page.
2. Click where you want to insert the image, video, audio file or document and do one of the following:
   - Type ‘!’ and then the first few characters of the image, file or document name.
   - Type the first few characters of the name of the image, file or document (or select relevant text) and then press Ctrl (or Cmd)+Shift+M.
3. Choose the relevant file from the list of suggestions.

If the item you need is not in the list, either:

- Choose Open file library to find images and documents using the image browser, or
- Choose Insert other media to embed videos, audio and other multimedia files using the macro browser.

Screenshot: Autocomplete for a link

I want to add a link to [sample]
Using autocomplete for macros

Type '{' or '/' to see a list of suggested macros to add to your page.

Autocomplete provides access to all available macros in your Confluence site, including any user macros that your administrator has added and made visible to all.

You need to know the name of macro. Autocomplete for macros will only match the name of the macro, not the description.

**To autocomplete a macro using '{' or '/':**

1. Edit the page.
2. Click where you want to insert the macro.
3. Type '{' and then the first few characters of the macro name.
4. Choose the relevant macro from the list of suggestions.
5. Configure the macro by completing the form fields as prompted.

If the macro you need is not in the list, choose **Open Macro Browser** in the list of suggestions to continue looking for the macro in the macro browser. *See macros*

**Screenshot: Autocomplete for a macro**

Using autocomplete for mentions
You can use autocomplete to automatically notify another Confluence user that you have mentioned them in a page, blog post, or comment. Type '@' and part of the person's name, to see a list of suggested users.

**Note:** Use the person's full name. Autocomplete will recognize users' full names only, not their usernames.

**Using autocomplete for emojis**

You can use the autocomplete as a fast way of searching for and inserting emojis to your page. Type ':' to see a list of emoji suggestions. If you continue typing, the list will change to predict and match your search.

**To autocomplete an emoji:**

1. Edit the page.
2. Click where you want to insert the emoji, and do one of the following:
   - Type ':' and then the first few characters of the emoji name or shortcut
   - Type ':' and then type the complete emoji name or shortcut
   - Type ':' and browse the emoji suggestions with your mouse or up/down arrows
3. Select the relevant emoji from the list of suggestions in the menu

Alternatively, if you type the complete emoji shortcut (which starts and ends with colons "::", for example :wave:), it will autoformat on the page. See **Symbols, emojis and special characters**.

**Screenshot: Autocomplete for an emoji**

I want to add an emoji :

![Autocomplete for an emoji](image)

**Canceling autocomplete**

The autocomplete starts automatically when you press the trigger characters. You may want to close the autocomplete menu or escape from autocomplete once it has started.

There are a few different ways to stop the autocomplete once it has started:

- Press the escape key, 'Esc', on your keyboard.
- Click somewhere else in the editor panel.
- Press an arrow key to move out of the autocomplete area.
- For the *link* autocomplete only: enter a right-hand square bracket, like this: ]
Enabling and disabling autocomplete

You can turn off the triggering of autocomplete by the ‘[’ and ‘]’ characters. This will prevent the autocomplete from starting automatically when you press one of the trigger characters. You can also turn it back on again.

Notes:

- This setting does not affect the keyboard shortcuts for autocomplete (Ctrl+Shift+K and Ctrl+Shift+M). Even if the trigger characters are disabled, you can still use the keyboard shortcuts for autocomplete.
- This setting affects only you. Other people using Confluence can enable or disable the setting on their user profiles independently.
- Note that autocomplete is enabled by default.

To enable or disable the autocomplete trigger characters:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Choose Editor under ‘Your Settings’ in the left-hand panel.
3. Choose Edit.
4. Either:
   - Disable autocompletion by selecting Disable Autocomplete.
   - Enable autocompletion by clearing Disable Autocomplete.
5. Choose Submit.

Screenshot: User settings for the editor

Ignoring autocomplete

You can add macros, links and images by wiki markup alone. Type the macro, including its parameters and the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an image or other embedded object, enclosed between exclamation marks. As soon as you close the macro, link, or embedded image, Confluence will convert it to rich text format and add it to the page.

For more information about mouse-free macros, links and images, choose Help ☰ > Keyboard Shortcuts from the Confluence header.
Page Layouts, Columns and Sections

The layout of your pages can have a big impact on how they're read, and layouts, used well, allow you to position text, images, macros, charts, and much more, to have the best visual impact.

There are two ways to modify the layout of a Confluence page:

- Use page layouts to add sections and columns
- Use macros to add sections and columns.

Page layouts provide a simple, visual representation of your page layout in the editor, while the macros are more flexible and allow for greater complexity in your layout.

Using Confluence Cloud? Check out our info on how to format your page in the new editor.

Use page layouts

The page layouts tool allows you to structure your page using horizontal sections and vertical columns. By adding multiple sections with different column configurations you can build quite complex layouts very easily.

Screenshot: Editor view of a page showing three sections with different column configurations.

Start by adding a horizontal section to your page.

To add a section:

1. Choose the Page Layout button in the toolbar
2. Choose Add Section

The new section appears below your current content, with the boundaries of the section(s) indicated by dotted lines (the dotted lines aren't visible when you view the page).

To change the column layout in a section:

1. Place your cursor in the section you wish to change
2. Choose a layout from the page layout toolbar (for example, two columns or three columns)
Any text, images or macros in your section are not lost when you change the column layout. When you decrease the number of columns, Confluence will move your content to the left. When you increase the number of columns, Confluence will add blank columns to the right of your existing content.

**To move a section to another part of the page:**

1. Place your cursor in the section you wish to move
2. Choose the **Move up** or **Move down** buttons

The section and all of its content will be moved above or below other sections on the page.

**To delete a section:**

1. Place your cursor in the section you wish to remove
2. Choose **Remove section**

The section and all of its content will be removed.

If you need to remove all layouts from a page, move all the content into one section, and set that section to be a single column. When you publish the page the layout will be removed.

**Notes about Page Layouts**

- **Column width** – The width of the columns are a fixed percentage. If you need more than three columns, or columns of a specific width, you should use the Section and Column macros described below.
- **Very wide tables** – The width of each column is set to a percentage of the page width. The icons in the drop-down menu indicate the relative widths for each layout. In most cases, Confluence will adapt the width of the columns to fit the width of the page. If a column includes an item that's too wide for it, you'll see a horizontal scroll bar when viewing the page.

**The Section and Column macros**

You can use the Section and Column macros to add a set of columns to the page. The Section macro defines an area that will contain the columns. You can have as many sections as you like. Within each section, you can have as many columns as you like.

The Section and Column macros are useful if you want to define a specific percentage or pixel width for each column.

**To add a section and some columns to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**
2. Find the **Section** macro, select it and insert it onto the page
3. Choose **Insert > Other Macros** again
4. Find and insert the **Column** macro
5. Add your content to the column

Insert as many columns as you like within the section.

⚠️ You should always have at least one column macro within a section macro. Using a section macro without any column macros can negatively affect page loading time.

**Screenshot: A section and two columns in the editor**
Macro parameters

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Parameters of the Section macro

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Border</td>
<td>false</td>
<td>Select this option to draw a border around the section and columns.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note:</strong> Without a Column macro, the border will not be displayed correctly.</td>
</tr>
</tbody>
</table>

Parameters of the Column macro

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Width</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>Specify the width of the column, in pixels (for example, 400px) or as a percentage of the available width (for example, 50%).</td>
</tr>
</tbody>
</table>

⚠️ All content within your section must be enclosed within a Column macro, otherwise the section layout will not work as expected.
Create Beautiful and Dynamic Pages

Confluence has a number of features that help you build attractive pages to engage your readers and give them the opportunity to interact with up-to-date information. This page summarizes those features and provides links to detailed instructions.

Add visual appeal

**Pictures, photographs and screenshots.** Confluence pages can display images from your Confluence site and from other websites. To put an image into Confluence, you can upload it and attach it to a page or blog post, then display it on any page, blog post or comment. Alternatively, display a remote image using its web address (URL). See Displaying Images.

**Galleries.** Use the Gallery Macro to display a set of images. When viewing the page, people can click any of the pictures to zoom in and view the images as a slide show.

**People.** Add a Profile Picture Macro to show a picture of a Confluence user, or a User Profile Macro to show a summary of the person's profile as well as their avatar.

Multimedia. You can display movies, animations and videos, and embed audio files on your Confluence page. For example, Confluence supports Adobe Flash, MP3, MP4, and various other movie formats. See Embedding Multimedia Content.

Social video and image sharing. The Widget macro displays live content from social sites such as YouTube and other video sharing sites, and Flickr for shared photographs. See the guide to the Widget Connector Macro.

Bring numbers to life

The Chart Macro offers a variety of graphs and charts that you can use to illustrate statistics and other numerical data.

*Illustration: A 3-dimensional bar chart produced by the Chart macro*

Display presentations and documents

Display your Office documents and other presentations directly in Confluence.

- Attach your Office documents to a Confluence page then display them on the page, using the View File Macro. This works for Excel spreadsheets, PowerPoint presentations and Word documents.
- Display PDF files in Confluence too, also with the View File Macro.
- Use the Widget Connector Macro to show slide decks hosted on SlideShare and other online presentation sites.

On this page:

- Add visual appeal
- Bring numbers to life
- Display presentations and documents
- Pull in content from Jira applications
- Tell a story in pictures
- Vary the structure of your pages
- Integrate your content with social media
- Show activity streams

Related pages:

- Macros
- The Editor
- Create and Edit Pages
Pull in content from Jira applications

Many project teams and customers also use Jira applications such as Jira Software or Jira Service Management. Rather than copying and pasting issues onto your Confluence page, you can display it directly from the source, thus ensuring that the information shown in Confluence is always up to date.

Link to a feature request in your issue tracker, or display a list of fixed issues – useful for release notes and project planning. See the Jira Issues Macro.

Tell a story in pictures

A number of Marketplace apps for Confluence provide sophisticated tools for creating diagrams and mockups.

For example:

- Balsamiq Mockups for Confluence
- Creately for Confluence
- Gliffy Confluence Plugin
- Graphviz Plugin for Confluence
- Lucidchart for Confluence

Search the Atlassian Marketplace for more apps.

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.
Illustration: A Gliffy diagram

Vary the structure of your pages

You can build up a custom layout by using the page layout tool to add sections and columns to your page. See the detailed guidelines to Page Layouts, Columns and Sections.

Do you need to display tabular data, which your readers can sort when viewing the page? See Tables.

Use other macros to highlight and format sections of your page:

- Panel
- Info, Tip, Note, and Warning
- Code block
- Noformat

Integrate your content with social media

People share information on various social sites. You can make Confluence a focal point where people collect their shared information and see what is happening in the areas that matter to them.

Use the Widget Connector macro:

- Show a live stream of tweets from a Twitter user, or tweets matching a Twitter search.
- Display a video from YouTube or other online movie sites.
- Share photographs from Flickr.
- See what else the Widget Connector macro can do.
Illustration: Twitter stream via the Widget macro

Show activity streams

Make your Confluence pages dynamic and interactive with:

- An activity stream showing updates and comments on Confluence and other linked applications. See Gadgets.
- An RSS feed from within Confluence or an external site. See Subscribe to RSS Feeds within Confluence.
- A list of recent blog posts from within Confluence. See Blog Posts Macro.
Page Templates

When you add a new page, you don't have to start from scratch. Instead, you can base your new page on a template – a Confluence page with predefined content. Some templates are provided by blueprints or Marketplace apps, and you can even create your own templates.

Some examples of useful templates are:

- The meeting notes template will help you and your team collaborate on notes and follow-up tasks
- The requirements template allows you to capture your software /hardware product requirements, and create related Jira issues from the page

Global templates and space templates

In Confluence, there are four categories of page templates:

- **Space templates:** These page templates are available in a specific space only. If you have space administrator permission, you can define templates via the space administration screen.
- **Global page templates:** These page templates are available in every space on your site. If you have Confluence Administrator permission, you can define global templates via the Confluence Administration Console.
- **Blueprints:** A blueprint is a page template with added functionality to help you create, manage and organize content in Confluence, and there's a collection of predefined ones that ship with Confluence. You can also download additional blueprints from the Atlassian Marketplace. You can customize the blueprint templates to suit your individual needs, disable particular blueprints or even develop your own blueprints.
- **System templates:** Confluence also provides ‘system templates’ containing content like the site welcome message and default space content. See Administering Site Templates. If you edit a system template, it is referred to as a custom or edited system template.

Create a template

You can write your template using the Confluence editor. You can also add special variables to the page, if you want to include fields that the author will complete when adding the page. See Create a Template for more information.

Use a template

Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some Marketplace apps provide enhanced template functionality. You can search the Atlassian Marketplace for template apps. See Create a Page from a Template for more information.

Promote templates in the Create dialog

Looking for new Confluence templates? A huge range of templates are now available in Confluence Cloud. Learn more about templates in Confluence Cloud.

These templates are not available for Confluence Data Center.
If you're a space administrator, you can choose to promote specific templates and blueprints in the Create dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular types of content, instead of blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank Page and Blog Post collapsed under them. To view the other types of content available choose the **Show more** link.

1. **Show more**: see more templates and blueprints.

**To promote a template or blueprint:**

1. Go to **Space Tools > Content Tools**
2. Choose **Promote** next to the templates or blueprints you want to appear in the Create dialog. You can only promote templates created in this space.

Remember, by promoting a blueprint or template you'll be hiding all other items, including blank page and blog post, under the **Show more** link.

If you use the **Show more** link in the create dialog more than three times in a single space, the dialog will show you all templates by default from then on.
Create a Template

In Confluence, there are four categories of page templates:

- **Space templates:** These page templates are available in a specific space only. If you have space administrator permission, you can define templates via the space administration screen.
- **Global page templates:** These page templates are available in every space on your site. If you have Confluence Administrator permission, you can define global templates via the Confluence Administration Console.
- **Blueprints:** A blueprint is a page template with added functionality to help you create, manage and organize content in Confluence, and there’s a collection of predefined ones that ship with Confluence. You can also download additional blueprints from the Atlassian Marketplace. You can customize the blueprint templates to suit your individual needs, disable particular blueprints or even develop your own blueprints.
- **System templates:** Confluence also provides ‘system templates’ containing content like the site welcome message and default space content. See Administering Site Templates. If you edit a system template, it is referred to as a custom or edited system template.

Add a template

To create a new space template:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Templates > Create new template.

To create a new global template:

1. Go to Administration > General Configuration Global Templates and Blueprints.
2. Choose Add New Global Template

Looking for new Confluence templates? A huge range of templates are now available in Confluence Cloud. Learn more about templates in Confluence Cloud.

These templates are not available for Confluence Data Center.

The template editor

When you create or edit a template, you’ll be using the editor in much the same way as when you edit a page or blog post. In addition you can add variables, which will produce a form for data collection when anyone adds a page based on the template.

Screenshot: The template editor with an image, table, text, and variables
Screenshot: The form displayed when you create a page based on the template

Template variables
When you add variables to your template, they will act as form fields. When you create a page based on a template, you’ll see a text entry box for each field. Enter data into each field, and it’ll be added to the page.

You can add the same variable more than once in the same template, which is useful if you need the same information in more than one place on the page.

**To insert a variable into a template:**

1. Create a new template or **Edit** a template.
2. From the editor toolbar, select ![Variable](variable_icon) then choose **New Variable** (or choose an existing variable to add it to the page).
3. Enter a name for the variable.
4. Press **Enter** (by default this will create a single-line text input field).

To change the variable type, click the variable placeholder and the variable’s property panel will appear. Choose one of the variable types: **Text**, **Multi-line Text**, or **List**.

You can change the number of lines and width in characters of a **Multi-line Text** field. If you choose **List**, enter each of the items in your list, separated by commas.

**Hint:** Type $ and the variable name, then press **Enter** to add a new variable or to select an existing variable from a list of suggestions. The suggestions dialog shows variables already defined in this template.

**Labels**

If you'd like all pages created using this template to have one or more labels, choose the labels icon ![Labels](labels_icon) next to the breadcrumbs at the top of the page to add them.

*Note:* Currently, it's not possible to edit the labels of blueprint templates.

**Images and other attachments**

You can't upload an image or other file into a template directly. First you'll need to upload the file to a page in your site, then in your template, choose **Insert > Files > Search on other pages** to embed the file or image.

**Instructional text**

Instructional text is placeholder content in a template, and is only visible while you're editing the page. Use it to give guidance to whoever is creating a page from the template.

**To insert instructional text:**

1. Create a new template or **Edit** a template.
2. From the editor toolbar, select ![Variable](variable_icon) then choose **Instructional text**.
3. Type in your instructional text (for example, *Insert an image of the interface here.*)
Instructional text appears in italics with a shaded background, to distinguish it from normal paragraph text.

You can also change the placeholder type from Text to either:

- **User mention** – Opens the user mention dialog.
- **Jira Macro** – Opens a dialog that allows you to create a new Jira issue, or search for one or more Jira issues to include on the page.

Add a description to your template

The template description displays in the 'Create' dialog, and is useful for explaining the purpose of your template to other users.

**To add a description to a template:**

- Go to the space or global templates page (as described above)
- Choose the **Edit** icon in the 'Description' column
- Enter your description and choose **Save**

1. **Edit**: use the pencil icon to edit your template's description.

Edit or delete a template

If you need to change anything about your template, or want to delete it, navigate to either your space or global template (as described above) and choose either **Edit** or **Delete**.

Notes

- Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some Marketplace apps provide enhanced template functionality. You can search the [Atlassian Marketplace](https://marketplace.atlassian.com) for template apps.
- When you use a Table of Contents macro in a template, you'll see an error when you preview the template, but the Table of Contents macro works on the pages that people create from the template.
- The editor for templates is available only in **Confluence 4.3 and later**. Please refer to the earlier documentation for a description of the wiki markup editor templates.
- Confluence also provides 'system templates' containing content like the site welcome message and default space content. See [Administering Site Templates](https://confluence的帮助).
Create a Page from a Template

You can create a page based on a global template (available to all spaces) or a space template (available only to that space).

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a page from a template, hit the Create from template button.

1. Create blank page
2. Create from template

Looking for new Confluence templates? A huge range of templates are now available in Confluence Cloud. Learn more about templates in Confluence Cloud.

These templates are not available for Confluence Data Center.

Information copied from the template to the page

When you create a page based on a template, Confluence will copy the following content and information from the template to the new page:

- Labels
- Text and styles
- Layouts and formatting
- Macros
- Embedded images and other files. Note that you cannot attach an image or other file to a template. But if the template displays an image or file from another page, the new page will display that image or file too.

Form fields displayed by the template

If the template author included variables in the template, Confluence will display a form prompting you to supply values for the variables when you add the page.

Using a template to create a page

To create a page based on a template:

1. Choose Create from template in the Confluence header
2. Select a space and the template you want to use and choose Next
   If the template contains variables, you’ll see a form allowing you to add values for the form variables.
3. Type the relevant information into the form fields, and choose Next
   Now you’ll see a new page based on the template. If you added information in the form fields, the page content will include that information.
4. Name your page, add content or make any other changes required and hit Save

Screenshot: Form showing template variables when creating a page from a template

On this page:

- Information copied from the template to the page
- Form fields displayed by the template
- Using a template to create a page
- Notes

Related pages:

- Create a Template
- The Editor
- Add, Remove and Search for Labels
Notes

Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some Marketplace apps provide enhanced template functionality. You can search the Atlassian Marketplace for template apps.
Blueprints

What's a blueprint?

A blueprint is a set of page templates with added functionality to help you create, manage and organize content in Confluence more easily.

Create meeting notes, shared file lists and requirements documentation out of the box, and Customize the blueprint templates to suit your individual needs. You can even develop your own blueprints.

Create content using a blueprint

1. Choose Create from template in the Confluence header
2. Select a blueprint from the create dialog
3. Hit Create

The editor will open, and, depending on the blueprint selected, a prompt to enter information or the page will appear. You can now follow the instructions built in to the blueprint to add content.

The first time a blueprint is used in a space, Confluence creates an index page and adds a shortcut to your sidebar (if you're using the default theme). The index displays a list of pages made with the blueprint, and information selected from your blueprint pages. For example, the meeting notes index displays a list of all meeting notes pages in the space, who created them, and when they were last modified. Here's the index page for the Meeting Notes blueprint:

1. Easy to find: notes from all your meetings are listed here.
2. Start a new meeting: create a new meeting notes page here.

Customize blueprint templates

Blueprints are made up of templates that can often be customized for an individual space or the whole site. This means you can adapt the content of the blueprint pages to suit your specific needs. For example, you might update the Meeting Notes blueprint templates to include a heading for apologies.

If you have space administrator permissions, you can customize blueprint templates for the spaces you are an administrator of. You must be a Confluence Administrator to customize blueprint templates for a whole site. See Administering Site Templates for more information.
To customize a blueprint template for a space:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Edit beside the blueprint template you wish to edit
3. Make your changes to the template and choose Save

Editing a blueprint template is very similar to editing a page template, except:

- Be careful not to remove any macros that the blueprint page or index page may use to store and display information
- You can't remove a blueprint template or change the template name
- Not all blueprints are customizable. Some, including the Team Playbook blueprints (health monitor, DACI, project poster, and experience) can't be edited.
- Currently, it’s not possible to edit the labels of blueprint templates.

To reset a blueprint template back to the default:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Reset to default beside the blueprint template you wish to reset

See Working With Templates and Administering Site Templates for more information on templates.

As with user created space and site templates, editing a blueprint template will not change existing pages, but any new blueprint pages will be based on the updated template.

Promote blueprints in the Create dialog

If you’re a space administrator, you can choose to promote specific templates and blueprints in the Create dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular types of content, instead of blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank Page and Blog Post collapsed under them. To view the other types of content available choose the Show more link.

1. Show more: see more templates and blueprints.

To promote a template or blueprint:

1. Go to Space Tools > Content Tools
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog. You can only promote templates created in this space.

Remember, by promoting a blueprint or template you'll be hiding all other items, including blank page and blog post, under the Show more link.

If you use the Show more link in the create dialog more than three times in a single space, the dialog will show you all templates by default from then on.

Add more blueprints
You can find more blueprints for Confluence in the Atlassian Marketplace. Blueprints are managed using apps (also known as add-ons, or plugins).

See Request Marketplace Apps for information on how you can search for new blueprint apps and send a request to your System Administrator.

If you are a System Administrator, see Managing System and Marketplace Apps for information on how to install new blueprint apps.

You can also develop your own blueprints. See our developer documentation on Writing a Blueprint.

Disable a blueprint

You may want to disable particular blueprints. For example, you may not want to see the Product Requirements blueprint in the create dialog in an HR or Social space. If you are a Confluence Administrator you can also disable particular page and space blueprints for the whole site.

To disable a blueprint in a space:

- Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
- Choose Disable next to the blueprint you wish to disable in that space

You can re-enable the blueprint at any time.

To disable a blueprint across a whole site:

- Select Administration then select General Configuration (You need Confluence Administrator permissions to do this)
- Choose Global Templates and Blueprints
- Choose Disable next to the page or space blueprint you wish to disable

The blueprint will not appear in the ‘Create’ or ‘Create Space’ dialogs.

Full list of blueprints

Here’s the full list of blueprints bundled with Confluence.

<table>
<thead>
<tr>
<th>Page blueprints</th>
<th>Space blueprints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meeting notes</td>
<td>Documentation space</td>
</tr>
<tr>
<td>File list</td>
<td>Team space</td>
</tr>
<tr>
<td>Decision</td>
<td>Knowledge base space</td>
</tr>
<tr>
<td>How-to article</td>
<td></td>
</tr>
<tr>
<td>Troubleshooting article</td>
<td></td>
</tr>
<tr>
<td>Jira report</td>
<td></td>
</tr>
<tr>
<td>Product requirements</td>
<td></td>
</tr>
<tr>
<td>Retrospective</td>
<td></td>
</tr>
<tr>
<td>Share a link</td>
<td></td>
</tr>
<tr>
<td>Task report</td>
<td></td>
</tr>
<tr>
<td>DACI decision</td>
<td></td>
</tr>
<tr>
<td>(Atlassian Team Playbook)</td>
<td></td>
</tr>
<tr>
<td>Experience canvas</td>
<td></td>
</tr>
<tr>
<td>(Atlassian Team Playbook)</td>
<td></td>
</tr>
<tr>
<td>Health Monitor</td>
<td></td>
</tr>
<tr>
<td>(Atlassian Team Playbook)</td>
<td></td>
</tr>
<tr>
<td>Project poster</td>
<td></td>
</tr>
<tr>
<td>(Atlassian Team Playbook)</td>
<td></td>
</tr>
</tbody>
</table>
Decisions Blueprint

The Decisions blueprint helps you make decisions and record the outcomes with your team.

The first time you use the Decisions blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you're using the default theme). The index acts as your Decision Log and lists all the decisions in that space.

To create a decision page:

1. Choose Create from template in the Confluence header
2. Select Decision and hit Next
3. Enter information about the decision and relevant stakeholders (the blueprint will prompt you) and hit Create

Once you save your first decision page, Confluence will create a decision log page for the space you're in, and add a shortcut to it in the space's sidebar.

Here's how the decisions page looks in the editor:

Once you save your first decision page, Confluence will create a decision log page for the space you're in, and add a shortcut to it in the space's sidebar. The decision log lists all the decisions in that space.
1. **Decision pages**: your existing decisions appear here.
2. **More decisions**: create new pages using the decision template.

The Decisions blueprint uses these Confluence features:

- **Page Properties** and **Page Properties Report** macro - content that you enter within the page properties macro can appear on the index page.
- **Mentions** - add a user as a stakeholder, owner or @mention them on the page and they will be notified in their workbox.

For an example of the Decisions Blueprint, and some other great page elements, check out: How to make better decisions as a development team.

### Customizing this blueprint

You can customize the templates that are used by the Decisions blueprint - see Customizing the blueprint templates. For example, you might choose to edit the decisions **index page** in a space to change the columns displayed by the Page Properties Report macro.

You can also edit the **page template** to add headings or instructional text to the background section, or even add rows to the Page Properties macro. For example, a row for the date the decision was made.

See Instructional text to find out more about using instructional text in templates.
File List Blueprint

The File List blueprint helps you to create lists of files to share with your team. Great for organizing documents, images and presentations.

The first time you use the File List blueprint in a space, Confluence will create an index page and add a shortcut to your space sidebar (if you're using the default theme). The index page lists the latest File List pages in that space. You can have as many File List pages as you need.

To create a file list:

1. Choose Create from template in the Confluence header
2. Select File List and hit Next
3. Enter the details for your file list and hit Create
4. Drag files from your desktop or choose browse for files to search for files on your computer

Here's an example of a file list page:
1. **Expand**: view each file's details and preview.
2. **Upload and download**: drop files to upload, and download all files.
3. **Version history**: see and manage other file versions.

Attachments appear on the page, and you can expand each attachment to preview the file and/or view its details.

In this example, we've created three file list pages to store project-related presentations, images and customer feedback. Confluence looks after the versioning of the files, so there's no need to use the document file name to mark version numbers.

Once you save your page, Confluence will create an index page and add a shortcut to your space sidebar. The index page lists the latest File List pages in the space. Create as many File List pages as you need.

1. **Space shortcut**: a quick way to find all of your file lists in this space.
2. **Create a new list**: create more file lists in this space.
3. **Current file lists**: see all the file lists in this space.

**Customizing this blueprint**
You can customize the templates that are used by the File List blueprint - see Customizing blueprint templates.

The File List blueprint template uses the attachments macro. You can customize the macro to change the sort order or hide features such as version history and the upload attachment fields.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages you want to display.
Meeting Notes Blueprint

The Meeting Notes blueprint helps you to plan your meetings and share notes and actions with your team.

The first time you use the Meeting Notes blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme). The index page lists the latest Meeting Notes pages in that space.

To create a meeting notes page:

1. Choose Create from template in the Confluence header
2. Select Meeting Notes and hit Next
3. Enter the information required by the template and hit Create
4. Save your page and get ready to attend your meeting

You can edit the page during or after your meeting, and enter your notes, action items and @mention users to assign tasks to them.

Screenshot: A Meeting Notes index page
The Meeting Notes blueprint uses some cool Confluence features:

- **Instructional text** - this handy text prompts you to enter information and disappears when you start typing or view the page.
- **Mentions** - @mention a user on the page and they will be notified in their workbox.
- **Task lists** - @mention a user in a task to assign it to them – the task will appear as a personal task in their workbox. You can also add a due date by typing //, then choosing a date from the calendar.

Customizing this blueprint

You can customize the templates that are used by the Meeting Notes blueprint – see Customizing the blueprint templates.

You might choose to edit the headings or add additional headings, or change the instructional text that prompts users to enter information to suit your context. To find out more about using instructional text in a template, see Instructional text.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages you want to display.
Product Requirements Blueprint

The Product Requirements blueprint helps you to define, scope and track requirements for your product or feature.

Learn more about writing downsized product requirements

The first time you use the Product Requirements blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (shortcut only available in the default theme). The index lists all the Product Requirements pages in that space, and displays a summary of the information on each page (such as status and owner). You can have as many Product Requirements pages as you need.

To create a requirements page:

1. Choose Create from template in the Confluence header
2. Select Product Requirements and hit Next
3. Enter information about your product or feature (the instructional text will prompt you) and hit Create

You can @mention team members to bring them into the conversation about the page.

In this example we've created a series of Product Requirements pages. The index page shows summary information about each one.

1. New requirements: create more requirements pages in this space.
2. Requirements pages: see the existing requirements pages in this space.

Here's how a requirements page looks in the editor:
The Product Requirements blueprint uses these Confluence features:

- **Page Properties** and **Page Properties Report** macro - content that you enter within the page properties macro can appear on the index page.
- **Instructional text** - this handy text prompts you to enter information or create a Jira issue and disappears when you start typing or view the page.
- **Mentions** - @mention a user on the page and they will be notified in their workbox.

Customizing this blueprint

As no two products or projects are alike, you can customize the templates that are used by the Product Requirements blueprint - see [Customizing the blueprint templates](#).

You might choose to edit the **index page** in a space to change the columns to be displayed by the Page Properties Report macro.

You might choose to edit the **page template** to:

- edit the headings or add additional headings
- change the instructional text that prompts users to enter information to suit your context
- add or remove rows within the Page Properties macro.

See [Instructional text](#) to find out more about using instructional text in templates.
Shared Links Blueprint

The Shared Links blueprint helps you take content from the web and share it with your team. You can use Shared Links to share and collaborate on web content, or to create a centralized repository of useful links.

The first time you use the Shared Links blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you’re using the default theme). The index lists all the shared links in that space.

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a page from a template, hit the Create from template button.

1. Create blank page
2. Create from template

To create a shared links page:

1. Choose Create from template in the Confluence header
2. Select Share a link and hit Next
3. Enter the URL of the web content you want to share, then hit Create

You can also:

- Include topics to help categorize your links – these are added as labels to your page.
- Share the link immediately with another user or group – users will receive a notification.
- Add a comment to start the discussion.

To make sharing links even faster, you can add a Share on Confluence button to your browser’s toolbar. Click this button and the webpage you’re currently viewing will be added as a shared link!

To add the Share on Confluence button to your browser:

1. Choose Create from template, then select Share a link
2. Drag the Share on Confluence button to your browser toolbar

Now, when you want to share a link in Confluence, choose the Share on Confluence button in your browser and follow the prompts.

Screenshot: Share a link from the Create dialog.
Security considerations and limitations

To prevent people from accidentally or maliciously sharing links that may pose a security risk to your site, domains must be added to the allowlist, before they can be shared using the share a link blueprint. For example if you wanted to use the blueprint to share links to this documentation site you would need to add https://confluence.atlassian.com/ to the allowlist. The shared link blueprint is different to just inserting a link on a page because it shows a preview of the linked site. See Configuring the allowlist for more information.

If external connections are disabled for your site, you can still share a link (as long as it’s in the allowlist), but we won’t show a preview of its contents. Your admin can enable external connections at Administration > General Configuration under Connection Timeouts.
Jira Report Blueprint

The Jira Report blueprint helps you create easy to read reports to communicate the progress of your Jira Software projects and releases. You can choose from a Change Log report that generates a list of Jira issues or a Status Report that includes charts to visually communicate your progress.

The first time you use the Jira Reports blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you’re using the default theme).

To use the Jira Report Blueprint your Confluence and Jira Data Center, or Cloud application (such as Jira Software) must be connected via Application Links.

Create a Change Log

The Change Log report displays a list of issues from your Jira application. This list can be static or dynamic, automatically updating as the status of your issues change in Jira.

To create a static change Log:

1. Choose Create from template in the Confluence header
2. Select Jira report and hit Next
3. Select a Change log and hit Next
4. Enter the information required for the change log and hit Create

A report page will be created with sample text and a list of all issues for the project and fix versions selected, organized by issue type. This list of issues is static; it won't be updated when the issues are updated, and is visible to users who don’t have Jira access or permissions to view that project.

Screenshot: Creating a Change Log in simple mode.
To create a dynamic change log:

1. Choose Create from template in the Confluence header
2. Select Jira report and hit Next
3. Select a Change log and hit Next
4. Choose Switch to advanced
5. Enter a JQL query or paste in the URL of a Jira search (find out about using JQL in the JIRA Documentation)
6. Hit Create

A report page will be created with sample text and a Jira issues macro that’s configured to show your issues. The macro is dynamic and will update when the issues are updated. For more information on changing the information displayed, refer to the JIRA Issues macro.

Screenshot: Dynamic list of Jira Issues displaying in the Change Log.
Create a Status Report

The Status Report displays the progress of a Jira project and fix version in pie charts by status, priority, component and issue type. The Status Report uses the Jira Chart macro, and is dynamic.

To create a status report:

1. Choose Create from template in the Confluence header
2. Select Jira report and hit Next
3. Select a Status report and hit Next
4. Enter the information required for the report and hit Create

A report page will be created with sample text and a series of pie charts, using the Jira Chart macro. The macro is dynamic and will update when the issues in Jira are updated. For more information refer to the JIRA Chart macro.

As with the Change Log, you can switch to Advanced mode and use JQL or paste in a Jira URL to search for issues to display in the report.

Screenshot: Excerpt from the Status Report.

Customizing this blueprint

You can customize the templates used by this blueprint. The Change Log uses the Snapshot Jira Report Template (for static list of issues) and the Dynamic Jira Report Template, and the Status Report uses the Status Report Template. See Customizing the blueprint templates. Variables represent the Jira Issues and Jira Chart Macros. While these can't be edited, they can be moved around the page or deleted if you don't want every chart to be included.

You can also choose to edit the page template to modify the format of the page, change some headings, or modify the instructional text. To See Instructional text to find out more about using instructional text in templates.
Retrospective Blueprint

Retrospective pages help you track team successes and opportunities after projects or at the end of a sprint. Use this blueprint to document what went well, what needed improvement, and assign actions for the future.

The first time you create a retrospective page in a space, Confluence will automatically create an 'index' page, which will list all retrospectives in the space, and add a shortcut to it in the space sidebar.

1. If you want to quickly create a blank page, hit the Create button in the header; if you want to create a page from a template, hit the Create from template button.

2. Create blank page

3. Create from template

To create a retrospective page:

1. Choose Create from template in the Confluence header
2. Select Retrospective and hit Next
3. Add participants, change the title if you want to and click Create

SSH Screenshot: The 'retrospective' template page

Related pages:
- Blueprints
- File List Blueprint
- Meeting Notes Blueprint
The Retrospective blueprint uses the following Confluence features:

- **Page Properties** and the **Page Properties Report** macro make content listed within the macro visible on the index page.
- **Instructional text** prompts you to enter information and disappears when you start typing or view the page.
- **Mention** a user on the page to notify them in their workbox.

Check out how the retrospectives blueprint can be used in the article [Create sprint retrospective and demo pages (like a BOSS)](https://confluence.example.com/sprint-retrospective).

### Customize this blueprint

Every team conducts retrospective meetings differently, so you can customize the Retrospective blueprint template to match your team's culture and practices. You can:

- Edit headings and pre-populated text
- Add instructional text to capture specific information
- Add additional sections and content

See [Customize blueprint templates](https://confluence.example.com/customize-blueprints) for instructions.
How-To Article Blueprint

The How-To Article blueprint helps you to provide step-by-step guidance for completing a task.

To create a How-To Article page:

1. Choose Create from template in the Confluence header
2. Select How-To Article and hit Next
3. Enter the article name and some labels and hit Create

Once you save your page, Confluence will create an index page and add a shortcut to your space sidebar. The index lists all the How-To Article pages in that space, and displays a summary of the information on each page (such as creator and modified).
The How-To Article blueprint uses some cool Confluence features:

- **Instructional text** - Prompts you to enter information and disappears when you start typing or view the page.
- **Content by Label Macro** - Displays lists of pages that have particular labels, to let you collect related pages together.
- **Page Properties Macro** - This works together with the Page Properties Report Macro to automatically create a list of 'related issues' on each article.

**Customizing this blueprint**

You can customize the templates used by the How-To Article blueprint - see [Customizing the blueprint templates](#). For example, you might choose to edit the How-to **index page** in a space to change the columns displayed by the Page Properties Report macro.

You can also edit the **page template** to add headings or instructional text to the background section, or even add rows to the Page Properties macro. For example, a row for the date the How-To Article was created.

See **Instructional text** to find out more about using instructional text in templates.
Troubleshooting Article Blueprint

The Troubleshooting Article blueprint helps you to provide solutions for commonly-encountered problems.

To create a Troubleshooting Article page:

1. Choose Create from template \[\ldots\] in the Confluence header
2. Select Troubleshooting Article and hit Next
3. Enter the article name and some labels and hit Create

Once you save your page, Confluence will create an index page and add a shortcut on your space sidebar. The index lists all the Troubleshooting Article pages in the space, and displays a summary of the information on each page (such as creator and modified).
The Troubleshooting Article blueprint uses some cool Confluence features:

- **Instructional text** - Prompts you to enter information and disappears when you start typing or view the page.
- **Content by Label Macro** - Displays lists of pages that have particular labels, to let you collect related pages together.
- **Page Properties Macro** - This works together with the Page Properties Report Macro to automatically create a list of 'related issues' on each article.

**Customizing this blueprint**

You can customize the templates used by the Troubleshooting Article blueprint - see Customizing the blueprint templates. For example, you might choose to edit the decisions index page in a space to change the columns displayed by the Page Properties Report macro.

You can also edit the page template to add headings or instructional text to the background section, or even add rows to the Page Properties macro. For example, a row for the date the Troubleshooting Article was created.

See Instructional text to find out more about using instructional text in templates.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages you want to display.
Create a Blueprint-Style Report

Using a combination of templates and macros you can make a wide range of reports for managing anything from customer interviews, product requirements to IT service catalogs and more. In this tutorial we'll guide you through the process of creating a blueprint-style report.

In this example, we'll create a multi-team status report. Here's the scenario we'll use for this tutorial.

The Design, Development and QA teams working on the Blue Sky Project need to produce a short status update page each week, containing the focus area for the week, contact person, risks and overall status for each team. They like the way the Product Requirements blueprint works and want to be able to manage their status updates in a similar way.

What do each of the players want out of this report?

- **Project Lead** – Wants an at-a-glance report that shows only the status for each team.
- **Team Leads** – Want a summary report, including the focus areas and risk, just for their team.
- **All team members** – Want it to be easy to create the new page each week.
- **Management Team** – Want to see all the details for a week on one page, and don't want to have to look at a different page for each team.

With this scenario in mind, this tutorial will guide you through how to:

1. Create a status update template containing a separate page properties macro for each team's section of the report.
2. Create a high level status report, showing just the status of all teams.
3. Create a summary report for each team.
4. Create your first status update page.

You'll need Space Administrator permissions to complete some of the steps in this tutorial.

Part 1: Create a status update template

First we'll create a page template and add the Page Properties macros.

1. Go to Space Admin > Content Tools > Templates
2. Choose Create Template
3. Give the template a name (in this example the template will be called ‘Status Update’)
4. Add the skeleton of your status report to the page
5. Choose the label icon at the top of the page to add a label to the template (in this example, we'll add the label: ‘status-update’)

Screenshot: Adding teams to our status update template
Now we'll add a Page Properties macro to record the status of the Design team.

6. Choose Insert > Other Macros > Page Properties to add the Page Properties macro to the page.
7. In the macro body create a two column table and remove the heading row.
8. In the left column enter the column headings for your report (these are known as metadata 'keys'). In this example we'll add 'Design Focus', 'Design Status', 'Design Contact' and 'Design Risks').
9. In the right column, leave the cells blank, or enter some instructional text to prompt your users (Choose Template > Instructional Text).
   We've also added a status macro.
10. Edit the Page Properties macro and enter a Page Properties ID for this macro (in this example we'll use 'status-update-design'. This will allow us to report on the status of just the Design team later on).
    Repeat this process for the Development and QA teams, remembering to specify a different ID for each macro (we used 'status-update-dev' and 'status-update-qa').
11. Finally, add any other headings, instructional text or content to your template and Save.
    You can enter a Description for your template - this appears in the Create dialog.

Screenshot: Our status update template
Part 2: Create a report showing the high level status of each team

Next we'll create an index page, just like you see in many blueprints.

1. In your space create a new blank page (this will be our ‘Status Report - all teams' page, showing just the status of each team)
2. Choose Insert > Other Macros > Page Properties Report to add the Page Properties Report macro to the page
3. Enter the Label to report on (in this example, it'll be the 'status-update' label we added to the template page)
4. Leave the Display options > Page Properties ID field blank (we want to report on all the macros on the page)
5. In the Columns to Show field, list the 'keys' from each macro that you want to include in the report (in this example, we only want to show the values of 'Design Status', 'Dev Status', 'QA Status')
6. Choose **Save** to add the macro to the page

**Screenshot: The page properties report macro on the 'Status Report - all teams' page**

Now we’ll add a button to the page to allow team leads to easily create new status update pages from the template we created earlier.

7. Choose **Insert > Other Macros > Create from Template** to add the Create from Template macro to the page

8. Enter the text for the button (in this example we’ll call the button 'New Status Update Page')

9. Select the template from the **Template Name** drop down (in this example our template was called ‘Status Update’)

10. Specify the title of any pages to be created (This is a great way to keep your titles consistent. In this example we’ll call the page ‘Status update week ending @currentDate’, which will append the current date when the page is created, as in the meeting notes blueprint)

11. Choose **Insert**

12. Add any other content, links or images to the page and **Save**

13. Choose **Space Tools > Configure Sidebar > Add Link** to add a shortcut to the page on the sidebar

**Part 3: Create a separate report for each team**

Now we’ll create some index pages that show a more detailed summary for each team, starting with the Design team.

1. Create a new blank page – this will be the ‘Design Status Report’ index page, showing just information for that team.

2. Choose **Insert > Other Macros > Page Properties Report** to add the Page Properties Report macro to the page

3. Enter the **Label** (the page label is once again 'status-update', the label we added to the template)

4. Expand the **Display options** and enter the **Page Properties ID** that was specified in the Page Properties macro in the template (in this example it was 'status-update-design') – this allows us to report on just information in that macro.

5. Leave all of the other fields blank (we want to show all columns from this Page Properties macro)
6. Choose **Save** to add the macro to the page

**Screenshot: The page properties report macro on the 'Design Status Report' index page**

7. Add any other content, links or images to the page and **Save**

8. Choose **Space Tools > Configure Sidebar > Add Link** to add a shortcut to the page on the sidebar

9. Create a new page and repeat this process for each team

   Remember to specify a different Page Properties ID each time (in this example 'status-report-dev' and 'status-report-qa').

If your Design, Dev and QA teams have their own team spaces, this summary report could even be created in their team spaces. Just be sure to specify the space where the Status Updates pages are created in the **Restrict to spaces** field, to make sure the macro can find the pages to report on.

### Part 4: Create your first status update page

That’s it! **Create from template** in the Confluence header, then select **Status Update**, or use the **Create a new status update** button to make your first status update page. Just like a blueprint, but 100% made by you.

Here’s how our finished pages look.

**Screenshot: Team Leads and the management team still have a single page for the weekly status update**
Screenshot: The Project Lead can see the status of each team, each week, at a glance in the All Teams status report.

Screenshot: Each team can see their focus, risks and status at a glance in their status report.
Remember, these concepts don't just apply to status updates – you can use them for any purpose at all.
Import Content Into Confluence

There are a number of ways you can get existing content, such as text, images and other content into Confluence.

Import content from other Confluence sites

To import content from another Confluence site you can:

- Import a backup of the entire Confluence site
- Import an XML export of an individual space. Page history, attachments, and page content will be preserved.

See Restore a Site and Restore a Space or multiple Spaces for more information.

Import content from a Microsoft Word document

The Office Connector allows you to create pages by importing Word documents. The document content is copied onto one or more Confluence pages. See Import a Word Document into Confluence.

Import web content

To embed web content on a page:

- Use the Widget Connector Macro to display videos, slide shows, twitter chats, documents and more, sourced from other web sites and displayed on your Confluence page.
- Embed an external web page into Confluence with the HTML Include macro.
- Use HTML code in a page with the HTML macro.

Note: The HTML macro is not enabled in all sites. Talk to your Confluence Admin about whether you can use this macro.

Importing content from another wiki

Confluence does not provide a method for importing content from another wiki.

You may be able to build your own import solution using our REST APIs, as mentioned below, or work with an Atlassian Solution Partner to develop a custom solution.

Import other content

Importing non-wiki markup into Confluence requires a conversion process:

- Text with basic formatting can be pasted directly into the editor. This includes simple Word documents or web pages.
- Confluence pages saved to disk can be imported from disk.
- Files can be uploaded in bulk using the Confluence WebDav Plugin. See Use a WebDAV Client to Work with Pages.
- Build your own import solution using the Confluence APIs.

Migrate to Confluence Cloud

If you're migrating from Confluence Server to Confluence Cloud, you can use the Confluence Cloud Migration Assistant to migrate your content and spaces.
Import a Word Document into Confluence

The Office Connector allows you to import Word documents and create one or more Confluence pages from the content.

You can create a single page, or divide the contents up into multiple pages, based on the headings in your document.

This is useful if you have a lot of content stored in existing documents, or if you are migrating from another system or platform that allows you to export to Word format.

On this page:
- Import a Word document
- Import options
- Supported file types
- Importing documents containing wiki markup
- Limitations

Related pages:
- Export Content to Word, PDF, HTML and XML

Import a Word document

To import a Word document in Confluence:

1. Create a page in Confluence or go to an existing page (you want to view the page, not edit it).
2. Choose More options > Import Word Document
3. Choose Browse and locate the Word document you want to import, then choose Next.
4. Enter a title for the new page (useful if you don't want to use the file name as your page title).
5. Choose where you want to import the file (as a brand new page, or overwriting an existing page with the same title).
6. Choose how to handle title conflicts (rename the new pages or replace existing pages).
7. Choose whether to create a single page or multiple pages based on the heading styles in the file (this option is only available if the file contains heading styles).
8. Click Import.

When the upload has finished, pages will be created with the content of the Word documents. You can then view and edit this page as normal. There’s no connection between the original Word document and this page.

Import options

There are a number of options when importing a Word document that control how pages are created, whether the import should overwrite existing pages in the space, and how it should handle page name conflicts.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root page title</td>
<td>This is the title of the page that will be created or updated by the import.</td>
</tr>
<tr>
<td>Where to import</td>
<td>Controls whether the document is imported into the current page (the page you were viewing when you selected Tools &gt; Import) or created as a new page. Choose from</td>
</tr>
<tr>
<td></td>
<td>- Import as a new page in the current space - a new page will be created as a child of the space home page.</td>
</tr>
<tr>
<td></td>
<td>- Replace &lt;page name&gt; - content will be imported into the current page. The title of this page will change to the title you specified in the Root page title field.</td>
</tr>
<tr>
<td></td>
<td>- Delete existing children of &lt;pagename&gt; - any existing children of the current page will be removed when the content of the page is replaced.</td>
</tr>
</tbody>
</table>
### Title conflicts

Controls how page name conflicts (a page with the same title already exists in the space) are handled.

- **Rename imported pages if page name already exists** - new pages get a new name (a number added to the end of the page title). Existing pages will be unchanged.
- **Replace existing pages with imported pages of the same title** - overwrite the content of existing pages. The change will be shown in the Page History for the page.
- **Remove existing pages with the same title as imported pages** - remove original pages and then create new pages. The change is not shown in the Page History for the page.

### Split by heading

If the document contains Word heading styles you can choose to create multiple pages based on the heading. Options are:

- **Don’t split** - creates a single page.
- **Level Headings** - creates multiple pages in a hierarchy based on the heading levels in the document.

A preview of the pages that will be created appears under Document Outline.

**Screenshot: Import Word options for a document that contains multiple heading levels.**

### Import Word Document: Configuration

- **Root page title:** Outline doc
- **Where to import:**
  - Import as a new page in the current space
  - Replace Temp
  - Delete existing children of Temp
- **Title conflicts:**
  - Rename imported pages if page name already exists
  - Replace existing pages with imported pages of the same title
  - Remove existing pages with the same title as imported pages
- **Split by heading:** Don’t split
- **Document Outline:** Outline doc

**Import**

### Supported file types

Confluence can import the content from Microsoft Word 97-2013 documents (.doc and .docx).

### Importing documents containing wiki markup

If your document contains characters that are the same as Confluence wiki markup (for example square brackets, hashes etc) these characters may be automatically converted to their wiki markup value when you import your document, or wrapped in a wiki markup macro to preserve the formatting.

### Limitations

In order to prevent out of memory errors, we limit the uncompressed size of the file you can import to 20 MB. Your administrator can change this limit using the `confluence.word.import.maxsize` system property.
Undefined Page Links

You can add links to pages that don't yet exist in Confluence, but you intend to create later. Known as links to 'undefined pages', they allow you to create a link which, when clicked, will create a page with the name you specify in the link.

Create an undefined page link

1. Choose Insert > Link or press Ctrl+K on your keyboard.
2. Choose Advanced.
3. Enter the name of the page to be created in the Link field.

A link to an undefined page is shown in dark red while in the editor. When anyone clicks the link, Confluence will create a new page with the name you typed in the Link field.

View undefined pages in a space

The Undefined Pages view shows you all undefined pages in your space. The undefined page links are badged with a • icon to remind you that those pages are yet to be created.

To view a list of the undefined links in a space:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Undefined Pages.

You can choose the link for an undefined page to create the page and add content to it.

Links to pages that are in the trash are not considered undefined links, and will not appear in this list.
**View Page Information**

The Page Information view for a page shows you useful information about the page.

**To see the information about the page:**

1. View the page.
2. Choose More options ••• > Page Information

You will see the following information:

- **Page details**: Title, author, date of creation, date of last modification and the tiny link (permalink) of the page.
- **Page hierarchy**: Parent-child relationships of the page.
- **Incoming links**: Lists other pages in your Confluence Site that have links to this page, or reference this page in an Include Page or Excerpt Include macro.
- **Labels**: Any labels (tags) that have been applied to this page. See Add, Remove and Search for Labels.
- **Page Permissions**: Displays page-level security restrictions that apply to the page (if present). See Page Restrictions.
- **Recent Changes**: Links to the five most recent versions of the page along with the name of the editor and the date of modification. See Page History and Page Comparison Views. Choose View page history to see the page history view, all the versions of the page in reverse chronological order and allows you to compare versions or to restore a previous version.
- **Outgoing links**: A summary of the links contained on this page, pointing to other pages on the Confluence site or to external websites.

Note: if there is no information to report (for example the page has no restrictions or no incoming links), that section of the Page Information won't appear.

**Screenshot: Page information for this page**
Page History and Page Comparison Views

Confluence tracks the history of changes to each page by creating a new version of the page each time it's modified. You can view the changes between different versions, and roll back to a previous version if you need to.

Access the page history

To view the history of a page:

1. Go to the page and choose **More options > Page History**
2. Choose a version number to view the content of that version

Screenshot: Page history

Hover over each avatar to see the names of people who contributed changes in that version. It is not possible to view the individual changes made by each person in a single page version.

View an older version

When you select a previous version of the page, you'll see a header like this at the top of the page:

⚠️ You are viewing an old version of this page. View the current version.

Compare with Current  ·  Restore this Version  ·  View Page History

« Previous  Version 3  Current »

If you want to send this page version to someone, copy and paste the URL from your browser. The link will look something like this: http://confluence.atlassian.com/pages/viewpage.action?pageId=12345.

When you're viewing a specific version of the page, the following functions are available:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>current version</td>
<td>View the latest version of the page.</td>
</tr>
<tr>
<td>Compare with Current</td>
<td>Compare the differences between the version of the page you are viewing and the current version.</td>
</tr>
</tbody>
</table>
### Restore a previous version

1. Go to the page and choose **More options  ➤ Page History**
2. Choose **Restore this version** beside the version you want to restore (or at the top of the page if you’ve opened the version)
3. Change the default change comment if necessary, and choose **OK**

> All page history is retained; restoring an older version creates a copy of that version. For example, if you restore version 39, Confluence will create a copy of version 39 and the copy will become the new, current version.

If the page has an unpublished draft, the content of the draft will be lost when you restore a previous version. We’ll warn you if there is an unpublished draft.

### Delete a specific version

Choose **Delete** next to a version in the page history, to remove that version.

Deleted versions do not go to the trash, and cannot be restored once deleted.

If you have **Confluence Data Center**, remaining versions will not be renumbered when a version is deleted. Older versions may also be deleted automatically, if your administrator has defined **retention rules** for the site or space.

### View the changes made

Using the page history view or the **page information view**, you can see the recent changes made to a page.

#### To view recent changes made to a page:

1. Choose **More options  ➤ Page Information**
   In the section titled 'Recent Changes' you’ll see the most recent versions of the page, along with the date of their modification and the name of the modifying author.
2. Choose **View Changes** beside the required version
   The page comparison view is displayed, showing the differences between the selected and previous versions.

### View unpublished changes

When you’re in the editor, you can see all changes since the page was last published. Go to **More options  ➤ View changes**.

Changes are not attributed to individual people. The avatars of everyone who has contributed will be shown at the top of the editor.

### Compare two versions
1. Go to the page and choose More options ... > Page History
2. Choose the versions you want to compare by selecting the check boxes beside them
3. Choose Compare selected versions

You'll see the page comparison view showing the differences between the selected versions. Changes are highlighted as follows:

<table>
<thead>
<tr>
<th>Highlighted color</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Added content</td>
</tr>
<tr>
<td>Red</td>
<td>Deleted content</td>
</tr>
<tr>
<td>Blue</td>
<td>Changed formatting</td>
</tr>
</tbody>
</table>

**Screenshot: Comparing changes**

<table>
<thead>
<tr>
<th>Versions Compared</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Cassie Owens</td>
<td>This line was added.</td>
</tr>
<tr>
<td>less than a minute ago</td>
<td>This line was removed.</td>
</tr>
<tr>
<td>Current Cassie Owens</td>
<td>Formatting was changed.</td>
</tr>
<tr>
<td>less than a minute ago</td>
<td></td>
</tr>
</tbody>
</table>

**View Page History**

- **We don't need this text anymore** This text was added
- **My heading has been reformatted**

**More about the comparison view**

When you view a page comparison, all large sections of unchanged text are hidden and reduced to an ellipsis (...).

You can view page changes between versions which are adjacent to your current page comparison view. Click the link containing:

- << to view the page comparison with the earlier adjacent version
- >> to view the page comparison with the more recent adjacent version

For example, if your page comparison view is between v. 30 and v. 34 of a page, you can view changes between:

- v. 29 and v. 30 by clicking **Changes from 29 to 30**
- v. 34 and v. 35 by clicking **Changes from 34 to 35 >>**
Confluence Markup

This section describes two types of markup found in Confluence:

- **Confluence storage format.** Confluence stores the content of pages and blog posts in an XHTML-based format. Advanced users can view the storage format of a page and even edit it, provided their Confluence site is configured to allow that.

- **Wiki markup.** Confluence allows data entry via a shorthand code called wiki markup. Some parts of the Confluence administration interface also accept wiki markup for defining content. For a description of the wiki markup syntax, see [Confluence Wiki Markup](#).

Wiki markup code examples for macros can be found in the documentation for each [macro](#).
Confluence Storage Format

This page describes the XHTML-based format that Confluence uses to store the content of pages, page templates, blueprints, blog posts and comments. This information is intended for advanced users who need to interpret and edit the underlying markup of a Confluence page.

We refer to the Confluence storage format as 'XHTML-based'. To be correct, we should call it XML, because the Confluence storage format does not comply with the XHTML definition. In particular, Confluence includes custom elements for macros and more. We're using the term 'XHTML-based' to indicate that there is a large proportion of HTML in the storage format.

You can view the Confluence storage format for a given page by choosing More options > View Storage Format. This option is only available if one of the following is true:

- You are a Confluence administrator.
- Your Confluence site has the Confluence Source Editor plugin installed and you have permission to use the source editor.
- If you would like to edit the storage format for a page, your Confluence system administrator will need to install the Confluence Source Editor plugin.
- Clarification of terminology: If you choose More options > View Source, you'll see the format used within the editor panel, not the source format of the page.

Headsings

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heading 1</td>
<td><code>&lt;h1&gt;Heading 1&lt;/h1&gt;</code></td>
<td>Heading 1</td>
</tr>
<tr>
<td>Heading 2</td>
<td><code>&lt;h2&gt;Heading 2&lt;/h2&gt;</code></td>
<td>Heading 2</td>
</tr>
<tr>
<td>Heading 3</td>
<td><code>&lt;h3&gt;Heading 3&lt;/h3&gt;</code></td>
<td>Heading 3</td>
</tr>
</tbody>
</table>

Headings 4 to 6 are also available and follow the same pattern

Text effects

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>strong/bold</td>
<td><code>&lt;strong&gt;strong text&lt;/strong&gt;</code></td>
<td>strong</td>
</tr>
<tr>
<td>emphasis</td>
<td><code>&lt;em&gt;Italics Text&lt;/em&gt;</code></td>
<td>emphasis</td>
</tr>
<tr>
<td><strong>strikethrough</strong></td>
<td><code>&lt;span style=&quot;text-decoration: line-through;&quot;&gt;strikethrough&lt;/span&gt;</code></td>
<td></td>
</tr>
<tr>
<td>--------------------</td>
<td>--------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td><strong>underline</strong></td>
<td><code>&lt;u&gt;underline&lt;/u&gt;</code></td>
<td></td>
</tr>
<tr>
<td><strong>superscript</strong></td>
<td><code>&lt;sup&gt;superscript&lt;/sup&gt;</code></td>
<td></td>
</tr>
<tr>
<td><strong>subscript</strong></td>
<td><code>&lt;sub&gt;subscript&lt;/sub&gt;</code></td>
<td></td>
</tr>
<tr>
<td><strong>monospace</strong></td>
<td><code>&lt;code&gt;monospaced&lt;/code&gt;</code></td>
<td></td>
</tr>
<tr>
<td><strong>preformatted</strong></td>
<td><code>&lt;pre&gt;preformatted text&lt;/pre&gt;</code></td>
<td></td>
</tr>
<tr>
<td><strong>block quotes</strong></td>
<td><code>&lt;blockquote&gt;&lt;p&gt;block quote&lt;/p&gt;&lt;/blockquote&gt;</code></td>
<td></td>
</tr>
<tr>
<td><strong>text color</strong></td>
<td><code>&lt;span style=&quot;color: rgb(255,0,0);&quot;&gt;red text&lt;/span&gt;</code></td>
<td></td>
</tr>
<tr>
<td><strong>small</strong></td>
<td><code>&lt;small&gt;small text&lt;/small&gt;</code></td>
<td></td>
</tr>
<tr>
<td><strong>big</strong></td>
<td><code>&lt;big&gt;big text&lt;/big&gt;</code></td>
<td></td>
</tr>
<tr>
<td><strong>center-align</strong></td>
<td><code>&lt;p style=&quot;text-align: center;&quot;&gt;centered text&lt;/p&gt;</code></td>
<td></td>
</tr>
<tr>
<td><strong>right-align</strong></td>
<td><code>&lt;p style=&quot;text-align: right;&quot;&gt;right aligned text&lt;/p&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>

**Text breaks**

---

215

*Created in 2023 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>New paragraph</td>
<td><code>&lt;p&gt;Paragraph 1&lt;/p&gt;</code></td>
<td>Paragraph 1</td>
</tr>
<tr>
<td></td>
<td><code>&lt;p&gt;Paragraph 2&lt;/p&gt;</code></td>
<td>Paragraph 2</td>
</tr>
<tr>
<td>Line break</td>
<td><code>Line 1 &lt;br /&gt; Line 2</code></td>
<td>Line 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Line 2</td>
</tr>
<tr>
<td>Horizontal rule</td>
<td><code>&lt;hr /&gt;</code></td>
<td></td>
</tr>
<tr>
<td>— symbol</td>
<td><code>&amp;ndash;</code></td>
<td>—</td>
</tr>
<tr>
<td>– symbol</td>
<td><code>&amp;ndash;</code></td>
<td>–</td>
</tr>
</tbody>
</table>

**Lists**

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unordered list – round bullets</td>
<td><code>&lt;ul&gt;</code></td>
<td>• Round bullet list item</td>
</tr>
<tr>
<td></td>
<td><code>&lt;li&gt;</code> <code>round bullet list item&lt;/li&gt;</code></td>
<td><code>&lt;/ul&gt;</code></td>
</tr>
<tr>
<td>Ordered list (numbered list)</td>
<td><code>&lt;ol&gt;</code></td>
<td>1. Ordered list item</td>
</tr>
<tr>
<td></td>
<td><code>&lt;li&gt;</code> <code>numbered list item&lt;/li&gt;</code></td>
<td><code>&lt;/ol&gt;</code></td>
</tr>
<tr>
<td>Task Lists</td>
<td><code>&lt;ac:task-list&gt;</code></td>
<td>□ task list item</td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:task&gt;</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:task-status&gt;</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>incomplete&lt;/ac:task-status&gt;</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:task-body&gt;</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>task list item&lt;/ac:task-body&gt;</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;/ac:task&gt;</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>&lt;/ac:task-list&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>

**Links**

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
</table>
## A note about link bodies

All links received from the editor will be stored as plain text by default, unless they are detected to contain the limited set of mark up that we allow in link bodies. Here are some examples of markup we support in link bodies.

### Link to another Confluence page

```xml
<ac:link>
<ri:page ri:content-title="Page Title" />
<ac:plain-text-link-body>
<![CDATA[Link to another Confluence Page]]>
</ac:plain-text-link-body>
</ac:link>
```

### Link to an attachment

```xml
<ac:link>
<ri:attachment ri:filename="atlassian_logo.gif" />
<ac:plain-text-link-body>
<![CDATA[Link to a Confluence Attachment]]>
</ac:plain-text-link-body>
</ac:link>
```

### Link to an external site

```xml
<a href="http://www.atlassian.com">Atlassian</a>
```

### Anchor link (same page)

```xml
<ac:link ac:anchor="anchor">
<ac:plain-text-link-body>
<![CDATA[Anchor Link]]>
</ac:plain-text-link-body>
</ac:link>
```

### Anchor link (another page)

```xml
<ac:link ac:anchor="anchor">
<ri:page ri:content-title="pagetitle"/>
<ac:plain-text-link-body>
<![CDATA[Anchor Link]]>
</ac:plain-text-link-body>
</ac:link>
```

### Link with an embedded image for the body

```xml
<ac:link ac:anchor="Anchor Link">
<ac:link-body>
</ac:link-body>
</ac:link>
```

⚠️ **For rich content like images, you need to use `ac:link-body` to wrap the contents.**
An example of different link bodies

```xml
<ac:link>
<!-- Any resource identifier -->
<ri:page ri:content-title="Home" ri:space-key="SANDBOX" />
<ac:link-body>Some <strong>Rich</strong> Text</ac:link-body>
</ac:link>
<ac:link>
<!-- A link body isn't necessary. Auto-generated from the resource identifier for display. -->
<ri:page ri:content-title="Plugin developer tutorial stuff" ri:space-key="TECHWRITING" />
</ac:link>
<ac:link>
<ac:plain-text-link-body><![CDATA[A plain <text> link body]]></ac:plain-text-link-body>
</ac:link>
```

The markup tags permitted within the <ac:link-body> are <b>, <strong>, <em>, <i>, <code>, <tt>, <sub>, <sup>, <br> and <span>.

### Images

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attached image</td>
<td><img src="atlassian_logo.gif" alt="Atlassian Logo" /></td>
<td><img src="atlassian_logo.gif" alt="Atlassian Logo" /></td>
</tr>
<tr>
<td>External image</td>
<td><img src="http://confluence.atlassian.com/images/logo/confluence_48_trans.png" alt="Confluence Logo" /></td>
<td><img src="http://confluence.atlassian.com/images/logo/confluence_48_trans.png" alt="Confluence Logo" /></td>
</tr>
</tbody>
</table>

Supported image attributes (some of these attributes mirror the equivalent HTML 4 IMG element):

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ac:align</td>
<td>image alignment</td>
</tr>
<tr>
<td>ac:border</td>
<td>Set to &quot;true&quot; to set a border</td>
</tr>
<tr>
<td>ac:class</td>
<td>css class attribute.</td>
</tr>
<tr>
<td>ac:title</td>
<td>image tool tip.</td>
</tr>
<tr>
<td>ac:style</td>
<td>css style</td>
</tr>
<tr>
<td>ac:thumbnail</td>
<td>Set to &quot;true&quot; to designate this image as a thumbnail.</td>
</tr>
<tr>
<td>ac:alt</td>
<td>alt text</td>
</tr>
<tr>
<td>ac:height</td>
<td>image height</td>
</tr>
<tr>
<td>ac:width</td>
<td>image width</td>
</tr>
<tr>
<td>ac:vspace</td>
<td>the white space on the top and bottom of an image</td>
</tr>
</tbody>
</table>
Tables

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| Two column, two row (top header row) | `<table>
<tbody>
<tr>
<th>Table Heading Cell 1</th>
<th>Table Heading Cell 2</th>
</tr>
<tr>
<td>Normal Cell 1</td>
<td>Normal Cell 2</td>
</tr>
</tbody>
</table> | Table Heading Cell 1 | Table Heading Cell 2 |
| Normal Cell 1 | Normal Cell 2 |

| Two column, three rows, 2nd and third with merged cells in first row | `<table>
<tbody>
<tr>
<th>Table Heading Cell 1</th>
<th>Table Heading Cell 2</th>
</tr>
<tr>
<td rowspan="2">Merged Cell</td>
<td>Normal Cell 1</td>
</tr>
<tr>
<td>Normal Cell 2</td>
</tr>
</tbody>
</table> | Table Heading Cell 1 | Table Heading Cell 2 |
| Merged Cell | Normal Cell 1 | Normal Cell 2 |

Page layouts
Confluence supports page layouts directly, as an alternative to macro-based layouts (using, for example, the section and column macros). This section documents the storage format XML created when these layouts are used in a page.

<table>
<thead>
<tr>
<th>Element name</th>
<th>In Confluence 5.2 and later</th>
<th>Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>ac:layout</td>
<td>Indicates that the page has a layout. It should be the top level element in the page.</td>
<td>None</td>
</tr>
<tr>
<td>ac:layout-section</td>
<td>Represents a row in the layout. It must be directly within the ac:layout tag. The type of the section indicates the appropriate number of cells and their relative widths.</td>
<td>ac:type</td>
</tr>
<tr>
<td>ac:layout-cell</td>
<td>Represents a column in a layout. It must be directly within the ac:layout-section tag. There should be an appropriate number of cells within the layout-section to match the ac:type.</td>
<td>None</td>
</tr>
</tbody>
</table>

The recognized values of ac:type for ac:layout-section are:

<table>
<thead>
<tr>
<th>ac:type</th>
<th>Expected number of cells</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>single</td>
<td>1</td>
<td>One cell occupies the entire section.</td>
</tr>
<tr>
<td>two_equal</td>
<td>2</td>
<td>Two cells of equal width.</td>
</tr>
<tr>
<td>two_left_sidebar</td>
<td>2</td>
<td>A narrow (~30%) cell followed by a wide cell.</td>
</tr>
<tr>
<td>two_right_sidebar</td>
<td>2</td>
<td>A wide cell followed by a narrow (~30%) cell.</td>
</tr>
<tr>
<td>three_equal</td>
<td>3</td>
<td>Three cells of equal width.</td>
</tr>
<tr>
<td>three_with_sidebars</td>
<td>3</td>
<td>A narrow (~20%) cell at each end with a wide cell in the middle.</td>
</tr>
</tbody>
</table>

The following example shows one of the more complicated layouts from the old format built in the new. The word (content) indicates where further XHTML or Confluence storage format block content would be entered, such as <p> or <table> tags.
Emojis

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Emoticons</td>
<td><code>&lt;ac:emoticon ac:name=&quot;smile&quot; /&gt;</code></td>
<td>😊</td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:emoticon ac:name=&quot;sad&quot; /&gt;</code></td>
<td>😞</td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:emoticon ac:name=&quot;cheeky&quot; /&gt;</code></td>
<td>😝</td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:emoticon ac:name=&quot;laugh&quot; /&gt;</code></td>
<td>😄</td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:emoticon ac:name=&quot;wink&quot; /&gt;</code></td>
<td>😜</td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:emoticon ac:name=&quot;thumbs-up&quot; /&gt;</code></td>
<td>👍</td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:emoticon ac:name=&quot;thumbs-down&quot; /&gt;</code></td>
<td>👎</td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:emoticon ac:name=&quot;information&quot; /&gt;</code></td>
<td>🌐</td>
</tr>
<tr>
<td></td>
<td><code>&lt;ac:emoticon ac:name=&quot;tick&quot; /&gt;</code></td>
<td>✔️</td>
</tr>
</tbody>
</table>
Resource identifiers

Resource identifiers are used to describe "links" or "references" to resources in the storage format. Examples of resources include pages, blog posts, comments, shortcuts, images and so forth.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Resource identifier format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td><code>&lt;ri:page ri:space-key=&quot;FOO&quot; ri:content-title=&quot;Test Page&quot;/&gt;</code></td>
</tr>
</tbody>
</table>

Notes:
- `ri:space-key:` (optional) denotes the space key. This can be omitted to create a relative reference.
- `ri:content-title:` (required) denotes the title of the page.

| Blog Post    | `<ri:blog-post ri:space-key="FOO" ri:content-title="First Post" ri:posting-day="2012/01/30" />` |

Notes:
- `ri:space-key:` (optional) denotes the space key. This can be omitted to create a relative reference.
- `ri:content-title:` (required) denotes the title of the page.
- `ri:posting-day:` (required) denotes the posting day. The format is YYYY/MM/DD.
| **Attachment** | `<ri:attachment ri:filename>`  
| | ... resource identifier for the container of the attachment ...  
| | </ri:attachment>  
| **Notes:** |  
| | • `ri:filename:` *(required)* denotes the name of the attachment.  
| | • the body of the `ri:attachment` element should be a resource identifier denoting the container of the attachment. This can be omitted to create a relative attachment reference (similar to `[foo.png]` in wiki markup).  
| **Examples:** |  
| | **Relative Attachment Reference**  
| | `<ri:attachment ri:filename="happy.gif" />`  
| | **Absolute Attachment Reference**  
| | `<ri:attachment ri:filename="happy.gif">  
| | `<ri:page ri:space-key="TST" ri:content-title="Test Page"/>`  
| | </ri:attachment>`  
| **URL** | `<ri:url ri:value="http://example.org/sample.gif"/>`  
| **Notes:** |  
| | • `ri:value:` *(required)* denotes the actual URL value.  
| **Shortcut** | `<ri:shortcut ri:key="jira" ri:parameter="ABC-123">`  
| **Notes:** |  
| | • `ri:key:` *(required)* represents the key of the Confluence shortcut.  
| | • `ri:parameter:` *(required)* represents the parameter to pass into the Confluence shortcut.  
| | • The example above is equivalent to `[ABC-123@jira]` in wiki markup.  
| **User** | `<ri:user ri:userkey="2c9680f7405147ee0140514c26120003"/>`  
| **Notes:** |  
| | • `ri:userkey:` *(required)* denotes the unique identifier of the user.  
| **Space** | `<ri:space ri:space-key="TST"/>`  
| **Notes:** |  
| | • `ri:space-key:` *(required)* denotes the key of the space.  

*Created in 2023 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
Template variables

This screenshot shows a simple template:

This is Sarah’s template

A single-line text variable: $MyText

A multi-line text variable: $MyMulti

A selection list: $MyList

End of page.

The template contains the following variables:

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Type</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>$MyText</td>
<td>Single-line text</td>
<td></td>
</tr>
<tr>
<td>$MyMulti</td>
<td>Multi-line text</td>
<td>Size: 5 x 100</td>
</tr>
<tr>
<td>$MyList</td>
<td>List</td>
<td>List items: Apples, Pears, Peaches</td>
</tr>
</tbody>
</table>

The XML export produces the following code for the template:
**Instructional Text**

Instructional text allows you to include information on how to fill out a template for an end-user (the person using creating a page from the template). Instructional text will:

- automatically clear all *instructional text* as the user types in a specific text block, and
- automatically trigger a @mention prompt for user selection (for 'mention' type instructional text).

**Screenshot: Example of instructional text.**

```
<ul>
    <li><ac:placeholder>This is an example of instruction text that will get replaced when a user selects the text and begins typing.</ac:placeholder></li>
</ul>
```

```
<ac:task-list>
    <ac:task>
        <ac:task-status>incomplete</ac:task-status>
        <ac:task-body><ac:placeholder ac:type="mention">@mention example. This placeholder will automatically search for a user to mention in the page when the user begins typing.</ac:placeholder></ac:task-body>
    </ac:task>
</ac:task-list>
```
Confluence Wiki Markup

This page describes the wiki markup used on some administration screens in Confluence.

Wiki markup is useful when you want to do one of the following:

- Type wiki markup directly into the editor. Confluence will convert it to the rich text editor format as you type.
- Create links using the Advanced tab of the Links Browser.
- Add custom content to the sidebar, header or footer of a space.
- Insert a block of wiki markup (or markdown) into the Confluence editor. (Choose Insert > Markup.)

Note: You cannot edit content in wiki markup. Confluence does not store page content in wiki markup. Although you can enter wiki markup into the editor, Confluence will convert it to the rich text editor format immediately. You will not be able to edit the wiki markup after initial entry.

Can I type wiki markup into the editor?

Yes. You can type wiki markup directly into the editor, and Confluence will convert it as you type. (You cannot edit the wiki markup after conversion.)

Can I insert markdown?

Confluence supports inserting content in markdown. This is often used in ReadMe files. See Markdown syntax guide for some examples of markdown syntax.

To insert markdown in the editor:

1. Choose Insert > Markup
2. Select Markdown
3. Type or paste your text - the preview will show you how it will appear on your page
4. Choose Insert.

As with wiki markup, Confluence will convert your markdown to the rich text editor format. You will not be able to edit your content using markdown.

Headings

To format a line as a heading, type "hn." at the start of your line, where n can be a number from 1 to 6.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you'll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>h1. Biggest heading</td>
<td>Biggest heading</td>
</tr>
<tr>
<td>h3. Big heading</td>
<td>Big heading</td>
</tr>
<tr>
<td>h5. Small heading</td>
<td>Small heading</td>
</tr>
</tbody>
</table>

Lists

Wiki markup allows you to create bulleted or numbered lists, and is flexible enough to allow a combination of the two list types.

If you need to separate the text within lists using line breaks, make sure you do so using a double slash ( //). Empty lines may disrupt the list.
Simple lists
Use the hyphen (‐) to create simple lists with square bullets. Make sure there's a space between the hyphen and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you'll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>‐ some</td>
<td>■ some</td>
</tr>
<tr>
<td>‐ bullet</td>
<td>■ bullet</td>
</tr>
<tr>
<td>‐ points</td>
<td>■ points</td>
</tr>
</tbody>
</table>

Bulleted lists
Use the asterisk (*) to create bullets. For each subsequent level, add an extra asterisk. Make sure there is a space between the asterisk and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you'll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>* some</td>
<td>• some</td>
</tr>
<tr>
<td>* bullet</td>
<td>• bullet</td>
</tr>
<tr>
<td>** indented</td>
<td>○ indented</td>
</tr>
<tr>
<td>** bullets</td>
<td>○ bullets</td>
</tr>
<tr>
<td>* points</td>
<td>• points</td>
</tr>
</tbody>
</table>

Numbered lists
Use the hash (#) to create numbered lists. Make sure there is a space between the hash and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you'll get</th>
</tr>
</thead>
<tbody>
<tr>
<td># a</td>
<td>1. a</td>
</tr>
<tr>
<td># numbered</td>
<td>2. numbered</td>
</tr>
<tr>
<td># list</td>
<td>3. list</td>
</tr>
</tbody>
</table>

A second level of hashes will produce a sub-list, such as the alphabetical sub-list shown below.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you'll get</th>
</tr>
</thead>
<tbody>
<tr>
<td># Here's a sentence.</td>
<td>1. Here's a sentence.</td>
</tr>
<tr>
<td>## This is a sub-list point.</td>
<td>a. This is a sub-list point.</td>
</tr>
<tr>
<td>## And a second sub-list point.</td>
<td>b. And a second sub-list point.</td>
</tr>
<tr>
<td># Here's another sentence.</td>
<td>2. Here's another sentence.</td>
</tr>
</tbody>
</table>

You can use a third level of hashes to produce a sub-sub-list.
1. Here’s a sentence.
   a. This is a sub-list point.
   i. Third list level.
   ii. Another point at the third level.
   b. And a second sub-list point.
   2. Here’s another sentence.

**Note:** In numbered lists as described above, the format of the ‘number’ displayed at each list level may be different, depending upon your browser and the style sheets installed on your Confluence instance. So in some cases, you may see letters (A, B, C, etc; or a, b, c, etc) or Roman numerals (i, ii, iii, etc) at different list levels.

**Mixed lists**

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
</table>
| # Here
#* is
#* an
# example
#* of
#* a
# mixed
# list | 1. Here
• is
• an
2. example
• of
• a
3. mixed
4. list |

**Tables**

You can create two types of tables.

**Table Type 1**

Allows you to create a simple table with an optional header row. Once you’ve added this type of table, you can set the width of the columns using the table controls in the toolbar.

Use double bars for a table heading row.

**What you need to type:**

| ||heading 1||heading 2||heading 3|| |
|---|---|---|---|
| cell A1|cell A2|cell A3|
| cell B1|cell B2|cell B3|

**What you’ll get:**

<table>
<thead>
<tr>
<th>heading 1</th>
<th>heading 2</th>
<th>heading 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>cell A1</td>
<td>cell A2</td>
<td>cell A3</td>
</tr>
<tr>
<td>cell B1</td>
<td>cell B2</td>
<td>cell B3</td>
</tr>
</tbody>
</table>

You can also use a vertical header.

**What you need to type:**
What you'll get:

| heading 1 | col A1 | col A2 | col A3 |
| heading 2 | col B1 | col B2 | col B3 |

### Table Type 2

This method uses section and column macros to create the table, and allows you to specify the width of the columns in the markup.

#### What you need to type

```markdown
{section:border=true}
{column:width=30%}
Text for this column goes here. This is the smaller column with a width of only 30%.
{column}
{column:width=70%}
Text for this column goes here. This is the larger column with a width of 70%.
{section}
```

#### What you'll get

Text for this column goes here.
This is the smaller column with a width of only 30%.
Text for this column goes here. This is the larger column with a width of 70%.

ℹ️ For more details please see the Column Macro and the Section Macro.

### Advanced Formatting

#### Color and Other Formatting

To add color and other formatting to your tables, you can use the Panel Macro within columns. More table-formatting options may be available if your Confluence administrator has installed additional macros.

#### Lists

Here's an example of how to embed lists in a table:

#### What you need to type

```markdown
<table>
<thead>
<tr>
<th>Heading 1</th>
<th>Heading 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>* Item 1</td>
<td></td>
</tr>
<tr>
<td>* Item 2</td>
<td></td>
</tr>
<tr>
<td>* Item 3</td>
<td></td>
</tr>
<tr>
<td># Item 1</td>
<td></td>
</tr>
<tr>
<td># Item 2</td>
<td></td>
</tr>
<tr>
<td># Item 3</td>
<td></td>
</tr>
</tbody>
</table>
```

#### What you'll get

| Heading 1 | Heading 2 |
## Text Effects

Use the markup shown in the examples below to format text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>strong</em></td>
<td>strong</td>
</tr>
<tr>
<td><em>bold text</em></td>
<td>bold text</td>
</tr>
<tr>
<td><em>emphasis</em></td>
<td>emphasis</td>
</tr>
<tr>
<td><em>italics</em></td>
<td>italics</td>
</tr>
<tr>
<td></td>
<td><em>(Hint: To italicize parts of a word, add braces (curly brackets) around the underscore. For example,)</em></td>
</tr>
<tr>
<td></td>
<td>Thing{<em>}x</em></td>
</tr>
<tr>
<td></td>
<td><em>(gives you this: Thingx)</em></td>
</tr>
<tr>
<td>??citation??</td>
<td>citation</td>
</tr>
<tr>
<td>-deleted-</td>
<td>deleted</td>
</tr>
<tr>
<td>+inserted+</td>
<td>inserted</td>
</tr>
<tr>
<td>Text with^superscript^</td>
<td><em>(Text with superscript)</em></td>
</tr>
<tr>
<td></td>
<td><em>(Hint: There are two ways to make superscripts work, when used directly after another word or character:)</em></td>
</tr>
<tr>
<td></td>
<td><em>(• Add a space before the superscript. For example, kg/m^3^ gives you this: kg/m^3^)</em></td>
</tr>
<tr>
<td></td>
<td><em>(• Add braces (curly brackets) around the superscript markup. For example,)</em></td>
</tr>
<tr>
<td></td>
<td>kg/m{^3^}</td>
</tr>
<tr>
<td></td>
<td><em>(gives you this: kg/m^3^)</em></td>
</tr>
<tr>
<td>Text with<del>subscript</del></td>
<td>Text with subscript</td>
</tr>
<tr>
<td>{{monospaced}}</td>
<td>monospaced</td>
</tr>
<tr>
<td>bq. Here's how you make a paragraph appear as a block quotation.</td>
<td>Here's how you make a paragraph appear as a block quotation.</td>
</tr>
</tbody>
</table>
Text Breaks

Paragraph Break

In wiki markup, a paragraph is a continuous line of text ending in two carriage returns. This is equivalent to a continuous line of text followed by a blank line.

When rendered into HTML, the result is a line of text wrapped in a set of `<p>` tags.

Line Break

Confluence provides two options for forcing a line break within a paragraph of text:

- Implicitly, by entering a single carriage return at its end.
- Explicitly, by entering two consecutive backslashes: `\`

When rendered into HTML, the result is a paragraph of text that is split into separate lines by `<br>` tags, wherever a forced line break appears.

For most purposes, explicit line breaks are not required because a single carriage return is enough.

The examples below show how to use explicit line breaks.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you'll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>here is some text</td>
<td>here is some text</td>
</tr>
<tr>
<td><code>\</code></td>
<td>divided</td>
</tr>
<tr>
<td><code>\</code></td>
<td>using line</td>
</tr>
<tr>
<td><code>\</code></td>
<td>breaks</td>
</tr>
</tbody>
</table>

|                        |                          |
| This is a short list:  | This is a short list:    |
| * Point 1              | * Point 1                |
| Text to go with point 1| Text to go with point 1  |
| `\`                   | `\`                      |
| `\`                   | `\`                      |
| Text to go with point 2 with a break | Text to go with point 2 with a break |

If you wish to use multiple consecutive line breaks, each should be separated by a space character. For example, use this for two consecutive line breaks:

`\` `\`

Horizontal Rule

To create a horizontal line across the width of your page or content block, type four dashes (like this: `-----`) at the beginning of a line, then press Enter or space.

Make sure that the dashes are on a separate line from the rest of the text.
## Links

You can use wiki markup to add hyperlinks to your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you’ll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>[#anchor]</td>
<td>A link to an anchor on the same page.</td>
</tr>
<tr>
<td>[Confluence Wiki Markup^attachment.ext]</td>
<td>A link to a file attached to the page.</td>
</tr>
<tr>
<td>[pagetitle]</td>
<td>A link to a page.</td>
</tr>
<tr>
<td>[pagetitle#anchor]</td>
<td>A link to an anchor on another page.</td>
</tr>
<tr>
<td>[pagetitle^attachment.ext]</td>
<td>A link to a file attached to another page.</td>
</tr>
<tr>
<td>[spacekey:pagetitle]</td>
<td>A link to a page in another space.</td>
</tr>
<tr>
<td>[spacekey:pagetitle#anchor]</td>
<td>A link to an anchor on a page in another space.</td>
</tr>
<tr>
<td>[spacekey:pagetitle^attachment.ext]</td>
<td>A link to a file attached to a page in another space.</td>
</tr>
<tr>
<td>[/2004/01/12/blogposttitle]</td>
<td>A link to a blog post. Note: blogposttitle is the title of the blog as it appears on the page.</td>
</tr>
<tr>
<td>[spacekey:/2004/01/12/blogposttitle]</td>
<td>A link to a blog post in another space. Note: blogposttitle is the title of the blog as it appears on the page.</td>
</tr>
<tr>
<td>[/2004/01/12]</td>
<td>A link to a whole day’s blog posts.</td>
</tr>
<tr>
<td>[spacekey:/2004/01/12]</td>
<td>A link to a whole day’s blog posts in another space.</td>
</tr>
<tr>
<td>[spacekey:]</td>
<td>A link to the space homepage (or the space summary page of the space.</td>
</tr>
<tr>
<td>[~username]</td>
<td>A link to the user profile page of a particular user.</td>
</tr>
<tr>
<td>[phrase@shortcut]</td>
<td>A shortcut link to the specified shortcut site. Shortcuts are configured by the site administrator.</td>
</tr>
<tr>
<td>[<a href="mailto:legendaryservice@atlassian.com">mailto:legendaryservice@atlassian.com</a>]</td>
<td>A link to an email address.</td>
</tr>
<tr>
<td>[file://z:/file/on/network/share.txt]</td>
<td>A link to a file on your computer or on a network share that you have mapped to a drive. This only works on Internet Explorer.</td>
</tr>
<tr>
<td><img src="http://external/link.html" alt="http://external/image.png" /></td>
<td>Displays an external image and links to an external URL.</td>
</tr>
</tbody>
</table>

Note that Confluence treats headings as anchors, so you can link to headings using this pattern: [spacekey: pagename#headingname], where headingname is case-sensitive and must be entered without spaces.
For each of these link forms:

- You can prepend a link alias, so that alternate text is displayed on the page. Example: [link alias|pagetitle#anchor]
- You can append a link tip, which appears as a tooltip. Example: [pagetitle#anchor|link tip]

**Images**

You can display images from attached files or remote sources.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you'll get</th>
</tr>
</thead>
<tbody>
<tr>
<td>![<a href="http://www.host.com/image.gif">http://www.host.com/image.gif</a>!]</td>
<td>An image from a remote source is displayed on the page. Uses a fully qualified URL.</td>
</tr>
<tr>
<td>![attached-image.gif!]</td>
<td>An image file attached to the page is displayed.</td>
</tr>
<tr>
<td>![pageTitle^image.gif!]</td>
<td>An image file attached to a different page is displayed.</td>
</tr>
<tr>
<td>![SpaceKey:pageTitle^image.gif!]</td>
<td>An image file attached to a page in a different space is displayed.</td>
</tr>
<tr>
<td>![/2010/05/23/My Blog Post^image.gif!]</td>
<td>An image file attached to a blog post is displayed.</td>
</tr>
<tr>
<td>![image.jpg</td>
<td>thumbnail]!</td>
</tr>
<tr>
<td>![image.gif</td>
<td>align=right, vspace=4!]</td>
</tr>
</tbody>
</table>

Available HTML image tags include:

<table>
<thead>
<tr>
<th>Image tag</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>align</td>
<td>Available values are 'left', 'right', 'bottom', 'center', 'top'.</td>
</tr>
<tr>
<td>border</td>
<td>Specifies the width of the border (in pixels).</td>
</tr>
<tr>
<td>bordercolor</td>
<td>Use with the 'border' tag. Specify colors by name or hex value.</td>
</tr>
<tr>
<td>hspace</td>
<td>Specifies the amount of whitespace to be inserted to the left and right of the image (in pixels).</td>
</tr>
<tr>
<td>vspace</td>
<td>Specifies the amount of whitespace to be inserted above and below the image (in pixels).</td>
</tr>
<tr>
<td>width</td>
<td>Specifies the width of the image (in pixels). This will override the natural width of the image.</td>
</tr>
<tr>
<td>height</td>
<td>Specifies the height of the image (in pixels). This will override the natural height of the image.</td>
</tr>
<tr>
<td>title</td>
<td>Specifies alternate text for the image, which is displayed when the pointer hovers over the image.</td>
</tr>
<tr>
<td>-------</td>
<td>--------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>alt</td>
<td>Specifies alternate text for the image. This text is retrievable via search, and contributes to accessibility of the page for text-only viewing.</td>
</tr>
</tbody>
</table>

**Page Layouts**

There is no wiki markup representation for page layouts.

**Macros**

Storage format and wiki markup examples have been included in the documentation for each macro.
Files

Share your team’s PDFs, Office documents, images, and more in one place by uploading your files to Confluence. Automatic versioning, instant previews, permissions, and full-text search, means shared network drives can be a thing of the past for your team.

When you upload a file it is attached to the current page or blog post. This is why files are often referred to as attachments in Confluence.

You can attach anything from project plans and design mockups to video and audio files. You and your colleagues can also collaborate by commenting on files displayed on Confluence pages.

Using Files

- Upload Files
- Display Files and Images
- Manage Files
- Share and Comment on Files
- Edit Files
- Edit in Office using the Office Connector
- Install Atlassian Companion

Permissions

The ‘Add Attachment’ and ‘Delete Attachment’ permissions are used to control who can upload and delete attachments in a space.

Users with ‘Add Page’ or ‘Add Blog’ permissions can insert existing attachments to their pages, but not upload new attachments unless they also have the ‘Add Attachment’ permission.

There is no permission that controls downloading attachments. See our knowledge base article about disabling the download of attachments if you need to do this.
Upload Files

When you upload a file, such as an image or document, it will be attached to the current page.

You can then choose to display the file on the page as a link, an image or embed it in the page (using a macro).

To upload a file you'll need the ‘Add Attachments’ space permission.

Upload a file

There are many ways to attach a file to a page.

In the editor you can:

- Drag the file directly onto the page.
- Go to Insert > Files and images and upload a file.

When viewing a page you can:

- Drag the file directly onto the page.
- Go to More options > Attachments and upload a file.

You can attach multiple files at a time.

Copy and pasting a file from another application doesn't work reliably in many browsers. We recommend you use one of the methods above to make sure the file is uploaded successfully.

Accepted file types and size

Confluence allows you to attach most file types, but you cannot attach a folder of files (including folders created by applications like Keynote - you'll need to export your presentation to zip or other format).

Although just about any file type can be attached to a page, not all file types can be displayed on or embedded in a page. See Display Files and Images to find out more.

The maximum file size you can upload to Confluence is set by your system administrator. By default it's 100mb, but your administrator may have increased or reduced this limit.

File versions

If you upload a file with the same name as an existing attachment on the same page, Confluence will overwrite the existing attachment. Version history is kept for all attachments. See Manage Files to find out more.

Any changes you make to the source file will not affect the copy that was uploaded to Confluence. To update the Confluence copy, you need to upload the new version of the file.

What happens after a file is uploaded?

Text extraction and indexing

When a file is uploaded, its text is extracted and indexed. This allows people to search for the content of a file, not just the filename.
See Configuring Attachment Size for more information on how files are indexed.

**Thumbnail and preview generation**

When you insert an uploaded file into a page (for example a Word document, or Excel spreadsheet), Confluence will generate thumbnail images of the file contents, so it can be viewed inline in the page, or in the preview.

Because this process can be very memory intensive, a 30second time limit applies when performing document conversion for complex image or presentation files (such as PPT, PPTX, EMF, WMF). Your administrator can increase or decrease this timeout using the `confluence.document.conversion.imaging.convert.timeout` or `confluence.document.conversion.slides.convert.timeout` system properties.

Thumbnails are not generated for TIFF or PSD (Photoshop) files by default. Your administrator can override this behaviour using the `confluence.document.conversion.imaging.enabled.tif` or `confluence.document.conversion.imaging.enabled.psd` system properties.

Confluence Data Center externalizes the file conversion process to minimise the impact on individual Confluence nodes. See Document conversion for Confluence Data Center to find out about how this affects thumbnail and preview generation.

**Notes**

⚠️ We recommend you don’t use special characters in page or attachment names, as the page or attachment may not be found by Confluence search, and may cause some Confluence functions to behave unexpectedly.
Display Files and Images

Files can be displayed on a page as a thumbnail or as a link. There are a few different ways to Upload Files.

You can control how the file appears on your page. The options available depend on the type of file.

Insert a file into your page

There's a few ways to insert a file into your page:

- Go to Insert > Files on the editor toolbar and select any of the previously uploaded files, or
- Drag the file directly into the editor (this will upload and insert the file in one step), or
- Type ! and choose an attached file from the autocomplete drop down.

Your file will appear on your page as a thumbnail. Click the thumbnail to resize it or to switch to showing the file as a link.

Insert a file attached to another page

You can display a file that's attached to a different page of the same Confluence site, if you know the name of the file.

To display an image attached to a different page:

1. Go to Insert > Files and choose the Search on other pages.
2. Enter the name of the file.
3. Choose whether to search the current space or All Spaces and choose Search.
4. Select the file from the search results and choose Insert.

Insert an image file from the web

You can display an image from a remote web page on your Confluence page, without needing to attach it to your page. You need to know the URL for the image, not for the web page it appears on. This is only available for image files, not other types of files (like documents).

To display an image from a web page:

1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Files and choose Images from the web.
4. Choose Preview to check that the URL and image are correct.
5. Choose Insert.

Delete files from your page

If you delete a file or image in the editor, the attached file will not be deleted. Go to More options > Attachments to delete the attachment completely from the page.

Seeing an 'unknown attachment' placeholder on your page? This means that the attached file has been deleted from the page (or another page).

Preview a file

Click an image, file thumbnail or link when viewing a page to launch the preview.

The preview includes images from the web that are displayed on the page and files that are attached to the page (even if they are not currently displayed on the page).

In the preview you can:

- download the image file
- upload a new version of the file (attached files only)
- comment on the file
- choose to edit the file with a desktop application
- zoom in, out or fit the image to the width of your browser
- browse like a slideshow using the next and back buttons
- see other files attached to the page and select a thumbnail to preview that file
- switch to a full screen presentation mode

Several file types can be previewed, including Office files, PDFs and many image types.

<table>
<thead>
<tr>
<th>Images files</th>
<th>Office files</th>
<th>Other files</th>
</tr>
</thead>
<tbody>
<tr>
<td>JPEG, PNG, TIFF, PSD, WMF, EMF, ICO, ICNS</td>
<td>DOC, DOCX, PPT, PPTX, XLS, XLSX</td>
<td>PDF, MP3, MP4</td>
</tr>
</tbody>
</table>
Office and PDF files

Inserting a file in a page is a great way to make useful documents, spreadsheets, presentations and other files available to your team.

As with all file types, you can choose to insert the file as a link, or as a thumbnail. The thumbnail shows a preview of the document's contents, and can be resized.

To view an Office or PDF file, click the link or thumbnail to see the full preview (no need to have Excel, Word or PowerPoint installed). Alternatively, use the Download button in the preview to download the file and view offline.

You can even edit and comment on Office and PDF files.

Image files

When editing the page, select an image to show the image properties panel. The panel allows you to set the display size, add a border, and effects, link the image to other pages, and provide a caption.

Screenshot: image properties panel

From the image properties panel you can:
• enter a width for the image (between 16px and 900px)
• set a preset size for the image
• add a border around the image
• add a link to the image
• add effects to the image such as drop shadow or snapshot (go to Properties > Effects)
• provide alt text used by screen readers and when the image can't be shown (go to Properties > Description)
• give the image a caption by typing it into the caption field (also available in Properties > Description)

Screenshot: image captions are displayed different in the editor, and in preview or page view.

1. In the editor, image captions are indicated by a label icon and grey strip below the image.
2. When viewing a page, image captions are displayed.

To add a caption to an image using the Instant Camera effect:

• Select Effects in the image properties panel and choose the Instant Camera image effect.
• Save the page.
• Go to More options > Attachments to go to the 'Attachments' view of the page.
• Choose Properties next to the image file.
• Add a comment to the attachment. The text in your comment will appear as the image caption.

You'll need to re-enter the comment each time you upload a new version of the image.

Note: The Instant Camera effect only works with Latin character languages, due to a lack of handwriting style fonts in multi-byte languages.

A note on using Image Effects
Displaying image effects can be resource intensive. Confluence will prevent users from applying an image effect if the image is very large (based on data size and dimensions in pixels).

Confluence also limits the threads that are dedicated to displaying image effects so that it does not impact your whole instance. If a thread is not available, Confluence will display the image without the effect. See Image effects are not displayed in Confluence 5.5 or later if you need to adjust the number of threads.

To wrap text around an image:

1. Select the image.
2. Use the left and right align buttons in the editor toolbar to text wrap around the image.
3. Double click on the same align button to remove text alignment (this will align the image without text wrap).
4. Save your page.

Multimedia files

The file preview also supports MP3 audio and MP4 video files. It uses HTML5 to play attached audio and video files. This means the file types people can play in the preview depends on the audio and video formats their browser supports.

You can also display a wider range of multimedia files (video, audio and animation) using the Multimedia Macro.

Display online video (such as YouTube or Vimeo videos) using the Widget Connector Macro.

Show a list of files on a page

There are several ways you can display a list of files on a page. You can:

- Use the Attachments Macro to show files attached to the current page.
- Use the Space Attachments Macro to show all files in a space.
- Use the Gallery Macro to show thumbnails of images attached to a page.

You can also use the File List blueprint for uploading, viewing and managing lists of files.
**Manage Files**

Files are attached to Confluence pages. See [Upload Files](#) to find out about attaching files to pages.

Once attached you can download, delete and edit these files, for example if you need to upload a new version of the file, or change the page it is attached to.

**Download attached files**

Any user with permission to view a page can also download any files attached to that page.

To download an individual file:

- Click the **Download** button in the file preview, or
- Go to **More options > Attachments**
- and then right click on the file name and save the link.

To download all files attached to a page as a zip file:

1. Go to **More options > Attachments**
2. Click **Download All**.

There's no option to download all attachments in a space.

**Delete an attached file**

You'll need the 'Delete Attachment' space permission to delete an attached file.

To delete all versions of an attached file:

1. Go to the page that contains the attachment.
2. Go to **More options > Attachments**
3. Choose **Delete** next to the attachment you want to delete.
4. Choose **Delete** to confirm your action.

Deleted files can be restored from the trash. You'll need to be a space admin to do this.

Space Admins can also delete specific versions of an attachment:

1. Go to **More options > Attachments**
2. Click the expand arrow next to the attachment name to see the list of attachment versions
3. Choose **Delete** next to the version you want to delete.

Deleted file versions are not recoverable from the trash.

*Screenshot: Attachments and attachment versions*
Upload a new version of an attached file

There are two ways to upload a new version of an attached file. You can:

- Upload a file with the same file name to the page.
- Use the **Upload a new version** button in the file preview to upload a file with a different name (for images and PDFs only).

To view attachment versions:

- Go to More options > Attachments
- Click the expand arrow next to the attachment name.

All earlier versions of the file will appear.

You can't revert to an earlier version of the file, but you can choose to remove earlier versions if you have Space Administrator permissions.

Move a file to another page

You'll need the 'Add Page', 'Add Attachment' and 'Remove Attachment' space permissions to move an attached file to another page.

To change the page that a file is attached to:

- Go to More options > Attachments
- Choose **Properties** next to the attachment you want to move.
- Enter the name of the page you want to move the attachment to (for example My Destination Page).
- Choose **Save**.

If you want to move the file to a page in another space, add the space key before the page name (for example DOC:My Destination Page).

Edit properties of an attached file

You'll need the 'Add Attachment' permission in the space to edit the file properties.

To edit the properties of an attached file:

- Go to More options > Attachments
- Click **Properties** beside the attachment you want to edit.

You can:

- change the file name
- add a comment (used in the version list and also by the Snapshot image effect)
- change the MIME type
- move the attachment to another page
- add a label.

Changing the MIME type may cause your file to display incorrectly.

View all attached files in a space

There are two ways you can view all files in a space. You can:

- Use the Space Attachments macro to display the list of files on a page.
- Go to the space and choose Space tools > Content Tools from the bottom of the sidebar Then choose Attachments.

You can use the filters to only show files with a particular label or file extension.

Screenshot: Space attachments macro
Share and Comment on Files

Collaboration doesn’t just happen on pages; often you'll need to collaborate with your team on documents, presentations, images and spreadsheets. Whether it’s mockups for a new marketing campaign or a full project plan, you can simplify your team’s feedback loop by working together on files in Confluence.

Share a file

Do you have lots of files on a page and want to get a team member’s input on just one of them? You can share the file with them directly.

It works just like sharing a page:

1. Click the thumbnail or link to preview the file.
2. Choose the Share button.
3. Enter an email address, user name or group name, add your message and send.

Your team members will get an email with your message and a link to view the file.

Comment on a file

Whether it’s an image – like a mockup of the new marketing campaign that needs feedback – a PDF, a presentation, or any other file you can preview in Confluence, you can drop a pin anywhere on the preview and add your comment to start a conversation.

To comment on a file:

1. Click the thumbnail or link to preview the file.
2. Drag the pin icon from the bottom of the preview and drop it where you want to comment.
3. Add your comment and Save.

Pinned comments work just like inline comments on pages. You can use @mentions and links, and drop as many pins as you need on any part of the file. You can even add simple macros such as the code macro using wiki markup autocomplete. Anyone with permission to add comments to the page can add and reply to comments on a file.

When you preview a file, you’ll see pins for any existing comments on that version of the file. Select a pin to view the comment.

Once the conversation is finished, you can resolve the comment to hide it (and any replies) from view. If you need to see resolved comments again, you can reopen them. Go to ▼ ▼ ▼ ▼ > Resolved comments in the preview.

On this page:

- Share a file
- Comment on a file

Related pages:

- Files
- Edit Files
- Display Files and Images
- Comment on pages and blog posts
1. **Resolved comments**: Choose the 'more options' button to show or hide resolved comments.
2. **Comments**: Drag a pin onto a file to comment.

You can’t comment on files that are hosted on a web server and added to Confluence using their URL, or on files that can’t be viewed in the preview (such as videos, zip files, and some other file types).

**What happens to comments when you upload a new version?**

Comments are specific to the version of the file. This is to avoid confusion when the part of the document or image the comment is pinned to has changed significantly.

To see inline comments on a previous version of the file:

1. Click the thumbnail or link to preview the file.
2. Click the filename dropdown in the top left and select a previous version.
3. Comment pins will now be visible, for all comments made on that version.

**How many comments can you add to one file?**

While there is no limit to the number of comments that can be added to a file, Confluence can only display 100 comments. See CONFSERVER-43397 for more information.
Edit Files

This page covers how to edit files attached to a Confluence page.

On this page:

- Install and connect the Atlassian Companion app
- Change your default app
- Edit conflicts
- Manually upload an edited file
- Limitations
- Revoke trust between Confluence and the Companion app

Related pages:

- Administering the Atlassian Companion app

Confluence provides two methods for editing files:

- **Edit files using the Atlassian Companion app**
  Allows you to edit any type of file, if you have a compatible application installed. Requires you to install Companion on your computer.

- **Edit in Office using the Office Connector**
  Allows you to edit Microsoft Excel, PowerPoint, and Word files with a compatible browser and Microsoft Office application. Provided for organizations who can't use Companion.

Your Confluence administrator will decide which method is best for your organisation.

To check which method is available in your site, go to the file preview (click an image or file thumbnail). If you don't see the Edit button, your site is using the Edit in Office method, so the information on this page doesn't apply to you.

To edit a file in Confluence:

1. **Edit an attached file**
   
   You can edit any file attached to a Confluence Data Center page using your preferred desktop application, then when you’re ready, upload the file back to Confluence. You can edit Office documents, Photoshop files, Keynote presentations — any attached file with a compatible application installed on your computer.

   To edit a file you'll need the 'Add Attachments' space permission.

   To edit files, you'll also need to install the Atlassian Companion app and allow it to connect to your Confluence site. Once the Companion app is installed and running, you can start editing.

   To edit a file in Confluence:
1. Go to the page containing the attached file.
2. Click the file to open it in preview.
3. Click Edit.
4. Your browser will prompt you open / launch the Companion app.
5. The Companion window will appear, and your file will open in the default application for that file type.
6. Make your changes and then save your file in the desktop application.
7. In the Companion window, click Upload to upload the edited file. It will be saved as a new file version.

Screenshot: Editing an image file with Companion.

1. Edit button - if a file can be edited, you’ll see an Edit button in the preview.
2. Download Companion - if you haven’t already installed Companion, you can download it from this flag. The flag always appears, but you only need to download Companion once.
3. Launch Companion - your browser will ask for your permission to open Companion. The prompt is different in each browser, and will appear each time you edit a file.
4. Upload or discard file - once you have saved the changes to your file, click the Upload button to upload your edited file back to Confluence, or click the x icon to discard the changes, and remove the file information from the list.

Other ways to edit files

You can also edit a file from the attachments macro, view file macros (Word, Excel, PowerPoint, and PDF), or the attachments page.

To edit a file from the attachments page:

1. Go to the page that contains the attached file.
2. Go to More options  *** > Attachments
3. Next to the file name, click Edit , then follow the instructions above to edit and save your changes.

Install and connect the Atlassian Companion app

The Atlassian Companion app manages the download and re-upload of files you edit in Confluence.

The first time you edit a file, you’ll be prompted to install the Companion app and allow it to connect to your Confluence site.
1. Click the file to open it in preview.
2. Click Edit.
3. Follow the prompts to download and install the Atlassian Companion app.
4. Launch the Companion app.
5. In Companion, click Trust to confirm you want to connect to Confluence.
6. Return to Confluence, and follow the steps above to edit the file.

You can also download and install the app manually for Mac or Windows or use a Microsoft Installer (.msi file). See Administering the Atlassian Companion app for details.

For detailed installation instructions for your operating system, see Install Atlassian Companion.

Change your default app

Confluence allows you to edit files in your operating system's default app for that file type (for example, .psd files will open in Photoshop). To change the app your Confluence file opens in, change the default app in your operating system.

Edit conflicts

When you edit a file, Companion downloads a copy of the file to your computer. Once you're finished editing and you attempt to upload the file, Companion will warn you if a newer version of the file was uploaded after you downloaded the file. You can choose to click the x icon to discard your changes, or continue to upload your changes as a new version. Both versions will be available in the file history.

Confluence doesn't provide an option to check-out a file before you start editing. There are apps available on the Atlassian Marketplace that can provide this functionality.

Manually upload an edited file

You can only upload changes back to Confluence if those changes are saved in the original file. You won't be able to upload if:

- you edit the file and save it as a new version (save as)
- the application you're using saves the file in a different format to the original — for example, from a PowerPoint file (.pptx) to a Keynote file (.key).

If this happens, you can upload your new version manually:

1. Click the original file in Confluence to open it in preview.
2. Click the Upload a new version button and select your new file version.
3. Click Done.

What to do if you lose your edited file

Any files you've opened with Companion will remain listed in the Companion window. The status information below the file will indicate the time since the file was downloaded, edited, or uploaded. Files that haven't been edited in the last 60 days are cleared when Companion app restarts.

You can also follow our guide to accessing Confluence files edited with the Atlassian Companion app if the file isn't listed or you're not able to re-open it in your desktop application.
Limitations

File size limits

Confluence won't allow you to upload your changes if the edited file is larger than your site's maximum file size limit. This limit is set by your system administrator. By default the limit is 10 MB, but your admin may have increased or reduced it. Check out Upload Files for more information.

Blocked file types

We block file types that might pose a risk to your security, including executable files such as .exe or .bat files.

It's possible to modify the file types companion can open using an environment variable. See How to change the file types blocked by Companion in Windows.

Cross file links and references

If your file links or references to other files (for example if you link a worksheet in one Excel file, to another Excel file) these links will not work once the files have been uploaded to Confluence.

Revoke trust between Confluence and the Companion app

If you want to disconnect the Companion app from your Confluence site, you can remove it as a trusted site.

To revoke trust:

1. Click the Companion app icon in your system's toolbar.
2. Choose Clear all trusted domains.

Note: clearing trusted domains won't kill active connections. If you select Clear all trusted domains while editing a file, you'll still be able to upload those changes back to Confluence.
Edit in Office using the Office Connector

This page covers how to edit files using the legacy Edit in Office method.

Confluence provides two methods for editing files:

- **Edit files using the Atlassian Companion app**
  Allows you to edit any type of file, if you have a compatible application installed. Requires you to install Companion on your computer.

- **Edit in Office using the Office Connector**
  Allows you to edit Microsoft Excel, PowerPoint, and Word files with a compatible browser and Microsoft Office application. Provided for organizations who can't use Companion.

Your Confluence administrator will decide which method is best for your organisation.

To check which method is available in your site, go to the file preview (click an image or file thumbnail). If you see the Edit button, your site is using the Companion app method, so the information on this page doesn't apply to you.

**Editing Office files attached to a page**

The Office Connector allows you to edit Office files that are attached to pages, if your site does not use the Companion App method. You'll need to use a browser, operating system and application (either Microsoft Office or OpenOffice) as described in the compatibility matrix below.

To edit an Office document attached to a Confluence page:

1. Go to More options > Attachments
2. Choose Edit in Office beside the attachment you want edit.
   Your browser will ask you to confirm that you want to open the file.
3. Choose OK.
   You may also see a security warning or be asked to log in to your Confluence server - enter your Confluence username and password, then choose OK.
4. The file will open in your Office application - make your changes then save the document. It will be saved back to Confluence.

⚠️ Edit in Office will not work on files that have special characters (such as `'# '@ or `€) in the filename.

*Screenshot: Edit in Office option on the attachments page*
Other ways to edit

Edit options also appear in the:

- **Attachments macro** (choose **Edit in Office** beside each attached office file)
- **Office Word** and **Office Excel** macros – choose the **Edit** button above the content.
- **Office PowerPoint** macro – choose the edit icon on the viewer.

**Office Connector pre-requisites**

You can only edit files using the Office Connector if your system administrator has enabled this feature on your site. By default, Confluence requires you to install the Atlassian Companion app to edit attached files. See [Edit Files](#).

**Configuration matrix**

Edit in Office is only compatible with desktop applications. Online versions of Office applications are not supported.

You need one of the following software combinations to edit Office files from your Confluence page.

<table>
<thead>
<tr>
<th>Software</th>
<th>Operating system</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Office 2010 SP2, 2013, 2016, 2019</td>
<td>• Windows</td>
<td>• Chrome</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Firefox</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Internet Explorer 11</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Edge</td>
</tr>
<tr>
<td>Microsoft Office 2011, 2016, 2019</td>
<td>• Mac OS</td>
<td>• Chrome</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Firefox</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Safari</td>
</tr>
<tr>
<td>Microsoft Office XP, 2003, 2007, 2010 SP1</td>
<td>• Windows</td>
<td>• Internet Explorer 11</td>
</tr>
<tr>
<td>OpenOffice 2.x – 3.x</td>
<td>• Windows</td>
<td>• Chrome</td>
</tr>
<tr>
<td></td>
<td>• Linux</td>
<td>• Firefox</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Safari</td>
</tr>
</tbody>
</table>
1. LibreOffice 6.x

- MacOS
- Windows
- Linux
- Chrome
- Firefox
- Safari

Firefox only works in Windows with Confluence 7.1 and later.

**Note**

The known supported Office editors for Linux are OpenOffice & LibreOffice, but in theory it should work with any WebDAV-aware application.

If you experience problems editing documents using the Office Connector (using an application, operating system and browser combination above) contact our support team, who can raise an issue about it. Tell us as much as you can about your operating system, application version, document version (if it's different to the version of Office / Open Office you're using to open the document) and browser.

Here are a few common issues:

- **Using Internet Explorer?** You can only edit documents in Microsoft Office. OpenOffice is not supported.
- **Using Linux?** You can only edit documents in OpenOffice. Microsoft Office is not supported.
- **Special characters in the filename?** Edit in Office does not work for files with special characters (like ` # @ €) in the filename. See CONFSERVER-22403 - Attaching office documents with special characters stops the ability to edit from office.
- **Not seeing the Office Connector options?** Your system administrator needs to enable this feature, and can control how it appears on your site. See Enable Edit in Office as a dark feature and Configuring the Office Connector.

**Enable Edit in Office**

You need System Administrator global permission to do this.

To enable the legacy Edit in Office functionality:

1. Go to Administration > General Configuration > Office Connector.
2. Choose Enable Edit in Office for all users and save your changes.

This will disable Companion app functionality for all users in the site.

**Troubleshooting**

Having problems with the Office Connector?

- The **WebDAV plugin** must be enabled, because the Office Connector uses WebDAV to transfer information to and from Office documents. The WebDAV plugin is bundled with Confluence, and can be enabled or disabled by the System Administrator. If necessary, refer to the instructions on managing system and marketplace apps and configuring the WebDAV options.
- Ensure that your Confluence server's base URL is set correctly (see Configuring the Server Base URL to find out how to check this). When a user edits a Confluence page in Word and then uploads the page back to the Confluence server, the base URL determines where the document will be saved. If the base URL is incorrect, the documents may be saved to a different Confluence server.
- **Using Office 2013?** Your administrator will need to enable 'Allow authentication tokens in the URL path' in the Office Connector configuration. See Configuring the Office Connector.

See the Office Connector Limitations and Known Issues knowledge base article for more troubleshooting tips.
Install Atlassian Companion

This page applies to Confluence Data Center

The Companion app was removed from Confluence Cloud at the end of March 2022. Read announcement

We currently have no plans to end support for the Companion app in Confluence Data Center.

If your site uses Atlassian Companion method to edit files, you will need to install the Atlassian Companion app before you can start editing. Learn more about Editing Files.

The way you install Companion will depend on your operating system, and your organisation's environment.

Download the latest Companion version

Download the Atlassian Companion app for Mac or Windows.

Windows

These instructions are for Windows 10. The process is similar in earlier, supported Windows versions.

1. Download the Companion app from Windows download
2. Double click to run the Atlassian Companion-1.X.X Setup.exe file you just downloaded.
3. That's it. You may briefly see a progress indicator like the one below.

Once installed, Companion runs in the background. You may need to click the Show hidden items arrow in the system tray to see it. Right click the Companion icon to see the version you have installed.
The first time you edit a file, you'll be prompted to trust your Confluence site. Once that's done, Companion is ready to use.

Mac

These instructions are for MacOS 10. Your version may look slightly different.

1. Download the Companion app from [Mac download]
2. Double click the Atlassian Companion.dmg file you just downloaded.
3. The install dialog will appear. Drag the Atlassian Companion icon to the Applications folder icon.

4. Launch the companion app:
   a. In Finder, go to your Applications folder, and click Atlassian Companion.app, or
   b. In Launchpad, select Atlassian Companion, or
   c. In Spotlight, search for Atlassian Companion.

Once launched, Companion runs in the background. Click the Companion icon in the status area of the menu bar to see the version you have installed.
The first time you edit a file, you'll be prompted to trust your Confluence site. Once that's done, Companion is ready to use.

**Linux**

Atlassian Companion is not currently available for Linux.

**Managed or restricted environments**

If you're not able to install applications on your computer, your administrator or IT team may need to do this for you.

Send them a link to [Administering the Atlassian Companion App](#) for information about MSI installation.

**Troubleshooting**

**Companion is installed twice in Windows**

It's possible to have two versions of Companion installed simultaneously if you have installed Companion using the installer (.exe) and the MSI (.msi). If this happens, you should uninstall both versions from Add/Remove programs and then re-install Companion (either using the .exe or the .msi depending on how you want to be able to update Companion in future).

**Remove residual files after uninstalling Companion in Windows**

If you need to completley uninstall Companion you may want to check if any residual files remain.

The default installation directories are:

- **EXE**: `%LOCALAPPDATA%\atlassian-desktop-companion`
- **MSI**: Program Files (x86)/Atlassian Companion

The app stores temporary data and edited files in:

- `%APPDATA%\Atlassian Companion`
- `C:\Users\<UserName>\.atlassian-companion`

Companion creates the following registry entries:

- `Computer\HKEY_CLASSES_ROOT\atlassian-companion`
- `Computer\HKEY_CURRENT_USER\Software\Classes\atlassian-companion`
- `Computer\HKEY_CURRENT_USER\Software\Microsoft\atlassian-desktop-companion`

You can do a registry search for "atlassian" to locate them. These are used for both the MSI and EXE.
Confluence Mobile

There are two ways to stay connected to your team's work in Confluence while you're out and about - the Confluence Data Center and Server mobile app for iOS and Android, or via your device's browser.

If you're a Confluence user, check out the two ways you can use Confluence on your device.

- Using the Confluence Data Center and Server mobile app
- Using Confluence via your mobile browser

What you'll need

Confluence requirements

In order for your users to try the Confluence Data Center and Server mobile app, you will need to:

- upgrade your Confluence site to Confluence 6.8 or later
- allow users to access your site on their device (if your site isn't accessible on the public internet, people will need be connected to your network or use a VPN)

Device requirements

In order to use the app, your users will need a device with either:

- Android 4.4 (KitKat) or later, or
- iOS 15 or later (iPhone, iPad or iPod Touch)

Users will need to log in to use the app, even if your site allows anonymous users.

Considerations for administrators

Here are some things to consider when determining whether your users will be able to use the app.

VPN and firewalls

If your Confluence site is not accessible on the public internet, users will need to connect their device to your network or virtual private network (VPN) in order to use the app.

We recommend providing your users with step-by-step instructions on how to connect to your VPN when you let them know the mobile app is available, as this is something Atlassian Support will not be able to help them with.

The mobile app will also attempt to check the compatibility of your site prior to presenting the login screen. If you've configured a custom filter to prevent unauthenticated requests to your server, you will need to change it to allow `<confluence-base-url>/rest/nativemobile/1.0/info/login` to pass through without authentication.

HTTPS and certificate requirements

In the latest version of the iOS and Android apps, you can connect to the app using either HTTP or HTTPS.

If you're using HTTPS your proxy must allow TLS 1.2 traffic. This is an iOS requirement that we've chosen to implement for both the iOS and Android apps to prevent confusion (for example where one device can log in, and another cannot).

Ideally, your certificate should be from a trusted Certificate Authority. If you have certificate that is self-signed, or from an unknown Certificate Authority (for example, you are your own CA), users may still be able to use the app by manually installing your certificate on their device. See our Knowledge base article for more information on how to do this.
iOS 13 introduced a number of other requirements that your certificate will need to meet if your users will be using the app on iOS devices. See Requirements for trusted certificates in iOS 13.

Login and authentication

The app supports all common Confluence user management configurations, including external user directories and SAML single sign-on. Users will need to sign in to use the app, even if your site allows anonymous access.

User-Agent header format

The app uses an RFC-compliant user-agent header for making the requests during login. This allows us to effectively identify the app and apply further processing based on the user's hardware and software.

Given the wide variety of supported configurations we decided to adopt the most versatile format. For both iOS and Android we compose the User-Agent header value by concatenating the standard WebView User-Agent and unique app identifier.

iOS User-Agent

**Format**

```
Mozilla/5.0 (<system-information>) <platform> (<platform-details>) Safari/<technical-version>
AtlassianMobileApp
```

**Example**

```
Mozilla/5.0 (iPhone; CPU iPhone OS 14_7 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Safari /604.1 AtlassianMobileApp
```

Android User-Agent

**Format**

```
Mozilla/5.0 (<system-information>) <platform> (<platform-details>) AtlassianMobileApp
```

**Example**

```
Mozilla/5.0 (Linux; Android 9; Mi A1 Build/PKQ1.180917.001) AppleWebKit/537.36 (KHTML, like Gecko) AtlassianMobileApp
```

Storage and encryption

The iOS and Android apps cache some content (spaces, pages, attachments) locally on the user's device. This helps keep the app responsive when navigating around pages and spaces. We don't use any application-level encryption when storing cached data, but the device's internal storage may be encrypted by the operating system.

When a user logs out, all cached data is deleted.

We don't store passwords in the app. Instead we use session cookies, which are encrypted by default.

Session timeout

Mobile apps rely only on the 401 response status code to recognize a session timeout event. If your environment has a proxy, make sure that it doesn't override the response status code (e.g. in case of ADFS you may run into a redirect to login.microsoft.com, a 3xx status code, when your session expires).

Otherwise, you might see errors like No connection or Can't show the issue/page when your session expires, and you should log in again explicitly to resolve them.
Mobile Device Management (MDM)

You can distribute the Confluence Data Center and Server app to people in your organisation using your MDM solution. For more info on how to do this, see Mobile Device Management.

Marketplace apps, themes, and visual customizations

The mobile app provides a simple, lightweight way for users to view, create, edit and collaborate on pages. Complex interactions, including those provided by Marketplace apps, such as blueprints, calendars, workflows will not be available in the app. Some third party macros may be available, depending on whether the third-party app supports rendering these macros on mobile.

Any theming or look and feel customizations you've made to your site will not be reflected in the mobile app.

Cloud services

In order to provide push notifications to users’ devices, we have developed a cloud-based notification service. This service is developed and maintained by Atlassian, and is hosted on our AWS infrastructure (AWS SNS). See Push notifications service below for more information.

This is the only cloud-based service used by the app.

Push notifications service

The Confluence Data Center and Server mobile app can push notifications directly to users’ devices. Users choose whether they’d like to receive push notifications from the app, and can opt out at any time. This feature uses a cloud-based notifications service developed and maintained by Atlassian and hosted on our AWS infrastructure. No user or message content is sent to the service, only notification IDs, and we don’t store any data.

If you need to avoid using any cloud-based services you can choose to disable push notifications entirely. Head to Administration > General Configuration > Mobile apps.

If you're using restrictive firewall or proxy server settings, you'll need to allow (whitelist) https://mobile-server-push-notification.atlassian.com to ensure push notifications work as expected.

For sites that are not accessible on the public internet (for example users need to be connected via VPN to use the app) we adapt the push notification message as follows:

- If the user is connected to your network or VPN, we'll show the full notification, for example “Sara Leung shared 'End of year party' with you”
- If the user is not currently connected to your network or VPN, we'll show a shorter notification, for example “1 new notification”.

Mobile web and linking directly to pages

It is not possible to go directly from a link, for example in an email notification, to the app. To help with this limitation, when people land on a Confluence page in their device's browser, they'll see the Open in app button. Tapping this prompt will open the app, if they have it installed, or take them to the App or Play store to download it.

If you don't want this button to display in mobile web, you'll need to disable the entire Confluence Mobile plugin, which is required to use the mobile app. There is currently a known issue with this workaround. See CONFSERVER-57423 - Open in app button doesn't hide when disabling Confluence Mobile Plugin while in Mobile View for details.

Limitations and known issues
Not all macros are available

Not all macros will display in the app or mobile web. If a macro can’t be displayed, you’ll see the message below, and have the option to tap through to the desktop version of the page, in your device’s browser.

Screenshot: Error that appears when a macro is not rendered in Confluence mobile

Administrators can disable Confluence mobile on your site

If you’re not able to use the mobile app or mobile web, it may be because your administrator has disabled one or both of the following system apps:

- Mobile plugin for Confluence Data Center and Server (formerly called Confluence mobile plugin). This is required to use the mobile app.
- Confluence mobile web plugin. This is required to use mobile web.

Disabling the Mobile plugin for Confluence Data Center and Server (formerly known as ‘Confluence Mobile Plugin’) will also disable all the modules of the Workbox - Host Plugin plugin. This issue is being tracked at

CONFSERVER-40782 - Disabling the Confluence Mobile Plugin also disables the Workbox - Host Plugin in Confluence

Seperate Cloud and Data Center mobile apps

While the functionality of the two mobile apps is very similar, you will need to download the Confluence Data Center and Server mobile app to be able to authenticate with a Data Center site. You can’t use the Confluence Cloud app with a Confluence Data Center site or vice versa.

Troubleshooting

Having other problems with the app? See Confluence Server and Data Center mobile apps in the knowledge base.
Using the Confluence Data Center and Server mobile app

Stay connected to your team’s work with the Confluence mobile app. No matter whether you have an iPhone, iPad, Android phone, or Android tablet, we’ve got you covered when you’re away from your desk.

If you’re the first in your organisation to try the app, ask your Confluence admin to have a read through Confluence Mobile - Considerations for administrators, so they can make sure you’re able to connect.

Which app do I need?

**Confluence Data Center and Server app** - If you’re using Confluence 6.8 or later, download the Confluence Data Center and Server app from Play Store or App Store.

**Confluence Cloud app** - If you’re using Confluence Cloud (your Confluence version number is 1000 or higher) head over to our Cloud documentation to find out about the Confluence Cloud app for iOS and Android.

Confluence Data Center and Server for Android

Here’s what you’ll get, and what you can do in the app:

- **Create and edit pages**
  Create a quick page when you’re on site with a customer, or fix that typo on an existing page before anyone notices. Create and edit lets you do the important stuff, wherever you are.

- **Notifications when you need them most**
  Get push notifications for mentions, comment replies, page shares, and tasks assigned to you, so you can act quickly when it really matters.

- **Collaborate on the go**
  Comment on pages to keep work moving, wherever you are. Like pages to show your support, and share them via email and other apps.

- **Get back to your work, fast**
  The Recents tab lets you quickly find pages you’ve viewed recently. Find those meeting notes you added yesterday, or the blog post you were reading earlier.

- **Visit any space, and browse using the page tree**
  The Spaces tab lets you visit your My Spaces, and any other space on your site. Pick a space and browse using the familiar Confluence page tree.

Have ideas on how to make the app even more useful? We want your feedback! Shake your phone (or head to Settings > Feedback) to drop us a note.
Limitations and known issues

- Some page macros won’t display in the app or mobile web. You’ll need to view the page in your browser (or switch to full desktop mode on your device).
- Image and file upload is not currently available in the app.
- Links to Confluence pages (from emails or other apps) don't automatically open in the app.
- Admins can disable push notifications for your entire site.
- We introduced a new editor in Android 0.11. If you have a problem editing a particular page tap the ellipsis (...) to temporarily switch to the legacy editor. This change doesn’t apply to the iOS app.

Confluence Data Center/Server for iOS

Confluence Data Center and Server for iOS is a universal app for iPhone and iPad, so you can choose the best device for the job. If you'd rather not create and edit pages on your iPhone, switch over to your iPad and take advantage of the larger screen and keyboard. You can also use split view on iPad and work side by side with other apps.

Here’s what you’ll get, and what you can do in the app:

- **Create and edit pages**
  Create a quick page when you’re on site with a customer, or fix that typo on an existing page before anyone notices. Create and edit lets you do the important stuff, wherever you are.

- **Notifications when you need them most**
  Keep up with what your team is doing with push notifications for new pages and posts, comments, mentions, page shares, likes, and tasks assigned to you.

- **Get back to your work, fast**
  The Your work tab serves up pages you’ve viewed or worked on recently. Find those meeting notes you added yesterday, or the blog post you were reading earlier.

- **Visit any space, and browse using the page tree**
  The Spaces tab lets you visit your My Spaces, and any other space on your site. Pick a space and browse using the familiar Confluence page tree. While you’re in the spaces list, you can add spaces to My Spaces or remove the ones that aren’t important any more.

- **Stay connected to your team**
  The activity feed lets you see all activity on your site, or filter it by space. Like and comment on pages, or share a link to any page, right from the app.

Have ideas on how to make the app even more useful? We want your feedback! Shake your phone (or head to Settings > Feedback) to drop us a note.
Limitations and known issues

- Some page macros won’t display in the app or mobile web. You’ll need to view the page in your browser (or switch to full desktop mode on your device).
- Image and file upload is not currently available in the app.
- Links to Confluence pages (from emails or other apps) don’t automatically open in the app.
- Admins can disable push notifications for your entire site.

Did you participate in our beta?

First of all, thank you! ❤️ Your feedback was invaluable to us. To keep using the app, however, you’ll need to:

- **Upgrade your site** to Confluence 6.8 or later, and
- **Update your app** to version 1.x or later:
  - For Android, head to the Play Store and hit Update.
  - For iOS, head to the App Store to download the official app.

If you update your app without upgrading Confluence, the app will still work for a while, but you won’t get access to new features, like push notifications. Also, once you log out, you won’t be able to log back in, as the app checks that you have the required Confluence version.

Customizing push notifications

Push notifications are a great way to stay in the loop, as they appear on your device, even when you’re not using the app. Tap the notification, and be taken straight into the app.

<table>
<thead>
<tr>
<th>Push notification setting</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Confluence logo" /></td>
<td><img src="image" alt="Push notification" /></td>
</tr>
</tbody>
</table>

There are three notification levels, 'All activity', 'Activity for me', and 'None'. iOS users also have an additional 'Custom' option, where they can turn off individual notifications.

To change your push notification settings:

- For Android tap 📱 > Settings > Push
- For iOS tap 📱 > Settings > Push

Here’s a summary of common Confluence actions, and whether a push notification is sent.
<table>
<thead>
<tr>
<th>Event</th>
<th>iOS</th>
<th>Android</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Someone comments on a page / blog post you're watching</td>
<td>✓</td>
<td>✔️</td>
<td>❌</td>
</tr>
<tr>
<td>Someone comments on a page / blog post you created</td>
<td>✓</td>
<td>✔️</td>
<td>❌</td>
</tr>
<tr>
<td>Someone replies to your comment</td>
<td>✓</td>
<td>✔️</td>
<td>❌</td>
</tr>
<tr>
<td>Someone likes a page / blog post you created</td>
<td>✓</td>
<td>✔️</td>
<td>❌</td>
</tr>
<tr>
<td>Someone likes your comment or your reply</td>
<td>✓</td>
<td>✔️</td>
<td>❌</td>
</tr>
<tr>
<td>Someone likes a page / blog post you're watching</td>
<td>❌</td>
<td>✔️</td>
<td>❌</td>
</tr>
<tr>
<td>Someone invites you to edit a page / blog post</td>
<td>❌</td>
<td>✔️</td>
<td>❌</td>
</tr>
<tr>
<td>Someone edits a page / blog post / comment</td>
<td>❌</td>
<td>✔️</td>
<td>❌</td>
</tr>
</tbody>
</table>

If you're using the iOS app, choose 'Custom' to further tailor your notifications, and turn off any of the following notifications individually:

- Shares
- Mentions
- Tasks
- Comments on pages / blog posts you created
- Likes on pages / blog posts / comments you created
- Comments on pages / blog posts you're watching.

**Good to know**

- If your site isn't accessible on the public internet (for example you need to be connected to your office wifi, or use a VPN to access it from home) we adapt the push notification message, so that you get a shorter version when you're not connected to your network.

- Your admin can disable push notifications for the entire site. If this is the case, you'll see a message when you go to the Push settings screen in the app.
- On iOS, when you first install the app, you'll be prompted to allow the app to send notifications to your device. We recommend you choose **Allow**, as you can very easily mute the notifications in the app later. If you do choose **Don't allow**, and change your mind, you'll need to go to **Settings > Notifications > Confluence** then make sure **Allow notifications** is enabled.
Using Confluence via your mobile browser

When you access Confluence using the browser on a mobile device, you'll see a version of Confluence which is optimized for mobile viewing. Confluence chooses the mobile or desktop interface based on your device, but you can still switch to the desktop site on your mobile by choosing menu then choosing Switch to desktop version.

You can also swap from the desktop view to the mobile view if you’re on a mobile device, by choosing Switch to Confluence Mobile at the top of the page.

On your supported mobile device, you can:

- View the Confluence dashboard, pages, blog posts, and user profiles.
- Add or reply to a comment on a page or blog post.
- Like a page, blog post or comment.
- Watch a page or blog post.
- See your notifications and tasks.

You can’t add or edit pages or blog posts, or edit existing comments, using the mobile interface.

The dashboard – the first thing you see

Choose a tab to see:

- Popular content – what people like in your wiki.
- Recent blogs – the latest blog posts.
- Network – updates by people in your network.

Tap the links to view the full content of a page, blog post or comment.
Searching for content and people

Tap the menu icon to open the menu panel on the left of the page. Then type text or a person’s name in the Search box. The mobile interface offers the quick search, which returns matches on page title only. To use advanced search, switch to desktop mode.

Viewing pages, blog posts and comments

Tap a link on the dashboard or on any other page. Confluence will display the linked page, blog post or comment.

You can:

- View the content, tap a link to move to another page, and interact with the page using the standard functionality supported by mobile browsers.
- Like or unlike a page, blog post or comment.
- Watch or stop watching a page or blog post.
- Add or reply to a comment.

Viewing people's profiles

Search for a person’s name, then view that person’s user profile. Tap the options to phone, SMS or email a colleague directly from your mobile device.

Following up on notifications

You can view and respond to your notifications on your phone or other mobile device. Tap the menu icon to open the menu panel on the left of the page. Choose Notifications, and tap a notification to see its details. You can reply, watch or like via the inline actions. Tap Open to open the page or blog post in a new page. For full details, see Workbox Notifications.
Viewing tasks

You can view and manage your tasks on your phone or other mobile device too. Tap the menu icon to open the menu panel on the left of the page. Choose Tasks then tap a task to see its details.
Mobile Device Management (MDM)

You can distribute the Confluence Data Center and Server app to people in your organisation using your MDM solution. This allows you to:

- Deploy the Confluence Data Center and Server app to company-approved iOS and Android devices.
- Apply security policies to require Face ID, Touch ID, or passcode to unlock the app, or prevent users from copying, pasting or sharing text. Requires Confluence Data Center and Server iOS app version 1.25.0 or later.
- Pre-populate your Confluence site URLs (just the URL, we don’t pass login credentials). People will still be able to enter a URL, which is useful if you have some rarely used sites, and don’t want to pre-populate them all. Requires Confluence Data Center and Server iOS app version 1.8.0 / Android app version 0.4.3 or later.

<table>
<thead>
<tr>
<th>MDM Function</th>
<th>Supported for Confluence Data Center and Server app</th>
</tr>
</thead>
<tbody>
<tr>
<td>App deployment</td>
<td>Yes</td>
</tr>
<tr>
<td>App configuration</td>
<td>Yes - to pre-populate the site URL only</td>
</tr>
<tr>
<td>App tunnel</td>
<td>Yes</td>
</tr>
<tr>
<td>Single sign-on (SSO)</td>
<td>No</td>
</tr>
<tr>
<td>Security policies &amp; access control</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Read more about AppConfig and what we currently support in our AppConfig Technical Capabilities white paper.

Using the Confluence Cloud app? Learn how to configure MDM for cloud apps

Distribute the app to managed devices

The way you do this will depend on your particular MDM provider. In most cases you will:

- Add the app to your MDM app catalog.
  - For iOS you will likely bulk purchase through the Apple VPP store, then link the app in your MDM solution (this might be by providing an sToken, or could happen automatically)
- Choose which devices should be able to install the app (this might be called something like distributing or assigning the app).

Refer to the documentation for your MDM provider for more information.

Apply security policies (iOS only)

The keys below are only applicable to iOS because Android supports security policies by MDM providers out of the box.

Use security policies to control things like copy / paste, sharing text, and unlocking the app. Requires Confluence Data Center and Server iOS app version 1.25.0 or later.

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prevent cut, copy, and paste</td>
<td></td>
</tr>
</tbody>
</table>
### cut, copying, and pasting data from the app to other apps. Set this value to 0 to allow clipboard use.

**Note:** Users will be able to copy and paste between Jira and Confluence Data Center or Cloud apps if those apps also set this value to 1.

### Prevent sharing text to other devices

<table>
<thead>
<tr>
<th><code>devicePolicyDataExportRestricted</code></th>
<th>Value type: Boolean (true/false)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description:</td>
<td>Set this value to true to prevent text from being shared to other devices via the iOS share sheet.</td>
</tr>
</tbody>
</table>

### Require Face ID, Touch ID, or password to unlock the app

<table>
<thead>
<tr>
<th><code>localAuthRequired</code></th>
<th>Value type: Boolean (true/false)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description:</td>
<td>Set this value to true to require users to unlock the app using Touch ID, Face ID, or a passcode.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><code>localAuthTimeout</code></th>
<th>Value type: Integer (number greater than zero)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description:</td>
<td>Enter a number in seconds (for example 100) to define the time that the app can be open but not in use (in the background), before a passcode is required again. If you don’t set a value, the default timeout is 120 seconds.</td>
</tr>
</tbody>
</table>

### Pre-populate site URLs on the login screen

If your MDM solution supports the AppConfig standard, you can save your users time and prevent mistakes by pre-populating your site URL in the app.

To pre-populate the mobile app login screen with one site URL:

1. In your MDM, navigate to the App Config section. Check the documentation for your MDM for how to do this.
2. Add a new key called "sites"
3. In the Value field for the key, enter your site title and URL in JSON format as shown in the examples below. Replace the title and base URL with your own site details.

   For a single URL:

   ```json
   [
     { "title": "My Confluence Site", "baseURL": "https://conf.example.com" }
   ]
   ```

   For multiple URLs:

   ```json
   [
     { "title": "My Docs Site", "baseURL": "https://docs.example.com" },
     { "title": "Intranet", "baseURL": "https://team.example.com/confluence", "skipInfo": false }
   ]
   ```

   Copy the JSON carefully, including the [ and ].

4. Save your changes. We recommend you access the Confluence Data Center and Server app on a device to check you have passed the URLs correctly, before distributing the app config changes to your users. You’ll see an error if the app can’t display your list of sites.

### Parameters
The following parameters are accepted for the `sites` key in app config.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>Yes</td>
<td>Descriptive name of your Confluence instance. This will appear above the URL on the app login screen.</td>
</tr>
<tr>
<td>baseURL</td>
<td>Yes</td>
<td>The base URL of your Confluence site. To check it, go to Administration &gt; General Configuration.</td>
</tr>
<tr>
<td>skipInfo</td>
<td>No</td>
<td>Use this parameter if you have log in problems in because your proxy server blocks any unauthenticated requests. When set to <code>true</code>, the mobile app won’t make login/server-info calls that require authorization and instead will redirect your users to your single sign-on page. In general, the Confluence Mobile plugin is a prerequisite for using the mobile app. However, if the <code>skipInfo</code> parameter is set to <code>true</code>, and the plugin is disabled, your users will see a desktop version of Confluence and be able to log into it, which is not the correct behavior, but might not look like an obvious error. (Requires iOS app 1.14.0 / Android app 0.6.2)</td>
</tr>
</tbody>
</table>

Here's an example of how the AppConfig looks in AirWatch and MobileIron, two popular MDMs. These screenshots are for the Jira Data Center and Server app, but the process is the same for Confluence.
Macros

Macros are how you supercharge your Confluence pages.

You can use macros to:

- change the format and layout of your page
- display media like video, audio, and social media content
- collate and organise Confluence pages, blogs, and files
- perform actions from a page, such as creating a page from a template.

Take your Confluence space to the next level using macros.

Screenshot: Page containing Status, Page Properties Report, Livesearch, and Profile Picture macros to help people find information about particular projects.

Macro basics

Add a macro to your page

To add a macro to your page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Select a macro from the list.
3. Enter any required parameters.
4. Choose Insert.

In the editor you’ll see a placeholder that represents the macro. Once you publish your page, you’ll see the macro in its full glory.

Edit a macro

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:
1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Head to the documentation for specific macros below for full details of the parameters available in each macro.

### Confluence macros

Here’s a list of macros currently available with Confluence Data Center.

Click a macro name for details of the usage, including optional parameters and examples.

- Advanced Roadmaps Macro
- Anchor Macro
- Attachments Macro
- Blog Posts Macro
- Change History Macro
- Chart Macro
- Cheese Macro
- Children Display Macro
- Code Block Macro
- Column Macro
- Content by Label Macro
- Content by User Macro
- Content Report Table Macro
- Contributors Macro
- Contributors Summary Macro
- Create from Template Macro
- Create Space Button Macro
- Excerpt Include Macro
- Excerpt Macro
- Expand Macro
- Favorite Pages Macro
- Gallery Macro
- Global Reports Macro
- HTML Include Macro
- HTML Macro
- IM Presence Macro
- Include Page Macro
- Info, Tip, Note, and Warning Macros
- Jira Chart Macro
- Jira Issues Macro
- Labels List Macro
- Livesearch Macro
- Loremipsum Macro
- Multimedia Macro
- Navigation Map Macro
- Network Macro
- Noformat Macro
- Office Excel Macro
- Office PowerPoint Macro
- Office Word Macro
- Page Index Macro
- Page Properties Macro
- Page Properties Report Macro
- Page Tree Macro
- Page Tree Search Macro
- Panel Macro
- PDF Macro
- Popular Labels Macro
Confluence 8.6 Documentation

- Profile Picture Macro
- Recently Updated Dashboard Macro
- Recently Updated Macro
- Recently Used Labels Macro
- Related Labels Macro
- Roadmap Planner Macro
- RSS Feed Macro
- Search Results Macro
- Section Macro
- Space Attachments Macro
- Space Details Macro
- Spaces List Macro
- Status Macro
- Table of Contents Macro
- Table of Content Zone Macro
- Task Report Macro
- Team Calendar Macro
- User List Macro
- User Profile Macro
- View File Macro
- Widget Connector Macro

Get more macros

This documentation provides information on all the macros that are provided with Confluence by default. There may be other macros in your site, from Marketplace Apps, or perhaps developed in-house.

Third-party macros from the Atlassian Marketplace

You can find a wide range of Atlassian and third party macros at The Marketplace. These are distributed as apps and can be installed by a Confluence Administrator.

Create your own macros

Users with System Administrator permissions can create user macros - see Writing User Macros.

If you want to create something more complex, you can develop your own plugin - see Writing Confluence Plugins.

Macro usage statistics

Confluence administrators can check how often each macro is used in your site.

To see how often a macro is used, go to Administration > General Configuration > Macro Usage. This lists how often each macro is used in current spaces but doesn’t include any macros used on pages in archived spaces or macros provided by disabled apps.

Unknown macro

In view page mode, disabled macros show a placeholder image:

Unknown macro: ‘expand’

When macros with body content are disabled, the content will be preserved and display in the editor.

To display the content in view mode:

1. In the editor, select the macro and choose Edit.
2. In the macro browser, select Back.
3. Search for a new macro and select it.
4. Check your content displays in the Preview pane.
5. Select **Insert**.

In the editor, the disabled macro will switch to the new macro and display your content. Update the page to display the content in view mode.

---

**Do more with Confluence**

Extend Confluence with one of the hundreds of other macros in the Atlassian Marketplace, such as:

- **Composition Tabs & Page Layouts**: Toggle or expand the visible portions of your pages with the Toggle and Cloak macro
- **Content Formatting for Confluence**: Over 30 easy-to-use Confluence macros gives you the ability to create better, more engaging content
Advanced Roadmaps Macro

Add the Advanced Roadmaps for Jira in Confluence macro to a page to share your team's plans and progress with stakeholders.

This is great for:

- reports and retrospectives
- project status updates
- sharing updates with people in your organization who don't use Jira regularly.

The macro can display issues from any connected Jira Server, Data Center, or Cloud application, including Jira Software and Jira Service Management.

Screenshot: An Advanced Roadmaps plan on Jira displayed on a Confluence page.

Connect Confluence and Jira

Before you can use this macro, your Confluence and Jira application must be connected via Application Links. People viewing the page will see the publicly accessible issues from the Jira site. If your Jira site has restricted viewing (that is, people need permission to view issues) then they will need to authenticate before seeing the restricted issues.

See Use Jira applications and Confluence together for more information.
Macro basics

Learn how to add this macro to your page
Anchor Macro

Add the Anchor macro to a page to link to a specific part of a page.

This is useful on long pages, where you want to link to specific parts of the page.

Don’t see the Anchor macro? This macro isn’t available in the new Confluence Cloud editor. See We’re cleaning up our macros for alternative ways to link.

The example below shows an example of an Anchor macro as it appears in the editor, and as it would appear to someone viewing the page.

1. Anchor macro as it appears in the editor
2. Anchor macro as it appears when viewing a page (it isn’t visible).

Add the anchor macro to your page

To add the Anchor macro to a page:

1. From the editor toolbar, choose Insert + > Other Macros.
2. Choose Anchor from the Confluence content category.
3. Enter the anchor name - this will form part of your link.
4. Choose Insert.

You can then add a link to your macro from this page or another page.

Linking to an anchor

To link to an anchor on the same page:

1. Click the Insert Link icon.
2. Choose the Advanced tab.
3. Enter # followed by your anchor name in the Link field. For example #top.
4. Choose Insert.

You can also link to an anchor on another page. See Anchors for more information on the different link syntax you can use.

Animation: Adding the Anchor macro to a page, then linking to that macro.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anchor Name</td>
<td>None</td>
<td>This is the anchor name that you will use when creating the link.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• The anchor name can include spaces. Confluence will remove the spaces</td>
</tr>
<tr>
<td></td>
<td></td>
<td>automatically when building a URL that points to this anchor.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• The anchor name is case sensitive. You must use the same pattern of upper</td>
</tr>
<tr>
<td></td>
<td></td>
<td>and lower case letters when creating the link as you used when creating the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anchor macro.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** anchor

**Macro body:** None.

```
{anchor:here}
```
Attachments Macro

This macro is available in Confluence Data Center and Confluence Cloud. Learn about the macros available in Confluence Cloud.

Add an Attachments macro to your page to display a list of files attached to your current page, or another page in your site.

This macro is great for providing quick access to:

- project files
- forms and downloadable templates
- images and diagrams.

Because you can display files attached to any page, you can use this macro to avoid duplication if you need to provide quick access to the same file on multiple pages.

On this page:
- Add this macro to your page
- Change the macro parameters
- Edit a file displayed by this macro
- Other ways to add this macro

Related pages:
- Display Files and Images

Screenshot: The Attachments macro, showing details of an attachment.

Once added to a page, people with appropriate space permissions can:

- view a list of attached files
- upload a file to the page, directly from the list
- edit attachment properties and labels
- delete an attached file (this deletes all versions of the file)
- preview image files
- download all files attached to the page as a zip file.

For general information about working with files in Confluence, see Files.

Add this macro to your page
To add the Attachments macro to a page:

1. From the editor toolbar, choose **Insert** > **Other Macros**.
2. Choose **Attachments** from the **Confluence content** category.
3. Set any parameters. These are all optional.
4. Choose **Insert**.

You can then publish your page to see the macro in action.

Screenshot: Entering parameters and changing the sort order in the Blog Posts macro.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.
2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Filename Patterns**| **all** | A comma-separated list of regular expressions, used to filter the attachments by file name. Note that the parameter values must be regular expressions. For example:
- To match a file suffix of 'jpg', use `.*jpg` (not `*.jpg`).
- To match file names ending in 'jpg' or 'png', use `.*jpg,.*png` |
| **Attachment Labels**| **none**| A list of labels, used to filter the attachments to display. If you wish to enter more than one label, separate the labels with commas. Confluence will show only attachments that have **all** the labels specified. (The match is an AND, not an OR.) For information on labelling the attachments, see Add, Remove and Search for Labels. |
Include Old Attachment Versions (old)

- false: A value of true will include previous attachment versions in the list.

Sort By (sortBy)

- date: The sort order for attachments. Note that people viewing the page can change the sort order by clicking the column headings. Valid values are:
  - date – sorts by updated date in reverse chronological order (newest first)
  - size – sorts largest to smallest
  - name – sorts alphabetically
  - created date - sorts by creation date in reverse chronological order (newest first)

Sort Order (sortOrder)

- ascending: Used in combination with the Sort By parameter, to sort the attachments in ascending or descending order.

Allow Upload (upload)

- true: If selected, the list of attachments will include options allowing users to browse for, and attach, new files.

Page Title (page)

- (none): Used to display attachments from another page. If you do not enter a page title, the macro will display the files attached to the current page.

Show Previews (preview)

- true: Used to display a preview of the attached file. If true, preview will be visible when the list item is expanded.

  It can be useful to disable previews if you have very large attachments.

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Edit a file displayed by this macro

There are a few ways to edit attachments in Confluence.

To edit a file from the attachments macro list:

1. Click the arrow next to the file name to view its version history.
2. Click Edit.
3. Atlassian Companion will open the file in your desktop application.
4. Make your changes and then save your file. When you’re ready, click Upload in Companion to send the file back to Confluence.

Learn more about editing files in Confluence.

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** attachments

**Macro body:** None.

```
{attachments:old=false|patterns=.*png,.*jpg|sortby=name|page=My page about chocolate|sortorder=descending|labels=chocolate,cookies|upload=false|preview=false}
```
Blog Posts Macro

This macro is available in Confluence Data Center and Confluence Cloud. Learn about the macros available in Confluence Cloud.

Add the Blog Posts macro to a page to display a curated list of blog posts. You can choose to show the just the title, an excerpt from the blog, or the entire contents of each blog post.

This macro is great when you want to present a curated list of blogs for:

- company announcements
- new team member introductions
- point-in-time project updates
- change management communications.

Because you can display blog posts from any space, with any label or author, you can display the same blogs on multiple pages. This reduces duplication and helps people in your team find information when they need it.

Screenshot: The Blog Posts macro, configured to show an excerpt of each blog post.

For general information about blogging in Confluence, see Blog Posts.

Add the Blog Posts macro to your page

To add the Blog Posts macro to a page:

1. From the editor toolbar, choose Insert + > Other Macros.
2. Choose Blog Posts from the Confluence content category.
3. Use the parameters below to determine how you want the blog posts to display, and to narrow your query by time frame, space, author, or label.

4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Entering display type, time frame, and label parameters in the Blog Posts macro.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Content Type to Display</td>
<td>No</td>
<td>titles</td>
<td>Available values:</td>
</tr>
<tr>
<td>(content)</td>
<td></td>
<td></td>
<td>• titles — Display the title, creator, space, and created date stamp for each blog post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• excerpts — Display a short excerpt from each blog post. If the post contains an Excerpt macro, the Blog Posts macro will display the content defined in the Excerpt macro. If the post does not contain an Excerpt macro, the Blog Posts macro will display the first few sentences of the post.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• entire  — Display the whole content of each blog post.</td>
</tr>
<tr>
<td>Time Frame</td>
<td>No</td>
<td>no limit</td>
<td>Specify how far back in time Confluence should look for the blog posts to be displayed.</td>
</tr>
<tr>
<td>(time)</td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• m — Minutes</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• h — Hours, so '12h' displays blog posts created in the last twelve hours.</td>
</tr>
</tbody>
</table>
### Restrict to these Labels

<table>
<thead>
<tr>
<th>Label</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>None</td>
<td>Filter the results by label. The macro will display only the blog posts which are tagged with the label(s) you specify here. You can specify one or more label values, separated by a comma or a space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Restrict to these Authors</strong> (author)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Author</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>None</td>
<td>Filter the results by author. The macro will display only the blog posts which are written by the author(s) you specify here.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Spaces</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>@self, i.e. the space which contains the page on which the macro is coded</td>
<td>This parameter allows you to filter content by space. The macro will display only the pages which belong to the space(s) you specify here. You can specify one or more space keys, separated by a comma or a space.</td>
</tr>
</tbody>
</table>

#### Special values:

- **@self** — The current space.
- **@personal** — All personal spaces.
- **@global** — All site spaces.
- **@favorite** — The spaces you have marked as favorite.
- **@favourite** — The same as @favorite above.
- **@all** — All spaces in your Confluence site.
- **@favourite** — The same as @all above.

When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.

<table>
<thead>
<tr>
<th>Max Results</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>15</td>
<td>Specify the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied.</td>
</tr>
</tbody>
</table>

- d — Days, so '7d' displays blog posts created in the last seven days.
- w — Weeks
Maximum Number of Blog Posts (max)

<table>
<thead>
<tr>
<th>Sort By (sort)</th>
<th>values</th>
<th>Reverse Sort (reverse)</th>
<th>values</th>
</tr>
</thead>
<tbody>
<tr>
<td>No creation</td>
<td>Specify how the results should be sorted. If this parameter is not specified, the sort order defaults to descending order (newest first) based on the creation date. Values:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>title — Sort alphabetically by title.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>creation — Sort by the date on which the content was added.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>modified — Sort by the date on which the content was last updated.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>No false</td>
<td>Select to change the sort from descending to ascending order (oldest first). Use this parameter in conjunction with the Sort By parameter. This parameter is ignored if the Sort By parameter is not specified.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>In storage format and wikimarkup a value of true changes the sort order.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

Macro name: blog-posts

Macro body: None.

```
{blog-posts:content=titles|spaces=@self,ds|author=jsmith|time=4w|reverse=true|sort=creation|max=10|label=chocolate,cookies}
```
Change History Macro

This macro is available in Confluence Data Center and Confluence Cloud. Learn about the macros available in Confluence Cloud.

Add the Change History macro to a page to display a table of recent updates to that page including version number, author, date and version comment.

This macro is great for:

- document control
- change management
- wiki gardening and keeping your pages fresh.

Screenshot: The Change History macro in Confluence showing two history versions.

Add the Change History macro to your page

To add the Change History macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Change History from the Confluence content category.
3. Choose the number of page versions to display.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: configuring the Change History macro in the macro browser.

For general information about version control in Confluence, see Page History and Page Comparison Views.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of versions to display</td>
<td>No</td>
<td>blank</td>
<td>Limit the amount of page history to display. Leave blank to display all versions in the page history.</td>
</tr>
</tbody>
</table>

Other ways to add this macro

Add this macro as you type

Type `{{` followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

Macro name: change-history

Macro body: None.
Chart Macro

This macro is available in Confluence Data Center and Confluence Cloud. Learn about the macros available in Confluence Cloud.

Add the Chart macro to a page to display a chart based on data in a table on the same page, or from an attached file.

This is great for showing a simple visualisation of data on the page.

On this page:
- Add the Chart macro to your page
- Change the macro parameters
- Pie chart
- Bar chart
- 3D Bar chart
- Time series chart
- XY Line Chart
- XY Area Chart
- Area chart
- Stacked area chart
- Gantt chart
- Other ways to add this macro
  - Add this macro as you type
  - Add this macro using wiki markup
  - Chart type parameters
  - Chart display parameters
  - Chart title and label parameters
  - Chart data parameters
  - Chart color parameters
  - Chart axis parameters
  - Pie chart Parameters
  - Chart attachment parameters

Screenshot: Page with two chart macros.

Add the Chart macro to your page

To add the Chart macro to a page:

1. From the editor toolbar, choose Insert + > Other Macros.
2. Choose Chart from the Visuals and images category.
3. Choose Insert.

Want to display information from Jira on your page? Check out the Jira Chart Macro.
4. Enter your chart data as one or more tables in the body of the macro placeholder. See the examples later in this page for more info.
5. Click the macro placeholder and choose **Edit**.
6. Select a chart type using the **Type** parameter (see below).
7. Choose other parameter settings in the macro browser, as described below.
8. Click **Refresh** in the 'Preview' area, to check that the chart appears as you expect.
9. Click **Save** to add the chart to your page.

You can then publish your page to see the macro in action.

**Screenshot: Two Chart macros in the editor, containing the data for a pie chart and stacked chart.**

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Chart Type Parameters</th>
<th>Display Control Parameters</th>
<th>Title and Label Parameters</th>
<th>Data Specification Parameters</th>
<th>Color Parameters</th>
<th>Axis Parameters</th>
<th>Pie Chart Parameters</th>
<th>Attachment Parameters</th>
</tr>
</thead>
</table>

**Chart Type Parameters**

These parameters determine the type of chart to display and the way the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>pie</td>
<td>The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based (see the <strong>Time Series</strong> parameter).</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Standard</strong> — pie, bar, line, area</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>XY Plots</strong> — xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Other</strong> — gantt</td>
</tr>
<tr>
<td>Display Orientation</td>
<td>vertical</td>
<td>Applies to area, bar and line charts.</td>
</tr>
<tr>
<td>---------------------</td>
<td>----------</td>
<td>---------------------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>📌 <strong>vertical</strong> — y-axis is vertical</td>
</tr>
<tr>
<td></td>
<td></td>
<td>📌 <strong>horizontal</strong> — x-axis is vertical</td>
</tr>
<tr>
<td>Show in 3D</td>
<td>false</td>
<td>Applies to area, bar and line charts.</td>
</tr>
<tr>
<td>Stacked Values</td>
<td>false</td>
<td>Applies to area and bar charts.</td>
</tr>
<tr>
<td>Show shapes</td>
<td>true</td>
<td>Applies to line charts. Shapes are shown at each data point.</td>
</tr>
<tr>
<td>Opacity</td>
<td></td>
<td>A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>📌 75 percent for 3D charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>📌 50 percent for non-stacked area charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>📌 100 percent for all other charts</td>
</tr>
</tbody>
</table>

**Display Control Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>300</td>
<td>The width of the chart in pixels. The maximum width is limited by the <code>confluence.chart.macro.width.max</code> system property.</td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
<td>The height of the chart in pixels. The maximum height is limited by the <code>confluence.chart.macro.height.max</code> system property.</td>
</tr>
<tr>
<td>Display rendered data</td>
<td>false</td>
<td>Sets whether to display the rendered body of the macro (usually the data tables). By default, the chart data table isn't rendered.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>📌 <strong>before</strong> — the data are displayed before the chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>📌 <strong>after</strong> — the data are displayed after the chart.</td>
</tr>
<tr>
<td>Image format</td>
<td>png</td>
<td>The image format to be used for the chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>📌 png</td>
</tr>
<tr>
<td></td>
<td></td>
<td>📌 jpg</td>
</tr>
</tbody>
</table>

**Title and Label Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Title</td>
<td>none</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>Chart Subtitle</td>
<td>none</td>
<td>A subtitle for the chart, using a smaller font than for <strong>Title</strong>.</td>
</tr>
<tr>
<td>Horizontal-axis Label</td>
<td>none</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>Vertical-axis Label</td>
<td>none</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Show a legend or key.</td>
</tr>
</tbody>
</table>
Data Specification Parameters

The data for the chart is taken from tables found when the macro body is rendered. These options control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. Additional conversion options can be specified using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>all first level tables</td>
<td>Comma separated list of table ids and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>Columns</td>
<td>all columns</td>
<td>Comma separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the (html) title attribute for the column in the header row.</td>
</tr>
</tbody>
</table>
| Content Orientation | horizontal    | ○ **vertical** — data table columns will be interpreted as series.  
○ **horizontal** — data tables rows will be interpreted as series. |
| Time Series     | false            | ○ true — the x values in an XY plot will be treated as time series data and so will be converted according to date formats. |
| Date format     | Confluence language defined date formats | For time series data, the date format allows for additional customization of the conversion of data to date values. If a **Date format** is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format. |
| Time Period     | Day              | The time period for time series data. Defines the granularity of how the data is interpreted. Valid values are: **Millisecond, Second, Minute, Hour, Day, Week, Month, Quarter, Year.** |
| Language        | none             | Use in combination with the **Country** parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages. Valid values are 2 character **ISO 639-1 alpha-2 codes**. |
| Country         | none             | Use in combination with the **Language** parameter to form a locale. Valid values are 2 character **ISO 3166 codes**. |
| Forgive         | true             | ○ true — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.  
○ false — enforce strict data format. Data format errors will cause the chart to not be produced. |

Color Parameters

Colors are specified using hexadecimal notation or HTML color names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
### Background Color

| Background Color | White | Background of the chart. |

### Border Color

| Border Color | no border | Border around the chart. |

### Colors

| Colors | Comma-separated list of colors used to customize category, sections, and series colors. |

### Axis Parameters

Depending on the chart type, the range and domain axis may be customized. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range Minimum Value</td>
<td>none</td>
<td>Range axis lower bound.</td>
</tr>
<tr>
<td>Range Maximum Value</td>
<td>none</td>
<td>Range axis upper bound.</td>
</tr>
<tr>
<td>Range Axis Tick Unit</td>
<td>none</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>Range Axis Label Angle</td>
<td>none</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>Domain Axis Lower Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the Date format parameter.</td>
</tr>
<tr>
<td>Domain Axis Upper Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the Date format parameter.</td>
</tr>
<tr>
<td>Domain Axis Tick Unit</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the Time Period parameter. The Time Period unit can be overridden by specifying a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).</td>
</tr>
<tr>
<td>Domain Axis Label Angle</td>
<td>none</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
</tr>
<tr>
<td>Category Label Position</td>
<td>none</td>
<td>Placement of the axis label text for categories.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- up45 — 45 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- up90 — 90 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- down45 — 45 degrees going downward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- down90 — 90 degrees going downward</td>
</tr>
</tbody>
</table>
Date Tick Mark Position

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Date Tick Mark Position start | | Placement of the date tick mark.  
  ○ start — tick mark is at the start of the date period.  
  ○ middle — tick mark is in the middle of the date period.  
  ○ end — tick mark is at the end of the date period. |

Pie Chart Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Pie Section Label Show only the pie section key value | | Format for how pie section labels are displayed. The format uses a string with special replacement variables:  
  ○ %0% is replaced by the pie section key.  
  ○ %1% is replaced by the pie section numeric value.  
  ○ %2% is replaced by the pie section percent value.  
  Example 1: "%0% = %1%" would display something like "Independent = 20"  
  Example 2: "%0% (%2%)" would display something like "Independent (20%)" |
| Pie Section Explode No exploded sections | | Comma separated list of pie keys that are to be shown exploded.  
  Note: requires JFreeChart version 1.0.3 or higher. |

Attachment Parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved as an attachment and have subsequent access re-use the attachment. This can be useful especially when combined with the Cache Plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Attachment      | none    | The name and location with which the chart image will be saved as an attachment. The user must be authorized to add attachments to the page specified.  
  ○ ^attachmentName.png — the chart is saved as an attachment to the current page.  
  ○ page^attachmentName.png — the chart is saved as an attachment to the page name provided.  
  ○ space:page^attachmentName.png — the chart is saved as an attachment to the page name provided in the space indicated. |
| Attachment Version | new    | Defines the the versioning mechanism for saved charts.  
  ○ new — creates new version of the attachment.  
  ○ replace — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorized to remove attachments for the page specified.  
  ○ keep — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated. |
Here’s an example of a pie chart.

**Fish Sold 2011**

![Pie chart example](image)

Herring (9,500 - 68%)
Salmon (2,900 - 21%)
Tuna (1,500 - 11%)

To create this chart, we set these parameters in the macro browser:

- **Type**: pie
- **Chart title**: Fish sold in 2011
- **Show legend**: true
- **Content orientation**: vertical

and added this table in the macro body:

<table>
<thead>
<tr>
<th>Fish Type</th>
<th>2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Herring</td>
<td>9,500</td>
</tr>
<tr>
<td>Salmon</td>
<td>2,900</td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
</tr>
</tbody>
</table>

Here’s an example of a bar chart.

Bar chart
To create this chart, we set these parameters in the macro browser:

- **Type**: bar
- **Chart title**: Fish sold
- **Show legend**: True

and added this table in the macro body:

<table>
<thead>
<tr>
<th>Fish Type</th>
<th>2010</th>
<th>2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Herring</td>
<td>9,500</td>
<td>8,300</td>
</tr>
<tr>
<td>Salmon</td>
<td>2,900</td>
<td>4,200</td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
<td>1,500</td>
</tr>
</tbody>
</table>

**3D Bar chart**

Here's an example of a 3D bar chart.

To create this chart, we set these parameters in the macro browser:
- **Type**: bar
- **Show in 3D**: true
- **Opacity**: 50
- **Show legend**: true

and added this table in the macro body:

<table>
<thead>
<tr>
<th></th>
<th>2009</th>
<th>2010</th>
<th>2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue</td>
<td>12.4</td>
<td>31.8</td>
<td></td>
</tr>
<tr>
<td>Expense</td>
<td>43.6</td>
<td>41.8</td>
<td></td>
</tr>
</tbody>
</table>

**Time series chart**

Here's an example of a Time series chart.

To create this chart, we set these parameters in the macro browser:

- **Type**: Time series
- **Date format**: MM/yyyy
- **Time period**: Month
- **Content orientation**: vertical
- **Range axis lower bound**: 0
- **Show legend**: true

and added these two tables in the macro body:

<table>
<thead>
<tr>
<th>Month</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2011</td>
<td>31.8</td>
</tr>
<tr>
<td>2/2011</td>
<td>41.8</td>
</tr>
<tr>
<td>3/2011</td>
<td>51.3</td>
</tr>
<tr>
<td>4/2011</td>
<td>33.8</td>
</tr>
<tr>
<td>5/2011</td>
<td>27.6</td>
</tr>
<tr>
<td>Month</td>
<td>Expenses</td>
</tr>
<tr>
<td>--------</td>
<td>----------</td>
</tr>
<tr>
<td>6/2011</td>
<td>49.8</td>
</tr>
<tr>
<td>7/2011</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2011</td>
<td>77.3</td>
</tr>
<tr>
<td>9/2011</td>
<td>73.8</td>
</tr>
<tr>
<td>10/2011</td>
<td>97.6</td>
</tr>
<tr>
<td>11/2011</td>
<td>101.2</td>
</tr>
<tr>
<td>12/2011</td>
<td>113.7</td>
</tr>
</tbody>
</table>

**XY Line Chart**

Here's an example of a XY Line chart.
To create this chart, we set these parameters in the macro browser:

- **Type**: `xyLine`
- **Show legend**: true

and added this table in the macro body:

<table>
<thead>
<tr>
<th></th>
<th>12</th>
<th>14</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue</td>
<td>41.1</td>
<td>31.8</td>
<td>12.4</td>
</tr>
<tr>
<td>Expense</td>
<td>31.1</td>
<td>41.8</td>
<td>43.6</td>
</tr>
</tbody>
</table>

**XY Area Chart**

Here's an example of an XY Area chart.

To create this chart, we set these parameters in the macro browser:

- **Type**: `xyArea`
- **Show legend**: true
and added this table in the macro body:

<table>
<thead>
<tr>
<th></th>
<th>12</th>
<th>14</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue</td>
<td>41.1</td>
<td>31.8</td>
<td>12.4</td>
</tr>
<tr>
<td>Expense</td>
<td>31.1</td>
<td>41.8</td>
<td>43.6</td>
</tr>
</tbody>
</table>

Area chart

Here's an example of an area chart.

To create this chart, we set these parameters in the macro browser:

- **Type**: area
- **Show legend**: true
- **Width**: 300
- **Height**: 300
- **Opacity**: 50

and added this table in the macro body:

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2009</th>
<th>2010</th>
<th>2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

Stacked area chart

Here's another example of an Area chart.
To create this chart, we set these parameters in the macro browser:

- **Type**: area
- **Show legend**: true
- **Width**: 300
- **Height**: 300
- **Stacked values**: true

and added this table in the macro body:

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2009</th>
<th>2010</th>
<th>2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>12</td>
<td>23</td>
<td>31</td>
</tr>
<tr>
<td>Satisfied</td>
<td>1</td>
<td>34</td>
<td>36</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>4</td>
<td>6</td>
<td>22</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>2</td>
<td>7</td>
<td>12</td>
</tr>
</tbody>
</table>

**Gantt chart**

Here’s an example of a Gantt chart.

To create this chart, we set these parameters in the macro browser:

- **Type**: gantt
- **Width**: 300
- **Height**: 200
- **Columns**: ,1,2,3,4 (note the two commas to start)
- **Date format**: MM/dd/yyyy

and added these two tables in the macro body:

<table>
<thead>
<tr>
<th>Plan</th>
<th>Start</th>
<th>End</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stage 1</td>
<td>6/25/2013</td>
<td>7/10/2013</td>
<td>30%</td>
</tr>
<tr>
<td>Stage 2</td>
<td>7/13/2013</td>
<td>11/28/2013</td>
<td>40%</td>
</tr>
<tr>
<td>Stage 3</td>
<td>12/1/2013</td>
<td>12/25/2013</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Actual</th>
<th>Start</th>
<th>End</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stage 1</td>
<td>6/25/2013</td>
<td>7/26/2013</td>
<td>100%</td>
</tr>
<tr>
<td>Stage 2</td>
<td>7/29/2013</td>
<td>12/01/2013</td>
<td>40%</td>
</tr>
<tr>
<td>Stage 3</td>
<td>12/10/2013</td>
<td>12/25/2013</td>
<td></td>
</tr>
</tbody>
</table>

⚠️ You must include the two leading commas in the column parameter (for example ,1,2,3,4) for the chart to be created correctly.

**Other ways to add this macro**

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name**: chart

**Macro body**: Accepts rich text, consisting of tables that hold the chart's data.

Below is a simple example of a pie chart. See more examples in [Wiki Markup Examples for Chart Macro](https://confluenceexample.com).

```
<table>
<thead>
<tr>
<th>Fish Type</th>
<th>2004</th>
<th>2005</th>
</tr>
</thead>
<tbody>
<tr>
<td>Herring</td>
<td>9,500</td>
<td>8,300</td>
</tr>
<tr>
<td>Salmon</td>
<td>2,900</td>
<td>4,200</td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
<td>1,500</td>
</tr>
</tbody>
</table>
```

This macro recognizes a large number of parameters, listed here by type.
### Chart type parameters

These parameters determine the type of chart to display and how the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>type</td>
<td>No</td>
<td>pie</td>
<td>The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based. See the <code>timeSeries</code> parameter.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <strong>Standard charts</strong> – pie, bar, line, area</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <strong>XY plots</strong> – xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <strong>Other charts</strong> – gantt</td>
</tr>
<tr>
<td>orientation</td>
<td>No</td>
<td>vertical</td>
<td>The display orientation. Applies to area, bar and line charts.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <strong>vertical</strong>  – y-axis is vertical</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- <strong>horizontal</strong>  – x-axis is vertical</td>
</tr>
<tr>
<td>3D</td>
<td>No</td>
<td>false</td>
<td>Show in three dimensions. Applies to area, bar and line charts.</td>
</tr>
<tr>
<td>stacked</td>
<td>No</td>
<td>false</td>
<td>Stacked values. Applies to area and bar charts.</td>
</tr>
<tr>
<td>showShapes</td>
<td>No</td>
<td>true</td>
<td>Applies to line charts. Shapes are shown at each data point.</td>
</tr>
<tr>
<td>opacity</td>
<td>No</td>
<td></td>
<td>A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• 75 percent for 3D charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• 50 percent for non-stacked area charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• 100 percent for all other charts</td>
</tr>
</tbody>
</table>

### Chart display parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
<tr>
<td>dataDisplay</td>
<td>No</td>
<td>false</td>
<td>Determines whether to display the body of the macro, consisting of the data table. By default, the chart data table is not displayed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- false  – the data is not displayed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- true or after  – the data is displayed after the chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- before  – the data is displayed before the chart.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>subTitle</td>
<td>No</td>
<td>(None)</td>
<td>A subtitle for the chart.</td>
</tr>
<tr>
<td>xLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>yLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>legend</td>
<td>No</td>
<td>false</td>
<td>Determines whether to show a legend (key) for the chart.</td>
</tr>
</tbody>
</table>

**Chart data parameters**

The data for the chart is taken from tables found in the macro body. The parameters below control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. You can specify additional conversion options using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| tables        | No       | All first level tables | You can supply a comma-separated list of table IDs and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).
| columns       | No       | All columns | You can supply a comma-separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the HTML title attribute for the column in the header row. |
| dataOrientation | No       | horizontal | The content orientation. By default, the data tables will be interpreted as columns (horizontally) representing domain and x values. |
|               |          |          | Available values: |
|               |          |          | • vertical – data table columns will be interpreted as series. |
|               |          |          | • horizontal – data tables rows will be interpreted as series. |
| timeSeries    | No       | false   | If 'true', the x values in an XY plot will be treated as time series data and so will be converted according date formats. |
dateFormat | No | Confluence language defined date formats | For time series data, the date format allows for additional customization of the conversion of data to date values. If a `dateFormat` is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format.

timePeriod | No | day | The time period for time series data. Defines the granularity of how the data is interpreted.

Available values: millisecond, second, minute, hour, day, week, month, quarter, year

language | No | (None) | Use in combination with the `country` parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages.

Available values are the two-character ISO 639-1 alpha-2 codes.

country | No | (None) | Use in combination with the `language` parameter to form a locale. Valid values are the two-character ISO 3166 codes.

forgive | No | true | Determines whether the macro will forgive (allow) some data formatting errors.

Available values:
- `true` — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.
- `false` — the macro enforces strict data formatting. If there are data format errors, the chart will not be produced.

**Chart color parameters**

Colors are specified using hexadecimal notation or HTML color names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>bgColor</td>
<td>No</td>
<td>White</td>
<td>Background color of the chart.</td>
</tr>
<tr>
<td>borderColor</td>
<td>No</td>
<td>No border</td>
<td>Color of the border around the chart.</td>
</tr>
<tr>
<td>colors</td>
<td>No</td>
<td>A comma-separated list of colors used to customize the colors of categories, sections, and series.</td>
<td></td>
</tr>
</tbody>
</table>

**Chart axis parameters**

Depending on the chart type, the range and domain axis may be customized. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rangeAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Minimum value for the range axis.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>----------</td>
<td>----------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>rangeAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Maximum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>rangeAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>domainAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the dateFormat parameter.</td>
</tr>
<tr>
<td>domainAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the dateFormat parameter.</td>
</tr>
<tr>
<td>domainAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the timePeriod parameter. The timePeriod unit can be overridden by specifying a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).</td>
</tr>
<tr>
<td>domainAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
</tr>
<tr>
<td>categoryLabelPosition</td>
<td>No</td>
<td>(None)</td>
<td>Placement of the axis label text for categories.</td>
</tr>
<tr>
<td>dateTickMarkPosition</td>
<td>No</td>
<td>start</td>
<td>Placement of the date tick mark.</td>
</tr>
</tbody>
</table>

**Pie chart Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
### pieSectionLabel

<table>
<thead>
<tr>
<th>No</th>
<th>Show only the pie section key value</th>
</tr>
</thead>
</table>

Format of pie section labels. The format uses a string with special replacement variables:

- `%0%` is replaced by the pie section key.
- `%1%` is replaced by the pie section numeric value.
- `%2%` is replaced by the pie section percent value.

**Example 1:** To display something like 'Independent = 20':

```
%0% = %1%
```

**Example 2:** To display something like 'Independent (20%)':

```
%0% (%2%)
```

### pieSectionExplode

<table>
<thead>
<tr>
<th>No</th>
<th>No exploded sections</th>
</tr>
</thead>
</table>

A comma-separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher.

---

**Chart attachment parameters**

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved as an attachment and have subsequent access to re-use the attachment. This can be useful especially when combined with the Cache plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>attachment</td>
<td>No</td>
<td>(None)</td>
<td>The name and location where the chart image will be saved as an attachment. The user must be authorized to add attachments to the page specified. Available syntax for this parameter:</td>
</tr>
</tbody>
</table>

- `^attachmentName.png` — the chart is saved as an attachment to the current page.
- `page name^attachmentName.png` — the chart is saved as an attachment to the page name provided.
- `name^attachmentName.png` — the chart is saved as an attachment to the page name provided in the space indicated.

<table>
<thead>
<tr>
<th>attachmen tVersion</th>
<th>No</th>
<th>new</th>
<th>Defines the the versioning mechanism for saved charts. Available values:</th>
</tr>
</thead>
</table>

- `new` — creates new version of the attachment.
- `replace` — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorized to remove attachments for the page specified.
- `keep` — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated.

<table>
<thead>
<tr>
<th>attachmen tComment</th>
<th>No</th>
<th>(None)</th>
<th>Comment used for a saved chart attachment.</th>
</tr>
</thead>
<tbody>
<tr>
<td>thumbnail</td>
<td>No</td>
<td>false</td>
<td>If true, the chart image attachment will be shown as a thumbnail (small, expandable) image.</td>
</tr>
</tbody>
</table>

- **Do more with Confluence**

   Create interesting and engaging charts for your Confluence pages with these top charts and diagrams apps on the Atlassian Marketplace.
Wiki Markup Examples for Chart Macro

This page is an extension of the documentation for the Chart Macro. This page contains additional examples for the Chart macro.

Pie chart

Here is a simple example of a pie chart.

Wiki markup

{chart:type=pie|title=Fish Sold}  
|| Fish Type || 2004 || 2005 ||  
|| Herring || 9,500 || 8,300 ||  
|| Salmon || 2,900 || 4,200 ||  
|| Tuna || 1,500 || 1,500 ||  
{chart}

Resulting chart

[Unknown macro: 'chart']

Bar chart

Here is a simple example of a bar chart.

Wiki markup

{chart:type=bar|title=Fish Sold}  
|| Fish Type || 2004 || 2005 ||  
|| Herring || 9,500 || 8,300 ||  
|| Salmon || 2,900 || 4,200 ||  
|| Tuna || 1,500 || 1,500 ||  
{chart}

Resulting chart

[Unknown macro: 'chart']

Time series chart

Here is an example of a time series chart.

Wiki markup
\begin{table}
\begin{tabular}{|c|c|}
\hline
Month & Revenue \\
\hline
1/2005 & 31.8 \\
2/2005 & 41.8 \\
3/2005 & 51.3 \\
4/2005 & 33.8 \\
5/2005 & 27.6 \\
6/2005 & 49.8 \\
7/2005 & 51.8 \\
8/2005 & 77.3 \\
9/2005 & 73.8 \\
10/2005 & 97.6 \\
11/2005 & 101.2 \\
12/2005 & 113.7 \\
\hline
\end{tabular}
\end{table}

Here is an example of an XY line chart.

\begin{chart}
\{chart:type=xyline\}
\begin{tabular}{|c|c|c|}
\hline
\multicolumn{3}{|c|}{\textbf{2005-2007}} \\
\hline
12 & 14 & 23 \\
\hline
Revenue & 41.1 & 31.8 & 12.4 \\
Expense & 31.1 & 41.8 & 43.6 \\
\hline
\end{tabular}
\end{chart}

Here is an example of an XY bar chart.

\begin{chart}
\{chart:type=xybar\}
\begin{tabular}{|c|c|c|c|}
\hline
\multicolumn{3}{|c|}{\textbf{2005-2007}} \\
\hline
2005 & 2006 & 2007 \\
\hline
Revenue & 41.1 & 31.8 & 12.4 \\
Expense & 31.1 & 41.8 & 43.6 \\
\hline
\end{tabular}
\end{chart}
XY area chart

Here is an example of an XY area chart.

Wiki markup

{chart:type=xyarea}
|| || 12 || 14 || 23 ||
| Revenue | 41.1 | 31.8 | 12.4 |
| Expense | 31.1 | 41.8 | 43.6 |
{chart}

Resulting chart

Area chart

Here are two examples of area charts.

Wiki markup for area chart 1

{chart:type=area|dataDisplay=true|legend=true|width=300|height=300|opacity=50}
|| Satisfaction || 2002 || 2003 || 2004 ||
| Very satisfied | 20 | 23 | 34 |
| Satisfied | 40 | 34 | 23 |
| Disatisfied | 25 | 26 | 25 |
| Very dissatisfied | 15 | 17 | 18 |
{chart}

Resulting area chart 1

Wiki markup for area chart 2

{chart:type=area|dataDisplay=true|legend=true|width=300|height=300|stacked=true}
|| Satisfaction || 2002 || 2003 || 2004 ||
| Very satisfied | 12 | 23 | 31 |
| Satisfied | 1 | 34 | 36 |
| Dissatisfied | 4 | 6 | 22 |
| Very dissatisfied | 2 | 7 | 12 |
{chart}

Resulting area chart 2
Cheese Macro

This macro is available in Confluence Data Center and Confluence Cloud. Learn about the macros available in Confluence Cloud.

Add a Cheese macro to your page to display the words "I like cheese!".

This macro is great for:

- testing Confluence macro functionality
- sharing your love of cheese.

Seriously though, this macro is just for testing purposes. It's provided by the Basic Macros system plugin, and you can disable the Cheese module if cheese isn't your thing.

Add the Cheese macro to your page

To add the Cheese macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Cheese from the Confluence content category.
3. Choose Insert.

You can then publish your page to see the macro in action.

Change the macro parameters

This macro has no parameters.

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

Macro name: cheese

Macro body: None.
Children Display Macro

Add the Children Display macro to a page to display a list of pages from a specific part of the page hierarchy. You can choose to display pages that are a child of the current page, or a child of any other page in a space.

This macro is great for providing quick access to:

- pages related to a project
- procedures and how-to pages.

Because it relies on the page hierarchy, the list of pages is automatically updated when pages are added, deleted, or moved. You can even show an excerpt from the page for extra context.

**Screenshot: The Children Display macro, showing a list of pages about printers.**

Want to create a table of contents from headings on your page? See Table of Contents Macro

Add the Children Display macro to your page

To add the Children Display macro to a page:

1. From the editor toolbar, choose Insert ➤ Other Macros.
2. Choose Children Display from the Confluence content or Navigation category.
3. Use the parameters below to specify which pages to display, and how you want them to look.
4. Choose Insert.

You can then publish your page to see the macro in action.

**Screenshot: Specifying the parent page and display options in the Children Display macro.**
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Show Descendants</strong></td>
<td>false</td>
<td>Choose whether to display all the parent page's descendants.</td>
</tr>
<tr>
<td><em>(all)</em></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>If true shows the complete tree of pages underneath the parent page,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>regardless of <strong>Depth of Descendants</strong></td>
</tr>
<tr>
<td><strong>Parent Page</strong></td>
<td>current</td>
<td>Specify the page to display children for, from either the current space or</td>
</tr>
<tr>
<td><em>(page)</em></td>
<td></td>
<td>a different space. Enter:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• '/ ' — to list the top-level pages of the current space, i.e. those</td>
</tr>
<tr>
<td></td>
<td></td>
<td>without parents.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 'pagename' — to list the children of the specified page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 'spacekey:' — to list the top-level pages of the specified space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 'spacekey:pagename' — to list the children of the specified page</td>
</tr>
<tr>
<td></td>
<td></td>
<td>in the specified space.</td>
</tr>
<tr>
<td><strong>Number of Children</strong></td>
<td>none</td>
<td>Restrict the number of child pages that are displayed at the top level.</td>
</tr>
<tr>
<td><em>(first)</em></td>
<td></td>
<td>Your administrator may enforce a maximum number for this parameter.</td>
</tr>
<tr>
<td><strong>Depth of Descendants</strong></td>
<td>none</td>
<td>Enter a number to specify the depth of descendants to display. For</td>
</tr>
<tr>
<td><em>(depth)</em></td>
<td></td>
<td>example, if the value is 2, the macro will display 2 levels of child pages.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This setting has no effect if <strong>Show Descendants</strong> is enabled.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Your administrator may enforce a maximum number for this parameter.</td>
</tr>
<tr>
<td><strong>Heading Style</strong>&lt;br&gt;<em>(style)</em></td>
<td>none</td>
<td>Choose the style used to display descendants.</td>
</tr>
<tr>
<td>---------------------------</td>
<td>------</td>
<td>----------------------------------------</td>
</tr>
<tr>
<td><strong>Include Excerpts</strong>&lt;br&gt;<em>(excerpt)</em></td>
<td>none</td>
<td>Allows you to include a short excerpt under each page in the list. Choose between:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>None</strong> - no excerpt will be displayed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>Simple</strong> - displays the first line of text contained in an Excerpt macro on any of the returned pages. If there is not an Excerpt macro on the page, nothing will be shown.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>Rich content</strong> - displays the contents of an Excerpt macro, or if there is not an Excerpt macro on the page, the first part of the page content including formatted text, images, and some macros.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note that your administrator may have set this parameter to <strong>none</strong> for it to apply to the whole site.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="confluence.child-macro.disable-excerpt" alt="The JVM parameter" /> can be set to &quot;true&quot; to disable excerpts in children display macros. See <a href="#">Recognized System Properties</a> for more details on this parameter and when it can be used.</td>
</tr>
<tr>
<td><strong>Sort Children By</strong>&lt;br&gt;<em>(sort)</em></td>
<td>Manual if manually ordered, otherwise alphabetical</td>
<td>Leave blank to display pages in the order they currently appear in the page tree. Alternatively, choose:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>creation</strong> — to sort by content creation date</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>title</strong> — to sort alphabetically on title</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>modified</strong> — to sort of last modification date.</td>
</tr>
<tr>
<td><strong>Reverse Sort</strong>&lt;br&gt;<em>(reverse)</em></td>
<td>false</td>
<td>Use with the <strong>Sort Children By</strong> parameter. When set, the sort order changes from ascending to descending.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets *(example)*.

### Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

![Macro suggestions](exa)

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** children

**Macro body:** None.

```markdown
{children:reverse=true|sort=creation|style=h4|page=Home|excerpt=none|first=99|depth=2|all=true}
```
Do more with Confluence

Extend Confluence with one of the hundreds of other macros in the Atlassian Marketplace. Here are a couple for organizing your Confluence page:

- **Navitabs**: Create tabs to group content to improve navigation between Confluence pages
- **Advanced Children Display for Confluence**: combine Confluence’s built-in children display and table of contents macros
- **Subspace Navigation for Confluence**: Use the navigation macro to create overviews of the menu within a Confluence page
Code Block Macro

This macro is available in Confluence Data Center and Confluence Cloud. Learn about the macros available in Confluence Cloud.

Add a Code Block macro to your page to display code examples with syntax highlighting.

This is great for sharing code snippets such as:

- sample code
- terminal commands
- excerpts from application logs.

Screenshot: code sample in the Code Block macro, with syntax highlighting and a dark theme.

Add the Code Block macro to your page

To add the Code Block macro to a page:

1. From the editor toolbar, choose Insert ➤ Other Macros.
2. Choose Code Block from the Formatting category.
3. Choose a language for syntax highlighting.
4. Use the parameters below to customise how the code block should appear on your page.
5. Choose Insert.
6. Type or paste your code into the macro placeholder.

You can then publish your page to see the macro in action.

Screenshot: Choosing syntax highlighting language and theme in the Code Block macro
Note: You type the code block directly into the macro placeholder in the editor. Note that any white space contained in the placeholder is not manipulated in any way by the Code Block macro. This is to provide the writer with flexibility over code indentation.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Syntax highlighting</td>
<td>java</td>
<td>Specifies the language (or environment) for syntax highlighting. The default language is Java but you can choose from one of the following languages/environments:</td>
</tr>
<tr>
<td>---------------------</td>
<td>------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
|                     |      | - ActionScript  
|                     |      | - AppleScript  
|                     |      | - Bash  
|                     |      | - C#  
|                     |      | - C++  
|                     |      | - CSS  
|                     |      | - ColdFusion  
|                     |      | - Delphi  
|                     |      | - Diff  
|                     |      | - Erlang  
|                     |      | - Groovy  
|                     |      | - HTML and XML  
|                     |      | - Java  
|                     |      | - Java FX  
|                     |      | - JavaScript  
|                     |      | - PHP  
|                     |      | - Plain Text  
|                     |      | - PowerShell  
|                     |      | - Python  
|                     |      | - Ruby  
|                     |      | - SQL  
|                     |      | - Sass  
|                     |      | - Scala  
|                     |      | - Visual Basic  
|                     |      | - YAML  
| Title               | none | Adds a title to the code block. If specified, the title will be displayed in a header row at the top of the code block. |
| Collapsible         | false | If selected, the code macro's content will be collapsed upon visiting or refreshing the Confluence page. Clicking the expand source link allows you to view this content. If false, the code macro's content is always displayed in full. |
| Show line numbers   | false | If selected, line numbers will be shown to the left of the lines of code. |
| First line number   | 1     | When Show line numbers is selected, this value defines the number of the first line of code. |
Theme

| Default | Specifies the color scheme used for displaying your code block. Many of these themes are based on the default color schemes of popular integrated development environments (IDEs). The default theme is **Confluence** (also known as **Default**), which is typically black and colored text on a blank background. However, you can also choose from one of the following other popular themes:

  * DJango
  * Emacs
  * FadeToGrey
  * Midnight
  * RDark
  * Eclipse
  * Confluence

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Administer the Code Block macro

You can configure the Code Block macro to use a specific language and theme by default and also upload new languages. You need Confluence Administrator permissions to change the default theme and language and System Administrator permissions to upload new languages.

To set the default appearance of code blocks in your site:

1. Go to **Administration** > **General Configuration** > **Configure Code Macro**.
2. Select a **Default Theme** and **Default Language**.
3. Choose **Save**.

All new code blocks will use the default theme and language unless you specify otherwise. Existing code blocks will be unchanged.

To add an additional language:

1. Go to **Administration** > **General Configuration** > **Configure Code Macro**.
2. Choose **Add a new language**.
3. Locate your language file and enter a **Name** for the new language (this will appear when selecting the language).
4. Choose **Add**.

Language files must be correctly formatted JavaScript files and adhere to the Custom Brush syntax. You can see examples in `<install-directory>/confluence/includes/js/third-party`.

To disable or remove a user-installed language:

1. Go to **Administration** > **Manage apps**.
2. Go to **User-installed Apps** and locate the app for your uploaded language - it will appear like this 'Custom Code Macro Highlighting for...'
3. Choose **Uninstall** or **Disable**.

The language will no longer appear in the Code Macro.

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** code

**Macro body:** Accepts plain text.

```
{code:title=This is my
title|theme=FadeToGrey|linenums=true|language=java|firstline=0001|collapse=true}
This is my code
{code}
```

---

Do more with Confluence

Extend Confluence with one of the hundreds of other macros in the [Atlassian Marketplace](https://marketplace.atlassian.com). Some of our most popular include:

- [Code Pro for Confluence](https://marketplace.atlassian.com) - Get a real-time view of your code from any source in Confluence.
- [Include Bitbucket Server for Confluence](https://marketplace.atlassian.com) - Easily include code snippets in Confluence that sync automatically to Bitbucket Server.
Column Macro

Add the column macro to a page to organise your content in columns. This macro is used in conjunction with the Section macro, and provides more flexibility than page layouts.

This macro is great for situations where:

- you need more than three columns, or
- you need your columns to be a specific width.

Screenshot: page with a four column layout using the Section and Column macros.

Add this macro to your page

Column macros must be added inside a page layout section, or within a Section macro.

To add the Column macro to a page:

1. Position your cursor inside the body of a Section macro, or page layout section.
2. From the editor toolbar, choose Insert ➔ Other Macros.
3. Choose Column from the Formatting category.
4. Choose Insert.

You can then start typing into the macro body, then publish your page to see the macro in action.

Screenshot: section and column macros in the editor
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>The width of the column. Can be specified either in pixels (for example, 400px) or as a percentage of the available page width (for example, 50%).</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.
Macro name: column

Macro body: Accepts rich text.

```html
{column:width=100px}
This is the content of 'column 1'.
{column}
```
Content by Label Macro

Add a Content by Label macro to your page to display a list of pages, blog posts or attachments that have particular labels.

This macro is great for collecting related pages together and filtering out content that you don’t want to see. You could:

- list of all pages that have the label ‘feature-shipped’ and include the word ‘Blueprint’
- list any pages with the label 'meeting-notes' that you've been mentioned in.

Screenshot: The Content by Label macro showing all pages that contain the label "printer".

For general information about using labels in Confluence, see Add, Remove and Search for Labels.

Add this macro to your page

To add the Content by Label macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Content by Label from the Confluence content category.
3. Enter the labels you want to use as the basis for your query.
4. Add additional filters to further narrow your query. These filters use CQL.
5. Choose Show to change the macro parameters. These are optional.
6. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Using CQL to search for content with a particular label in two spaces in the Content by Label macro.
CQL filters

CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the **Add a filter** link to add more filters to your query.

- For an OR search, specify multiple values in the same field.
  So to show pages with 'label-a', 'label-b' or both you'd put 'label-a' and 'label-b' in the same Label field, like this:

  ![Label field with 'label-a' and 'label-b'](image)

- For an AND search, add more than one filter and specify a single value in each.
  To show only pages with label-a and label-b you'd put 'label-a' in one label field, then add a second Label field to the macro, and put 'label-b' in the second one, like this:

  ![Label field with 'label-a' and 'label-b'](image)

  Put simply, OR values are entered in the same filter, AND values are entered in different filter.
  Only some filters support AND. If the filter doesn't support the AND operator, you won't be able to add that filter more than once.

- For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that label.

You can use the following CQL filters to build your query:

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
<th>Operators</th>
</tr>
</thead>
</table>

Table of parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label*</td>
<td></td>
<td>Include pages, blog posts or attachments with these labels.</td>
</tr>
<tr>
<td>With ancestor</td>
<td></td>
<td>Include pages that are children of this page.</td>
</tr>
<tr>
<td>Contributor**</td>
<td></td>
<td>Include pages or blog posts that were created or edited by these people.</td>
</tr>
<tr>
<td>Creator</td>
<td></td>
<td>Include items created by these people.</td>
</tr>
<tr>
<td>Mentioning user</td>
<td></td>
<td>Include pages and blog posts that @mention these people.</td>
</tr>
<tr>
<td>With parent</td>
<td></td>
<td>Include only direct children of this page (further sub-pages won't be included)</td>
</tr>
<tr>
<td>In space**</td>
<td></td>
<td>Include items from these spaces.</td>
</tr>
<tr>
<td>Including text**</td>
<td></td>
<td>Include items that contain this text.</td>
</tr>
<tr>
<td>With title</td>
<td></td>
<td>Include items that contain this text in the title.</td>
</tr>
<tr>
<td>Of type**</td>
<td></td>
<td>Include only pages, blogs or attachments.</td>
</tr>
</tbody>
</table>

* This field is required in CQL-powered macros.

** You can add these filters in CQL-powered macros but in search they're part of the standard search filters, so they don't appear in the Add a filter menu.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort by</td>
<td>Modified</td>
<td>Sort the list by title, the date it was created, or the date it was last modified. If you don't select an option, CQL default ordering by relevancy is used.</td>
</tr>
<tr>
<td>Reverse sort</td>
<td>False</td>
<td>Sort the list descending instead of ascending (Z - A, earliest - latest)</td>
</tr>
<tr>
<td>Maximum number of pages</td>
<td>15</td>
<td>Limit the number of items to include in the list. This can be any value up to 500 pages.</td>
</tr>
<tr>
<td><strong>List title</strong></td>
<td>Blank</td>
<td>Include an optional heading for the macro</td>
</tr>
<tr>
<td>---------------</td>
<td>-------</td>
<td>-----------------------------------------</td>
</tr>
<tr>
<td><strong>Show labels for each page</strong></td>
<td>True</td>
<td>Show or hide the labels applied to each item</td>
</tr>
<tr>
<td><strong>Show space name for each page</strong></td>
<td>True</td>
<td>Show or hide the space name for each item</td>
</tr>
<tr>
<td><strong>Display excerpts</strong></td>
<td>False</td>
<td>Allows you to include a short excerpt under each page in the list. Choose between:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>None</strong> - no excerpt will be displayed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>Simple</strong> - displays the first line of text contained in an Excerpt macro any of the returned pages. If there is not an Excerpt macro on the page, nothing will be shown.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>Rich content</strong> - displays the contents of an Excerpt macro, or if there is not an Excerpt macro on the page, the first part of the page content, as formatted text, including images and some macros.</td>
</tr>
<tr>
<td><strong>Exclude current page</strong></td>
<td>False</td>
<td>Allows you to exclude the page the macro appears on from the list. This is useful when the current page contains the same labels as the pages you want to include in the list.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

**Other ways to add this macro**

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

![Macro suggestions](image)

**Add this macro using wiki markup**

You can't use wiki markup to add this macro.
Content by User Macro

Add the Content by User macro to a page to display a list of all the things created by a particular user including spaces, pages, blog posts, comments, attached files, and even user accounts.

This is a legacy macro, and doesn't provide any way to limit the amount of information displayed. This means it can cause timeouts if the user specified has created a lot of content.

Advanced search is a much better way to find all content created by a specific person.

Screenshot: The Content by User macro displaying everything created by a particular user.

Add this macro to your page

To add the Content by User macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Content by User from the Confluence content category.
3. Enter the username of the person you want to activity for.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: specifying a user in the Content by User macro
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>yes</td>
<td>none</td>
<td>The Confluence username for a person who has created content. This parameter is unnamed in wiki markup.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

```
{content-by-user:jsmith}
```

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name**: `content-by-user`

**Macro body**: None.

```
{content-by-user:jsmith}
```
Content Report Table Macro

Add the Content Report Table to a page to display a table of pages and blog posts with a specific label along with the creator and modified date.

This macro is great for situations where you need to see information about a set of pages at a glance, such as:

- project pages
- document control
- change management
- process and procedure documentation.

You can see this macro in action in the Meeting Notes blueprint.

Screenshot: The Content Report Table macro, configured to show pages with the label "printer".

For general information about using labels in Confluence, see Add, Remove and Search for Labels.

Add this macro to your page

To add the Content Report Table macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose Content Report Table from the Confluence content category.
3. Enter the labels you want to display pages for.
4. Use the parameters below to narrow your query.
5. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Entering the label parameter in the Content Report Table macro.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Label(s)** *(labels)* | Yes      | None    | This parameter is required. Specify one or more labels, separated by a comma. The macro will display the content tagged with any of the label(s) specified here.  
For example, if you specify labels ‘A’ and ‘B’, the macro will display all pages that have the label ‘A’, and all pages that have the label ‘B’, and all pages that have both those labels.  |
| **Space(s)** *(spaces)* | No       | (All spaces) | Specify one or more **Space Keys**, separated by a comma or a space. The macro will display only the content which belongs to the space(s) specified here.  
When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com.  |
| **Maximum Number of Pages** *(maxResults)* | No       | 20      | Define the maximum number of pages that the macro will show in a single set of results. If there are more pages to be shown, the macro will display a link labeled ‘Find more results’. People viewing the page can choose the link to go to a search view, which shows all pages tagged with the specified label(s).  
Which pages will appear? Before displaying the results, Confluence will sort them by the date the page was last modified. The most-recently created/updated pages will appear first.  |
Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

You can't use wiki markup to add this macro.
Contributors Macro

Add the Contributors macro to a page to display a list of Confluence users who have contributed to this page, another page, or set of pages. Contributors includes people who:

- created or edited the pages
- commented on the pages
- added labels to the pages, or
- are simply watching the pages.

This macro is great for:

- document control and compliance
- providing a list of people to contact about a page.

Screenshot: Page showing contributors to the printer how-to pages.

In this example, the Display Format parameter has been set to list.

Add this macro to your page

To add the Contributors macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose Contributors from the Confluence content category.
3. Enter the type of contributor you want to display, and set any parameters.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Setting parameters in the Contributors macro
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contribution Type</td>
<td>authors</td>
<td>Filters by either the type of contribution made to a page (and optionally its descendant pages), or the watches on the page. Contribution types are:</td>
</tr>
<tr>
<td>(include)</td>
<td></td>
<td>- authors - includes people who created or have edited the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- comments - includes people who have added comments to the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- labels - includes people who have added labels to the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- watches - includes people who are watching the page(s).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can specify one or more contribution types, separated by commas.</td>
</tr>
<tr>
<td>Sort By</td>
<td>count</td>
<td>Specifies the criteria used to sort contributors. Sort criteria are:</td>
</tr>
<tr>
<td>(order)</td>
<td></td>
<td>- count - sorts people based on the total number of contributions to the page(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- name - sorts people into alphabetical order</td>
</tr>
<tr>
<td>Reverse Sort</td>
<td>false</td>
<td>Reverses the sort order of contributors in the list. Must be used in conjunction with the <strong>Sort By</strong> parameter.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Maximum Number of Contributors</td>
<td>Limits the number of contributors in the list. If a number is not specified, all contributors are included.</td>
<td></td>
</tr>
<tr>
<td>(limit)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Display Format</td>
<td>Sets how the list of contributor's names is formatted:</td>
<td></td>
</tr>
<tr>
<td>(mode)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>inline</td>
<td>• inline — a comma-separated list</td>
<td></td>
</tr>
<tr>
<td>list</td>
<td>• list — a bullet list</td>
<td></td>
</tr>
<tr>
<td>Show Anonymous Contributions?</td>
<td>Sets whether to include those who contributed anonymously to a page.</td>
<td></td>
</tr>
<tr>
<td>(showAnonymous)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>false</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Count?</td>
<td>Sets whether to show the number of times each person made a contribution of the specified Contribution Type.</td>
<td></td>
</tr>
<tr>
<td>(showCount)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>false</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Last Contribution Time?</td>
<td>Sets whether to show the last time each person made a contribution of the specified Contribution Type.</td>
<td></td>
</tr>
<tr>
<td>(showLastTime)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>false</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page Name</td>
<td>Specifies the page to use when generating the list of contributors. If Page Name and Space(s) are left blank, the current page is assumed.</td>
<td></td>
</tr>
<tr>
<td>(page)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>current</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Label(s)</td>
<td>Filters the list of contributors to those who created the specified labels from a page. You can specify one or more labels, separated by commas.</td>
<td></td>
</tr>
<tr>
<td>(labels)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>none</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Space(s)</td>
<td>Specifies the space key of the Confluence space that contains the page set in Page Name or alternatively, specifies the spaces to search. Space keys are case-sensitive. This parameter also takes special values, including:</td>
<td></td>
</tr>
<tr>
<td>(spaces)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>current</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Content Type</td>
<td>Restricts the content type to use when generating the list of contributors:</td>
<td></td>
</tr>
<tr>
<td>(contentType)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>both pages and blog posts</td>
<td>• pages — pages</td>
<td></td>
</tr>
<tr>
<td>Blog Post Date</td>
<td>Specifies the publish date for a blog post. The date format required is:</td>
<td></td>
</tr>
<tr>
<td>(publishDate)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>none</td>
<td>YYYY/MM/DD.</td>
<td></td>
</tr>
</tbody>
</table>

Created in 2023 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Include Page Hierarchy (scope) | specified page only | Specifies additional pages to include when generating the list of contributors:
- **children** — just the child pages of the specified page
- **descendants** — all descendants of the specified page.

Show Selected Pages (showPages) | false | Sets whether to show a list of the pages used to generate the list of contributors.

Custom "None Found" Message (noneFoundMessage) | default message | Specifies the message to be used to override the default message that is displayed when no contributors are found.

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** `contributors`

**Macro body:** None.

This example specifies a content type of blog posts:

```
{contributors:limit=10|spaces=ds, @personal|reverse=true|labels=chocolate, cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=blogposts|include=authors, comments, labels, watches|mode=list|showAnonymous=true|order=update|showLastTime=true|publishDate=2012/06/30}
```

This example specifies a content type of pages:

```
{contributors:limit=10|spaces=ds, @personal|reverse=true|scope=descendants|labels=chocolate, cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=pages|include=authors, comments, labels, watches|mode=list|showAnonymous=true|order=update|page=d:Advanced Topics|showLastTime=true}
```
Contributors Summary Macro

Add the Contributors macro to a page to display statistics about people contributing to this page, a specific page, or set of pages. Contributors includes people who:

- created or edited the pages
- commented on the pages
- added labels to the pages, or
- are simply watching the pages.

This macro is great for:

- collaboration leaderboards
- recognising frequent documentation contributors
- tracking contributions to high value pages.

Screenshot: Page with two Contributors Summary macros, one displaying contributions by user, the other by page.

Add this macro to your page

To add the Contributors Summary macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose Contributors Summary from the Confluence content category.
3. Choose whether to show contributions by user or page
4. Set any parameters to refine your query.
5. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Setting parameters in the Contributors Summary macro
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Group By (groupby)   | contributors | Specifies the basis for grouping contribution-based statistics:
|                      |          | • contributors — group by the people who have contributed
|                      |          | • pages — group by the pages used to find contributors. |
| **Columns to Display** (columns) | edits, commentss, labels | Sets the columns that should appear in the table. The statistics or type of information presented depends on the basis for grouping set with the **Group By** parameter. Statistics may be calculated for:

- **edits** — the number of times each contributor has edited the page(s) or the number of edits made to each page.
- **edited** — a list of the pages edited by each contributor or a list of contributors who have edited each page.
- **comments** — the number of times each contributor has added comments to the page(s) or the number of comments on each page.
- **commented** — a list of pages to which each contributor has added comments or a list of contributors who have commented on each page.
- **labels** — the number of times each contributor has added labels to the page(s) or the number of labels on each page.
- **labeled** — a list of pages to which each contributor has added labels or a list of contributors who have added a label to each page.
- **labellist** — a list of labels either added by each contributor or on each page.
- **watches** — the number of pages being watched by each contributor/person or the number of contributors/people watching each page.
- **watching** — a list of pages being watched by each contributor/person or a list of contributors/people watching each page.
- **lastupdate** — the last time each contributor made an update or when each page was last updated. Valid updates can include edit, comment or label modifications to a page.

One or more columns can be used.

| **Sort By** (order) | edits | Sets the criterion used for sorting items in the table. The items sorted depend on the basis for grouping set with the **Group By** parameter. Sort criteria are:

- **edits** — sorts items in the table based on the total number of edits made, either by a contributor or to a page.
- **name** — sorts items in the table in alphabetical order, either by contributor or page name.
- **editTime** — sorts items in the table based on when the contributor last edited a page (or a specified set of pages) or when the page was last edited.
- **update** — sorts items in the table based on when the contributor last made any contribution to a page (or a specified set of pages) or when the page last had any contribution made to it.

| **Reverse Sort** (reverse) | false | Reverses the sort order of items in the table, as specified using the **Sort By** parameter. (Used only in conjunction with the **Sort By** parameter.)

| **Maximum Number of Items** (limit) | no limit | Limits the number of contributors or pages in the table to the value specified. If no number is specified, all items are included.

<p>| <strong>Show Anonymous Contributions?</strong> (showAnonymous) | false | Includes individuals who have made anonymous contributions to a page. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Zero Counts?</td>
<td>false</td>
<td>Sets whether contributors or pages are included for which a calculated statistic is zero.</td>
</tr>
<tr>
<td>Page Name (page)</td>
<td>current</td>
<td>Sets the page for which to calculate the contribution-based statistics. If no values for <strong>Page Name</strong> and <strong>Space(s)</strong> are specified, the current page is assumed.</td>
</tr>
<tr>
<td>Label(s) (labels)</td>
<td>none</td>
<td>Restricts the contribution-based statistics to the specified labels only. You can specify one or more labels, separated by commas.</td>
</tr>
</tbody>
</table>
| Space(s) (spaces)         | current     | Specifies the space key of the Confluence space which contains the specified page name or alternatively, specifies a scope of spaces to search. Space keys are case-sensitive. This parameter also takes special values, including:  
  - @global — All site spaces.  
  - @personal — All personal spaces.  
  - @all — All spaces in your Confluence site. You can specify one or more space keys or special values, separated by commas. If no **Page Name** and **Label(s)** are specified, all pages from the specified set of spaces are included. |
| Content Type (contentType) | both pages and blog posts | Restricts page types to either pages (pages) or blog posts (blogposts). If no value is specified in the Macro Browser, both pages and blog posts are included. Available values pages and blogposts. |
| Blog Post Date (publishDate) | none       | Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD. |
| Include Page Hierarchy (scope) | specified page only | Includes either the immediate children or all descendants of the specified page. If no value is indicated in the Macro Browser, only the specified page is included. |

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

**Other ways to add this macro**

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

**Add this macro using wiki markup**
This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** contributors-summary

**Macro body:** None.

This example specifies a content type of blog posts:

```
{contributors-summary:limit=10|spaces=ds, @personal|reverse=true|showAnonymous=true|order=update|labels=chocolate,cake|columns=edits,comments, labels,lastupdate|groupby=pages|contentType=blogposts|showZeroCounts=true|publishDate=2012/06/07}
```

This example specifies a content type of pages:

```
{contributors-summary:limit=10|spaces=ds, @personal|reverse=true|showAnonymous=true|scope=descendants|order=update|page=ds:Advanced Topics|labels=chocolate,cake|columns=edits,comments,labels, lastupdate|groupby=pages|contentType=pages|showZeroCounts=true}
```
Create from Template Macro

Add the Create from Template macro to a page to provide a way to create pages in a specific location, using a particular template.

When someone clicks the button, the macro opens the editor, loads the template or blueprint, and is ready to use. When saved, the page will be a child of the page containing the macro.

This macro is great for:

- project pages
- documentation
- recurring processes.

Screenshot: Page showing the Create from template button, used to create DACI decision pages.

Add this macro to your page

To add the Create from Template macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Create from Template from the Confluence content category.
3. Select a template.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Configuring the macro to have custom button text, and a default page title which includes the current date.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Button Text</td>
<td></td>
<td>'Create from Template'</td>
<td>The description that people will see when viewing this macro on the page.</td>
</tr>
<tr>
<td>Template Name</td>
<td>None</td>
<td>None</td>
<td>Select the template or blueprint to base the new page on. Only global and user-created templates for the current space appear (unless you have specified a different space in the 'Space Key' field).</td>
</tr>
<tr>
<td>Template Title</td>
<td>Blank</td>
<td>Blank</td>
<td>Specify a default title for pages created using this macro (optional). You can include @currentDate, @spaceName and @spaceKey variables in the title. Some blueprints, such as the Decision blueprint, will override your custom title.</td>
</tr>
<tr>
<td>Space Key</td>
<td></td>
<td>The space where the current page is located</td>
<td>Supply the unique space identifier (space key), to determine where the new page will be created when someone uses this macro to create a page.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro as you type

Type {{ followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

You can't use wiki markup to add this macro.
Create Space Button Macro

Add the Create Space Button macro to a page to provide a quick, visual prompt to create a space in Confluence. The Create Space Button provided by the macro is only be visible to people who have the who have the Create Space global permission.

This is a legacy macro and was primarily used before you could create a space directly from the Spaces dropdown in the header. However, it might be useful when documenting a procedure that requires creating a space, for example a set-up guide for new teams.

Screenshot: page showing the Create Space Button macro.

Add this macro to your page

To add the Create Space Button macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Create Space Button from the Confluence content category.
3. Choose Insert.

You can then publish your page to see the macro in action.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

On this page:
- Add this macro to your page
- Change the macro parameters
- Other ways to add this macro
Icon Size

<table>
<thead>
<tr>
<th>size</th>
<th>large</th>
<th>Specify whether to use large or small icon. Available values:</th>
</tr>
</thead>
</table>
|       |       | • large
|       |       | • small |

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

Macro name: create-space-button

Macro body: None.

{create-space-button:size=small}
{create-space-button:height=50px|width=50px}

The following additional parameters are available in wiki markup.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>Natural size of icon (1:1 pixel ratio)</td>
<td>The width of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the width of the icon to the number of pixels specified. Note: This parameter is not available via the macro browser.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>Natural size of icon (1:1 pixel ratio)</td>
<td>The height of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the height of the icon to the number of pixels specified. Note: This parameter is not available via the macro browser.</td>
</tr>
</tbody>
</table>
Excerpt Include Macro

Add the Excerpt Include macro to display the contents of an Excerpt macro on another page.

This is great single sourcing important information. For example you could provide the contact details and dates from each project page on a summary page. When the info is updated in the excerpt, it will flow though to all the other places it is used.

This is a two-step macro. You need to add the Excerpt macro to another page, before you can use the Excerpt Include macro.

The example below shows an example of an Excerpt Include macro as it appears in the editor, and as it would appear to someone viewing the page. We have set the options to show both the title of the page and the panel surrounding the content.

On this page:
- Add this macro to your page
- Change the macro parameters
- Other ways to add this macro

1. The Excerpt Include macro as it appears in the editor.
2. The Excerpt Include macro as it appears when viewing the page.

The content is being pulled from a Excerpt macro on a page called ‘reusable note’.

Add this macro to your page

To add the Excerpt Include macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Excerpt Include from the Confluence content category.
3. Enter the title of the page containing the Excerpt macro you want to include.
4. Choose Insert.

You can then publish your page to see the macro in action.

If the page contains more than one Excerpt macro, the Excerpt Include macro will display the contents of the first one on the page. It can’t display content from multiple Excerpt macros on the same page.

Want to show more than just an excerpt? The Include Page Macro allows you to include the entire contents of another page.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:
1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page Containing the Excerpt</strong> <em>(default parameter)</em></td>
<td>none</td>
<td>Type the name of the page that contains the excerpt to be displayed. You can use an excerpt from a page in the same space or another space in the same wiki. When you type the name of the page into the Excerpt Include macro dialog, Confluence will offer a list of matching pages, including those from other spaces. Alternatively, you can type the space key followed by a colon (:) and the page name, like this: <code>SPACEKEY:Page name</code> This parameter is unnamed in wikimarkup.</td>
</tr>
<tr>
<td><strong>Remove Surrounding Panel</strong> <em>(nopanel)</em></td>
<td>false</td>
<td>Determines whether Confluence will display a panel around the excerpted content. The panel includes the title of the page containing the excerpt, and the border of the panel. By default, the panel and title are shown.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets *(example)*.

**Other ways to add this macro**

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

![](https://example.com/suggestions.png)

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** excerpt-include

**Macro body:** None.

```none
{excerpt-include:My page name|nopanel=true}
```
Excerpt Macro

Add the Excerpt macro to a page to define a snippet of content to be reused on another page.

This is great single sourcing important information. For example you could provide the contact details and dates from each project page on a summary page. When the info is updated in the excerpt, it will flow though to all the other places it is used.

This is a two-step macro. Once you've added the Excerpt macro to one page, use the Excerpt Include, Children Display, or Blog Posts macro to display the contents of that excerpt on another page.

Screenshot: A project summary page containing a Children Display macro, configured to show the contents of the Excerpt macro on each child page.

Add this macro to your page

To add the Excerpt macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose Excerpt from the Confluence content category.
3. Choose Insert.

Enter your text into the macro body. You can then publish your page to see the macro in action.

Screenshot: the Excerpt macro in the editor, containing a short project summary.
Using this macro

This macro must be used in conjunction with either the **Excerpt Include**, **Children Display**, or **Blog Posts** macros.

You can only have one excerpt per page. If you add more than one excerpt macro to a page, only the first one will be used by these macros.

You can choose to position the excerpt on its own line, or inline with the surrounding text. This option affects only the page that contains the Excerpt macro, it doesn’t affect how the content displays when it is reused on other pages.

*Screenshot: The Excerpt macro placeholder and options panel*

1. **New line**
2. **Inline**

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Excerpted Content</td>
<td>false</td>
<td>Controls whether the page content contained in the Excerpt macro placeholder is displayed on the page.</td>
</tr>
<tr>
<td>(hidden)</td>
<td></td>
<td>Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets *(example)*.

Other ways to add this macro

*Add this macro as you type*

Type `{` followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** excerpt

**Macro body:** Accepts rich text.

```markdown
{excerpt:hidden=true|atlassian-macro-output-type=BLOCK}
This is the *text* I want to reuse in other pages. This text is inside an Excerpt macro.
{excerpt}
```
Expand Macro

This macro is available in Confluence Data Center and Confluence Cloud. Learn about the macros available in Confluence Cloud.

Add the Expand macro to your page to provide content in an expandable / collapsible section.

This is one of Confluence’s most popular macros. It’s great for:

- visually reducing the amount of information on a page
- breaking process information down into clickable steps
- hiding background or obsolete information, while still keeping it on the page for future reference.

The macro is collapsed by default, people need to click each one to expand it. There’s no way to expand all macros on a page at once, however all Expand macros are automatically expanded when you print or export the page to PDF.

Screenshot: page showing four expand macros. Two are collapsed, and two are expanded.

Add this macro to your page

To add the Expand macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Expand from the Formatting category.
3. Enter a Title. This is the text a user will click on to show the hidden content.
4. Type or paste your text into the body of the macro. This content will be visible when someone clicks the macro title.
5. Choose Insert.

You can then publish your page to see the macro in action.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Click here to expand...</td>
<td>Defines the text that appears next to the expand/collapse icon.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.
**Macro name**: expand

**Macro body**: Accepts rich text.

```
{expand}
This text is hidden until you expand it.
{expand}
```

**Notes**

- **Text is expanded in PDF and HTML exports**. When you export the page to PDF or HTML, the text between the macro tags is expanded so that readers can see it in the PDF and HTML versions of the page.
- **Nesting your Expand macros**. You can put one Expand macro inside another, and Confluence will correctly show and hide the contents of all Expand macros, including the nested ones.
- **Using the Confluence Cloud editor?** This macro may not be available in the new editor. See [Expand macro](https://confluence.cloud.atlassian.com/) for more information.

**Do more with Confluence**

Extend Confluence with one of the hundreds of other macros in the [Atlassian Marketplace](https://marketplace.atlassian.com/), such as:

- **Composition Tabs & Page Layouts**: Toggle or expand the visible of portions of your pages with the Toggle and Cloak macro
- **Content Formatting for Confluence**: Over 30 easy-to-use Confluence macros gives you the ability to create better, more engaging content
Favorite Pages Macro

Add the Favorite Pages macro to a page to display a list of all the pages you've saved for later.

This is a legacy macro and was primarily used in personal spaces, before you could access starred pages from the dashboard or profile menu. However, it can be a useful way to share pages you've saved for later with other people.

Screenshot: A page with the Favorite pages macro to help new people in a team.

Add this macro to your page

To add the Favorite Pages macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Favorite Pages from the Confluence content category.
3. Choose Insert.

You can then publish your page to see the macro in action.

Change the macro parameters

This macro has no parameters.

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup
This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** favpages

**Macro body:** None.

```{favpages}
```
Gallery Macro

Add the Gallery macro to a page to display a collection of images attached to this page, or other Confluence pages.

This macro is great for situations where you need to:

- curate a collection of images that are attached to several different pages
- display a set of images in a particular order, such as by date.

One benefit of the Gallery macro over simply inserting images into a page is that it will automatically update when files are added or removed from the page.

Screenshot: Gallery macro on a page showing images from this page, with captions.

The captions below the images are drawn from the comments on the attachments. For information about adding comments to attachments, see [Upload Files](#).

For general information about working with files in Confluence, see [Files](#)

Add this macro to your page

To add the Gallery macro to a page:

1. From the editor toolbar, choose **Insert** ➔ **Other Macros**.
2. Choose **Gallery** from the **Media** or **Visuals & Imagery** categories.
3. Use the macro parameters below to specify the files you want to display.
4. Choose **Insert**.

You can then publish your page to see the macro in action.

*Screenshot: Entering parameters for the Gallery macro*
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.
2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gallery Title (title)</td>
<td>Nothing</td>
<td>Specify a title for your gallery.</td>
</tr>
<tr>
<td>Number of Columns (columns)</td>
<td>4</td>
<td>Specify the number of columns for your table.</td>
</tr>
<tr>
<td>Images to Exclude (exclude)</td>
<td>No exclusions.</td>
<td>The gallery will ignore any pictures specified. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognized as 'my picture.png'.</td>
</tr>
<tr>
<td>Include these Images Only (include)</td>
<td>Include all the pictures on the page.</td>
<td>If you specifically include one or more pictures, the gallery will show only those pictures. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognized as 'my picture.png'.</td>
</tr>
<tr>
<td><strong>Exclude Images with these Labels (exclude Label)</strong></td>
<td>No exclusions. Include all the pictures on the page.</td>
<td>The gallery will ignore any pictures that have the specified label. You can specify more than one label, separated by commas. For information on labeling the attachments, see Add, Remove and Search for Labels.</td>
</tr>
<tr>
<td><strong>Include Images with these Labels Only (include Label)</strong></td>
<td>None. The images are not filtered by label.</td>
<td>Filters the images to display, based on a list of labels. If you wish to enter more than one label, separate the labels with commas. Confluence will show only images that have all the labels specified. (The match is an AND, not an OR.) For information on labeling the attachments, see Add, Remove and Search for Labels.</td>
</tr>
<tr>
<td><strong>Use Images in these Pages (page)</strong></td>
<td>If no page is specified, the gallery macro displays the images attached to the page on which the macro is used.</td>
<td>Specify the title of the page which contains the images you want displayed. You can specify more than one page name, separated by commas. To specify a page in a different space, use the following syntax: SPACEKEY:Page Title</td>
</tr>
</tbody>
</table>
| **Sort Images By (sort)** | None. The sort order is unspecified and therefore unpredictable. | Specify an attribute to sort the images by. Sort order is ascending, unless you select the Reverse Sort parameter (see below). Options are:  
- name – file name.  
- comment – comment linked to the attached file.  
- date – date/time last modified.  
- size – size of the attached file. |
| **Reverse Sort (reverse)** | Off. Sort order is ascending | Used in combination with the Sort Images By parameter above. Use Reverse Sort to reverse the sort order, from ascending to descending.  
Available values in storage format and wikimarkup:  
- true – Sort order is descending.  
- false – Sort order is ascending. |

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

If the name of an attached file or page contains a comma, you can refer to it in the relevant parameters below by enclosing it in single or double quotes, for example "this,that.jpg", theother.png

**Image file formats**

You can attach image files of any format to a page. Confluence supports the following image formats in the Gallery macro and when displaying an image on a page:

- gif
- jpeg
- png
- bmp (depending on browser support)

**Other ways to add this macro**
Add this macro as you type

Type \{ followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** gallery

**Macro body:** None.

```
{gallery:title=My holiday pictures|reverse=true|sort=size|page=My page1, ds:Welcome to Confluence|excludeLabel=badlabel1, badlabel2|columns=3|exclude=badpicture.png}
```
Global Reports Macro

Add the Global Reports macro to a page for access to several feeds that can help you stay on top of new content in your site.

This is a **legacy macro** and is no longer fully functional. However, the link to new or updated pages since your last login can be quite useful.

**On this page:**
- Add this macro to your page
- Change the macro parameters
- Other ways to add this macro

**Screenshot: The Global Reports macro**

Global Reports

- New or updated **pages** since your last login.
- Find all **undefined** pages.
- **RSS** Feed for **new pages and blogs**.

Add this macro to your page

To add the Global Reports macro to a page:

1. From the editor toolbar, choose **Insert ➔ Other Macros**.
2. Choose **Global Reports** from the **Reporting** category.
3. Choose **Insert**.

You can then publish your page to see the macro in action.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.
2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of Table</td>
<td>99%</td>
<td>Specify the width of the table in which the links are displayed, as a percentage of the window width.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

Other ways to add this macro
Add this macro as you type

Type `{` followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** global-reports

**Macro body:** None.

```{global-reports:width=50%}```
HTML Include Macro

Add the HTML Include macro to a page to include the contents of specific URL in a Confluence page. This allows you to embed a webpage in your Confluence page.

This is a legacy macro, and is often disabled by Confluence administrators for security reasons.

Security considerations

⚠️ HTML macros are disabled by default

The HTML macro will only be available if it has been enabled by an administrator. Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks.

Add this macro to your page

To add the HTML Include macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose HTML Include from the External content category.
3. Enter the URL you want to display.
4. Choose Insert.

You can then publish your page to see the macro in action.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML Page’s URL</td>
<td>Yes</td>
<td>None</td>
<td>The URL of the page to include.</td>
</tr>
<tr>
<td>(url)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Enabling the HTML Include Macro
The HTML Include macro is disabled by default. You'll need Confluence Administrator or System Administrator permissions to enable this macro.

⚠️ Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks. You should only turn on these macros if you trust all your users not to attempt to exploit them. We strongly recommend leaving this macro disabled if you allow self-signed up or anonymous users to create content.

To enable the HTML Include macro:

1. Go to Administration > Manage apps
2. Select System from the drop down and search for the Confluence HTML Macros system app.
3. Expand the listing and enable the html-include (html-include-xhtml) module.

Administrators can also choose to use the allowlist to restrict URLs that can be displayed in the HTML Include macro.

Troubleshooting

- Administrators can define an allowlist of trusted URLs. If a URL is not in the allowlist, you will see an error message in the HTML Include macro.
- You can only use the HTML Include macro for pages with absolute links. If you use the macro to include an HTML page that has relative links, you will see a ‘Page Not Found’ error. See CONFSERVER-6567 - HTML Include macro should rewrite relative links to point to remote site.

Other ways to add this macro

Add this macro as you type

Type `{` followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** html-include

**Macro body:** None.

{html-include:url=http://www.example.com}
HTML Macro

This macro is available in Confluence Data Center and Confluence Cloud. Learn about the macros available in Confluence Cloud.

Add the HTML macro to a page to embed content from an external website. For example you can use this macro to embed content from your company website, or a web-based tool.

This is a legacy macro, and is often disabled by Confluence administrators for security reasons.

Security considerations

**HTML macros are disabled by default**

The HTML macro will only be available if it has been enabled by an administrator. Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks.

Add this macro to your page

To add the HTML macro to a page:

1. From the editor toolbar, choose Insert + > Other Macros.
2. Choose HTML from the Development category.
3. Choose Insert
4. Paste the HTML embed code from the website you want to display into the body of the macro.

You can then publish your page to see the macro in action.

Change the macro parameters

This macro has no parameters.

Enabling the HTML Macro

The HTML macro is disabled by default. You'll need Confluence Administrator or System Administrator permissions to enable this macro.

⚠️ Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks. You should only turn on these macros if you trust all your users not to attempt to exploit them. We strongly recommend leaving this macro disabled if you allow self-signed up or anonymous users to create content.

To enable the HTML macro:

1. Go to Administration > Manage apps.
2. Select System from the drop down and search for the Confluence HTML Macros system app.
3. Expand the listing and enable the html (html-xhtml) module.

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** html

**Macro body:** Text, consisting of HTML code.

```html
<a href="http://www.atlassian.com">Click here</a> to see the <b>Atlassian</b> website.
```
IM Presence Macro

The IM Presence macro indicates graphically when a contact is signed into an Instant Messaging (IM) service. The IM Presence macro appears as a small icon on the page.

Using the IM Presence Macro

We ended support for this macro in Confluence 7.0
The macro no longer appears in the macro browser and can't be added to a page. Any macro already on a page will still work.

Parameters

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User ID/Screen Name</td>
<td>Identify the user by their ID, account name or screen name.</td>
</tr>
<tr>
<td>Service</td>
<td>aim – AOL Instant Messenger</td>
</tr>
<tr>
<td></td>
<td>gtalk – Google Talk</td>
</tr>
<tr>
<td></td>
<td>icq – ICQ</td>
</tr>
<tr>
<td></td>
<td>jabber – Jabber</td>
</tr>
<tr>
<td></td>
<td>msn – MSN Instant Messenger</td>
</tr>
<tr>
<td></td>
<td>sametime – IBM Lotus Sametime</td>
</tr>
<tr>
<td></td>
<td>skype – Skype. Note: Skype requires 'Show my status on the web' to be checked under 'Privacy' preferences</td>
</tr>
<tr>
<td></td>
<td>skypeme – Skype</td>
</tr>
<tr>
<td></td>
<td>wildfire – Openfire Server</td>
</tr>
<tr>
<td></td>
<td>yahoo – Yahoo! Messenger</td>
</tr>
<tr>
<td>Show User ID Showid</td>
<td>Shows or hides the User ID of the contact.</td>
</tr>
</tbody>
</table>

Wiki markup example

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

Macro name: im

Macro body: None.

{im:MySkypeName|service=skype|showid=false}
Include Page Macro

Add the Include Page macro to a page to display the contents of another page or blog post in this page.

This macro is great for:

- single-sourcing instructions and procedures
- sharing useful information in multiple spaces
- all types of content reuse.

You can add multiple Include Page macros to your page, and combine them with text, images, tables and other macros.

Because you’re simply including the content of the other page, rather than duplicating it, any changes to the original automatically flow through to wherever the page is used.

The Include Page macro respects space permissions and page restrictions, so be sure to check who can view the page you’re including.

Screenshot: Meeting notes page with a reusable warning at the top.

To learn how to create a reusable content library, check out Develop Technical Documentation in Confluence.

Add this macro to your page

To add the Include Page macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Include Page from the Confluence content categories.
3. Enter the title of the page you want to include. It can be in this space, or another space.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: The Include Page macro nested within a Note macro in the editor.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.
2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Page to Include    | None    | This is the name of the Confluence page or blog post that you want to include in the current page. Start typing a page title, and Confluence will suggest matching pages from the current space and other spaces. Alternatively you can specify the page as follows:

- If the page or blog post is located in another space, add the space key and a colon in front of the page name. For example, `DOC:My page name`. The space key is case sensitive.
- To include a blog post, specify the date as well as the title of the blog post. For example: `/2010/12/01/My blog post`.
- You can include pages from personal spaces using `~username` as the space key, where 'username' is the person's username. For example, `~jsmith:My page name`.

| Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example). |

Limitations

This macro has a few limitations you need to be aware of:

- The macro respects space permissions and page restrictions. It won't display the contents of the included page to anyone who doesn't have adequate permissions to see the included page.
- The macro will include the entire page content. If you only want to display part of a page, use the **Excerpt Include Macro** instead.
- The macro can only display pages that exist in your current site. You can't use the Include Page macro to display the contents of pages in other Confluence sites.

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** include

**Macro body:** None.

```
{include:DOC:My chocolate page}
```
Info, Tip, Note, and Warning Macros

Add an Info, Tip, Note, or Warning macro to your page to make important information stand out. The macro is used to format your text in a colored panel.

As the names suggest, these macros are great for:

- Tips and tricks
- Warnings
- Important notes and other info.

You can configure this macro with or without the icon and title.

_Screenshot: examples of the Info, Note, Tip, and Warning macros on a page_

Want more control over the color of the boxes? Try the [Panel Macro](#).

Add this macro to your page

To add the Info, Tip, Note, or Warning macro to a page:

1. From the editor toolbar, choose **Insert > Other Macros**.
2. Choose either **Info**, **Tip**, **Note**, or **Warning** from the **Formatting** categories.
3. Enter a title for the panel.
4. Choose **Insert**.

You can then publish your page to see the macro in action.

_Screenshot: The Info, Tip, Note, and Warning macros in the editor_

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:
1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title <em>(title)</em></td>
<td>none</td>
<td>The title of the box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>Show information/tip/Exclamation Mark/Warning Icon <em>(icon)</em></td>
<td>true</td>
<td>If &quot;false&quot;, the icon will not be displayed.</td>
</tr>
</tbody>
</table>

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

```
{exa
Macro suggestions
  { Example macro
  --- Open macro browser
}
```

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** info/tip/note/warning

**Macro body:** Accepts rich text.

```
{info:title=This is my title|icon=false}
This is _important_ information.
{info}
```

**Using Confluence Cloud?** Head to Add formatting to your page if your info panel looks more like the one below.

```
[Info panel in the new Confluence Cloud editor](image)
```
Jira Chart Macro

Add the Jira Charts macro to a page to build visual graphs and charts from information in Jira.

This is great for:

- team meetings and retrospectives
- project status updates
- sharing updates with people in your organization who don't use Jira regularly.

The macro can display issues from any connected Jira Server, Data Center, or Cloud application, including Jira Software and Jira Service Management.

Screenshot: Meeting notes page with a Jira Chart macro showing a breakdown of all issues for a software version, by priority.

Connect Confluence and Jira

Before you can use this macro, your Confluence and Jira applications must be connected via Application Links. People viewing the page will see charts for publicly accessible issues. If your Jira application has restricted viewing (that is, people need permission to view issues) then they’ll need to authenticate before seeing the charts. This macro is compatible with Jira 5.x and later.

See Use Jira applications and Confluence together for more information.

Add this macro to your page

To add the Jira Chart macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose Jira Chart from the Development category.
3. Choose the type of report you want to create (for example Pie, Created vs Resolved)
4. Select your Jira server.
   - If you have multiple Jira servers linked to Confluence the drop down will default to the primary application link.
5. Search for issues - you can enter the query in JQL or paste a Jira URL directly into the search field.
6. Choose Preview to generate the chart.
7. Choose Display Options to further control how your chart appears.
8. Choose Insert.

You can then publish your page to see the macro in action.
To find out more about searching for issues see Displaying issues using JIRA Query Language (JQL).

Screenshot: Configuring the Jira Chart Macro in the macro browser.

Pie chart

Pie charts can be used to report on issue status, priority, assignee and more.

To further control how this chart appears on your page. Choose Display options:

- **Chart by** - select the field you want to segment the pie chart by such as:
  - Status
  - Fix version
  - Assignee name
  - Priority
  - Component
  - Issue type
- **Width** - define the total width of the chart area. You can enter values in pixels, percent or leave blank to auto fit.
- **Show border** - add a border around the chart area.
- **Show chart information** - include a text summary under the chart with the total issues count and chart by value.

Created vs Resolved chart
Created vs Resolved charts can be used to show the difference between the number of issues created versus the number of issues resolved over time.

To further control how this chart appears on your page choose **Display options**:

- **Period** - choose a time frame to report by (week, month, quarter etc).
- **Days previously** - the total number of days to report on (counting back from today).
- **Cumulative totals** - choose to progressively add totals or report individual values for each period.
- **Show unresolved trend** - add a subplot showing unresolved issues over time.
- **Show versions** - indicate version release dates as a vertical line on the chart.
- **Width** - define the total width of the chart area. Enter values in pixels, percent or leave blank to auto fit.
- **Show border** - add a border around the chart area
- **Show chart information** - include a text summary under the chart with the total issues count and chart by value.

Two Dimensional Chart

Two Dimensional Charts can be used to show issue statistics in a matrix. You can configure the X and Y axes to display these issue fields:

- Status
- Priority
- Assignee
- Fix version
- Component
- Issue type.

For example you could use the chart to show issue types by status (as shown above).

To configure the chart axes choose **Display options**:

- **X Axis** - the issue field to display on the X axis (columns).
- **Y Axis** - the issue field to display on the Y axis (rows).
- **Rows to display** - the maximum number to display in the chart.
Disable the Jira Chart macro

The functionality is provided by a system app (plugin) called 'Jira Macros'. This is also used for the Jira Issues macro. To make the macro unavailable on your site, you can disable the app. See Disabling and enabling apps.

Notes

HTTPS: The Jira Chart macro can access a Jira site running under SSL provided the Confluence server is configured to accept the Jira SSL certificate. See Connecting to LDAP or Jira applications or Other Services via SSL.

Authentication: If the query includes issues that require authentication (issues that are not visible to anonymous users in Jira), users will be prompted to authenticate to view charts on the Confluence page.

In order to search for issues in the macro browser you will need to authenticate.

Other ways to add this macro

Add this macro as you type

Type `{` followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

You can't use wiki markup to add this macro.
Jira Issues Macro

Add the Jira Issues macro to a page to display information from Jira. You can display a single issue, a list of issues, or a count, based on a JIRA Query Language (JQL) search, filter, or URL.

This is great for:

- team meetings and retrospectives
- project status updates
- release notes and customer communications
- sharing updates with people in your organization who don't use Jira regularly.

The macro can display issues from any connected Jira Server, Data Center, or Cloud application, including Jira Software and Jira Service Management.

On this page:

- Connect Confluence and Jira
- Add this macro to your page
- Displaying issues via a Jira Query Language (JQL) search
- Displaying issues via a Jira URL
- Displaying a single issue, or selected issues
- Displaying a count of issues
- Creating a new issue
- Configuring application links to display restricted issues
- Rendering HTML from Jira applications
- Disabling the Jira Issues macro
- Notes
- Other ways to add this macro

Screenshot: Project status page with a Jira issues macro showing issues that must be resolved before release.

Connect Confluence and Jira

Before you can use this macro, your Confluence and Jira application must be connected via Application Links. People viewing the page will see the publicly accessible issues from the Jira site. If your Jira site has restricted viewing (that is, people need permission to view issues) then they will need to authenticate before seeing the restricted issues.
See Use Jira applications and Confluence together for more information.

Add this macro to your page

To add the Jira macro to a page:

1. From the editor toolbar, choose Insert + > Other Macros.
2. Choose Jira from the Development category.
3. Enter a filter or search for a Jira issue.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Configuring the Jira Issues Macro to show a list of issues.

Displaying issues via a Jira Query Language (JQL) search

You can use the macro to display a table of issues on your page, based on the results of a search using JIRA Query Language (JQL).

JQL is a simple query language that is similar to SQL. A basic JQL query consists of a field, followed by an operator (such as = or >), followed by one or more values or functions.

Examples:

- The following query will find all issues in the 'TEST' project:

  ```
  project = "TEST"
  ```

- The following query will find all issues in the 'documentation' component of the 'CONF' project:

  ```
  project = CONF and component = documentation
  ```

For more information about JQL syntax, see Advanced searching in the Jira Software documentation.

To display a table of issues based on a JQL search:
1. Insert the Jira Issues macro onto your Confluence page, as described above.
2. Choose a Jira server next to the Search button.
3. If prompted, log in to the Jira server.
4. Enter the JQL query into the Search box.
5. Choose Search.
6. If you want to customize the display, choose Display options and adjust the columns and number of issues that will appear in your table of issues.
7. Choose Insert.

Screenshot: Display options in the Jira Issues macro browser.

Displaying issues via a Jira URL

You can paste any of the following Jira application URLs into the Jira Issues macro. Confluence will immediately convert the URL to a JQL search.

- Any URL for an issue search or filter.
- A URL for a single issue.
- The URL of the XML view of a search.

**Auto-convert:** You can paste URLs directly into the Confluence editor (without calling up the macro browser). Confluence will automatically convert the URL into a Jira Issues macro.

Displaying a single issue, or selected issues

To display a single Jira issue, choose one of the following methods:

- Paste the URL of the issue directly onto the Confluence page. (There is no need to use the macro browser.) Confluence will auto-convert the link to a Jira Issues macro.
- Or: Add the Jira issues macro to the page as described above, and choose Recently Viewed to see the issues you have visited recently. Select an issue and choose Insert.
- Or: Add the Jira issues macro to the page as described above, and paste the issue URL into the search box in the macro browser.
- Or: Add the Jira issues macro to the page, define your search criteria in the macro browser via JQL as described above, then select the check box next to the issue in the search results, within the macro browser.

You can choose to show just the issue key, or the issue key and a summary. Select the macro placeholder and choose Show Summary or Hide Summary.

To display a subset of Jira issues from your search results:

1. Add the Jira issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
3. Select the check boxes next to the required issues in the search results, within the macro browser.
Displaying a count of issues

You can choose to display the number of issues returned by your search, rather than a table of issues. The Jira Issues macro will display a count of issues, linked to the search in your Jira application.

Screenshot: The Jira Issues macro displaying an issue count.

To display an issue count:

1. Add the Jira Issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
3. Choose Display options, then choose Total issue count next to ‘Display options’ in the macro browser.
4. Choose Insert.

Creating a new issue

While editing a Confluence page, you can create an issue in Jira and display it on your Confluence page, without leaving the Confluence editor.

To create an issue and add it to your page:

1. Add the Jira Issues macro to the page, as described above.
2. Choose Create New Issue.
3. Supply the information about your Jira server, project, and issue, as prompted.
4. Choose Insert.

Confluence will send a request to your Jira application, to create the issue, then display the newly created issue on your page.

Limitations

The Jira Issues macro will notify you if it is unable to create an issue in the selected project. This may be because the project has a required field, field configuration or other customization that is not supported by the Jira Issues macro. In this situation you will need to create the issue directly in your Jira application.
Configuring application links to display restricted issues

Before you can use this macro, your Confluence and Jira sites must be connected via Application Links.

If the Jira site allows anonymous users to view issues, you must configure an application link, but there’s no need to configure any incoming or outgoing authentication between the Jira application and Confluence. People viewing the Confluence page will see the publicly accessible issues.

If your Jira site has restricted viewing, or if some projects or issues are restricted to viewing by certain people, then people will be prompted to Log in & Approve before seeing the restricted issues.

Rendering HTML from Jira applications

Formatted fields from Jira can be displayed in Confluence if you set up a Confluence-to-Jira application link. Otherwise, such formatted fields will be escaped within the output of the Jira issues macro. This is to prevent the possibility of malicious HTML being served by an untrusted Jira server. The most likely field where you will notice this is in the description field.

This example shows how a description column may be displayed in Jira:

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is</td>
</tr>
<tr>
<td>• the description</td>
</tr>
<tr>
<td>• of my issue</td>
</tr>
</tbody>
</table>

If there is no application link between Jira and Confluence, the description will appear in the Jira issues macro like this:

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;p&gt;This is&lt;ul&gt;&lt;li&gt;the description&lt;/li&gt;&lt;li&gt;of my issue&lt;/li&gt;&lt;/ul&gt;&lt;/p&gt;</td>
</tr>
</tbody>
</table>

Disabling the Jira Issues macro

The functionality is provided by a system app called ‘Jira Macros’. To make the macro unavailable on your site, you can disable the app. See Disabling and enabling apps.

Notes

HTTPS: The Jira Issues macro can access a Jira application running under SSL provided the Confluence server is configured to accept the Jira SSL certificate. See Connecting to LDAP or Jira applications or Other Services via SSL.

Custom fields can be added as columns to the table simply by using the name of the field with no quotes. Earlier versions of the macro required you to use the custom field id, e.g. customfield_10100.

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** jiraissues

**Macro body:** None.

This example uses a Jira filter.

```
{jiraissues:anonymous=true|url=https://jira.atlassian.com/issues/?filter=41225}
```

A number of additional parameters that are not available via the macro browser are available in storage format and wiki markup.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| anonymous      | No       | false   | If this parameter is set to 'true', your Jira application will return only the issues which allow unrestricted viewing. That is, the issues which are visible to anonymous viewers. If this parameter is omitted or set to 'false', then the results depend on how your administrator has configured the communication between the Jira application and Confluence. By default, Confluence will show only the issues which the user is authorized to view.  
**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The macro browser does not offer this parameter. |
<p>| baseurl        | No       | The value of the 'url' parameter | If you specify a 'baseurl', then the link in the header, pointing to your Jira application, will use this base URL instead of the value of the 'url' parameter. This is useful when Confluence connects to Jira with a different URL from the one used by other users. |</p>
<table>
<thead>
<tr>
<th>columns</th>
<th>No</th>
<th>By default, the following columns are shown:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>A list of Jira column names, separated by semi-colons (;). You can include many columns recognized by your Jira application, including custom columns. Some columns, such as those that need to be calculated by Jira like 'work ratio' or 'time to resolution', can't be viewed in Confluence.</td>
</tr>
<tr>
<td>count</td>
<td>No</td>
<td>false</td>
</tr>
<tr>
<td>cache</td>
<td>No</td>
<td>on</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>480 (if render mode is dynamic)</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| renderMode | No static | If the value is 'dynamic', the Jira Issues macro offers an interactive display which people can manipulate as follows:  
  - Click the column headers to sort the output.  
  - Drag and drop the columns into a different order.  
  - Temporarily remove a column from the display.  
  - View a page of issues at a time, for faster response times.  
  
  A value of 'static' will disable the dynamic display features.  
  
  **Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The macro browser does not offer this parameter. |
| title | No Jira Issues | You can customize the title text at the top of the issues table with this parameter. For instance, setting the title to 'Bugs-to-fix' will replace the default 'Jira Issues' text. This can help provide more context to the list of issues displayed.  
  
  **Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The macro browser does not offer this parameter. |
| url | Yes none | The URL of the XML view of your selected issues.  
  
  **Note:** If the URL in the 'url' parameter does not contain a `tempMax` argument, then the value of `tempMax` will default to 500. If your Jira server is version 3.12 or earlier, this means that the Jira Issues macro will return a maximum of 500 issues. If your Jira server is version 3.13 or later, a value of 500 means that the Jira Issues macro will return a maximum of 500 issues per page. |
| width | No 100% | The width of the table displaying the issues. Can be entered as a percentage (%) or in pixels (px).  
  
  **Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The macro browser does not offer this parameter. |

**Do more with Confluence and Jira**

Take displaying Jira issues to the next level, with these apps on the [Atlassian Marketplace](https):  
- **Issue Macro from Jira to Confluence**: customize the look of a single Jira Issue report or generate a well-formatted filter report  
- **Issues Forms for Confluence**: Create and display Jira issues/tickets on Confluence pages
Labels List Macro

Add the Labels List macro to a page to create a directory of all the labels used in a space. People can then click a label to see a list of all pages with that label.

This macro is great for providing an alternative way of navigating the content of a space, especially if you use Confluence for process, procedure, or other documentation.

_Screenshot: Page with a Labels List macro to help people find help guides on a particular topic_

For general information about using labels in Confluence, see Add, Remove and Search for Labels.

Add this macro to your page

To add the Labels List macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose Labels List from the Confluence content categories.
3. Enter a space key, and any labels you might want to exclude.
4. Choose Insert.

You can then publish your page to see the macro in action.

_Screenshot: The Labels List macro configured to show labels from the IT Help space, and exclude the labels ‘test’ and ‘testing’. _
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to this Space Key</strong> <em>(spaceKey)</em></td>
<td>No</td>
<td>Current space</td>
<td>The key of the space whose labels you want to display.</td>
</tr>
<tr>
<td><strong>Excluded label(s)</strong> <em>(excludedLabels)</em></td>
<td>No</td>
<td>Blank</td>
<td>The labels that you do not want to appear in the list.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (*example*).

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

```
exa
```

**Add this macro using wiki markup**
This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** listlabels

**Macro body:** None.

```none
{listlabels:spaceKey=DOC}
```
Livesearch Macro

Add the Livesearch macro to a page to provide a fully customizable search field. When someone starts typing into the search field, Confluence will suggest matching pages, blogs, or comments.

This macro is great when you want to:

- provide a way to search the current space, such as in a knowledge base
- encourage people to search for particular types of content, such as pages with a particular label.

Because you can limit the search by space, label, content type, you can provide a very targeted search experience for people viewing your space.

Screenshot: page with a Livesearch macro showing search results for the search term 'printer'

Add this macro to your page

To add the Livesearch macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose Livesearch from the Navigation category.
3. Use the parameters below to narrow down the content to be searched.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: configuring the Livesearch macro to search for pages with particular labels in a specific space.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to this Space Key</strong> (spaceKey)</td>
<td>all spaces</td>
<td>Specify a space key to limit the search to a single space. Case-sensitive. You can't specify multiple spaces. Alternatively, use @self to restrict the search to the current space.</td>
</tr>
<tr>
<td><strong>Restrict to label(s)</strong> (labels)</td>
<td></td>
<td>Specify labels to limit the search to content with that label. If unspecified will search all content regardless of label.</td>
</tr>
<tr>
<td><strong>Size</strong> (size)</td>
<td>medium</td>
<td>Choose a medium or large search field size.</td>
</tr>
<tr>
<td><strong>Placeholder text</strong> (placeholder)</td>
<td></td>
<td>Specify the placeholder text to appear in the search field, for example ‘Search this space’</td>
</tr>
<tr>
<td><strong>Type</strong> (type)</td>
<td>all</td>
<td>Specify the content types to be included in the search - choose from pages, blogs, comments, space descriptions, or all content types.</td>
</tr>
<tr>
<td><strong>Additional</strong> (additional)</td>
<td>space name</td>
<td>Display the space name, a page excerpt or nothing under the search result.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets `(example)`. 
Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** `livesearch`

**Macro body:** None.

```
{livesearch:spaceKey=DOC|size=large|placeholder=Search this space}
```
Loremipsum Macro

Add the Loremipsum macro to a page to display a paragraph of Lorem ipsum placeholder text.

This is a legacy macro, and is mostly used for demonstrating how a particular page layout or format might look with content. The text is deliberately non-meaningful so that it does not influence the viewer's perception of the page arrangement or design.

Screenshot: a page with headings and the Loremipsum macro in place of actual content.

Add this macro to your page

To add the Loremipsum macro to a page:

1. From the editor toolbar, choose Insert + > Other Macros.
2. Choose Loremipsum from the Development category.
3. Enter the number of paragraphs to include.
4. Choose Insert.

You can then publish your page to see the macro in action.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Paragraphs</td>
<td>3</td>
<td>Determines the amount of placeholder text to display. The macro will display a maximum number of 30 paragraphs. Parameter is unnamed in storage format and wiki markup.</td>
</tr>
</tbody>
</table>
Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro as you type

Type `{` followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** loremipsum

**Macro body:** None.

```{loremipsum:2}```
Multimedia Macro

Add the Multimedia macro to a page to embed an attached video, animation, or other multimedia file.

The macro uses the HTML5 `<video>` tag, so the type of video your page viewers can see depends on the video formats their browser supports with the HTML5 `<video>` tag.

This macro is great for:

- training videos
- customer interviews and research recordings
- workshop or meeting recordings.

Screenshot: a meeting notes page containing a demo video.

If you want to display online multimedia content, like YouTube and Vimeo videos, take a look at the Widget Connector Macro.

The file preview also supports MP3 audio and MP4 video files. This is handy when you want to play a video in a larger format.

Add this macro to your page

To add the Multimedia macro to a page:

1. Upload the file to your page.
2. From the editor toolbar, choose Insert ➔ Other Macros.
3. Choose Multimedia from the Media category.
4. Select the file you want to play.
5. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: configuring the Multimedia macro
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page name</strong></td>
<td>No</td>
<td>Current page</td>
<td>The name of the page to which the multimedia file is attached. Start typing the name of the page and then select it from list of suggested pages. Include the spacekey if you want to specify a page in another space (for example, MYSPACE:My Page Title)</td>
</tr>
<tr>
<td><strong>File</strong></td>
<td>Yes</td>
<td>None</td>
<td>File name of the attached multimedia file.</td>
</tr>
<tr>
<td><strong>Width</strong></td>
<td>No</td>
<td>If not specified, the browser will determine the width based on the file type.</td>
<td>Width of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's width, or any other value accepted by HTML.</td>
</tr>
<tr>
<td><strong>Height</strong></td>
<td>No</td>
<td>If not specified, the browser will determine the height based on the file type.</td>
<td>Height of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's height, or any other value accepted by HTML.</td>
</tr>
<tr>
<td><strong>Autoplay</strong></td>
<td>No</td>
<td>false</td>
<td>If the parameter is set to <strong>true</strong> then the video or audio file will start playing as soon as the page is loaded. If this option is set to <strong>false</strong> then the file will not play until the user clicks the icon or image on the page.</td>
</tr>
</tbody>
</table>
Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro as you type

Type `{` followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** multimedia

**Macro body:** None.

`{multimedia:space=DOC|page=My macros|name=ninjas.swf|autostart=true}`
Navigation Map Macro

Add the Navigation Map macro to a page to display pages tagged with a specific label in a grid layout.

This macro is great for visually representing a small set of pages with a particular label. You could:

- display all pages that have the label 'needs-review' for highlighting pages that need work
- display all pages with the label 'how-to' in your knowledge base.

If you want to get really fancy, you can style the macro by creating your own Velocity theme. This does require writing some code though.

On this page:
- Add this macro to your page
- Change the macro parameters
- Create your own navmap theme
- Other ways to add this macro

Screenshot: page with a Navigation Map macro displaying pages with the label 'printer-how-to'.

Want more flexibility? Check out the Content by Label Macro for a more modern way to display a list of pages with specific labels and more.

Add this macro to your page

To add the Navigation Map macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Navigation Map from the Navigation category.
3. Enter a label.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: specifying a label and title in the Navigation Map macro
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>none</td>
<td>Specify the label associated with the pages you want to show in the navigation map.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This parameter is unnamed in storage format and wikimarkup.</td>
</tr>
<tr>
<td>Map Title (title)</td>
<td>none</td>
<td>Specify a title for the navigation map.</td>
</tr>
<tr>
<td>Number of Cells Per Row (wrapAfter)</td>
<td>5</td>
<td>Specify the number of cells in a row</td>
</tr>
<tr>
<td>Cell Width (Pixels) (cellWidth)</td>
<td>90</td>
<td>Specify the cell width (enter a number only, don't include px)</td>
</tr>
<tr>
<td>Cell Height (Pixels) (cellHeight)</td>
<td>60</td>
<td>Specify the cell height (enter a number only, don't include px)</td>
</tr>
<tr>
<td>Navigation Map Theme (theme)</td>
<td>Confluence</td>
<td>Define a theme for the navmap. See further info below.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
Create your own navmap theme

If you want to create your own navmap 'look and feel' (for example, one with rounded corners), you need to add a customized navmap macro theme file to the WEB-INF/classes/com/atlassian/confluence/plugins/macros/advanced directory. The file name convention to use is navmap-mytheme.vm. Use the name of your choice for the mytheme part of the file name, which is also the value you use for this parameter. Hence, if your theme was called navmap-roundededges.vm, use the value of roundededges for this parameter.

The theme must be written in Velocity. See Velocity User Guide for more information.

Other ways to add this macro

Add this macro as you type

Type `{` followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** navmap

**Macro body:** None.

{navmap:mylabel|wrapAfter=4|title=My map name|cellHeight=50px|theme=navmap-mytheme.vm|cellWidth=80px}
Network Macro

The Network macro displays a list of Network activity on a Confluence page or blog post. You can specify the user whose network activity you wish to show. These interactions include the users that the specified user is following or users who are following the specified user. The Network macro shows each listed user by their profile picture. It also provides a choice of two themes and the ability to limit the number of users in the list.

Screenshot: Network macro

Using the Network macro

Parameters

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>Current user's username</td>
<td>The username of the Confluence user whose network interactions you wish to show. If no username is specified, then current user's (that is, your) network interactions are shown.</td>
</tr>
<tr>
<td>Mode</td>
<td>following</td>
<td>Determines which users are listed, with respect to the specified user:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>○ following – those who the user is following.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>○ followers – those who are following the user.</td>
</tr>
<tr>
<td>Theme</td>
<td>full</td>
<td>Determines how the user's network is displayed:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>○ full – shows a large version of user's profile pictures and, if the following mode is set, provides an entry field function to follow more users.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>○ tiny – shows only the small version of user's profile pictures.</td>
</tr>
<tr>
<td>Maximum Results</td>
<td>No limit imposed up to a maximum of 30</td>
<td>Restricts the number of users displayed. If the number of users exceeds the specified maximum, then a Show All link is provided. This link leads to the specified user's Network view, showing the complete list of network interactions.</td>
</tr>
</tbody>
</table>

Wiki markup example

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

⚠️ We ended support for this macro in Confluence 7.0
The macro no longer appears in the macro browser and can't be added to a page. Any macro already on a page will still work.
Macro name: network

Macro body: None.

```{network:followers|username=admin|max=10|theme=full}
```

Disabling the Network macro

The Network macro is provided by the 'network' module in the 'Profile Macros' system app (plugin). To remove the macro from your site, you can disable this module. See Disabling and enabling apps.
Noformat Macro

Add the Noformat macro to a page to display text in monospace font with no other formatting.

This is a legacy macro, and is similar to the Code Block Macro, but doesn't provide any additional functionality such as line numbering or syntax highlighting.

Add this macro to your page

To add the Noformat macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Noformat from the Formatting category.
3. Choose Insert.
4. Paste or type your text into the macro body.

You can then publish your page to see the macro in action.

Screenshot: the Noformat macro in the editor

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Panel (nopanel)</td>
<td>False</td>
<td>Removes the panel around the content.</td>
</tr>
</tbody>
</table>
Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** noformat

**Macro body:** Accepts plain text.

```
{nofORMAT: npanel=true}http://www.example.com{nofORMAT}
```
Office Excel Macro

Add the Office Excel macro to a page to display the contents of an Excel spreadsheet.

This is great for situations where you need more than a basic Confluence table can provide, such as for financial information or planning data.

This macro embeds your spreadsheet in the page, rather than showing a simple preview. People viewing the page don't need Excel installed to be able to see the spreadsheet.

On this page:

- Add this macro to your page
- Edit the attached file
- Change the macro parameters
- Limitations
- Other ways to add this macro

Screenshot: a page with an Office Excel macro displaying an Excel spreadsheet.

Add this macro to your page

To add the Office Excel macro to a page:

1. Upload the Excel file to your page, then publish the page. See Upload Files to learn how to do this.
2. From the editor toolbar, choose Insert > Other Macros.
3. Choose Office Excel from the Confluence content category.
4. Select the attached file you want to display.
5. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: configuring the Office Excel macro in the macro browser.

There are other ways to add a spreadsheet to your page:

- Insert the file directly into the page. We'll display a PDF thumbnail of the sheet. This is okay for simple spreadsheets but may not be suitable for complex or multi-sheet files.
- Use the Widget Connector Macro to embed a Google Sheet.
Edit the attached file

If you have Excel installed, you can edit the attached file, and automatically re-upload the file back to Confluence.

See Edit Files for more information on the ways to do this.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Name</td>
<td>The page which contains the macro</td>
<td>Enter a page name, if you wish to display a document which is attached to another Confluence page.</td>
</tr>
<tr>
<td>File Name</td>
<td>none</td>
<td>The file name of the Office or PDF document to be displayed. The document must be attached to a page on your Confluence site. If the file does not appear, publish the page, then head back into the editor and try again.</td>
</tr>
<tr>
<td>Show Grid?</td>
<td>true</td>
<td>Select to show grid lines around each cell of the Excel spreadsheet. Clear to hide these grid lines.</td>
</tr>
<tr>
<td><strong>Worksheet Name</strong></td>
<td>Last worksheet viewed in the spreadsheet</td>
<td>The name of the worksheet that you want displayed.</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td><strong>Last Row</strong></td>
<td>Last row with content</td>
<td>The number of the last row you want displayed, starting from '0' as the first row.</td>
</tr>
<tr>
<td><strong>Last Column</strong></td>
<td>Last column with content</td>
<td>The number of the last column you want displayed, starting from '0' as the first column.</td>
</tr>
</tbody>
</table>

**Hint for reducing the size of the spreadsheet:** Use the *Last Column* and *Last Row* parameters to reduce the size of the spreadsheet displayed on the wiki page. This is especially useful to prevent the display from showing empty cells. This will also help to prevent 'out of memory' errors.

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

**Limitations**

The Office file must be attached to the current page, or another Confluence page. The macro can't display live Office 365 files. If you use Office 365, you'll need to download the file, and then upload it to Confluence to display it with this macro. Alternatively, you could just link to the Office 365 file.

If your uploaded file does not appear in the *File Name* menu in the macro browser, you'll need to publish the page, and then hit **Edit** to return to the editor.

Rendering very large or complex files can put a lot of load on Confluence. For this reason, in Confluence Data Center we'll prompt you to download the file if we can't display with a set time limit. This limit varies depending on system properties set by your administrator, but is generally about 30 seconds. You can continue to view other content on the page while we attempt to display the file contents.

**Other ways to add this macro**

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** viewxls

**Macro body:** None.

```wiki
{viewxls:col=5|page=Docs|name=My document.xls|grid=false|sheet=mysheet|row=5}
```
Office PowerPoint Macro

Add the Office PowerPoint macro to a page to display the content of a PowerPoint presentation.

This is great for sharing presentations, training sessions, and other visual data.

This macro displays your presentation in a viewer with next and back buttons, rather than showing a simple preview. People viewing the page don't need PowerPoint installed to be able to see the presentation.

Screenshot: Project page with an Office PowerPoint macro.

Add this macro to your page

To add the Office PowerPoint macro to a page:

1. Upload a PowerPoint file to your page, then publish the page. See Upload Files to learn how to do this.
2. From the editor toolbar, choose Insert > Other Macros.
3. Choose Office PowerPoint from the Confluence content category.
4. Select the attached PowerPoint file you want to display.
5. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Configuring the Office PowerPoint macro.
Edit the attached file

If you have PowerPoint installed, hit the Edit icon on the macro to edit the attached file, and automatically re-upload it back to Confluence.

See Edit Files for more information on the ways to do this.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Name</td>
<td>The page which contains the macro</td>
<td>Enter a page name, if you wish to display a document which is attached to another Confluence page.</td>
</tr>
<tr>
<td>File Name</td>
<td>none</td>
<td>The file name of the PowerPoint file to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>Height</td>
<td></td>
<td>Specify the height of the display, in pixels (default) or as a percentage of the window's height.</td>
</tr>
<tr>
<td>Slide Number</td>
<td>none</td>
<td>Specify the number of the slide that you want displayed on the Confluence page, where the first slide is numbered zero. Instead of a slide show, the page will display just the single slide, represented as a JPEG image. If not specified, all slides display as a slideshow.</td>
</tr>
<tr>
<td>Width</td>
<td>Specify the width of the display, in pixels (default) or as a percentage of the window’s width.</td>
<td></td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Limitations

The Office file must be attached to the current page, or another Confluence page. The macro can't display live Office 365 files. If you use Office 365, you'll need to download the file, and then upload it to Confluence to display it with this macro. Alternatively, you could just link to the Office 365 file.

If your uploaded file does not appear in the File Name menu in the macro browser, you'll need to publish the page, and then hit **Edit** to return to the editor.

Rendering very large or complex files can put a lot of load on Confluence. For this reason, in Confluence Data Center we'll prompt you to download the file if we can't display with a set time limit. This limit varies depending on system properties set by your administrator, but is generally about 30 seconds. You can continue to view other content on the page while we attempt to display the file contents.

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** viewppt

**Macro body:** None.

```
{viewppt:height=20%|page=Docs|width=20%|name=My document.ppt|slide=4}
```
Office Word Macro

Add the Office Word macro to a page to display the contents of a Word document.

This is great for situations where you can't simply copy the content into the Confluence page, because you want to preserve formatting or other Word functionality.

This macro embeds your document in the page, rather than showing a simple preview. People viewing the page don't need Word installed to be able to see the document.

Screenshot: A page with an Office Word macro displaying a Word document with images and tracked changes.

There are other ways to add a document to your page:

- Insert the file directly into the page. We'll display a PDF thumbnail of the document.
- Use the Widget Connector Macro to embed a Google Doc.

Add this macro to your page

To add the Office Word macro to a page:

1. Upload the Word file to your page, then publish the page. See Upload Files to learn how to do this.
2. From the editor toolbar, choose Insert > Other Macros.
3. Choose Office Word from the Confluence content category.
4. Select the attached file you want to display.
5. Choose Insert.
You can then publish your page to see the macro in action.

*Screenshot: Configuring the Office Word macro in the macro browser.*

**Edit the attached file**

If you have Word installed, you can edit the attached file, and automatically re-upload the file back to Confluence.

See [Edit Files](#) for more information on the ways to do this.

**Change the macro parameters**

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page Name</strong></td>
<td>The page which contains the macro</td>
<td>Enter a page name, if you wish to display a document which is attached to another Confluence page.</td>
</tr>
<tr>
<td><strong>File Name</strong></td>
<td>none</td>
<td>The file name of the Office or PDF document to be displayed. The document must be attached to a page on your Confluence site. If the file does not appear, publish the page, then head back into the editor and try again.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
Limitations

The Office file must be attached to the current page, or another Confluence page. The macro can't display live Office 365 files. If you use Office 365, you'll need to download the file, and then upload it to Confluence to display it with this macro. Alternatively, you could just link to the Office 365 file.

If your uploaded file does not appear in the File Name menu in the macro browser, you'll need to publish the page, and then hit Edit to return to the editor.

Rendering very large or complex files can put a lot of load on Confluence. For this reason, in Confluence Data Center we'll prompt you to download the file if we can't display with a set time limit. This limit varies depending on system properties set by your administrator, but is generally about 30 seconds. You can continue to view other content on the page while we attempt to display the file contents.

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

Macro name: viewdoc

Macro body: None.

{viewdoc:page=Docs|name=My document.doc}
Page Index Macro

Add the Page Index macro to a page to create an alphabetical index of all pages in the current space.

This is a legacy macro, and does have some limitations, so it's not suitable for use in very large spaces.

In small spaces, this macro can be useful for providing a directory of pages, such as:

- project pages
- knowledge base articles
- process and procedure pages.

Add this macro to your page

To add the Page Index macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Page Index from the Navigation category.
3. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Page Index macro on a page.

Limitations

The Page Index macro can be quite memory hungry in large spaces. To prevent it causing out of memory errors in your site, we:

- don't show page excerpts when there are more than 200 pages in the space,
- don't list any pages if there are more than 1000 in the space. This limit is configurable. System Administrators can use the page.index.macro.max.pages system property to reduce the number of pages displayed.
Change the macro parameters

This macro has no parameters.

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

Macro name: index

Macro body: None.

{index}
Page Properties Macro

When used together, the Page Properties and Page Properties Report macro can be used to create a table of information drawn from multiple pages.

These macros are great for:

- Decision registers
- Status reports
- Policy and procedure documentation

In short anywhere you have several distinct pieces of information you want to be able to roll-up, and cross-reference in a table on another page.

To use this macro, you need to add a Page Properties macro on one or more pages, and then you can add a Page Properties Report macro on another page, as shown below.

Screenshot: A project page with status information presented in a Page Properties macro.

Screenshot: A page with a Page Properties Report macro showing status information from the Page Properties macro on several different project pages.

On this page:

- Add this macro to your page
- Page properties layout options
- Using multiple Page Properties macros on one page
- Change the macro parameters
- Limitations
- Other ways to add this macro

Related pages:

- Page Properties Report Macro
- Decisions Blueprint
- Product Requirements Blueprint
Add this macro to your page

There are quite a few steps involved to set up this macro correctly, but once it’s done, it’s very easy to copy the macro to other pages, or add it to a template.

To add the Page Properties macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose Page Properties from the Confluence content category.
3. Choose Insert.
4. In the macro body create a two column table
5. In the left column list your ‘properties’ – these will be the column headings in your report table.
6. Apply the Heading column style to the left column - this will indicate to the Page Properties Report macro that these are your properties.
7. In the right column list the value for each property – these will populate the rows in your report table
8. Save your page.
9. Add a label to your page - you’ll need to specify this label in the page properties report macro.

Next you need to add the Page Properties Report macro to a different page.

Screenshot: The Page Properties macro on a page in the editor, with a vertical layout.

Page properties layout options
**Horizontal or vertical layout**

You can choose to arrange the properties in your table vertically or horizontally. Just make sure you apply the **Heading row** or **Heading column** style to your properties, to tell the Page Properties Report macro, where to find them.

Here’s an example of a horizontal layout.

*Screenshot: The Page Properties macro on a page in the editor with a horizontal layout.*

**Hidden or visible**

You can choose whether the contents of the Page Properties macro should be visible when someone views the page.

This is useful when the information isn’t relevant to everyone. For example if you’re using this macro to track when a policy was last reviewed and approved, you may only want that info to be visible on the page containing the Page Properties Report macro, not the page itself.

*Screenshot: Configuring the Page Properties macro to be hidden.*

**Using multiple Page Properties macros on one page**

You can add multiple Page Properties macros on a single page, and choose whether to include all or only specific macros in the report. You might use multiple macros because you want the information in the macro to display in context with the rest of the page, or because you want to be able to report on individual Page Properties macros separately.
The Page Properties macro includes an optional ID parameter that can be used to identify specific Page Properties macros.

To show the contents of all Page Properties macros in the report:

1. Add a label to the page containing the Page Properties macros
2. Specify this label in the Page Properties Report macro

To show the contents of selected Page Properties macros in the report:

1. Add a label to the page containing the Page Properties macros
2. Specify an ID in the Page Properties macro that you want to report on
3. Specify both the label and ID in the Page Properties Report macro

**Note:** The Page Properties Report macro can only accept one page label, and one ID.

See the Page Properties macro in action in [How to document product requirements in Confluence](#). This powerful macro lets you create a summary page that pulls in information from multiple pages.

### Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page Properties ID</strong></td>
<td>(None)</td>
<td>Optional ID used to identify a particular Page Properties macro on a page. Specify this ID in the Page Properties Report to include summary information from macros with this ID only.</td>
</tr>
<tr>
<td><strong>Hidden</strong></td>
<td>False</td>
<td>Determines whether the data in the Page Properties macro will be displayed on the current page. This setting does not affect the display of the detail in the Page Properties Report macro.</td>
</tr>
</tbody>
</table>

### Limitations

- You can't use macros in the left column as the data in this column is used to populate the column headings in your Page Properties Report macro.
- It is not possible to reference the metadata using the metadata key from within the page, or anywhere else on a Confluence page.
- There's a known issue where the macro does not work correctly when placed inside an expand macro, which is inside a panel macro. See [CONFSERVER-59594](#). GATHERING IMPACT

### Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

You can't use wiki markup to add this macro.
Page Properties Report Macro

The Page Properties and Page Properties Report macro work together to enable you to show summary information from one page on another page. You can see examples of these two macros in action on the Decision and Product Requirements blueprints.

This macro was previously known as the Details Summary macro.

Adding the Page Properties Report macro to a page

To add the Page Properties Report macro to a page:

1. In the editor, choose Insert > Other Macros > Page Properties Report.
2. Enter the Labels you want to report on - this is the label added to pages containing the Page Properties macro.
3. Further narrow down your search by adding more fields, or specifying a Page Properties ID (more info on this below)
4. Choose Insert.

Here’s how the macro looks on your page:

<table>
<thead>
<tr>
<th>Title</th>
<th>Current status</th>
<th>Deadline</th>
<th>Team</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project DEF</td>
<td>Not started</td>
<td>1 June</td>
<td>Purple Monkeys</td>
</tr>
<tr>
<td>Project ABC</td>
<td>In Progress</td>
<td>15 November</td>
<td>Green Parrots</td>
</tr>
</tbody>
</table>

And here’s how you would set it up in the macro browser:
Reporting on specific Page Properties macros

It's possible to add multiple Page Properties macros on a page, and choose whether to include all or only specific macros in the report. The Page Properties macro includes an optional ID parameter that can be used to identify specific Page Properties macros.

To show the contents of:

- **Selected Page Properties macros** in the report - specify the label for the page and the ID of the particular Page Properties macro (under Options).
- **All Page Properties macros** in the report - specify just the label for the page - leave the Page Properties ID field blank.

**Note:** The Page Properties Report macro can only accept one ID.

CQL fields

CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the **Add a filter** link to add more filters to your query.

- For an OR search, specify multiple values in the same field.
  So to show pages with 'label-a', 'label-b' or both you'd put 'label-a' and 'label-b' in the same Label field, like this:

  ![Label field example]

- For an AND search, add more than one filter and specify a single value in each.
  To show only pages with label-a and label-b you'd put 'label-a' in one label field, then add a second Label field to the macro, and put 'label-b' in the second one, like this:

  ![Multiple Label fields example]
Put simply, OR values are entered in the same filter, AND values are entered in different filter. Only some filters support AND. If the filter doesn't support the AND operator, you won’t be able to add that filter more than once.

- For a NOT search, enter a minus sign (-) before the label. This’ll exclude everything with that label.

You can use the following CQL filters to build your query:

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
<th>Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label*</td>
<td>Include pages, blog posts or attachments with these labels.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AND (multiple Label filters)</td>
</tr>
<tr>
<td>With ancestor</td>
<td>Include pages that are children of this page.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td></td>
<td>This allows you to restrict the macro to a single page tree.</td>
<td></td>
</tr>
<tr>
<td>Contributor**</td>
<td>Include pages or blog posts that were created or edited by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Creator</td>
<td>Include items created by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Mentioning user</td>
<td>Include pages and blog posts that @mention these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>With parent</td>
<td>Include only direct children of this page (further sub-pages won't be included)</td>
<td>EQUALS (one page only)</td>
</tr>
<tr>
<td>In space**</td>
<td>Include items from these spaces.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td>Including text**</td>
<td>Include items that contain this text.</td>
<td>CONTAINS (single word or phrase)</td>
</tr>
<tr>
<td>With title</td>
<td>Include items that contain this text in the title.</td>
<td>CONTAINS (single word or phrase)</td>
</tr>
<tr>
<td>Of type**</td>
<td>Include only pages, blogs or attachments.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
</tbody>
</table>

* This field is required in CQL-powered macros.

** You can add these filters in CQL-powered macros but in search they're part of the standard search filters, so they don't appear in the Add a filter menu.

Macro display options

These options control how the macro appears on your page.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2023 by Atlassian. Licensed under a [Creative Commons Attribution 2.5 Australia License](https://creativecommons.org/licenses/by/2.5/au/).
### Page Properties ID

<table>
<thead>
<tr>
<th>ID</th>
<th>Blank</th>
<th>If not specified, the report will show data from all Page Properties macros on a page, where there are multiple macros. Specify an ID to include only data from Page Properties macros with the same ID.</th>
</tr>
</thead>
</table>

### Title column heading

<table>
<thead>
<tr>
<th>Heading</th>
<th>Title</th>
<th>The heading to display on the first column in the report table. This column contains links to pages displayed by the report. The default column heading is 'Title'.</th>
</tr>
</thead>
</table>

### Columns to show

<table>
<thead>
<tr>
<th>Column</th>
<th>If not specified, the report will show all columns. You can specify a comma separated list of columns to include.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>If your column heading includes commas, use double quotes around the column name. If your column heading includes quotes, use double quotes. For example, A column, &quot;My &quot;new&quot; column, yes&quot;, Third column</td>
</tr>
</tbody>
</table>

### Number of items to display

<table>
<thead>
<tr>
<th>Number</th>
<th>30</th>
<th>Number of items to display in the table before displaying pagination options for additional items.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>The macro can display a maximum of 3000 pages. System administrators can increase or decrease this limit. It is a good idea to use pagination, rather than listing all your pages in one go.</td>
</tr>
</tbody>
</table>

### Sort by

<table>
<thead>
<tr>
<th>Sort</th>
<th>Modified</th>
<th>Sort the table by a specific column heading. Enter the column name, exactly as it appears in the corresponding Page Properties macro.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Select the Reverse Sort check box to sort the table in reverse order.</td>
</tr>
</tbody>
</table>

### Show Comments Count

<table>
<thead>
<tr>
<th>Show</th>
<th>No</th>
<th>Displays the number of comments for each page in the table.</th>
</tr>
</thead>
</table>

### Show Likes Count

<table>
<thead>
<tr>
<th>Show</th>
<th>No</th>
<th>Displays the number of likes for each page in the table.</th>
</tr>
</thead>
</table>

### Troubleshooting

If your report is empty, check:

- You have entered the label correctly and that the label does appear on pages containing a Page Properties macro.
- The Page Properties macros on each page are configured correctly.
- Any other fields you have specified have not narrowed your search too far (for example there are no pages with that label under the Parent page you've specified).

### Limitations

You can enter a maximum of 60 labels in the macro browser.

The macro can display a maximum of 3000 pages. System administrators can increase or decrease this limit using the `pagePropertiesReportContentRetrieverMaxResult` system property.
Page Tree Macro

Add the Page Tree macro to a page to display all or part of the hierarchy of pages in a space.

This macro is great for providing:

- quick and easy navigation to pages about a specific project, if the pages are organised together under one parent page
- a table of contents like experience to help people navigate a set of procedures
- an overview of pages in the current part of the hierarchy in documentation spaces.

Screenshot: The Page Tree macro in Confluence showing two levels of hierarchy.

Add this macro to your page

To add the Page Tree macro to a page:

1. From the editor toolbar, choose Insert → Other Macros.
2. Choose Page Tree from the Confluence content category.
3. Choose the number of page versions to display.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Configuring the Page Tree macro to display all pages below a specific page, in another space.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Root Page**         | The home page of the space | Specify the parent page for the page tree. The tree will include all children of the given page, plus their children and grand-children etc. The tree will **not** include the root page itself.  

Specify the page title or a special value as follows:

- Your page title — to specify a page name for the parent or root of the tree. The tree will include all children and grand-children of the specified root. The tree will **not** include the specified root page itself.
- '@home' — will include all pages under the home page of the space (default).
- '@self' — will include all pages under the current page.
- '@parent' — will include all pages under the parent of the current page, including the current page.
- '@none' — will include all pages in the space, including orphaned pages and the home page. |
| **Restrict to this space key** | Current space | Enter a space name to show the page tree for a different space. Leave blank to use the current space.  

Set this parameter **before** the Root Page if you intend to specify a root page in another space. |
### Sort Pages By (sort)

- **position**
  - Specify the order to display the pages in the tree. This sort order is for display purposes only. It does not permanently re-arrange the page order. The value may be one of the following:
    - **bitwise** — sort alphabetically, for example: title1, title10, title2.
    - **creation** — sort by date of creation.
    - **modified** — sort by order of date last modified.
    - **natural** — sort in 'natural' alphabetical order, for example: title1, title2, title10.
    - **position** — sort by the default Confluence sorting rules. If your pages have been ordered manually, this sort will respect the defined order. Otherwise the pages will be displayed in the 'natural' alphabetical order, such as: title1, title2, title10.

### Include Excerpts in Page Tree (excerpt)

- **false**
  - Select if you want the page tree to show excerpts from each page. The excerpts must be defined on each page by the Excerpt macro.

### Reverse Order (reverse)

- **false**
  - Select to show the pages in reverse (descending) natural order. Must be used in combination with the Sort Pages By parameter.

### Include Search Box above Page Tree (searchBox)

- **false**
  - Select if you want to include a search box above the page tree. The search box allows your readers to search within the page tree for the specified value.

### Show Expand/Collapse Links (expandCollapseAll)

- **false**
  - Select if you want to display the 'expand all' and 'collapse all' links at the top of your page tree. Your readers can click these links to open or close all branches of the tree at once.

Available values in wikimarkup and storage format:
  - **true** — Show the 'expand all' and 'collapse all' options.
  - **false** — Do not show the options.

### Start Depth (startDepth)

- **1**
  - Enter any number greater than 0 to set how many levels of children the tree should show when it opens for the first time.

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

**Other ways to add this macro**

**Add this macro as you type**

Type `{ followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** pagetree

**Macro body:** None.

```
{pagetree:root=Page Name|sort=natural|excerpt=true|reverse=false|startDepth=3|expandCollapseAll=true|searchBox=true}
```
Page Tree Search Macro

Add the Page Tree Search macro to a page to provide users with a way to search for pages in a specific page hierarchy.

This macro is useful when you want to provide a way to search:

- one section of the current space, such as in a knowledge base
- a specific part of a page hierarchy, such as one project in a space that contains multiple projects.

After someone enters a keyword and clicks the Search button on this macro, the results are presented on Confluence's advanced search screen.

Screenshot: Page Tree Search macro on a Confluence page.

For a better search experience, check out the Livesearch Macro, or enable the integrated search field in the Page Tree Macro.

Add this macro to your page

To add the Page Tree Search macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Page Tree Search from the Confluence content category.
3. Choose the number of page versions to display.
4. Choose Insert.

You can then publish your page to see the macro in action.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.
### Parameter | Default | Description
--- | --- | ---
**Name of Root Page (root)** | none | The name of the root page whose hierarchy of pages will be searched by this macro. If this not specified, the root page is the current page.

**Note:** Unlike the Page Tree macro, the Page Tree Search macro does not accept the special values that start with an @ sign, such as @home or @self.

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

**Other ways to add this macro**

---

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

![Macro suggestions]

---

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** pagetreesearch

**Macro body:** None.

```
pagetreesearch:root=My page name
```
Panel Macro

This macro is available in Confluence Data Center and Confluence Cloud. Learn about the macros available in Confluence Cloud.

Add the Panel macro to a page to format your text in a customizable coloured panel. It's similar to the Info, Tip, Note, and Warning Macros except you have complete control over the border, background, title and text colours.

This is great for adding some visual interest to your pages. You can use panels in table cells and in page layouts, as in the example below.

Screenshot: page with a purple Panel macro containing a list of useful links.

Add this macro to your page

To add the Panel Map macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Panel from the Formatting category.
3. Enter any parameters. Leave blank for a simple white panel with a grey border.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: specifying a title, border, and background colour in the Panel macro.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panel Title (title)</td>
<td>none</td>
<td>The title of the panel. If specified, this title will be displayed in its own title row.</td>
</tr>
<tr>
<td>Border Style (borderStyle)</td>
<td>solid</td>
<td>The style of the panel's border. Accepted values are <strong>solid</strong>, <strong>dashed</strong> and other valid CSS border styles.</td>
</tr>
<tr>
<td>Border Color (borderColor)</td>
<td></td>
<td>The color of the panel's border. Colors can be specified as HTML color names or hexadecimal codes.</td>
</tr>
<tr>
<td>Border Pixel Width (Value Only) (borderWidth)</td>
<td></td>
<td>The width of the panel's border (in pixels).</td>
</tr>
<tr>
<td>Background Color (bgColor)</td>
<td></td>
<td>The background color of the panel. Colors can be specified as HTML color names or hexadecimal codes.</td>
</tr>
<tr>
<td>Title Background Color (titleBGColor)</td>
<td></td>
<td>The background color of the title row of the panel. Colors can be specified as HTML color names or hexadecimal codes.</td>
</tr>
<tr>
<td>Title Text Color (titleColor)</td>
<td></td>
<td>The color of the text in the title row of the panel. Colors can be specified as HTML color names or hexadecimal codes.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).
Available colors

You can enter the HTML or X11 name for a color such as Fuchsia, Teal, or MediumOrchid, or you can enter hexadecimal values such as \#FF00FF, \#008080, and \#BA55D3. You will need to include the \# symbol when entering a hexadecimal value. See Web colors for general information.

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.

```
{exa
Macro suggestions
  Example macro
  Open macro browser
}
```

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** panel

**Macro body:** Accepts rich text.

```
{panel:title=My title|borderStyle=dashed|borderColor=blue|titleBGColor=#00a400|titleColor=white|bgColor=#72bc72}
A formatted panel
{panel}
```

Do more in Confluence

To further customize panels, check out these apps on the Atlassian Marketplace:

- **Panelbox:** Create a set of designed panelboxes to display identical topics in the same style, keeping your pages clear and easy to read
- **Panels:** Make your intranet more interactive with a customizable panels
PDF Macro

Add the PDF macro to a page to display the content of a PDF document. First attach the document to a Confluence page, then use the macro to display the document.

This is great for sharing presentations, design documents, whitepapers, and other visual data.

This macro displays your file in a viewer, with next and back buttons, rather than showing a simple preview.

Screenshot: A page with a PDF macro displaying an A4 PDF document.

Add this macro to your page

To add the PDF macro to a page:

1. Upload the PDF file to your page, then publish the page. See Upload Files to learn how to do this.
2. From the editor toolbar, choose Insert > Other Macros.
3. Choose PDF from the Confluence content category.
4. Select the attached file you want to display.
5. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Configuring the PDF macro in the macro browser.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page Name</strong></td>
<td></td>
<td>The page which contains the macro</td>
</tr>
<tr>
<td><strong>(page)</strong></td>
<td></td>
<td>Enter a page name, if you wish to display a document which is attached to</td>
</tr>
<tr>
<td></td>
<td></td>
<td>another Confluence page.</td>
</tr>
<tr>
<td><strong>File Name</strong></td>
<td>none</td>
<td>The file name of the PDF document to be displayed. The document must be</td>
</tr>
<tr>
<td><strong>(name)</strong></td>
<td></td>
<td>attached to a page on your Confluence site.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

**Add this macro using wiki markup**

...
This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** viewpdf

**Macro body:** None.

```text
{viewpdf:page=Docs|name=My document.pdf}
```
Popular Labels Macro

Add the Popular Labels macro to a page to highlight the most popular labels used throughout your Confluence site or within a space. A popular label is a label that has been added to many pages.

This is great for surfacing labels that might be trending in your site, for example in a knowledge base.

Screenshot: The Popular Labels macro showing a heatmap of the 20 most popular labels.

For general information about using labels in Confluence, see Add, Remove and Search for Labels.

Add this macro to your page

To add the Panel Map macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Popular Labels from the Reporting category.
3. Enter any parameters and choose how you want the labels to display.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: specifying a space key, number of labels, and heatmap display style.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display</td>
<td>100</td>
<td>Specifies the total number of labels to display in the heatmap.</td>
</tr>
<tr>
<td>(count)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Restrict Labels to this Space Key</td>
<td>none</td>
<td>Restricts the list of popular labels to the specified space.</td>
</tr>
<tr>
<td>(spaceKey)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Style of Labels</td>
<td>list</td>
<td>• <strong>list</strong> – displays the popular labels as a bulleted list, ordered by popularity (highest first).</td>
</tr>
<tr>
<td>(style)</td>
<td></td>
<td>• <strong>heatmap</strong> – displays the popular labels using different font sizes for each label depending on the label's popularity, ordered by label names.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

Other ways to add this macro

Add this macro as you type

Type `{` followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** popular-labels

**Macro body:** None.

```{popular-labels:style=heatmap|count=20|spaceKey=ds}```
Profile Picture Macro

Add the Profile Picture macro to a page to display a user’s profile picture.

It's great for putting a face to the name on team and project pages.

On this page:

- Interacting with the macro on a page
- Change the macro parameters
- Other ways to add this macro

Screenshot: Page with several Profile Picture macros.

Add this macro to your page

To add the Profile Picture macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Profile Picture from the Confluence content category.
3. Enter a username.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: specifying a user in the macro browser.
Interacting with the macro on a page

When viewing a page, hover your mouse-over the picture to see the Hover Profile for the user, and choose the user's picture or name to view their user profile. When editing the page, you can also select the macro and choose View User Profile to see the profile for the user.

Screenshot: The user profile macro displaying the profile picture for a user.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

446
| **User** | none | The username of the person you want to display a profile picture for. |

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

**Add this macro using wiki markup**

You can’t use wiki markup to add this macro.
Recently Updated Dashboard Macro

Add the Recently Updated Dashboard macro to a page to show a list of pages, blogs, files, and comments that have been created or edited recently.

This is a legacy macro, and was previously used to display recently updated content on the dashboard. It is very similar to the Recently Updated Macro, except that it has a tabbed view, that lets you switch between all updates, updates from your favorite spaces, updates from your network (the people you follow), or particular space categories.

Screenshot: The Recently Updated Dashboard macro My Spaces tab showing a personalised view of recent updates in the site.

Add this macro to your page

To add the Recently Updated Dashboard macro to a page:

1. From the editor toolbar, choose Insert \( \text{+} \) > Other Macros.
2. Choose Recently Updated Dashboard from the Confluence content category.
3. Enter any parameters.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Configuring the Recently Updated Dashboard macro to show updates from specific people.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.
2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space(s)</td>
<td></td>
<td>The space which contains the page on which the macro is added. Filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here. You can specify one or more space keys, separated by commas. Use &quot;*&quot; for all spaces.</td>
</tr>
<tr>
<td>Include these Content Types Only</td>
<td>all types</td>
<td>Filter content by type. You can specify one or more types, separated by commas. Available types are: page, blogpost or news, spaced esc, attachment, comment, mail, userinfo.</td>
</tr>
<tr>
<td>Label(s)</td>
<td>none</td>
<td>Filter content by label. The macro will display only the pages etc which are tagged with the label(s) you specify here. You can specify one or more labels, separated by commas. <em>Note:</em> If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages.</td>
</tr>
<tr>
<td>User(s)</td>
<td>all users</td>
<td>Filter by username of the user who updated the content. The macro will only display content created and updated by the user(s) you specify here. You can specify one or more usernames separated by commas.</td>
</tr>
<tr>
<td>Width of Table (width)</td>
<td>100%</td>
<td>Specify the width of the macro display, as a percentage of the window width.</td>
</tr>
<tr>
<td>-----------------------</td>
<td>------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Show User Profile Pictures (showProfilePic)</td>
<td>false</td>
<td>Select whether profile pictures of the users who updated the content are displayed.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro as you type

Type `{` followed by the start of the macro name, to see a list of macros.

![Macro suggestions](image)

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** `recently-updated-dashboard`

**Macro body:** None.

```markdown
{recently-updated-dashboard:spaces=ds|users=admin|width=50%|showProfilePic=true|labels=choc|types=page}
```
Recently Updated Macro

Add the Recently Updated macro to a page to show a list of pages, blogs, files, and comments that have been created or edited recently.

This is great for:

- project landing or information pages
- team space home pages

It’s very flexible, you can limit the list to specific people, spaces, types of content, and more.

Screenshot: project landing page showing recently created and updated pages.

Add this macro to your page

To add the Recently Updated macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose Recently Updated from the Confluence content category.
3. Enter any parameters.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: configuring the Recently Updated macro to show updates from specific people in a particular space.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Author(s) by username</strong></td>
<td>None specified. That is, display all content</td>
<td>Filter the results by author. The macro will display only the pages etc which were last modified by the author(s) you specify here.</td>
</tr>
<tr>
<td><strong>(author)</strong></td>
<td></td>
<td>You can specify multiple users.</td>
</tr>
</tbody>
</table>
| **Space(s)**  
| (spaces) | `@self`  
| That is, the space which contains the page on which the macro is used | This parameter allows you to filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here.  
|  |  
| | You can specify one or more space keys, separated by a comma or a space.  
|  | • To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of `BADSPACE` you will get only content which is not in the BADSPACE.  
|  | • To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of `GOODSPACE` you will get only content in GOODSPACE.  
|  | (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)  
| Special values: |  
|  | • `@self` — The current space.  
|  | • `@personal` — All personal spaces.  
|  | • `@global` — All site spaces.  
|  | • `@favorite` — The spaces you have marked as favorite.  
|  | • `@favourite` — The same as `@favorite` above.  
|  | • `@all` — All spaces in your Confluence site.  
|  | • `*` — The same as `@all` above.  
| When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as `~jbloggs` or `~jbloggs@example.com`. |  

| **Label(s)**  
| (labels) | None specified i.e. display all content | Filter the results by label. The macro will display only the pages etc which are tagged with the label(s) you specify here.  
|  | You can specify one or more label values, separated by a comma or a space.  
|  | • To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of `-badpage` you will get only content which is not labeled with 'badpage'.  
|  | • To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of `+superpage,+goodpage` you will get only content which has at least two labels, being 'superpage' and 'goodpage'.  
| The labels parameter only applies to the page and blog content types. |  

| **Width of Table**  
<p>| (width) | 100% | Specify the width of the macro display, as a percentage of the window width. |</p>
<table>
<thead>
<tr>
<th><strong>Include these Content Types Only</strong></th>
<th><strong>All types</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>This parameter allows you to filter content by content type. The macro will display only the content of the type you specify here.</td>
<td></td>
</tr>
<tr>
<td>You can specify one or more types, separated by a comma or a space.</td>
<td></td>
</tr>
<tr>
<td>To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of -blogpost you will get pages and all other content except for blog posts.</td>
<td></td>
</tr>
<tr>
<td>Available values:</td>
<td></td>
</tr>
<tr>
<td>• page — Pages.</td>
<td></td>
</tr>
<tr>
<td>• blogpost or news — Blog posts, also known as news items.</td>
<td></td>
</tr>
<tr>
<td>• comment — Comments on pages and blog posts.</td>
<td></td>
</tr>
<tr>
<td>• attachment — Attachments.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Maximum Number of Results</strong></th>
<th><strong>15</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify the maximum number of results to be displayed. If this parameter is omitted, then a maximum of 15 results are displayed. The theoretical maximum value that this parameter can accept is 2 to the power of 31, minus 1 (or 2147483647), though this has been limited to 200 in the code, for performance reasons. More details are <a href="#">here</a>.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>theme</strong></th>
<th><strong>concise</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose the appearance of this macro:</td>
<td></td>
</tr>
<tr>
<td>• concise — the default list, showing the names of pages which were updated or commented on, the users who made the page modifications and time when the modifications occurred.</td>
<td></td>
</tr>
<tr>
<td>• social — lists recent modifications in reverse chronological order, but groups them by user into short time segments. A 'sub' list appears within each user's time segment, showing the names of pages which they updated or commented on and time when these modifications occurred.</td>
<td></td>
</tr>
<tr>
<td>• sidebar — lists recent updates in reverse chronological order, showing the names of pages which were updated or commented on and time when the page modifications occurred. This theme does not show authorship.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Show User Profile Pictures</strong></th>
<th><strong>false</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify showProfilePic=true to display the profile pictures of the users who updated the content.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Hide Title</strong></th>
<th><strong>False</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Determines whether the macro hides or displays the text ‘Recently Updated’ as a title above the list of content. Only available in wikimarkup and storage format.</td>
<td></td>
</tr>
<tr>
<td>Accepted values:</td>
<td></td>
</tr>
<tr>
<td>• true – Title is hidden.</td>
<td></td>
</tr>
<tr>
<td>• false – Title is shown.</td>
<td></td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** recently-updated

**Macro body:** None.

```markdown
[recently-updated:spaces=ds|author=admin|max=10|hideHeading=true|width=50% |theme=sidebar|showProfilePic=true|labels=choc|types=page]
```
Recently Used Labels Macro

Add the Recently Used Labels macro to a page to display a list of labels that have recently been applied to a page, blog post or attached file.

This is great for keeping track of when new topics are added to things like:

- knowledge base articles
- process and procedure documentation
- project documentation.

You can confine the search to the current space, or the entire site.

Screenshot: a page using the Recently Used Labels macro to show the list of topics applied to knowledge base articles recently.

You can also choose to configure this macro to show more detail, including the page titles and information about the user who added the label.

Add this macro to your page

To add the Recently Used Labels macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose Recently Used Labels from the Confluence content category.
3. Enter any parameters.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: configuring the Recently Used Labels macro to show 35 recently applied labels.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display</td>
<td>10</td>
<td>Specifies the total number of labels to display in the list.</td>
</tr>
<tr>
<td>(count)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scope for Retrieving Labels</td>
<td>global</td>
<td>Specifies the scope of labels to be displayed in the list. Valid values</td>
</tr>
<tr>
<td>(scope)</td>
<td></td>
<td>include:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>•    global — covers all site spaces (non-personal) in the Confluence</td>
</tr>
<tr>
<td></td>
<td></td>
<td>installation.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>•    space — the current space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>•    personal — your own personal space.</td>
</tr>
<tr>
<td>List Style (style)</td>
<td>list</td>
<td>•    list — displays the list of labels horizontally.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>•    table — includes additional information such as the page to which the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>label was added and the user who added it.</td>
</tr>
<tr>
<td>Table Title (title)</td>
<td>none</td>
<td>Adds a title to the top of the list in table style. Titles are only visible</td>
</tr>
<tr>
<td></td>
<td></td>
<td>when the List Style parameter has been set to table.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro
Add this macro as you type

Type `{` followed by the start of the macro name, to see a list of macros.

```
| exa
| Macro suggestions
| Example macro
| Open macro browser
```

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** recently-used-labels

**Macro body:** None.

```
{recently-used-labels:title=My title|scope=space|style=table|count=20}
```
Related Labels Macro

Add the Related Labels macro to give people a way to navigate to related content in your site.

It works by finding labels that pages have in common. It takes the label used on the current page, looks for other pages that use this label, and then lists any other labels that are found on those pages.

This macro is great for:

- Knowledge base articles
- Process and procedure documentation.

Basically any situation where you want a map of related pages in your site. The list updates automatically, as labels are added and removed from pages over time.

Screenshot: the Related Labels macro guiding people to related articles in a knowledge base.

Add this macro to your page

To add the Related Labels macro to a page:

1. From the editor toolbar, choose Insert ➤ Other Macros.
2. Choose Related Labels from the Confluence content category.
3. Enter specific labels the macros should look for, or leave blank to use any labels on the page.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: configuring the Related Labels macro in the macro browser.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to these Labels</strong></td>
<td>none</td>
<td>Specify the labels for which you want to view related labels. For example, documentation, how-to.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

**Add this macro as you type**

Type `{ ` followed by the start of the macro name, to see a list of macros.

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** related-labels
Macro body: None.

{related-labels:labels=choc,cake}
Roadmap Planner Macro

Add the Roadmap Planner macro to a page to create a simple, visual timeline that's useful for planning projects, software releases and much more.

Roadmaps are made up of:

- **bars** to indicate phases of work
- **lanes** to differentiate between teams, products or streams
- **markers** to highlight important dates and milestones
- a **timeline** showing months or weeks.

You can provide more information about items on your roadmap by linking a bar to a page.

*Screenshot: Page with a Roadmap Planner macro showing the various stages of a project.*

**Add this macro to your page**

To add the Roadmap Planner macro to a page:

1. From the editor toolbar, choose **Insert** > **Other Macros**.
2. Choose **Roadmap Planner** from the **Visuals and images** category.
3. **Add** lanes, bars and markers as described below.
4. **Choose Insert**.

You can then publish your page to see the macro in action.

**Editing your Roadmap**

To **edit your roadmap**:

- Select the roadmap and choose **Edit**.
- **Add** lanes, bars and markers.
- Drag lanes, bars and markers to the desired location on the roadmap.
- Select lanes, bars and markers to add text, change colors and remove from the roadmap.
- Select bars to add links to existing pages, create new pages or add a description.
- Set the start and end dates for the roadmap and choose to display it by weeks or months.

*Screenshot: Adding bars and markets to the Roadmap Planner macro in the editor.*
1. **Add lanes:** to differentiate your teams or streams of work.
2. **Date range:** display the plan by weeks or months.
3. **Add bar info:** to provide more info or link a bar to a page.

**Change the macro parameters**

This macro does not use the macro browser to set parameters. You also cannot add this macro via wiki markup or by editing the storage format directly.

**Other ways to add this macro**

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

![Macro suggestions](image)

**Add this macro using wiki markup**

You can't use wiki markup to add this macro.

**Notes**

The Roadmap macro was previously available from [The Marketplace](https://marketplace.atlassian.com). The macro has changed significantly. If you had an older version of the macro installed you will be able to view your existing roadmaps but not edit them.

---

**Do more with Confluence**

To extend Confluence's roadmap capability, check out these apps on the [Atlassian Marketplace](https://marketplace.atlassian.com):

- **Live Roadmap:** Build your Roadmap and keep it alive connecting it to your Jira
- **ProductPlan for Confluence Server:** Embed your roadmap in Confluence to keep your team aligned around high-level goals
RSS Feed Macro

Add the RSS Feed macro to a page to display the contents of an external or internal RSS feed. For example, to display blog posts or to list recently updated pages in a space, you can create an internal feed in the Feed Builder, then render it using this macro.

This is a legacy macro, and is often disabled by Confluence administrators for security reasons.

Security considerations

The RSS Feed macro may be disabled by your Confluence administrator. Also, your Confluence administrator can define a list of trusted URLs. You will see an error message on the Confluence page, if the included URL is not in the allowlist.

CAUTION: Including unknown HTML inside a webpage is dangerous.

HTML inside an RSS feed can contain active scripting components. This means that it would be possible for a malicious attacker to present a user of your site with script that their web browser would believe came from you. Such code could be used, for example, to steal a user's authentication cookie and give the attacker their Confluence login password.

Add this macro to your page

To add the RSS Feed macro to a page:

1. From the editor toolbar, choose Insert + > Other Macros.
2. Choose RSS Feed from the External content category.
3. Enter the RSS feed URL.
4. Choose Insert.

You can then publish your page to see the macro in action.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.
Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSS Feed URL (url)</td>
<td>none</td>
<td>The URL of the RSS feed link you want to show.</td>
</tr>
<tr>
<td>Maximum Number of Entries (max)</td>
<td>15</td>
<td>Limit the number of entries displayed.</td>
</tr>
<tr>
<td>Show Item Titles Only (showTitlesOnly)</td>
<td>false</td>
<td>Show only the titles of the news items, not the content.</td>
</tr>
<tr>
<td>Show Name/Title of RSS Feed (titleBar)</td>
<td>true</td>
<td>Hide the feeds title bar.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

How up to date is the feed?

By default, the RSS Feed macro caches the feed results for 60 minutes before fetching the data again.

If you wish to change the default caching, use the Cache macro to define how often the RSS Feed macro fetches the feed updates. You will need to install the Cache plugin onto your Confluence site.

What happens to a page containing a disallowed URL?

Your Confluence Administrator can set up an allowlist of allowed URLs. If this is the case, you may see an error on the pages which contain the RSS Feed macro.

A user can add the RSS Feed macro or the HTML-include macro to a Confluence page. The macro code includes a URL from which the content is drawn. When the page is displayed, Confluence will check the URL against the allowlist. If the URL is not allowed, Confluence will display an error message on the page.

The error message says that Confluence "could not access the content at the URL because it is not from an allowed source" and displays the offending URL. If the person viewing the page is a Confluence Administrator, they will also see a link to the Administration page where they can configure the URL allowlist.

Here is an example of the error message, including the link shown only to Confluence Administrators:

Could not access the content at the URL because it is not from an allowed source.

atlassian.com

Configure allowlist >>

Here is an example of the error message, but without the link.

Could not access the content at the URL because it is not from an allowed source.

http://feathers.wordpress.com

You may contact your site administrator and request that this URL be added to the list of allowed sources.

Authentication

Private feeds from external sites
RSS feeds which require authentication cannot be accessed using the RSS Feed macro.

**Accessing internal HTTPS feeds**

This applies only to Confluence instances which have enabled HTTPS for all content. If your site is fully HTTPS, the RSS Feed macro cannot access internal feeds. To enable the RSS Feed macro to access internal feeds without affecting your HTTPS setup, enable local-only HTTP access:

1. Shut down Confluence.
2. Consult the SSL guide to enable HTTP access to Confluence. You'll want to ensure that you have an HTTP connector and an SSL connector, both commented in. This means that Confluence will be accessible via both HTTP and HTTPS. However, you should not have a redirect port, nor rules in web.xml to redirect all traffic.
3. Instead of using web.xml to redirect traffic, insert a firewall rule to redirect all HTTP requests not from the Confluence server to the equivalent HTTPS URL. This ensures that users will only be able to access Confluence via HTTPS, as intended. If you have still left HTTP access for attachments enabled (to avoid the IE download bug) you must selectively enable those URLs as well.
4. Modify your Confluence RSS Feed macro feed link to use the HTTP URL, and restart Confluence.

**Enable or disable the RSS Feed macro**

To enable or disable the RSS Feed macro:

1. Go to Administration > Manage apps.
2. Select System from the drop down and search for the Confluence HTML Macros system app.
3. Expand the listing and enable or disable the rss (rss-xhtml) module.

**Other ways to add this macro**

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

```markdown
{rss:max=10|showTitlesOnly=true|url=http://myblog.com/feed|titleBar=false}
```

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** rss

**Macro body:** None.

```markdown
{rss:max=10|showTitlesOnly=true|url=http://myblog.com/feed|titleBar=false}
```
Search Results Macro

Add the Search Results macro to a page to display the results of a pre-defined search.

Add this macro to your page

⚠️ We ended support for this macro in Confluence 7.0
The macro no longer appears in the macro browser and can't be added to a page.
Any macro already on a page will still work.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Terms (query)</td>
<td>none</td>
<td>The search terms which this macro will use to generate its results. You can refine your search query by using operators such as 'AND' and 'OR'. For example: my_query1 AND my_query2. For more information, take a look at the documentation on the Confluence search syntax.</td>
</tr>
<tr>
<td>Maximum Number of Results (maxLimit)</td>
<td>10</td>
<td>Set a limit to the number of search results displayed.</td>
</tr>
<tr>
<td>Restrict to this Space Key</td>
<td>all</td>
<td>Start typing the space name to find the space, or specify the key of the space you want to search in. Note that the key is case sensitive.</td>
</tr>
<tr>
<td>Content Type (type)</td>
<td>all</td>
<td>Specify the content type. The content types are: page, comment, blogpost, attachment, userinfo (the content of user profiles only) and spacedesc (the content of space descriptions only).</td>
</tr>
</tbody>
</table>
### Last Modified (lastModified)

<table>
<thead>
<tr>
<th>all</th>
<th>Specify a period of time in weeks, days, hours and/or minutes, to see the content modified within that time frame. These are the values you can use:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• w = weeks</td>
<td>• d = days</td>
</tr>
<tr>
<td>• h = hours</td>
<td>• m = minutes</td>
</tr>
</tbody>
</table>

For example:

- 2h 35m
- 3d 30m

Notes:

- If no time category is specified, Confluence assumes minutes.
- If you specify more than one time period (for example, weeks and days), you must separate the periods with a space. You can put them in any order.
- The time categories are not case sensitive. For example, '4d' is the same as '4D'.

### Restrict to this Username (contributor)

| all | Specify the username of a Confluence user, to show only content created or updated by that user. |

Notes:

**Permissions:** When a user views the page containing the Search Results macro, the search results will show only pages and other content types for which the user has 'View' permission.

**Other ways to add this macro**

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** `search`

**Macro body:** None.

```
{search:lastModified=3w|query=choc|contributor=admin|maxLimit=10|type=page|spacekey=ds}
```
Section Macro

Add the Section macro to a page to organise your content in sections and columns. This macro is used in conjunction with the Column macro, and provides more flexibility than page layouts.

This macro is great for situations where:

- you need more than three columns, or
- you need your columns to be a specific width.

Screenshot: page with a four column layout using the Section and Column macros.

Add this macro to your page

To add the Section macro to a page:

1. From the editor toolbar, choose **Insert** $\rightarrow$ **Other Macros**.
2. Choose **Section** from the **Formatting** category.
3. Choose **Insert**.

You can then start typing into the macro body, add some **Column macros**, then publish your page to see the macro in action.

Screenshot: section and column macros in the editor

On this page:

- Add this macro to your page
- Change the macro parameters
- Other ways to add this macro

Tip: Want a simpler way to lay out your page? Try a [page layout](https://confluence.example.com) instead.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Border</td>
<td>false</td>
<td>Select this option to draw a border around the section and columns.</td>
</tr>
<tr>
<td>(border)</td>
<td></td>
<td><strong>Note:</strong> Without a Column macro, the border will not be displayed correctly.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** `section`
**Macro body:** Rich text, consisting of one or more Column macros.

```mermaid
{section:border=true}
{column:width=100px}
This is the content of *column 1*.
{column}
{column}
This is the content of *column 2*.
{column}
{section}
```
Space Attachments Macro

Add the Space Attachments macro to a page to display a list of all files attached to pages in the current space, or another space.

This is great for:

- design assets
- frequently used files, like forms
- image libraries.

It shows details of the file and the includes a link to the page the file is attached to. Filter the list by label or file extension to find the file you’re looking for more easily.

**Screenshot: A page containing the Space Attachments macro, to provide quick access to files used in a project.**

To add the Space Attachments macro to a page:

1. From the editor toolbar, choose **Insert** > **Other Macros**.
2. Choose **Space Attachments** from the **Confluence content** category.
3. Enter any parameters.
4. Choose **Insert**.

You can then publish your page to see the macro in action.

**Screenshot: Configuring the Space Attachments macro to only show files attached to pages in a specific space.**
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.
2. Update the parameters as required then choose **Insert**.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>(none)</td>
<td>Selects the Confluence space to display attachments for. If you do not specify a space, the current space will be used.</td>
</tr>
<tr>
<td>Show Filter Controls</td>
<td>true</td>
<td>Determines whether or not the filter panel is shown. If you select this option, people viewing the page will be able to filter the list of attachments by file type (extension) and by label.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

Other ways to add this macro

*Add this macro as you type*

Type `{` followed by the start of the macro name, to see a list of macros.

*Add this macro using wiki markup*
This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** space-attachments

**Macro body:** None.

```
{space-attachments:showFilter=false|space=ds}
```
Space Details Macro

The Space Details macro displays the details of a Confluence space, including the space name, description, and more.

Add this macro to your page

⚠️ We ended support for this macro in Confluence 7.0
The macro no longer appears in the macro browser and can't be added to a page. Any macro already on a page will still work.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Width of Table</strong></td>
<td>100%</td>
<td>The width of the space details table, specified as a percentage (%) of the page width.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** space-details

**Macro body:** None.

```
{space-details:width=50%}
```
Spaces List Macro

Add the Spaces List macro to a page to display a list of spaces on a page.

This is legacy macro. It was previously used in the dashboard, and has been known to cause issues large sites. Although limited, this macro is great if you want to:

- highlight spaces that have been created in the last 7 days
- provide a list of spaces, that can be filtered by space category.

On this page:

- Add this macro to your page
- To add the Spaces List macro to a page:
- Change the macro parameters
- Troubleshooting
- Other ways to add this macro

Screenshot: Page with a Spaces List macro showing cross-team spaces.

This macro works best with space categories. See Use Labels to Categorize Spaces to find out how to categorize spaces in your site.

Add this macro to your page

To add the Spaces List macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Spaces List from the Confluence content category.
3. Enter any parameters.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Configuring the spaces list macro to show spaces by category.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.
2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scope of spaces</td>
<td>no</td>
<td>all</td>
<td>The view from which spaces are listed. Available options are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• (blank) - All spaces in your site, with tabs.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• all – All spaces in your Confluence site.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• category – Spaces grouped according to space categories.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• favorite – Spaces which you have added to My Spaces.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• new – spaces created within the last 7 days.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>This parameter is unnamed in wiki markup and storage format.</td>
</tr>
<tr>
<td>Width of List (width)</td>
<td>no</td>
<td>100%</td>
<td>The width of the spaces list, specified as a percentage (%) of the window width.</td>
</tr>
<tr>
<td>Include archived spaces</td>
<td>no</td>
<td>False</td>
<td>Include spaces that have been archived in the list. These are excluded by default.</td>
</tr>
<tr>
<td>(includeArchivedSpaces)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (`example`).

**Troubleshooting**
This macro is known to cause issues in sites with large number of spaces. See

[CONFSERVER-59804 - Using the Spaces List macro in a Confluence Page may overload the database](CONFSERVER-59804)

This macro is provided by the Dashboard Macros system app. Disable the Spaces module if you want to prevent people using this macro.

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

- `exa`
- `Macro suggestions`
- `Example macro`
- `*** Open macro browser`

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** spaces

**Macro body:** None.

```markdown
{spaces:favourite|width=80%}
```
**Status Macro**

Add the Status macro to a page to highlight the status of a project, task, or item with a colored lozenge (rounded box).

This macro is great for indicating:

- items that are problematic or removed
- a successful project
- tasks that are in progress.

You can choose a solid or light background color for the lozenge and the text that appears inside the lozenge. The macro displays its current status directly in the editor.

**Screenshot: Status macros in a table highlighting important tasks, actions, and items.**

Using the Status macro

To add the Status macro to a page:

1. From the editor toolbar, choose **Insert ➤ Other Macros**.
2. Choose **Status** from the **Confluence content** category.
3. Enter a status and choose a color.
4. Choose **Insert**.

You can then publish your page to see the macro in action.

**Screenshot: Selecting lozenge colour in the Status macro.**
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color (colour)</td>
<td>Grey</td>
<td>The color of the lozenge. The following colors are available: Grey, Red, Yellow, Green and Blue.</td>
</tr>
<tr>
<td>Title (title)</td>
<td></td>
<td>The text that will appear inside the lozenge. If you do not specify any text, the title will be the color of the lozenge, that is 'Grey', 'Red', 'Yellow', 'Green' or 'Blue'.</td>
</tr>
<tr>
<td>Use lighter lozenge color (subtle)</td>
<td>False</td>
<td>The lozenge background color and text color. The default lozenge style is a solid background color with white text. Select this parameter to use a lighter lozenge background color with colored text.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** status

**Macro body:** None.

```
{status:colour=Green|title=On track|subtle=true}
```

**Do more with Confluence**

For more customizable status macros check out these apps on the Atlassian Marketplace:

- **Build Status Tracker for Confluence:** Provide visibility on build status from Bamboo or Jenkins on your Confluence pages
- **Spectrum Formatting Macros:** Show a page status as a draft, as outdated, as action required or as official
Table of Contents Macro

Add the Table of Contents macro to a page to help your readers skip directly to the information they’re looking for.

This macro is great for situations where:

- you have a large page with lots of information
- you want to build your headings into a neat table of contents.

This macro is popular because it helps you navigate lengthy pages. The macro organises your table of contents by nesting Heading 2 under Heading 1, and indenting progressively, like in the image below.

*Screenshot: Table of Contents macro neatly organises lengthy blog content.*

Using the Table of Contents macro

To add the Table of Contents macro to a page:

1. From the editor toolbar, choose **Insert > Other Macros**.
2. Choose **Table of Contents** from the **Confluence content** category.
3. Enter any parameters.
4. Choose **Insert**.

You can then publish your page to see the macro in action.

*Screenshot: Entering parameters for the Table of Contents macro.*
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.
2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Output Type</strong></td>
<td>list</td>
<td>- list — produces a typical list-type table of contents.</td>
</tr>
<tr>
<td>(type)</td>
<td></td>
<td>- flat — produces a horizontal menu-type series of links.</td>
</tr>
<tr>
<td><strong>Display Section Numbering</strong></td>
<td>clear</td>
<td>Select the check box to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.</td>
</tr>
<tr>
<td>(outline)</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>List Style</strong></td>
<td>default</td>
<td>Select the style of bullet point for each list item. Enter any valid CSS style, such as:</td>
</tr>
<tr>
<td>(style)</td>
<td></td>
<td>- default - matches Confluence's default bullet style which uses a different style for each level</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- none — no bullet</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- disc — a filled circle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- circle — an open circle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- square — a square</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- decimal — a numbered list (1, 2, 3, 4, 5)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- lower-alpha — a lower-case, alphabetical list (a, b, c, d, e)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- lower-roman — a lower roman numeral list (i, ii, iii, iv, v, vi)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- upper-roman — an upper roman numeral list (I, II, III, IV, V, VI)</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Heading Indent (indent)</td>
<td>Sets the indent for a list according to CSS quantities. Entering 10px will successively indent heading groups by 10px. For example, level 1 headings will be indented 10px and level 2 headings will be indented an additional 10px.</td>
<td></td>
</tr>
<tr>
<td>Separator (separat or)</td>
<td>This parameter applies to flat lists only. You can enter any of the following values:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- <strong>brackets</strong> — Each item is enclosed by square brackets: [ ].</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- <strong>braces</strong> — Each item is enclosed by braces: { }.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- <strong>parens</strong> — Each item is enclosed by parentheses: ( ).</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- <strong>pipe</strong> — Each item is separated by a pipe:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- <strong>anything</strong> — Each item is separated by the value you enter. You can enter any text as a separator, for example &quot;**&quot;. If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters.</td>
<td></td>
</tr>
<tr>
<td>Minimum Heading Level (minLevel )</td>
<td>Select the highest heading level to start your TOC list. For example, entering 2 will include levels 2, and lower, headings, but will not include level 1 headings.</td>
<td></td>
</tr>
<tr>
<td>Maximum Heading Level (maxLevel )</td>
<td>Select the lowest heading level to include. For example, entering 2 will include levels 1 and 2, but will not include level 3 headings and below.</td>
<td></td>
</tr>
<tr>
<td>Include Headings (include)</td>
<td>Filter headings to include according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.</td>
<td></td>
</tr>
<tr>
<td>Exclude Headings (exclude)</td>
<td>Filter headings to exclude according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings.</td>
<td></td>
</tr>
<tr>
<td>Printable (printable)</td>
<td>By default, the TOC is set to print. If you clear the check box, the TOC will not be visible when you print the page.</td>
<td></td>
</tr>
<tr>
<td>CSS Class Name (class)</td>
<td>If you have custom TOC styles in your CSS style sheet, use this parameter to output the TOC inside &lt;div&gt; tags with the specified class attribute.</td>
<td></td>
</tr>
<tr>
<td>Absolute URL (absolut eUrl)</td>
<td>By default, the links in the TOC are relative URLs pointing to the current page. If checked, the links in the TOC will be full URLs. This setting is useful when you are including a page with a Table of Contents in another page, and want to control where the links should take the user.</td>
<td></td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets ([example]).

**Examples**

The examples below are based on this table of contents:
Filtered Table of Contents

This example filters the headings to include those that contain 'Favorite', but excludes headings which end with 'Things'. The list is styled with Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td>.*Things</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

I. Favourite Places
   II. Favourite Foods

Flat List

This example filters all headings to render a flat list of 'Unknowns' enclosed in square brackets (the default list style).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Maximum Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** toc

**Macro body:** None.

This example shows a list-type table of contents.

```markdown
{toc:printable=true|style=square|maxLevel=2|indent=5px|minLevel=2|class=bigpink|exclude=[1//2]
|type=list|outline=true|include=.*}
```

This example shows a flat table of contents.

```markdown
{toc:printable=true|maxLevel=2|minLevel=2|class=bigpink|exclude=[1//2]
|type=flat|outline=true|separator=pipe|include=.*}
```

Notes and known issues

- When you use a Table of Contents macro in a **template**, you will see an error when you preview the template itself. But the Table of Contents macro works on the pages that people create from the template – the table of contents shows up after they have saved the page. (This is probably because the template is not defined as a page, and the Table of Contents macro works for pages only.)

- The Table of Contents macro only displays page or blog post content. You can't use it to add a table of contents of headings in a comment for example.

- Due to an outstanding issue in the Table of Contents macro (CONF-10619), the macro browser's **Refresh** function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Contents macro occurs only after the page is saved.

- **Using HTML heading markup with the Table of Contents macro**

  The Table of Contents macro cannot handle HTML heading markup on its own. Hence, if you use the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Contents macro will not create a contents list out of these headings. However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Contents macro will incorporate these headings into your contents list.

  ```html
  <h2><a name="pagename-headingname"></a>Heading Name</h2>
  ```

  The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

- There is a known issue where if you click a heading in the Table of Contents macro, then click the back button in your browser, you won't be returned to the table of contents (or to your previous page). As a workaround, use the **Table of Content Zone Macro**. See CONFSERVER-40462 GATHERING IMPACT and CONFSERVER-52497 GATHERING IMPACT for more information.
Do more with Confluence

Extend Confluence with one of the hundreds of other macros in the Atlassian Marketplace. Here’s some specific to documentation:

- **Scroll Office for Confluence** - turn your Confluence pages into professionally styled documents
- **Advanced Children Display for Confluence** - combine Confluence’s built-in children display and table of contents macros
Table of Content Zone Macro

Add the Table of Content Zone macro to a page to display a table of contents from a defined section of the page.

This macro is great for:

- creating a table of contents from sections of a page
- having multiple table of contents throughout a very long page.

You’ll have to create a table of contents for headings within the body of the macro.

Screenshot: The Table of Content Zone macro configured with flat Output Type.

Add this macro to your page

To add the Table of Content Zone macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose Table of Content Zone from the Confluence content category.
3. Enter any parameters.
4. Choose Insert.
5. Add or paste your content into the macro body. The headings within the macro will be included in the table of contents.

You can then publish your page to see the macro in action.

Screenshot: Entering headings within the body of the Table of Content Zone macro.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose **Edit**.

2. Update the parameters as required then choose **Insert**.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>location (location)</td>
<td>both</td>
<td>Specifies where in the zone the output list is displayed: <strong>top</strong>, <strong>bottom</strong>, or <strong>both</strong>, which encloses the page zone content.</td>
</tr>
<tr>
<td>Output Type (type)</td>
<td>list</td>
<td>Specifies the layout for the table of contents:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>list</strong> – produces a vertical list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>flat</strong> – produces a horizontal menu-type series of links, for example: [Heading 1] [Heading 2] [Heading 3].</td>
</tr>
<tr>
<td>Display Section Numbering (outline)</td>
<td>false</td>
<td>Select to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.</td>
</tr>
<tr>
<td>Table of Contents Settings</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>---------------------------</td>
<td>-------------</td>
<td></td>
</tr>
</tbody>
</table>
| **List Style (style)**    | default | Select the style of bullet point for each list item. Enter any valid CSS style, such as:
  - default - matches Confluence's default bullet style which uses a different style for each level
  - none — no bullet
  - disc — a filled circle
  - circle — an open circle
  - square — a square
  - decimal — a numbered list (1, 2, 3, 4, 5)
  - lower-alpha — a lower-case, alphabetical list (a, b, c, d, e)
  - lower-roman — a lower roman numeral list (i, ii, iii, iv, v, vi)
  - upper-roman — an upper roman numeral list (I, II, III, IV, V, VI) |
| **Heading Indent (indent)** | | Sets the indent for a list output type, according to CSS quantities. Entering "10px" will successively indent list heading levels by 10px. For example, h1 headings will be indented 10px and h2 headings will be indented an additional 10px. |
| **Separator (separator)** | brackets | Only applies to the flat output type. Specifies the display style of the links. You can enter any of the following values:
  - brackets — Each item is enclosed by square brackets: [ ].
  - braces — Each item is enclosed by braces: { }.
  - parens — Each item is enclosed by parentheses: ( ).
  - pipe — Each item is separated by a pipe:
  - anything — Each is separated by the value you enter. You can enter any text as a separator, for example "***". If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters. |
| **Minimum Heading Level (minLevel)** | 1 | Select the largest heading level to start your list. For example, 2 will list h2, h3, and h4 headings, but will not include h1 headings. |
| **Max Heading Level (maxLevel)** | 7 | Select the smallest heading level to include in the table of contents. For example, 2 will list h1 and h2, but will not include h3 and below. |
| **Include Headings (include)** | | Filter the included headings according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings. |
| **Exclude Headings (exclude)** | | Exclude headings according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings. |
| **Printable (printable)** | true | By default, the table of contents is set to print. If you clear this parameter, the table of contents will not be visible when you print the page. |
| **CSS Class Name (class)** | | If you have a custom table of contents in your CSS style sheet, you can use this parameter to output the table of contents with the specified "class" attribute. |
Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Examples

The examples are based on a page with the following headings:

- **Places**
  - Favourite Places
  - Unknown Places
- **Foods**
  - Favourite Foods
  - Unknown Foods
- **Things**
  - Favourite Foods
  - Unknown Foods

Filtered Table of Contents

This example will filter all headings to include those that contain "Favorite", but will exclude any heading which ends with the word "Things". The list is styled with upper-case Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>list</td>
</tr>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td>.*Things</td>
</tr>
</tbody>
</table>

*Screenshot: Filtered TOC 'zone' headings*

I. Favourite Places
II. Favourite Foods

Flat List

This example will filter all headings to render a flat list of "Unknowns" enclosed in square brackets.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Separator</td>
<td>brackets</td>
</tr>
<tr>
<td>Max Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

*Screenshot: Filtered TOC 'zone' headings displayed as a flat list*
Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** `toc-zone`

**Macro body:** Accepts rich text.

```
{toc-zone:printable=false|maxLevel=2|minLevel=2|location=top|type=flat|outline=true|separator=pipe}
Only headings within this block are included in the table of contents.
{toc-zone}
```

Troubleshooting

Using HTML heading markup with the Table of Content Zone macro — The Table of Content Zone macro cannot handle HTML heading markup on its own. Hence, if you used the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Content Zone macro will not create a contents list out of these headings.

However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Content Zone macro will incorporate these headings into your contents list.

```
<h2><a name="pagename-headingname"></a>Heading Name</h2>
```

The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.
Task Report Macro

Add the Task Report macro to a page to display a list of tasks. Filter the tasks by space, page, user, label, created date and more.

This macro is great for:

- meeting notes
- status reports
- project planning pages.

See Add, Assign, and View Tasks for more information on creating and assigning tasks. You can also use the Task Report blueprint, which will create a page and add this macro for you.

On this page:

- Add this macro to your page
- Change the macro parameters
- Other ways to add this macro

Related pages:

- Add, Assign, and View Tasks

Screenshot: The Task Report macro showing incomplete tasks on a meeting notes page.

Add this macro to your page

To add the Task Report macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Task Report from the Confluence content category.
3. Enter any parameters.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Configuring the Task Report macro to show tasks from a specific space.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space(s) and Page(s)</td>
<td>No</td>
<td>None</td>
<td>Filter by the task location. The macro will only display tasks in the spaces or parent pages (and their child pages) specified. You can enter a combination of spaces and pages.</td>
</tr>
<tr>
<td>(spaceAndPage)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Label(s)</td>
<td>No</td>
<td>None</td>
<td>Filter by Label. The macro will only display tasks on pages with at least one of the specified labels (for example, 'label-a' OR 'label-b'). Enter multiple labels, separated by a comma.</td>
</tr>
<tr>
<td>(labels)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assigned to</td>
<td>No</td>
<td>None</td>
<td>Filter by Assignee. The macro will only display tasks assigned to the users specified.</td>
</tr>
<tr>
<td>(assignee)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Created by</td>
<td>No</td>
<td>None</td>
<td>Filter by Creator. The macro will only display tasks created by the users specified.</td>
</tr>
<tr>
<td>(creator)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Created after</td>
<td>No</td>
<td>None</td>
<td>Filter by created date. The macro will only display tasks created on or after the date specified. Date must be entered as \texttt{dd-mm-yyyy}.</td>
</tr>
<tr>
<td>(createddateFrom)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Task status</td>
<td>Yes</td>
<td>Incomplete</td>
<td>Show complete or incomplete tasks.</td>
</tr>
<tr>
<td>(status)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Table

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of tasks to display (pageSize)</td>
<td>No 20</td>
<td>The number of tasks to display on each page of results in the table. Choose from 10, 20 or 40.</td>
</tr>
<tr>
<td>Display columns (columns)</td>
<td>No description, duedate, assignee, location</td>
<td>Columns to include in the table. Available columns include description, duedate, assignee, location, completedate and labels.</td>
</tr>
<tr>
<td>Sort by (sortBy)</td>
<td>No Due date</td>
<td>Sort tasks by due date, assignee or page title. Select the Reverse Sort check box to sort the table in reverse order.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

### Other ways to add this macro

#### Add this macro as you type

Type `{` followed by the start of the macro name, to see a list of macros.

![Macro suggestions](image)

#### Add this macro using wiki markup

You can't use wiki markup to add this macro.
Team Calendar Macro

Add the Team Calendar macro to a page to display a calendar on a Confluence page, making it easy to track and manage events.

This macro is great for:

- displaying team events, project timelines, and milestones in project and team spaces
- sharing Jira issue due dates and sprint dates on sprint planning or retrospective pages
- publishing schedules and on-call rotations where everyone can see them.

Screenshot: The Team Calendar macro showing important project dates.

Add the Team Calendar macro to your page

To add the Team Calendar macro to a page:

1. From the editor toolbar, choose **Insert** ➔ **Other Macros**.
2. Select **Team Calendar** from the **Reporting** category.
3. Select **Add Existing Calendar**.
4. Search for the calendar name
5. Select **Add**.

You can then publish your page to see the macro in action.

Screenshot: configuring the Team Calendar macro in the macro browser.

For general information about creating calendars, or subscribing to existing calendars, see **Team Calendars**.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calendar</td>
<td>Yes</td>
<td>blank</td>
<td>The name of the calendar to display.</td>
</tr>
</tbody>
</table>
| View (defaultView) | No       | month   | Format to display the calendar. Available values:
|                    |          |         | • month  
|                    |          |         | • week   
|                    |          |         | • list    
|                    |          |         | • timeline |
| Width (width)      | No       | none    | Width of the calendar in pixels. Leave blank, and the calendar will fill the available space. |
| Height             | No       | none    | Maximum height of the calendar in pixels. Only applies to the timeline view. |
| Calendar legend    | No       | none    | Location of the calendar legend in the month and week views. The legend shows the event types present in the selected calendar. Available values:
|                    |          |         | • Right  
|                    |          |         | • Bottom 
|                    |          |         | • None   |
Calendar ID (id) | Yes (Wiki markup only) | blank | One or more calendar IDs, separated by commas. This parameter is only required when adding the macro using wiki markup.

To find out the ID for a calendar:

1. Choose **Calendars** from the Confluence header or space sidebar
2. Click **More options ...** next to a calendar and choose **Embed**
   A dialog appears with the link to the calendar.

The last part of the link contains the ID of the calendar. For example:

http://<your_site_url>/calendar/previewcalendar.action?
subCalendarId=890143d3-5c7d-4f17-ad4b-70d8a4a4d345

Other ways to add this macro

**Add this macro as you type**

Type `{` followed by the start of the macro name, to see a list of macros.

```
{calendar:id=4f5f9524-f588-468e-a48c-668ea480a77c,49221951-cca9-424f-b1ee-42ec4452bcc|defaultView=month|width=400}
```

**Add this macro using wiki markup**

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** calendar

**Macro body:** None.

```
{calendar:id=4f5f9524-f588-468e-a48c-668ea480a77c,49221951-cca9-424f-b1ee-42ec4452bcc|defaultView=month|width=400}
```
User List Macro

Add the User List macro to a page to display a list of Confluence users, in a particular group. The macro can also indicate when users are online or offline.

This is a legacy macro, and can cause performance issues in very large sites. We recommend you don't use this macro to attempt to show all users in a site.

Screenshot: A page containing two User List macros.

Limitations

The User List macro can be quite memory hungry in sites with lots of users. To prevent it causing out of memory errors in your site, we don't show this macro if there are more than 10,000 people in the groups specified. Your administrator can change this limit using the `confluence.extra.userlister.limit` system property.

Add this macro to your page

To add the User List macro to a page:

1. From the editor toolbar, choose Insert ➤ Other Macros.
2. Choose User List from the Confluence content category.
3. Enter the group you want to display.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Configuring the User List macro to show the members of a group.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group(s) (groups)</td>
<td>none</td>
<td>Specify the group name. Specify multiple groups separated by a comma, or use * to show all users in Confluence.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>See this knowledge base page for more information about controlling which users can see the details of other users.</td>
</tr>
<tr>
<td>Display Online/Offline Users</td>
<td>All registered</td>
<td>List online or offline users. Leave blank to show all users, irrespective of status.</td>
</tr>
<tr>
<td>(online)</td>
<td>users</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Accepted values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Unspecified – The macro will show all registered users.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• true – The macro will show only online users.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• false – The macro will show only offline users.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.
Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** `userlister`

**Macro body:** None.

```plaintext
{userlister:groups=confluence-users|online=false}
```
User Profile Macro

Add the User Profile macro to a page to show profile information about a user.

This can be useful for:
- team space homepages
- project pages.

The macro will display any details the user has added to their profile, such as their phone number, role, department, and location.

Screenshot: Four User Profile macros on a project page.

Add this macro to your page

To add the User Profile macro to a page:

1. From the editor toolbar, choose Insert ➔ Other Macros.
2. Choose User Profile from the Confluence content category.
3. Enter the username of the person you want to display.
4. Choose Insert.

You can then publish your page to see the macro in action.

Screenshot: Specifying a user in the User Profile macro.

On this page:

- Add this macro to your page
- Change the macro parameters
- Other ways to add this macro

This macro is more useful if your profile is complete. Head to Your User Profile to find out how you can edit your profile details.
Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.
2. Update the parameters as required then choose Insert.

Here's a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>none</td>
<td>The username of the Confluence user whose profile summary you wish to show.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Other ways to add this macro

Add this macro as you type

Type `{` followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

**Macro name:** profile
Macro body: None.

{profile:user=admin}
View File Macro

The View File macros allow you to embed an Office or PDF document on a page. First attach the document to a page and then use one of the View File macros to display the document's content.

When people view the page, they will see the content of the Office or PDF document. They do not need to have Office installed in order to see the content of the file.

For specific information about each macro, see:

- Office Excel Macro
- Office PowerPoint Macro
- Office Word Macro
- PDF Macro

Add this macro to your page

To add a View File macro to a page:

1. From the editor toolbar, choose Insert > Other Macros.
2. Choose Office Excel, Office PowerPoint, Office Word, or PDF from the Confluence content category.
3. Select the file you want to display and enter any additional parameters.
4. Choose Insert.

You can then publish your page to see the macro in action.

Supported file types

To display an Office or PDF document in a page, use one of the following View File macros in the macro browser:

- Office Excel (.xls and .xlsx)
- Office PowerPoint (.ppt and .pptx)
- Office Word (.doc and .docx)
- PDF (.pdf)

Editing files

You can edit files embedded with the View File macro using your preferred desktop application, then save the file back to Confluence automatically. Head to Edit files for instructions.

- Word and Excel – choose the Edit button above the content.
- PowerPoint and PDF – choose the edit icon on the viewer.

Importing content from Word documents

If you want to use the contents of your Word document to create a Confluence page, see Import a Word Document into Confluence.
Widget Connector Macro

Add the Widget connector to a page to embed online videos, slideshows, photostreams and more.

This is great for bridging the gap between Confluence and other sites and services your team uses to get work done.

The macro currently supports content from these sites:

- YouTube
- Vimeo
- Twitter
- Google Docs, Sheets, and Slides
- Google Calendar
- Google Maps
- Wufoo
- Facebook
- LinkedIn
- Microsoft Stream
- Figma
- Spotify
- Prezi

It can also display content from these sites, once they have been added to the allowlist:

- Scribd
- Flickr (requires Flash)
- Slideshare (requires Flash)
- Viddler (requires Flash)

Add this macro to your page

To add the Widget Connector macro to a page:

1. From the editor toolbar, choose Insert + Other Macros.
2. Choose Widget Connector from the Media category.
3. Enter the URL you want to display.
4. Choose Insert.

You can then publish your page to see the macro in action.

Change the macro parameters

Macro parameters are used to change the behaviour of a macro.

To change the macro parameters:

1. In the editor, click the macro placeholder and choose Edit.

2. Update the parameters as required then choose Insert.

Here’s a list of the parameters available in this macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>

On this page:
<table>
<thead>
<tr>
<th>Web Site’s Widget URL (url)</th>
<th>This is the external site's URL. In some sites this will be the URL shown in the address bar of your browser, and in other sites you may need to click a Share or Link button to get the URL.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pixel Height (Value Only) (height)</td>
<td>The height of the display, in pixels.</td>
</tr>
<tr>
<td>Pixel Width (Value Only) (width)</td>
<td>The width of the display, in pixels.</td>
</tr>
</tbody>
</table>

Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

**Examples**

Every site is a little different, so we've put together some info on what you'll need to do to embed content from each site on a page.

**YouTube**

The fastest way to embed a YouTube video is to paste the URL into the editor. Confluence will autoconvert the link and insert the macro for you, like magic. Autoconvert works with both long and short YouTube URLs.

If you're pasting the URL into the Widget Connector macro URL field manually, you'll need to use the long URL (from the address bar). Long URLs look something like this https://www.youtube.com/watch?v=k61K5h1B1nQ.

If you're not able to see the video in some browsers, try using https rather than http in your link.

Links that contain a parameter to start a video at a particular time won't autoconvert or work in the Widget Connector macro, like this link: https://www.youtube.com/watch?v=LhHKodOPFo. Paste in the short sharing URL to be sure it works.
Vimeo

The fastest way to embed a Vimeo video is to paste the URL into the editor. Confluence will autoconvert the link and insert the macro for you.

You can use the URL from the address bar in your browser or the Share button in Vimeo.

Flickr

You can embed albums (formerly known as sets) and tags. You can't embed individual photos or user photostreams.

You'll need to add the Widget Connector macro to the page first and then paste your link into the URL field. Use the URL from the address bar in your browser.

The Widget Connector uses Flash to display this content. For security reasons, Flash is disabled in most modern browsers.

Twitter

You can embed single tweets, profiles, lists, and moments.

Single Tweets

To embed a single tweet, click Copy link to tweet. Add the Widget Connector macro to the page and paste the link into the URL field.

When the embedded Tweet is a reply, the parent Tweet will be displayed above the reply.
Profiles and Lists

Click on the Profile or List and copy the URL from the address bar of your browser. Paste the URL into the editor and Confluence will autoconvert the link and insert the macro for you.

Alternatively, you can Copy link to profile or Copy link to List. These links won't autoconvert, you'll need to add the Widget Connector macro to the page and paste the link into the URL field.

Moments

Click on the Moment, copy the URL from the address bar of your browser, or select Copy link to this. Add the Widget Connector macro to the page and paste the link into the URL field. If you see an error rendering tweet message, replace the word 'events' with 'moments' in the URL field.

Google Docs, Slides, and Sheets

In Google Docs, Sheets, or Slides, click File and select Publish to the web. Click Publish then copy the link. Paste it into the editor and Confluence will autoconvert the link and insert the macro for you.

Google Calendar

Open Google Calendar and select Settings. Click the name of the calendar you want to embed.

You can only embed public calendars. To allow all visitors to see your calendar, open Access permissions and check the box next to Make available to public.

In the Integrate calendar section, copy the Public URL to this calendar. Paste the URL into the editor and Confluence will autoconvert the link and insert the macro for you.

Google Maps
You can embed interactive maps for a business, address, place, Street View 360-degree panorama, and some (not all) search results (such as Bars, Banks, and Restaurants).

**Business, address, and place**

Copy the URL of a business, address, or place from the address bar of your browser and paste it into the editor. Confluence will autoconvert the link and insert the macro for you.

**Street View and search results**

In Street View mode, or when viewing search results, click the menu and go to Share or embed map > Embed a map > COPY HTML. Paste the link into the editor and Confluence will autoconvert the link and insert the macro for you. You'll need to delete the additional iframe tags in the editor or they will display alongside the map.

**Facebook**

On a public post, go to Embed > Advanced Settings and copy the URL of this post. Paste the URL into the editor and Confluence will autoconvert the link and insert the macro for you. If you can't see the post headline, description, or like count, change the Pixel Height and Pixel Width Values in the macro parameters.

**LinkedIn**

Only LinkedIn posts that an author has shared as Public can be embedded. Posts can include articles, images, and videos. Select Embed this post.

Copy the code without including the HTML iframe tags, like in the image below. Paste the code into the editor and Confluence will autoconvert the link and insert the macro for you.

```
<iframe src="https://www.linkedin.com/embed/feed/update/urn:li:share:e662864286231842048" height="633" width="504" frameborder="0" allown fullscreen="" title="Embedded post"></iframe>
```

Alternatively, click Copy code. Paste the code into the editor and Confluence will autoconvert the link and insert the macro. You'll need to delete the additional iframe tags in the editor or they will display alongside the LinkedIn post.

**Microsoft Stream**

To share a video, select the Share button and copy the Direct link to video. Paste the link into the editor and Confluence will autoconvert the link and insert the macro for you. You can also paste the URL from the address bar on the video page.

Only people authorized to see a video will be able to view it. If you receive a playback error message, select the Open in new window button in the message to play the video in a new window.

**Figma**

Open a Figma file and click Share. In the Link Sharing settings, select Anyone with the link can view. Click Copy link. Paste the link into the editor and Confluence will autoconvert the link and insert the macro for you.

If you're using Figma in the browser, you can copy the URL from the address bar and paste it into the editor. Confluence will autoconvert the link.

Hover your cursor over the embedded file to see options for full-screen mode and zooming in and out. You can click, hold, and drag the embedded file to see more of it. Clicking the file name link in the bottom-left of the embedded file will open the file directly in Figma.
Spotify

You can embed a song, album, or artist.

Click Copy Link when using the web player. If you’re using the desktop app, select Share > Copy Link. Paste the link into the editor and Confluence will autoconvert the link and insert the macro for you.

Alternatively, in the web player, copy the URL from the address bar and paste it into the editor. Confluence will autoconvert the link.

Prezi

Open a Presentation, Design, or Video, and Copy the link. Paste the link into the editor and Confluence will autoconvert the link and insert the macro for you.

Alternatively, from your Prezi dashboard, select Share view link on a Presentation or Share on a Design. Copy the link, paste it into the editor and Confluence will autoconvert the link.

Troubleshooting

If the Widget Connector can't display content from the external site, the macro will look like this:

![example.com](example.com)

We rely on the external website's APIs to display content in the Widget Connector macro. APIs do change from time to time and this can cause the Widget Connector macro to stop rendering content.

If you experience problems, you can raise an issue about it to let us know.

Some sites must be added to the allowlist

The following sites need to be added to Confluence's allowlist before the macro can display any content. This is due to the way we need to connect to that site.

- Scribd
- Flickr
- Slideshare
- Viddler
Some content requires Flash

The Widget Connector requires Flash for Flickr, Slideshare, and Viddler. This is blocked by most modern browsers due to security concerns. We don't recommend you enable the Flash plugin in your browser.

Other ways to add this macro

Add this macro as you type

Type { followed by the start of the macro name, to see a list of macros.

Add this macro using wiki markup

This is useful when you want to add a macro outside the editor, for example as custom content in the sidebar, header or footer of a space.

Macro name: widget

Macro body: None.

{widget:height=400|width=400|url=http://youtube.com/watch?v=23pLByj_q5U}
Your profile and settings

Confluence is very flexible – not only in the many ways you can create and share content, but also in how you can tailor your own Confluence experience. Things like your profile picture, favorite spaces and pages, and your personal space can say a lot about you, and can also make navigating Confluence much quicker and easier. Even a simple thing like adding shortcut links to the sidebar of your personal space, can save you a lot of time in finding the things you use all the time.

Set up your personal space, and take a look at any of the pages below, to start making Confluence feel like home.

- Your User Profile
- Change Your Password
- Edit Your User Settings
- Set Your Profile Picture
- Choose Your Home Page
- Save for later
- View and Revoke OAuth Access Tokens

Related pages:
- Watch Pages, Spaces and Blogs
- Create a Space
- Save for later
Your User Profile

Your user profile contains basic information about you, which other Confluence users can see. It's also displayed to other users when they click your name in the People Directory, if you haven't set up your personal space.

In your own profile, you can access account management features and update information about yourself, like your name, email address, and password. You can also view other users' profiles.

Find your user profile

**To find your user profile:**

Choose your profile picture at top right of the screen, then choose Profile, or choose the Profile link in the sidebar of your personal space.

**To find someone else's user profile:**

Hover your mouse pointer over a user's linked name or profile picture and choose the user's linked name to open their user profile. Alternatively, you can choose the Profile link in the sidebar of their personal space, or go directly to this URL:

http://your.confluence.site/users/viewuserprofile.action?username=USERNAME

**Screenshot: User profile screen for the current user**

From your user profile, you can access the following:

<table>
<thead>
<tr>
<th>Profile</th>
<th>View and edit your personal details, such as your name and email address details and optionally, your photograph and other personal information. Note that as a security precaution, in order to change your email address, you will be required to re-enter your password.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Upload a profile picture (optional).</td>
</tr>
<tr>
<td></td>
<td>Change your password.</td>
</tr>
</tbody>
</table>
### Network
- View the recent activity of users that you are following via the Network view.
- Follow other users from this view.

### Saved for later
- View a list of pages you saved for later.

### Watches
- View a list of the pages and spaces you are currently watching.

### Drafts
- Retrieve any pages you were in the process of editing. See Drafts.

### Settings
- Edit your General Settings (homepage, language and timezone).
- Subscribe to email notifications.
- View and revoke your OAuth access tokens.

#### Edit your user profile

1. Choose your profile picture at top right of the screen, then choose **Profile**
   Or, choose the **Profile** link in the sidebar of your personal space.
2. Choose **Edit Profile**.
3. Enter details about yourself in the form displayed.
4. Choose **Save**.

#### Fields in your user profile:

<table>
<thead>
<tr>
<th>Detail</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Name</td>
<td>Your name as you’d like it to appear in your profile.</td>
</tr>
<tr>
<td>Email</td>
<td>Your email address that will be used to send you mail notifications.</td>
</tr>
<tr>
<td>Phone</td>
<td>Your phone number.</td>
</tr>
<tr>
<td>IM</td>
<td>Your Instant Messenger (IM) details.</td>
</tr>
<tr>
<td></td>
<td>☭ To suit a variety of IM applications, this option accepts any string value.</td>
</tr>
<tr>
<td></td>
<td>For example, you can enter IM details in the form of an email address, or a user ID, like ‘123456789’.</td>
</tr>
<tr>
<td>Website</td>
<td>Your website's URL.</td>
</tr>
<tr>
<td>About me</td>
<td>Information about yourself that other users can view (such as your professional information, hobbies, and other interests). You can use Confluence wiki markup in this field.</td>
</tr>
<tr>
<td>Position</td>
<td>Your title or position within your organization.</td>
</tr>
<tr>
<td>Department</td>
<td>The name of your department or team.</td>
</tr>
<tr>
<td>Location</td>
<td>Your location. This can be your town, city, region or country.</td>
</tr>
</tbody>
</table>
Handy Hint

Confluence administrators can configure Confluence to mask email addresses (e.g. 'example at atlassian dot com'), protecting your email address from search engine spiders and the like.

Notes

The 'Administer User' link is visible to Confluence administrators only. The administrator can click this link to go directly to the user management screen in the Administration Console.
Change Your Password

There are two scenarios where you may want to change your Confluence password:

- You're logged in, but you want or need to change your password
- You've forgotten your password and can't log in, so you need to reset your password

From within Confluence

Change your password when you're logged in:

1. Choose your profile picture at top right of the screen, then choose Profile
2. On your Profile tab, click Password in the left-hand column
3. Enter your current password and your new password in the form displayed
4. Click Submit

From the login page

If you've forgotten your password and need to reset it, you can do so from the Confluence login page. Choose the 'Forgot your password?' link and Confluence will step you through the process to reset your password.

Don't see the Password option?

You may not be able to change your password directly in Confluence if your login credentials are coming from another user directory, for example if Confluence is integrated with an LDAP directory or Jira for user management.

Talk to your administrator about where you should change your password.
Edit Your User Settings

If you want to make Confluence fit you, like a well-worn pair of sneakers, you can set some preferences that will make you feel more at home:

- **General preferences** such as home page, language and time zone
- **Editor settings**
- **Email settings** for subscriptions to email reports.
- **OAuth access tokens** that you have granted from your Confluence user account.

General User Preferences

To edit your general user settings:

1. Choose **your profile picture** at top right of the screen, then choose **Settings**
2. Choose **Edit** and update the settings
3. Choose **Submit**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site Homepage</td>
<td>Select the page that you would like to see whenever you log into Confluence.</td>
</tr>
<tr>
<td>Language</td>
<td>Select your language. See below.</td>
</tr>
<tr>
<td>Time zone</td>
<td>Select your time zone.</td>
</tr>
<tr>
<td>Use Keyboard Shortcuts</td>
<td>Enable keyboard shortcuts, other than for the editor.</td>
</tr>
<tr>
<td>Text select</td>
<td>Turn off the popup options panel when highlighting text.</td>
</tr>
</tbody>
</table>

**Screenshot: Editing your user profile settings**

More about Language

Setting your language preference in your user profile is described in the section above. This section gives more information about that setting and other settings that affect the language Confluence will use.
Individual users can choose the language that Confluence will use to display screen text and messages. Note that the list of supported languages depends on the language packs installed on your Confluence site.

The language used for your session will depend on the settings below, in the following order of priority from highest to lowest:

- The language preference defined in your user profile. Note that you need to be logged in for this setting to take effect.
- The language that you choose by clicking an option at the bottom of the Confluence login screen. Confluence stores this value in a cookie. When the cookie expires, the setting will expire too.
- The language set in your browser. The browser sends a header with a prioritized list of languages. Confluence will use the first supported language in that list. Confluence administrators can disable this option by setting the `confluence.browser.language.enabled` system property to false.
- The default language for your site, as defined by your Confluence site administrator.

Editor Preferences

You can set some options that determine the way the Confluence editor works. Note that these settings affect only you. Other people using Confluence can enable or disable the settings on their user profiles independently.

To change your editor preferences:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Click Editor under ‘Your Settings’ in the left-hand panel
3. Click Edit and make your changes
4. Click Submit

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable Autocomplete</td>
<td>Select to disable autocompletion when you press one of the trigger characters.</td>
</tr>
<tr>
<td>Disable Autoformatting</td>
<td>Select to disable autoformatting when you type wiki markup in the editor. Click ? on the editor toolbar to learn more.</td>
</tr>
</tbody>
</table>

Screenshot: User settings for the editor

![User settings for the editor](image)
Set Your Profile Picture

Your profile picture is used as the icon for your personal space, to represent you in the People Directory, and to illustrate your comments. It also appears in various other places next to your name, such as in the list of recent updates on the dashboard.

When you upload your profile picture, you can resize and reposition it to make sure it looks great.

Upload and adjust your profile picture:

1. Choose your profile picture at top right of the screen, then choose Profile
2. Choose Picture on the left
3. Choose Upload image > Upload an image
4. Locate and select the picture on your computer or file server
5. Adjust the size and position of your photo, then choose Save

Related pages:

- Your User Profile
- Create a Personal Space
- Your profile and settings

This page is about Confluence Server and Data Center. If you use Confluence Cloud head over here to see how to update your personal profile.

Screenshot: Choosing a profile picture

Screenshot: Resize and position your profile picture
You can't remove your own profile picture, but you can upload a new one any time. Alternatively you can ask your admin to remove your profile picture for you.
Choose Your Home Page

The dashboard is the default landing page when you log into Confluence. It gives you easy access to what's happening in your site, and helps you get back to pages you recently viewed and worked on.

You can choose to personalize your experience, and use an existing space home page as your landing page.

To set your home page:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Edit.
3. Choose an option from the Site Homepage drop down. Only spaces you're allowed to view will appear.
4. Choose Submit.

You'll be directed to your new home page the next time you log in. You can change your personal home page at any time.

Alternatively, if your Confluence administrator has set a space home page as the landing page for the whole site, you can choose Dashboard from the Site Homepage drop down to use the dashboard as your landing page.

Screenshot: Profile Settings

> You can access the dashboard at any time using the dashboard URL. It'll look something like this: https://yoursite.com/wiki/dashboard.action.
Save for later

Saving pages for later helps you access them quickly from the dashboard or from your profile.

No time to read that page now? No problem, hit Save for later and it'll be waiting for you on the dashboard when you have more time. It's also a great place to store those pages that you use on a day to day basis.

Save for later was previously called Favorites.

Save a page for later

To save a page for later, hit the Save for later button at the top of the page.

The star icon will change to dark grey to indicate the page is saved. Hit the button again if you want to remove the page from the list.

Get back to your saved pages

To view your saved pages:

- Choose Saved for later on the dashboard sidebar.
- Choose your profile picture at top-right of the screen, then choose Saved for later – there's a list of your saved pages, and the spaces that you've added to My spaces.

You can also use the Favorite Pages Macro to include a list of your saved pages on any page.

Screenshot: Viewing and removing saved pages from the dashboard
View and Revoke OAuth Access Tokens

OAuth access tokens allow you to use a Confluence gadget on an external web application or website (also known as the ‘consumer’) and grant this gadget access to Confluence data which is restricted or privy to your Confluence user account.

OAuth access tokens will only appear in your user profile if the following conditions have been met:

1. Your Confluence Administrator has established an OAuth relationship between your Confluence site and the consumer. Confluence Administrators should refer to Configuring OAuth for more information about establishing these OAuth relationships.
2. You have accessed a Confluence gadget on the consumer and have conducted the following tasks:
   a. Logged in to your Confluence user account via the gadget and then,
   b. Clicked the ‘Approve Access’ button to allow the gadget access to data that is privy to your Confluence user account.

Confluence will then send the consumer an OAuth ‘access token’, which is specific to this gadget. You can view the details of this access token from your Confluence site’s user account.

An OAuth access token acts as a type of ‘key’. As long as the consumer is in possession of this access token, the Confluence gadget on the consumer will be able to access Confluence data that is both publicly available and privy to your Confluence user account. As a Confluence user, you can revoke this access token at any time. Furthermore, all access tokens expire after seven days. Once the access token is revoked or has expired, the Confluence gadget will only have access to publicly available Confluence data.

View your OAuth Access Tokens

To view all of your Confluence user account’s OAuth access tokens:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Click View OAuth Access Tokens. A view similar to screenshot below is displayed. Refer to OAuth Access Token Details below for information on interpreting this table.

If no access tokens have been set, then ‘None specified’ is shown.

Screenshot: Viewing your OAuth Access Tokens

<table>
<thead>
<tr>
<th>Consumer</th>
<th>Consumer Description</th>
<th>Issued on</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Atlassian JIRA</td>
<td>Atlassian JIRA at <a href="http://jira.atlassian.com">http://jira.atlassian.com</a></td>
<td>Oct 30, 2017 expires in 1,730 days</td>
<td>Revoke Access</td>
</tr>
</tbody>
</table>

OAuth Access Token Details

Your list of OAuth access tokens is presented in a tabular format, with each access token presented in separate rows and each property of these tokens presented in a separate columns:

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Consumer</td>
<td>The name of the Confluence gadget that was added on the consumer.</td>
</tr>
</tbody>
</table>
### Consumer Description

A description of this consumer application. This information would have been obtained from the consumer’s own OAuth settings when an OAuth relationship was established between Confluence and that consumer.

*If the consumer is another Atlassian application, this information is obtained from the Consumer Info tab's 'Description' field of the OAuth Administration settings. The application's administrator can customize this Consumer Info detail.*

### Issued On

The date on which the OAuth access token was issued to the consumer by Confluence. This would have occurred immediately after you approved this gadget access to your Confluence data (privy to your Confluence user account).

### Expires On

The date when the OAuth access token expires. This is seven days after the 'Issued On' date. When this date is reached, the access token will be automatically removed from this list.

### Actions

The functionality for revoking the access token.

### Revoke your OAuth Access Tokens

**To revoke one of your OAuth access tokens:**

1. View your Confluence user account's OAuth access tokens (described above).
2. Locate the Confluence gadget whose OAuth access token you wish to revoke and click Revoke OAuth Access Token next to it.

   The gadget's access token is revoked and the Confluence gadget on the consumer will only have access to publicly available Confluence data.
Collaboration

Confluence is all about encouraging team collaboration to get the best results, so we’ve built in a number of ways you can notify other people about content that may be of interest to them.

You can:

- Work together with your team on a page or blog and see their changes in real time
- Share a link to a page or blog post via email
- Mention a user when you write a page, blog post, comment, or add a task
- Like a page, blog post or comment

Whenever you mention another user, they’ll receive an email notification; if you like a page, blog post, or comment, the author will be notified that you like the content.

Other users can also find out about changes to content in Confluence by watching pages and spaces.

Another way to share Confluence content is by exporting it to other formats such as XML, HTML, Microsoft Word and PDF.

Related pages:
- Pages and blogs
- Watch Pages, Spaces and Blogs
- Export Content to Word, PDF, HTML and XML
Network Overview

You can Create a *network* of users who are important to you, to make sure you’re always up-to-date with their Confluence activity. You might want to follow your boss or teammates, to see what they’re working on, or whoever creates the most entertaining blog posts.

When someone’s part of your network, you’ll be able to see when they:

- Add or edit *pages* or *blog posts*
- Comment on a page or blog post or edit existing comments
- Update their *user profile*

Follow another user

You can follow another user by using either their Hover Profile or your Network view.

To follow a user with their **Hover Profile**, hover your mouse over their profile picture when it appears in a page and choose **Follow**.

To follow a user from your **Network view**:

1. Choose your *profile picture* at top right of the screen, then choose **Network**
   Alternatively, choose **More** in the **Network** section of your profile sidebar.
2. Search for and select the user in the **Following** field
3. Choose **Follow**

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just followed will appear within the **Following** list on the right. Their tracked activities will also start appearing in the **Recent Activity** list.

Access your network view

If you want to see what’s been happening in your network, access your network view as described above.

You can access another user’s Network view using the Hover Profile by choosing **More > Network Page**.

**Screenshot: Example of the Network view**

Notes
• **RSS feeds:** you can subscribe to any Confluence user’s network RSS feed and receive summaries on the activities of other users they’re following in their network. See [Subscribe to a Network RSS Feed](#).

• **Email notifications:** you can request email notifications of any activity in your network. See [Email Notifications](#).
Likes and Popular Content

Has someone written a good blog post or page on Confluence? Or made a comment you agree with? Click the Like button to them know.

When you like a page, blog post or comment, the author of the content receives a notification. If enough people like the content, it'll appear on the Popular tab of the dashboard.

Disabling the 'like' feature

The like functionality is provided by a system app called the 'Confluence Like Plugin'. To remove the like functionality from your site, Disabling and enabling apps.

Disabling notifications when your content is 'liked'

There are two ways to turn the 'someone likes your page' notifications off.

Do either of the following:

- Open an email notification of a like, and click Manage Notifications
- Go to <your confluence URL>/plugins/likes/view-notifications.action

On this page:

- Disabling the 'like' feature
- Disabling notifications when your content is 'liked'

Related pages:

- The dashboard
- Email Notifications
- Network Overview
Mentions

Mentions (often known as @mentions) are a useful way of drawing someone's attention to a page or comment, or assigning a task to them. When you mention a user, they'll receive a notification by email and in their workbox; if you mention them in a task, the task is assigned to them and appears in their tasks list.

There are two ways to mention someone: using autocomplete, or via the Insert menu in the editor toolbar.

Use autocomplete

To mention someone using autocomplete, type '@' in the editor then start typing their name. Choose the person you want to mention from the list of suggestions.

Confluence will suggest people you've mentioned previously (after yourself, of course).

It then continues to suggest matches as you type. If you've not mentioned the person recently, we'll also include information about whether they've commented or contributed to the current page, to help you find the right person, fast.

Use the Insert menu

If you'd rather use the Insert menu, choose Insert > User Mention then search for and select the user you want to mention.
Notes

- **Disable mentions** – The functionality is provided by a plugin called the 'Confluence Mentions Plugin'. If you need to remove the user mention functionality from your site, you can disable the plugin. See Disabling or Enabling a Plugin.

- **Mentioning groups** – You can only mention individual users who have the 'Can Use' Confluence global permission. There's a feature request to allow mentions for groups: [CONFSERVER-23015 - Extend 'Mentions' to work with groups as well](http://jira.atlassian.com/projects/CONFSERVER/requests/23015).

- **Link to a user profile** – You can use a square bracket '[ ]' and a person's name to trigger Confluence autocomplete and link to a person's user profile or personal space. Confluence will send the person a notification just as if you had used @mention (unless the administrator has disabled the user mention feature).

- **Mention notifications** – A notification is sent to a person the first time you mention them in the content of a page, but not for subsequent mentions. If you need to catch someone's attention, and you've already mentioned them on the page, try mentioning them in a comment. A notification is sent every time you mention someone in a page comment or inline comment, not just the first time.

- **Frequently mentioned people** – Confluence relies on your browser's local storage to remember the people you mention regularly. You may see different results if you switch devices, or don’t allow local storage. Confluence doesn’t indicate whether someone is a creator, contributor or commenter when they are also a recent mention (because we’re grabbing them straight from your local storage, not the page itself).

- **Changing the mention name** – If you change the mention name in the editor (for example you backspace to remove their surname, or edit the mention link to change their full name to their preferred name) this will be treated as free text and won’t be updated if the person changes their name, or is deleted from Confluence.
Share a Page or Blog Post

Use the Share button when viewing a page or blog post to email anyone a link to that page or blog post. You can either grab the short URL from the share dialog, or enter a Confluence user, group or email address.

To share a page or blog post by email:

1. Go to the page or blog post you wish to share.
2. Choose Share.
3. Enter a username, group or email address, and select the appropriate user, group or email address from the list of suggestions. Repeat this process to add multiple recipients to the list (or use the trash icons to remove people from the list).
4. Enter an optional message.
5. Choose Share to send the link via email.

In addition to an email, Confluence users will also receive a notification in their Confluence workbox. See Workbox Notifications.

You can also share pages from inside the editor. Hit the button in the editor to invite people to edit the page with you.

Notes:

- The option to add people is only available if your site has a mail server configured.
- Sharing or inviting someone to edit a page or blog post does not automatically grant any permissions - they will still need the appropriate Confluence permissions to access Confluence and view or edit the page.
Comment on pages and blog posts

Comments are a great way to bring others into the conversation about a page or blog post. They allow you to remark on content, add important information, ask questions, and generally drive collaboration and teamwork.

You can add a comment at the bottom of any page or blog post, or add an inline comment by highlighting specific text on the page.

Add a page or blog post comment

1. Type your comment in the comment field at the bottom of the page
2. Optionally, choose Preview to see how your comment will appear
3. By default, Watch this page is ticked (This means you'll start receiving notifications about the page. Uncheck it if you don't want to watch the page.)
4. Choose Save (Ctrl+S or +S)

Other users can reply and/or like your comment, and you or a space administrator can edit your comment(s).

Add an inline comment

1. Highlight the text you want to comment on
2. Choose the add comment button that appears above the highlighted text
3. Type your comment and choose Save (Ctrl+S or +S)

Screenshot: Create an inline comment by highlighting text.
View inline comments

Text will appear with a yellow highlight to indicate there is an inline comment; select any highlighted text on the page to display the related comment(s).

Just like page and blog post comments, others can reply to, or like, your inline comments, and you’ll be notified when they do.

An easy way to check whether there are any inline comments on a page is to select View inline comments from the page tools, or use the keyboard shortcut “v”.

Screenshot: No inline comments on a page.

Resolve inline comments

Hit Resolve to hide the thread of inline comments once the conversation’s finished. If you want to view resolved comments, select More options *** > Resolved comments. To reopen a resolved comment, choose Reopen at the bottom left.

Rich comments

Inline and page comments might look simple, but they support rich text (like bold, underline, and italics), bulletted and numbered lists, links, and @mentions. You can also drop images into any comment, to really illustrate your point.

Link to a comment

You can link directly to a comment on a page. See Links for more information.

If you don’t see a popup when you highlight text, check that Text Select is enabled in your profile settings.

Inline comments in the editor

When you are in the editor, there are limitations to how you can interact with inline comments. The below table summarises the differences in behavior when you are in viewing a page and editing it.
<table>
<thead>
<tr>
<th>Feature</th>
<th>Enabled</th>
<th>Optional</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resolve inline comments</td>
<td>✔️</td>
<td>✓</td>
</tr>
<tr>
<td>Delete inline comments</td>
<td>✔️</td>
<td>✓</td>
</tr>
<tr>
<td>Reply to inline comments</td>
<td>✔️</td>
<td>x</td>
</tr>
<tr>
<td>Like/unlike inline comments</td>
<td>✔️</td>
<td>x</td>
</tr>
<tr>
<td>Close/hide inline comments</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Quick nav between inline comments</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Link to inline comment</td>
<td>✔️</td>
<td>x</td>
</tr>
</tbody>
</table>

When an inline comment is added, resolved, or deleted on a page, this is reflected in the editor without you having to refresh the page. These changes may take up to a minute to reflect on the page.

**Comment permissions**

- **Add a comment** – You need the ‘Add Comments’ permission in the space.
- **Edit a comment** – You need the ‘Add Comments’ permission. Space administrators can edit all comments within their space. The date on a comment always indicates the time the comment was last edited.
- **Delete a comment** – You need the ‘Remove Comments’ permission. Deleted comments cannot be restored. If you don’t have the ‘Remove Comments’ permission, you can delete your own comments, but only if there are no replies to your comment.
- **Disable comments** – If you don’t want comments in a particular space, remove the ‘Add Comments’ permission from the ‘confluence-users’ or ‘users’ group, anonymous users and all other users and groups. The option to add comments will no longer appear on pages or blog posts in that space.

See [Space permissions](#) for more information. There is no permission that controls comments across the entire site.

Members of the Confluence-administrators group can add, edit and delete comments, even if you remove their comment permissions in the Space permissions configuration.

**Notes**

- Choose **Watch** at the top-right of the page to receive an email notification whenever anyone edits or adds a comment to the page.
- On blog posts only, an ‘Author’ lozenge will appear on any comments made by the original author of the post.
- It’s not possible to delete all comments on a page simultaneously, or change the order of comments.
- Inline comments on text that is included on a page using the Include macro or Excerpt include macro won’t be visible. They are only visible on the original page.
Watch Pages, Spaces and Blogs

You can ‘watch’ a Confluence page, blog post or space. Confluence will then send you a notification email whenever anyone updates your watched content.

You’ll receive email notifications for:

- Page / blog post edits (unless the author clears the ‘Notify watchers’ check box).
- Deletions.
- Attachments, including new versions or deletions of an existing attachment.
- Comments, including new comments or deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behavior is called ‘autowatch’.

There's no daily digest for email notifications. You’ll receive immediate emails for important notifications (like mentions and new pages), but when lots of changes are being made at the same time, you'll only receive a single email with all the changes (within a 10 minute window).

You **will not** receive email notifications for content changes due to the output of a macro, because the page content itself hasn’t been edited. We also don't send a notification when a comment is edited.

You need ‘View’ permission for the page, blog post or space to receive notifications.

Watching a page or blog post

To start watching a page or blog post:

1. Go to the page or blog post.
2. Choose **Watch** and select the relevant check box.

To stop watching the page or post, deselect the relevant check box.

Watching an entire space

You can choose to watch all the pages and blog posts in a particular space.

The quickest way is to use the **Watch** option on a page or blog post, as described above.

To stop watching the space, deselect the relevant check box.

Alternatively, choose **Pages** in the space sidebar, then choose **Watch this space** at the top right.

Watch for new blog posts in a space

You can choose to receive a notification whenever someone adds a blog post in the space. You will not receive notification when a blog post is updated, deleted or commented on.

To watch for new posts:

1. Go to a blog post in the space.
2. Choose **Watch** and select **Watch for new blog posts in this space**.

To stop watching for new blog posts, deselect the relevant check box. Alternatively, choose **Blog** in the space sidebar, then choose **Watch this blog** at the top right.
Watch all spaces on the site

You can receive notifications about changes to the content of pages, blog posts and comments from all spaces on a Confluence site.

To start watching for content changes across the whole site:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Choose Email.
3. Choose Edit then choose Subscribe to daily updates.
4. Choose Submit.

Watching for all new blog posts on the site

You can choose to watch for all new blog posts in all spaces on the Confluence site. You will not receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

To start watching for all new blog posts:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Choose Email.
3. Choose Edit then choose Subscribe to all blog posts.
4. Choose Submit.

Manage watches from your user profile

The ‘Watches’ page in your user profile displays a list of all pages and spaces you are currently watching.

To manage your watches:

1. Choose your profile picture at top right of the screen, then choose Watches.
2. Choose Stop Watching for any unwanted spaces or pages.

Manage watches from the email message

The email notifications that you receive from Confluence have some useful links at the bottom of the email message. The links in each message vary, depending on the context. In general, the links allow you to view the page online, reply to a comment, and so on.

In particular with respect to setting your notification preferences, you will see one or more of the following links:

- **Stop watching page** – Click this link to stop watching the page that triggered the email notification.
- **Stop watching space** – Click this link to stop watching the space that triggered the email notification.
- **Stop following this user** – Click this link to stop following the user whose update triggered the email notification.
- **Manage Notifications** – Click this link to go to the email settings page in your user profile.

Screenshot: Example email notification footer showing links

Autowatch and other notification options
By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behavior is called 'autowatch'. You can turn autowatch on or off, and set other notification options, in the email settings section of your user profile. See Edit Your User Settings.
Manage Watchers

As a space admin, you may want to control who’s notified about changes and updates to pages and posts within a space. You’ll do this by managing the watchers of specific pages and posts, or of the entire space.

Take the example of a new member starting on your team, who should see when changes are made in the team space — you can add them as a space watcher so they get updates when any page or post in the space is changed. If someone no longer needs to be notified, you can remove them as a watcher just as easily.

To manage the watchers of a page or blog post:

1. Go to the page or blog post for which you want to manage the watchers
2. Choose Watch > Manage Watchers
   The left-hand column of the ‘Manage Watchers’ dialog shows the users watching the page or blog post. The right-hand column shows the users watching the space.
3. Do either of the following:
   - Add someone as a watcher of the page, post, or space — type their username in the relevant search box and hit Add
   - Remove an existing page, post, or space watcher — choose the trash icon next to their name

Manage Watchers

Watching this page
These people are notified when the page is changed.

Full name or username
Add

Gil Admin (gbrunning)

Watching this space
These people are notified when any content in the space is changed.

Full name or username
Add

Gil Admin (gbrunning)
Email Notifications

You can ‘watch’ a page, blog post or space. Confluence will then send you a notification by email whenever anyone adds or updates content on that page or space. You’ll receive immediate emails for important notifications (like mentions and new pages), but when lots of changes are being made at the same time, you’ll only receive a single email with all the changes within a short window (usually 10 minutes).

You can also subscribe to daily email reports and other notifications of various updates, as described below.

You’ll only receive notifications for content that you have permission to view. Users that have been disabled by an administrator will not receive email notifications.

Subscribing to email notifications

You can subscribe to be notified when:

- A blog post is added or changed in a space that you have permission to view.
- Someone you’re following makes an update in a space that you have permission to view.
- Someone follows you.

You can also subscribe to these summary reports:

- A daily report of the 30 most popular updates to all spaces that you have permission to view.
- A daily or weekly report of recommended updates, in all spaces that you have permission to view.

To edit your email notification settings:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Click Email in the left-hand panel
3. Click Edit

Here’s an explanation of all the email settings.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autowatch</td>
<td><strong>Option:</strong> Do you want Confluence to automatically add you as a watcher on each page or blog post that you add or update? If you are a watcher of a page or a post, you will receive notification of future changes.</td>
<td>• Pages and blog posts that you create, edit or comment on.</td>
</tr>
<tr>
<td>Subscription</td>
<td>Description</td>
<td>Included Updates</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
<td>------------------</td>
</tr>
</tbody>
</table>
| **Subscribe to daily updates** | Receive daily email reports showing changes to content in all spaces that you have permission to view.  
*Note: Daily email reports do not include information about attachments on a page or blog post that are added, edited or deleted. Up to 30 updates will be included, sorted by popularity.* | - Pages and blog posts that are added, edited or deleted.  
- Comments on a page or blog post that are added, edited or deleted.  
- Updates by users who have changed their personal profile. |
| **Subscribe to all blog posts** | Receive email notifications for changes to blogs in your Confluence installation that you have permission to view. | - Blog posts added, edited or deleted. |
| **Subscribe to network** | Receive email notifications for changes to content by all users that you are following, which you have permission to view. | - Space is created.  
- Page or blog post is created. |
| **Subscribe to new follower notifications** | Receive an email message when anyone chooses to follow you. | |
| **Notify on my actions** | **Option:** Do you want to receive email notifications for your own changes?  
*Note: If you have not subscribed to any email notifications and are not watching any pages/spaces, then selecting 'Notify on my actions' will not do anything.* | - All pages and spaces that you are watching.  
- This affects all subscriptions set. |
### Show changed content

**Option:** Do you want your notifications to include details of the changes made to the content?

- If you do not select this option, your notifications will include only the title of the page, and any comment the author made when updating the page.
- If you do select this option, your notifications will show the differences between the current and previous versions of the page. See [Page History and Page Comparison Views](#).

- **Edits to pages and blog posts.**

### Subscribe to recommended updates

Receive a daily or weekly email message showing the top content that is relevant to you from spaces that you have permission to view.

**How do you set the frequency of the mail message?** A link in the email message allows you to choose daily or weekly notifications.

**How do you enable and disable the notification?** You can turn off the notification by clicking a link in the email message. You can also turn the notification on or off by setting the 'Subscribe to recommended updates' option in your user profile.

Confluence chooses the content to display, based on:

- Pages and blog posts that people have recently liked.
- Pages and blog posts that people have recently commented on.
- Pages and blog posts that have recently been created.

'Recent' means any activity that occurred since the last recommended updates message was sent to you.

The activities are listed in order of popularity, with the most popular at the top. Likes, comments and content creations are scored equally. Activity that involves people in your network ranks higher than activity not involving your network. Content from My spaces also ranks higher than content in other spaces. The recommended updates summary does not include any content that you created yourself, and it gives a lower ranking to content that you have participated in, for example by adding a comment or updating the page.

If there is no activity to report, Confluence will not send the email message.

### Notes

- **Mail server:** To enable Confluence to send email notifications, a System Administrator must configure an email server. See [Configuring a Server for Outgoing Mail](#).
- **Batching window:** System Administrators can change the batching window for changes and comments on the same page or blog post in the **Send batched notifications** scheduled job. Increase the time for fewer emails or reduce the time if more immediate notifications are essential in your site.
- **Recommended updates email:** Confluence Administrators can set the default options for the recommended updates notification.

Select Administration then select **General Configuration**.

- Click **Recommended Updates Email** in the left-hand panel. See [Configuring the Recommended Updates Email Notification](#).

---

*Created in 2023 by Atlassian. Licensed under a [Creative Commons Attribution 2.5 Australia License](https://creativecommons.org/licenses/by/2.5/au/).*
• **Email threading**: Confluence will attempt to group all the email notifications about changes to a specific page together. Other notifications such as sharing a page, requesting access to a page, or recommended updates emails are intentionally not grouped. Not all mail clients support email threading, and different email clients use different methods for threading emails. We've tested Confluence's email threading with Apple Mail 10.3, Outlook 2011, Outlook 2016, GMail, Google Inbox and Outlook.com.
Subscribe to RSS Feeds within Confluence

An RSS feed is a format for delivering summaries of regularly changing web content. Subscribing to an RSS feed allows you to stay informed of the latest content from sites that you are interested in.

RSS is not designed to be read in a regular web browser. Specialized RSS newsreader programs can check RSS files every so often, and tell you what's new on a site. Your reader may be on a website, a browser extension, part of your email program, or a stand-alone program.

Confluence generates its own RSS feeds for tracking updates to content within Confluence. You will need an RSS reader which can grab the RSS feeds from Confluence and display them for you.

Confluence's RSS macro allows you to display the contents of an RSS feed on a Confluence page. The feeds may come from a Confluence feed generator or from external sites. In this way, Confluence can act as an RSS reader.

Confluence RSS feeds

RSS feeds allow you to track updates to content within Confluence. You will need an RSS newsreader to read a feed.

You can create a customized RSS feed using the RSS Feed Builder or subscribe to one of the pre-specified feeds generated by Confluence.

What would you like to do?

- Create and subscribe to customized RSS feeds using the RSS Feed Builder – Create a customized RSS feed. For example, you can filter your feed using a label, specify the number of items and days to include in your feed, and so on.
- Subscribe to pre-specified RSS feeds – Generate an RSS feed automatically in a minimal number of steps.
- Subscribe to a feed of any Confluence user's network – Track the activities of users the selected person is following.

Remove an RSS feed

There is no need to try to delete or remove an RSS feed built by the Confluence RSS feed builder.

Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:

http://confluence.atlassian.com/createrssfeed.action?types=page&sort=modified&showContent=true...

The above feed URL will generate a list of pages ('types=page'), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.
Subscribe to pre-specified RSS feeds

This page tells you how to get hold of an RSS feed which Confluence has predefined for you.

To subscribe to predefined RSS feeds for a particular space:

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose **RSS Feeds**
3. Copy and paste the link for one of the feeds into your RSS newsreader

Feeds include:

- Pages
- Blog
- Mail
- Comments
- Attachments
- All content

To subscribe to predefined RSS feeds for a particular page (where available):

Note that the word ‘page’ here means a part of the Confluence user interface, rather than a page that contains Confluence content. For example, your **Network** view offers an RSS feed.

1. Go to the page
2. Locate the following icon, which is available in the top-right corner of certain pages: 📰
3. Copy and paste the icon’s link into your RSS newsreader

Notes

The predefined RSS feed will return no more than 10 entries within the last 5 days, if you want to customize your Confluence RSS feed (for example, use a label to filter your feed), use the **RSS Feed builder** instead of the above instructions.

Related pages:

- The RSS Feed Builder
- RSS Feed Macro
- Network Overview
The RSS Feed Builder

Using the RSS feed builder, you can create customized RSS feeds to subscribe to changes within Confluence.

Wondering what an RSS feed is? See more information about RSS Feeds.

Build an RSS feed

Follow the steps below to build your feed, choosing the type of content and the time period you want to monitor.

To create a customized RSS feed:

1. Choose the help icon at top right of the screen, then choose Feed Builder
2. Select the content types you want in your feed. Check Mail if you want to know when the email archive is updated. (See the overview of mail archives in Confluence.)
3. Select one or more spaces from the list
4. Click Advanced Options to set the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed Name</td>
<td>The default name is based on the name of your Confluence installation. For example, 'Extranet RSS Feed'.</td>
</tr>
<tr>
<td>With these labels</td>
<td>Enter one or more labels separated by spaces or commas. Confluence returns all content (of the selected types) that matches one or more of the labels. See the hint below about using labels to customize your feeds.</td>
</tr>
<tr>
<td>Exclude these spaces</td>
<td>Exclude specific spaces from those already selected.</td>
</tr>
<tr>
<td>Sorted by</td>
<td>While you can choose to sort by creation or the date they were last updated, there is a known issue where the feed is always sorted by the last updated date. See CONFSERVER-52542 CLOSED.</td>
</tr>
<tr>
<td>Limit to</td>
<td>Specify the number of items returned in your feed.</td>
</tr>
<tr>
<td>Within the last</td>
<td>Specify how old items returned can be.</td>
</tr>
<tr>
<td>Include content for pages</td>
<td>Specify whether the entire page is displayed in the feed.</td>
</tr>
</tbody>
</table>

5. Choose Create RSS Feed
6. Drag or copy the link into your RSS reader

Hints

- **Separate feeds.** Try building separate feeds, one for pages only and one that includes comments as well. This allows you to monitor only pages if you are short of time, and to read the comments when you have more time.
- **Labels to customize your feed.** You can use the RSS feed builder to track updates to labeled pages and comments on those pages. Here is an idea for customizing your RSS feed by using your own personal label(s). This is useful if you want to track updates to specific pages or blog posts, and you do not want to deal with emails. You can use this method as an alternative to watching pages.
  - Build an RSS feed that returns pages, blog posts and comments labeled with a personal label, such as ‘my:feed’.
  - Each time you want to 'watch' a page, just label it with 'my:feed'.
  - All updates and comments will automatically come through your RSS feed.

Notes

- **Removing an RSS feed:**

  There is no need to try to delete or remove an RSS feed built by the Confluence RSS feed builder.

  Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:

  ```
  http://confluence.atlassian.com/createrssfeed.action?types=page&sort=modified&showContent=true...
  ```

  The above feed URL will generate a list of pages ('types=page'), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.

- **Feed authentication options:** Confluence can offer you the option of an anonymous feed or a feed that requires authentication.
  - An **anonymous** feed will show only the content that is visible to anonymous users. The feed URL does not contain the &os_authType parameter mentioned below. This feed is useful only if your Confluence site allows anonymous access. If a feed is anonymous, you only get anonymously-viewable content in the feed regardless of whether you are a Confluence user or not.
  - An **authenticated** feed requires you to log in to Confluence before you can retrieve the content. The feed URL contains the following parameter: &os_authType=basic.
  - The option to choose between an anonymous and an authenticated feed is currently not available on the feed builder screen. The feed builder offers only authenticated feeds. See CON NF-21601 for details and a workaround.
Subscribe to a Network RSS Feed

You can create an RSS Feed from any user's network view, allowing you to receive summaries on the activities of users they are following in their network. The types of activities tracked in these RSS feed summaries include:

- Additions or edits to pages or blog posts
- Comments added to a page or blog post or edits to existing comments
- Updates to a user's profile

Subscribe to a user's network feed

To subscribe to a user's network RSS feed:

1. Locate the RSS icon, which is available from the top-right of:
   - The 'Recent activity of the users you are following' section of your network page, or
   - The 'Activity of followed users' section of another user's network page.
2. Copy and paste the icon's link into your RSS newsreader

Customize your network RSS feed

Confluence does not provide a way of customizing a network RSS feed via the user interface. However, you can modify the maximum number of results and type of content displayed in these feeds by directly editing the RSS feed link in your RSS newsreader.

To modify the maximum number of results displayed in your RSS feed:

1. Edit the RSS feed link in your RSS newsreader.
2. Change the value of the max parameter from its default value of 40 to a value of your choice.
   Example:
   http://confluence.atlassian.com/feeds/network.action?
   username=MYNAME&max=60&publicFeed=false&os_authType=basic/rssType=atom
3. Save the modified link in your RSS newsreader.

To modify the type of content displayed in your RSS feed:

1. Edit the RSS feed link in your RSS newsreader.
2. Append the parameter contentType to the end of the link, followed by an equals sign (=) and then add the appropriate content type value of your choice:
   - PAGE --- restricts the RSS feed to page additions or updates.
   - BLOG --- restricts the RSS feed to blog post additions or updates.
   - ATTACHMENT --- restricts the RSS feed to attachment additions or updates.
   - COMMENT --- restricts the RSS feed to comment additions or updates.

Content type values are case-sensitive. Ensure that each parameter is separated from the other by an ampersand (&).
   Example:
   http://confluence.atlassian.com/feeds/network.action?
   username=gaskell&max=40&publicFeed=false&os_authType=basic&rssType=atom&contentType=BLOG
3. Save the modified link in your RSS newsreader.

Notes
It is not possible to filter for more than one type of content by adding multiple values to the contentType parameter.
Workbox Notifications

The Confluence workbox displays all notifications collected from Confluence page watches, shares, mentions, and tasks. From your workbox you can reply to comments, like a comment or page, watch a page, or open the relevant page or blog post.

If your Confluence site is linked to a Jira application such as Jira Software or Jira Service Management, you’ll also see notifications from your Jira application in the workbox.

Looking to manage your notification email messages instead? See Email Notifications.

Manage your notifications

1. Choose the workbox icon in the header.
   - A number will appear the workbox icon, to indicate the number of unread notifications waiting for your attention.
   - You can use the keyboard shortcut: Type g then n. (When in the Confluence editor, click outside the editor before pressing the keyboard shortcut keys.)

2. Choose a notification from the list, to see the notification details. You can then:
   - Open the related page, blog post, or comment.
   - Like or Unlike the page, blog post, or comment.
   - Watch or Stop Watching to receive notifications, or stop receiving notifications, about a page or blog post.
   - Reply a comment, without leaving the workbox.

Screenshot: Your Confluence notifications in the workbox
Which notifications are included?

The workbox displays a notification when someone does one of the following in Confluence:

- **Shares** a page or blog post with you.
- **Mentions** you in a page, blog post, comment or task.
- Comments on a page or blog post that you are watching.
- **Likes** a page or blog post that you are watching.

The workbox does not show notifications triggered because you are watching a space. Only watches on pages and blog posts are relevant here.

The notification in your workbox appears as 'read' if you have already viewed the page or blog post.

If your Confluence site is linked to a Jira application, you will also see the following Jira notifications in your workbox:

- Comments on issues that you are watching.
- Mentions.
- Shares of issues, filters and searches.

Keyboard shortcuts
Create notifications with Confluence mobile

You can also view and respond to notifications on your phone or other mobile device. See Confluence Mobile for more about mobile platforms.

Notes

- Read notifications are automatically deleted after 2 weeks.
- Unread notifications are automatically deleted after 4 weeks.
- You cannot delete your notifications yourself.
- If a new notification arrives while you have workbox open, the count appears on the workbox icon but the notification is not added to the workbox. You need to close workbox and re-open it to see the new notification.
- The ability to receive notifications from Jira or another Confluence site is available in Confluence 4.3.3 and later. To receive Jira notifications, you need Jira 5.2 or later.
- Administrators can enable and disable the workbox on your Confluence site. They can also connect a Jira site or another Confluence site, so that notifications from those sites appear in your workbox too. See Configuring Workbox Notifications.
- The Confluence workbox is provided by a set of plugins. To remove the personal notifications and tasks functionality from your site, you can disable the following plugins. See Disabling or Enabling a Plugin for instructions. Disabling these plugins will disable the entire workbox. It is not possible to disable only tasks or only notifications:
  - Workbox - Common Plugin
  - Workbox - Host Plugin
  - Workbox - Confluence Provider Plugin
- If you want to re-enable the plugins, do so in the following order: Common Plugin, Host Plugin, Confluence Provider Plugin.
- There is no option to disable the workbox for an individual user.
Analytics

Use analytics data to understand how your site, spaces, and pages are performing, and how active your users are. You can also export reports to share with your team.

Analytics data is useful for identifying:

- most viewed content
- usage and activity trends across your site
- frequent contributors and viewers
- spaces with few views that could potentially be archived.

If required, you can set who can view analytics on your site and spaces.

How to access analytics

Analytics is only available with a Confluence Data Center license.

Your administrator may have limited who can view analytics reports. See Administer analytics for more information.

Access Analytics from the Confluence navigation

When you access analytics from the navigation, you get an overview of your site’s usage and access to insights on spaces, users, and searches.

Go to Analytics in the Confluence header.

See View insights on your site for more information.

Access Analytics from a space

When you access analytics from a space, you get an overview of all the pages and attached files in that space.

Go to Analytics in the space sidebar.

See View insights on spaces for more information.

Access Analytics from a page

When you access analytics from a page, you can get a quick summary of insights on your page, such as total page views. From there, you can view more detailed page analytics, such as which users have viewed the page, which versions of the page they viewed, and more.

At the top of any page, click Analytics. Click View analytics to see the detailed analytics about your page.

See View insights on pages for more information.

Limit who can view analytics reports for specific spaces
You can further limit who can view analytics reports for specific spaces. You need Space Administrator permission to do this.

To change who can see analytics reports in a space:

1. Go to the space and choose **Space tools > Permissions** from the bottom of the sidebar.
2. Select the **Analytics Permissions** tab.
3. Select **Viewing Analytics Restricted** from the drop down.
4. Enter the users and/or groups you want to allow to view analytics reports.
5. Save your changes.

Good to know:

- If a Confluence administrator has denied a group permission to view analytics, adding the group at the space level will not grant this permission.
- The space will still appear in the site analytics report (if the user has permission to see the space, and use analytics globally), but they will be prevented from viewing the space analytics report if they don't have space permissions.

**Analytics for Confluence marketplace app**

If you previously installed the Good Software Analytics for Confluence marketplace app, you can continue to use the app until it reaches end of life, but your version may not contain the same features.

**Analytics for Confluence is now part of Confluence Data Center**

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. See our FAQ for all the details.
View insights on your site

Get an overview of the usage of your site, and view insights on spaces, users, and searches.

To view the analytics report for your site:

1. Go to Analytics in the header.
2. Use the filters at the top to choose the date range for your data. You can also choose how you want to group the data, whether to display it by total number of users or unique users, and more.
3. Hover over the chart to view a summary of data for a specific date.
4. Below the chart, see the lists of your most popular spaces, most active readers, and most active contributors.

On this page:
- View insights on your site's users
- Export analytics reports

Related pages:
- Analytics

Screenshot showing the site analytics overview tab.

View insights on your site's users

To get an overview of and insights on how active users are on your site:

1. Go to Analytics in the header
2. Select the Users tab.
3. Use the filters at the top to choose the date range for your data. You can also choose the type of content and space you want to get data on. For example, you can view users' activity on pages in site spaces.

Because sites generally contain many thousands of users, we display users in batches. Only the first 200 users (sorted by views) will appear in the list. Sorting the columns will query the whole list, not just the users displayed.

From the Users tab, you can view the following insights:

- **Name** - The name of the user (or an anonymized alias)
- **Created** - The number of pages has created for the date range
- **Updated** - The total number of times the user has edited pages for the date range
- **Comments** - The total number of times a user has commented on pages for the date range
- **Search** - The total number of times a user has performed a search for the date range
- **Views** - The total number of times a user has viewed pages for the date range

Your administrator may have enabled increased privacy mode, which replaces people’s real names with an anonymized alias and avatar. Each alias represents an individual user, so you can still get an idea of engagement, but not attribute activity to particular people.

**Export analytics reports**

You can export and download some reports in Microsoft Excel format. Export is available on the Users and Search tabs.

1. Select the ellipses More options on the top right of the page.
2. Select Export Excel.

---

**Analytics for Confluence is now part of Confluence Data Center**

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. See our FAQ for all the details.
View insights on spaces

Get an overview of how each space in your site is performing.

1. Navigate to a space.
2. Select Analytics in the space sidebar.
3. Use the filters at the top to choose the date range for your data. You can also choose the type of content and space you want to get data on.

Alternatively you can go to Analytics in the header, then choose a space.

From the Overview tab, you can view the following insights:

- **Created** - The number of pages that have been created within the space for the date range
- **Updated** - The total number of times pages have been edited within the space for the date range
- **Views** - The total number of views of pages within the space for the date range

Screenshot showing the space analytics overview tab.

View insights on the pages in a space

Get an overview of how your space's pages and blogs are performing.

1. Select Analytics in the space sidebar.
2. Select the Content tab.
3. Use the filters at the top to choose the date range for your data and the type of content you want to get data on.

From the Content tab, you can view a table with:
• **Page name** - The name of the page
• **Created** - The date the page was created
• **Last modified** - The last time the page was edited for the date range
• **Last viewed** - The last time a user has viewed the page for the date range
• **Comment activity** - The total number of comments on the page for the date range
• **Users viewed** - The total number of unique users that have viewed the page for the date range
• **Views** - The total number of views for the page for the date range

**Screenshot showing the space analytics report content tab.**

**View insights on the users of your space**

To get an overview of how active users are on your space:

1. Select **Analytics** in the space sidebar.
2. Select the **Users** tab.
3. Use the filters at the top to choose the date range for your data and the type of content you want to get data on.

From the **Users** tab, you can view a table with:

• **Name** - The name of the user (or anonymized alias)
• **Created** - The number of pages the user has created for the date range
• **Updated** - The number of times the user has edited pages for the date range
• **Comments** - The number of time the user has commented on pages for the date range
• **Views** - The total number of times the user has viewed pages for the date range

Your administrator may have enabled increased privacy mode, which replaces people’s real names with an anonymized alias and avatar. Each alias represents an individual user, so you can still get an idea of engagement, but not attribute activity to particular people.

**Export analytics reports**

You can export and download reports in Microsoft Excel format. Export is available on the Overview, Content, and Users tabs.

1. Select the ellipses **More options** on the top right of the page.
2. Select **Export Excel**.

*Analytics for Confluence is now part of Confluence Data Center*
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. See our FAQ for all the details
View insights on pages

Get detailed analytics of your pages and blogs to determine how they’re performing.

1. Go to the page whose analytics you’d like to view.
2. Select Analytics (above the page title)
3. Use the filters at the top to choose the date range for your data. You can also choose how you want to group the data and whether to display it by total number of users or unique users.
4. Hover over the chart to get the number of views for a specific date.

From the page’s analytics, you can view a table with:

- **Name** - The name of the user (or anonymised alias)
- **Last version viewed** - The latest version of the page that the user has viewed
- **Last viewed** - The last time the user viewed the page
- **Views** - The total number of times the user viewed the page

![Screenshot showing the page analytics view tab, sorted by last view date.](image)

Your administrator may have enabled increased privacy mode, which replaces people’s real names with an anonymized alias and avatar. Each alias represents an individual user, so you can still get an idea of engagement, but not attribute activity to particular people.

View insights on attached files

Select the Attachments tab for insights on files attached to it.

The Attachments tab provides the following insights for each file on the page:

- **Name** - The filename name of the attached file
- **Last viewed** - The last time a user has viewed the attached file
- **Views** - The total number of views for the attached file
Analytics for Confluence is now part of Confluence Data Center
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. See our FAQ for all the details.
Search

Confluence gives you a few ways to find what you’re looking for. Here’s an overview of Confluence search, and a few tips to help you find things more easily.

How Confluence search works

When you enter a search term, Confluence looks for content in all spaces (including personal spaces), pages, mail, personal profiles, and space descriptions. It also looks at the content of some attached file types (Word, Text, PowerPoint, Excel, PDF, and HTML).

Search results are based on your Confluence permissions, so you’ll only see content you’re allowed to view.

Learn how Confluence ranks search results

Start a search

To search Confluence:

1. Click the search field in the top-right of Confluence to open the search panel.
2. Start typing your search term.

Results will appear as you type — you don’t need to hit enter.

We exclude comments from your search results unless you select the comment option from the type filter.

Screenshot: the search panel

On this page:

- How Confluence search works
- Start a search
- Filter your search results
- Search for admin options
- Advanced search
- Advanced search syntax

Related pages:

- Confluence Search Syntax
- Confluence Search Fields
- Ranking of Search Results
- Recently Viewed Pages and Blog Posts
- Search Results Macro
- Livesearch Macro
- Search the People Directory
1. **Search filters** – refine your results by space, contributor, type, date, label, or space category.
2. **Advanced search** – go to the advanced search page.
3. **Search tips** – get search help, and tips for refining your search.

Tip: Type / on your keyboard to quickly open the search panel.

Filter your search results

You can refine your search using interactive filters on the left-hand side of the search panel.

**Search within a space**

Use the space filter to find content within a particular space or list of spaces. The space you're currently in will appear at the top of the list by default. Start typing the space name and choose from the list of suggested spaces.

Click the toggle to search within archived spaces.

**Search for content by a specific person**
Use the **contributor** filter to restrict your search to content modified (created, updated, or commented on) by particular people. Start typing the person's username, or part of their name, and we'll show you a list of possible matches. You can add as many people as you like.

**Tip:** To search for your own work, click the **Contributor** filter, then select your profile from the drop-down menu. Your name appears here by default, so it's easy to find.

**Filter by content type**

Use the **type** filter to only show content of a certain type, such as pages, blog posts, comments or user profiles.

**Search within a specific time frame**

Use the **date** filter to search for content last modified (created, updated, or commented on) within a particular period of time.

To search within a specific date range:

1. Click **Advanced Search** on the left-side of the search panel.
2. In the **Last modified** section, choose **Custom**.
3. Select the date range from the drop-down date picker.

**Search for content with a specific label**

Use the **label** filter to search for content containing a specific label. Start typing the name of the label and choose from the list of possible matches.

**Search within a space category**

Use the space category filter to search within a group of related spaces. Start typing the category name and choose from the list of possible matches. You can browse existing categories from the **Space directory**.

**Tip:** Space admins can organize spaces into categories. You can create space categories for departments, subject areas, office locations — whatever works for your team. [Learn how to create a space category](#).

**Search for admin options**

As a Confluence admin, you can quickly access admin options from the search panel.

Start typing what you want to do. We'll show the top three matching admin items at the top of your search results. You'll only see options you have permission to perform.

If you apply a search filter, admin items will no longer appear in your results.

**Advanced search**

The advanced search page allows you to add more search filters, such as creator, title, date range or ancestor page.

To use advanced search:

1. Click the search field at the top-right of Confluence.
2. Click **Advanced search** on the left-side of the search panel.
3. Type your keyword in the search field and hit enter.
Adding a filter from the advanced search page

To add a search filter from the advanced search page:

1. Click **Add a filter** on the bottom left of the advanced search page.
2. From the drop-down menu, select the relevant filter.

**Screenshot: advanced search page**

1. **Search filters** – narrow your search by adding filters.
2. **Add a filter** – add more filters for even more precise search.

You can choose from these additional filters:

- **Creator** – Restrict your search to content created by a particular person. Start typing the person’s username or part of their name and Confluence will offer you a list of possible matches.
- **Label** – Only search for content containing specific labels.
- **With parent** – Only search for direct children of a specific parent page.
- **With ancestor** – Only search for pages below a certain page in the hierarchy.
- **Created** – Choose or enter a date to only show content created within a particular period of time.
- **Mentioning user** – Only search for content that mentions a particular Confluence user.
- **With title** – Only search within page or blog titles.

These filters are provided by **Confluence Query Language (CQL)**.

Advanced search syntax

You can also refine your search using Confluence search syntax. These are words or symbols you enter into the search field to help narrow down your results. Learn more about **Confluence Search Syntax**.
Confluence Search Syntax

You can create an advanced search query using Confluence search syntax. These are special words and symbols you enter into the search field to narrow the focus of your search.

This page outlines the syntax supported by Confluence’s search engine, Lucene.

On this page:
- How to use search syntax
- Search for an exact match
- Search using wildcards
- Exclude words from your search
- Combine search terms
- Search for nearby words (proximity search)
- Search within an alphabetical range
- Search for words spelled similarly (fuzzy search)
- Combining search operators
- Searching for macros
- Search specific fields in Confluence
- Confluence search fields

Related pages:
- Search
- Confluence Search Fields
- Search the People Directory
- Ranking of Search Results

How to use search syntax

To create a search query using Confluence syntax:

1. Click the search field at the top right of Confluence to open the expanded search panel.
2. Type your query using syntax supported by Confluence.

You can use multiple search words and operators in your query.

Screenshot: an example of a search query using Confluence search syntax
Search for an exact match

Use double quotes around your search term to find a specific word or phrase. For example "product roadmap" will search for content that contains the phrase 'product roadmap', or a phrase where 'product' and 'roadmap' are the major words.

"product roadmap"

Limitations with exact match search

Phrases with stop words

Confluence ignores common words (stop words) — such as 'and', 'the', 'or', and 'it' — even if they are included within double quotes.

For example, searching for "the IT budget" will only return pages containing 'budget', because 'the' and 'it' are stop words.

If you'd like to change this, vote on this improvement request:

CONFSERVER-14910 - Provide ability to override Lucene tokenisation and stemming and search for exact text (literal search) IN PROGRESS

Phrases with special characters

Confluence ignores all symbols, such as hyphens or underscores, even if they are included within double quotes.

For example, if you search for "DOC-8510", you get all pages containing 'doc' and '8510'.

Avoid using special characters, such as hyphens, in page or attachment names as they may not be found by Confluence search.

Search using wildcards

Wildcards replace one or more characters in your search. They can help expand your search. For example, the search below would find https://www.atlassian.com or http://www.atlassian.jp

http*.atlassian.*

Confluence doesn't support leading wildcards. This means searching for *heese will not return cheese.
Multiple characters
Use an asterisk (*) at the end of your word to replace multiple characters.

**print** finds content containing 'printer', 'printing', 'prints' and so on.

Multiple wildcards
Use asterisks (*) to add more than one multiple-character wildcard

**r*c** finds content containing 'react', 'recovery', 'refactor' and so on.

Single character
Use a question mark (?) to replace a single character in your search.

**b?tter** finds content containing 'butter', 'bitter', 'better', 'batter' and so on.

---

**Leading wildcards**

Lucene doesn't allow wildcards at the beginning of your search, but you can format your search as a regular expression as a workaround. For example, you can't search for *hum* or ?hum*, as they begin with a wildcard, but you can search for /.*hum.*/ and find things like hum, human, and inhumane.

---

**Exclude words from your search**

Use NOT or minus (-) to exclude words from your search.

chalk NOT cheese

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>NOT</td>
<td>Use NOT (in capital letters) to exclude a word from your search.</td>
<td>chalk NOT cheese finds content containing 'chalk' but NOT 'cheese'</td>
</tr>
<tr>
<td>Minus (-)</td>
<td>Put a minus sign (-) in front of words you want to leave out.</td>
<td>chalk butter -cheese finds content containing 'chalk' and 'butter' but not 'cheese'</td>
</tr>
</tbody>
</table>

---

**Combine search terms**

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>OR</td>
<td>Use OR (in capital letters) to search for content that contains one of the terms.</td>
<td>chalk OR cheese finds content containing either 'chalk' or 'cheese'</td>
</tr>
<tr>
<td>AND</td>
<td>Use AND (in capital letters) to search for content that contains more than one search term.</td>
<td>chalk AND cheese finds content containing both 'chalk' and 'cheese'</td>
</tr>
</tbody>
</table>

You can also combine search terms and operators, for example:

(cheese OR butter) AND chalk

---

**Search for nearby words (proximity search)**

Use a tilde (~) followed by a number to find two words within a certain number of words of each other.

For example, the following search will return 'Octagon blog post', but not 'Octagon team blog post':

"octagon post"~1

The following search won't work, because you can't search for two words within zero words of each other. If you think the words are next to each other, use the matched phrase search.
Search within an alphabetical range

Use 'TO' (in capital letters) to search for names that fall alphabetically within a specified range. For example:

```
[adam TO ben]
```

**Note:** You can't use the AND keyword inside this statement.

Search for words spelled similarly (fuzzy search)

Use a tilde (~) to find words spelled similarly, or to pick up misspellings.

For example, if you want to search for octagon, but you're not sure how it's been spelled, type the word followed by a tilde:

```
octog~
```

Combining search operators

You can also combine various search terms together:

```
o?tag* AND past~ AND ("blog" AND "post")
```

Searching for macros

You can search Confluence pages to find where a macro is used. Start your search with `macroName:` and type the macro name after the colon. For example, to search for all excerpt-include macros:

```
macroName:excerpt-include*
```

Search specific fields in Confluence

Confluence data is stored in fields, for example title, label, type and so on. To search for content using a specific field, type the name of that field into the search box followed by a colon ("), and then the term you're looking for.

You can use multiple fields in the same query. For example, you could use the following query to find all blog posts containing the Excerpt Include macro.

```
type:blogpost AND macroName:excerpt-include*
```

Confluence will only look for the term directly after the colon. For example, the query below will search for 'some' in the title field and 'title' in the default fields:

```
title:some title
```

Use double quotes if you want to find multiple keywords:
Confluence search fields

This table lists some common search fields, and shows examples of what to type into the search box. Fields are case sensitive, so make sure you type the field name exactly as it appears in the table below.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>macro</td>
<td>Searches for pages that contains a specific macro. Type the name of the macro in lowercase. You can use a wildcard to make sure Confluence finds the macro you’re after.</td>
<td>macroName: excerpt-include* \nmacroName: jira*</td>
</tr>
<tr>
<td>space key</td>
<td>Searches for content within a specific space, using the space key. Type the name of the space key in capital letters. You can add multiple spaces using brackets and commas.</td>
<td>spacekey: MARKETING \nspacekey: (IT, MARKETING)</td>
</tr>
<tr>
<td>title</td>
<td>Searches for content with specific words in the title.</td>
<td>title: &quot;product roadmap&quot;</td>
</tr>
<tr>
<td>type</td>
<td>Searches for content of a particular type. You can use the following content types in your query: \n\n- page \n- blogpost \n- attachment \n- comment (only supported when using advanced search).</td>
<td>type: attachment \ntype: blogpost</td>
</tr>
<tr>
<td>labelText</td>
<td>Searches for content containing a specific label. If the label has a hyphen, include it within double quotes.</td>
<td>labelText: roadmap \nlabelText: &quot;product-roadmap&quot;</td>
</tr>
</tbody>
</table>

For more information about search fields, see Confluence Search Fields.
Confluence Search Fields

This page gives an overview of the Apache Lucene search fields used in Confluence.

Filter with CQL

Before you dive into learning more about Lucene fields, you may want to learn about the powerful search filtering offered by Confluence Query Language (CQL).

CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the Add a filter link to add more filters to your query.

- For an OR search, specify multiple values in the same field. So to show pages with 'label-a', 'label-b' or both you'd put 'label-a' and 'label-b' in the same Label field, like this:

  ![Example OR filter]

- For an AND search, add more than one filter and specify a single value in each. To show only pages with label-a and label-b you'd put 'label-a' in one label field, then add a second Label field to the macro, and put 'label-b' in the second one, like this:

  ![Example AND filter]

Put simply, OR values are entered in the same filter, AND values are entered in different filter. Only some filters support AND. If the filter doesn't support the AND operator, you won't be able to add that filter more than once.

- For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that label.

You can use the following CQL filters to build your query:

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
<th>Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>Include pages, blog posts or attachments with these labels.</td>
<td>OR (multiple values in the same filter) AND (multiple Label filters)</td>
</tr>
</tbody>
</table>

On this page:

- Filter with CQL
- Searching for content in specific fields
- Confluence search fields
  - Personal Information
  - Pages
  - Blog
  - Attachments
  - Mail items
- Notes

Related pages:

- Search
- Confluence Search Syntax
- Search the People Directory
- Ranking of Search Results
<table>
<thead>
<tr>
<th><strong>With ancestor or</strong></th>
<th>Include pages that are children of this page. This allows you to restrict the macro to a single page tree.</th>
<th>OR (multiple values in the same filter)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Contributor</strong></td>
<td>Include pages or blog posts that were created or edited by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Creator</strong></td>
<td>Include items created by these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Mentioning user</strong></td>
<td>Include pages and blog posts that @mention these people.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>With parent</strong></td>
<td>Include only direct children of this page (further sub-pages won't be included)</td>
<td>EQUALS (one page only)</td>
</tr>
<tr>
<td><strong>In space</strong></td>
<td>Include items from these spaces.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
<tr>
<td><strong>Including text</strong></td>
<td>Include items that contain this text.</td>
<td>CONTAINS (single word or phrase)</td>
</tr>
<tr>
<td><strong>With title</strong></td>
<td>Include items that contain this text in the title.</td>
<td>CONTAINS (single word or phrase)</td>
</tr>
<tr>
<td><strong>Of type</strong></td>
<td>Include only pages, blogs or attachments.</td>
<td>OR (multiple values in the same filter)</td>
</tr>
</tbody>
</table>

* This field is required in CQL-powered macros.

** You can add these filters in CQL-powered macros but in search they're part of the standard search filters, so they don't appear in the Add a filter menu.

### Searching for content in specific fields

Confluence data is stored in fields which can be specified in the search. To search a specific field, type the name of the field followed by a colon `:` and then the term you are looking for. For example:

```
title:"Some Title"
```

```
labelText: chalk
```

The field specification applies only to the term directly preceding the colon. For example, the query below will look for "Some" in the title field and will search for "Heading" in the default fields.

```
title: Some Heading
```
To learn more about using Confluence search fields in an advanced search query, head to [Confluence Search Syntax](#).

## Confluence search fields

Below are the fields which can be searched, listed by content type.

### Personal Information

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenized</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>fullName</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

### Pages

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenized</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used on the page</td>
</tr>
</tbody>
</table>

### Blog

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenized</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

Created in 2023 by Atlassian. Licensed under a [Creative Commons Attribution 2.5 Australia License](#).
<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenized</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>filename</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>comment</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used in the blog</td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
</tbody>
</table>

**Attachments**

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenized</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>filename</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>comment</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

**Mail items**

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenized</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>messageid</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>inreplyto</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>recipients</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

**Notes**
To find out the version of Lucene Confluence is using go to `<installation directory>/confluence/WEB-INF/lib` and locate the Lucene jar files. The Lucene version number will be part of the filename.
Search the People Directory

The people directory displays a list of people who are authorized to log in to your Confluence site (they have the ‘Can Use’ global permission).

The people directory includes anybody who has logged into Confluence or who has had a user account created for them in Confluence.

The people directory does not include users who can log into Confluence using external user management if they have never yet logged in.

View the people directory

Choose People at the top of the screen.

Search for people

To search for a particular person, type their first name and/or last name into the search box and choose Search.

- To see everyone who uses your Confluence site, choose All People.
- To see just those people who have set up a personal space, choose People with Personal Spaces.

Follow people’s activities

Confluence’s network features allow you to ‘follow’ (that is, keep track of) other people’s activities in your Confluence site. For more information, please refer to Network Overview. You can use the hover profile feature in the people directory to start following other people.

- To start following someone, move your mouse over their name or profile picture and choose Follow in their profile popup.
- To stop following someone, move your mouse over their name or profile picture and choose Stop Following in their profile popup.

Once you start following another person, their activities will start appearing in your network view.

Screenshot: The people directory

Notes

- The people directory uses the hCard microformat for simple integration with a variety of microformat-enabled tools. hCard is an open data format for representing people, companies, organizations, and places. Read more about microformats and hCard.
- By default, deactivated users (disabled user accounts) are excluded from the people directory. You can include them by adding the showDeactivatedUsers parameter to the URL. For example:
Any user who does not have the 'Can Use' Confluence global permission won't appear in the People directory (for example, Jira Service Management customers who can view KB articles, but do not have a Confluence license).

By default, externally deleted users (for example, users deleted from an LDAP repository) are excluded from the people directory. You can include them by adding the `showExternallyDeletedUsers` parameter to the URL. For example:

```
http://my.confluence.com/dopeopledirectorysearch.action?showExternallyDeletedUsers=true
```

The Confluence administrator can hide the people directory. If it is hidden, you will not see the People Directory option.
Recently Viewed Pages and Blog Posts

The Recently Viewed list in Confluence keeps track of pages and blog posts you've recently visited, and allows you to easily navigate back to them.

To view your recently viewed content:

1. Choose your profile picture at top right of the screen, then choose Recently Viewed
2. Choose the title of the page you want to revisit

To filter the list, type part of a page title or user's name in the Filter field.

Your last ten recently viewed pages also appear when you click in Confluence's Search field before you start typing a search query.
Ranking of Search Results

When you perform a search in Confluence, it is likely that there will be many pages or other content items that match your search terms.

Confluence will rank these matching items by evaluating their relevance. This should mean that the items most relevant to you will appear at the top of the search results list so that you can quickly select the item you need.

Below is an overview of the method Confluence uses to determine the relevance of the items returned by the search, that is, to rank the search results.

Summary of the ranking method

When displaying the search results, Confluence applies a weighting to each of the content items returned.

To come up with this single weighting, Confluence first combines three separate weightings based on the following factors:

1. The content type of the matching item – this includes user profiles, pages, blog posts, images and other attachments, etc. More details below
2. The field type in which the matching term was found – this includes title, name, body content, labels, etc. More details below
3. The recency of the matching item – that is, when it was created or last modified; this could be today, yesterday, up to 1 week ago, up to 1 year ago, or over 1 year ago. More details below

The item with the heaviest final weighting will appear at the top of the list of search results. All of the other content items will appear below in descending order of weighting.

Weighting by content type

<table>
<thead>
<tr>
<th>Content type</th>
<th>Weighting</th>
</tr>
</thead>
<tbody>
<tr>
<td>User profile</td>
<td>1.5</td>
</tr>
<tr>
<td>Space</td>
<td>1.5</td>
</tr>
<tr>
<td>Page</td>
<td>1.5</td>
</tr>
<tr>
<td>Blog</td>
<td>1.3</td>
</tr>
<tr>
<td>Attachment (files, videos and images)</td>
<td>1</td>
</tr>
<tr>
<td>Comment</td>
<td>1</td>
</tr>
<tr>
<td>Mail</td>
<td>1</td>
</tr>
</tbody>
</table>
On Confluence, you're most likely to be searching for knowledge articles, work done by a particular team or person, or ways to collaborate. Our ranking logic prioritises content types such as user profiles, spaces, and pages that are most suitable for these tasks.

**Simple example**

If your search result returns 3 items – a page, a blog, and a comment – and they are the same in every other way, then they will be ranked in the order shown above.

### Weighting based on field type

<table>
<thead>
<tr>
<th>Field type</th>
<th>Weighting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>2</td>
</tr>
<tr>
<td>Content</td>
<td>1</td>
</tr>
<tr>
<td>Unstemmed title</td>
<td>1</td>
</tr>
<tr>
<td>Label</td>
<td>0</td>
</tr>
</tbody>
</table>

Search results that match the title field are twice as important and weighted twice as highly as matches in the body content.

**Simple example**

If you search for a user's name, the search results will rank the person's user profile above a page that only contains their name in the content. This is because the profile contains the name in the title field. This example assumes the results are the same in every other way.

### Weighting based on recency

<table>
<thead>
<tr>
<th>Last activity</th>
<th>Weighting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Today</td>
<td>2.01-2.05</td>
</tr>
<tr>
<td>Yesterday</td>
<td>1.92-2.01</td>
</tr>
<tr>
<td>Up to 1 week ago</td>
<td>1.52-1.92</td>
</tr>
<tr>
<td>Up to 1 month ago</td>
<td>1.46-1.52</td>
</tr>
<tr>
<td>Up to 3 months ago</td>
<td>1.36-1.46</td>
</tr>
<tr>
<td>Up to 6 months ago</td>
<td>1.25-1.36</td>
</tr>
<tr>
<td>Up to 1 year ago</td>
<td>1.11-1.25</td>
</tr>
<tr>
<td>Beyond a year</td>
<td>1-1.11</td>
</tr>
</tbody>
</table>

Recency is based on when an item was created or last modified, whichever happened more recently. Search gives a higher weighting to recently updated items because it assumes this content is likely to be more relevant than idle or older content.

When a content item has not been modified in over a year, we say that it is in a state of "decay". In this state, we assume it is less relevant and it is de-prioritised in the search results in favour of content modified within the last year, and even more so within the last week.
Simple example

- If two documents match in all other ways, then the newer one will be shown first.
- If the two documents being compared are both older than a year then their relative age does not matter.

Confluence uses the Apache Lucene search engine library. Lucene’s score calculation has a number of additional terms, not mentioned in the above example. We have simplified the above explanation of search ranking for purposes of illustration. If you are interested, you can see more information in the Lucene documentation.
Permissions and restrictions

As a tool for communication and collaboration, we believe Confluence is at its best when everyone can participate fully. Confluence keeps a history of all changes to pages and other content, so it's easy to see who has changed what, and reverse any changes if you need to.

Confluence does, however, give you the choice to make your site, spaces, and pages as open or closed as you want to.

Levels of permission

There are three levels of permissions in Confluence:

- global permissions
- space permissions, and
- page restrictions.

Global permissions

Global permissions are site-wide permissions, and are assigned by a Confluence administrator or system administrator.

Global permissions cover things like whether a user can log in or create a space. They don't really interact with space permissions or page restrictions.

For full details, check out the Global Permissions Overview.

Space permissions

Every space has its own independent set of permissions, managed by the space administrators, which determine the access settings for different users and groups.

They can be used to grant or revoke permission to view, add, edit, and delete content within that space, and can be applied to groups, users, and even to anonymous users (people who aren't logged in) if need be.

For full details, check out the Space Permissions Overview.

Page restrictions

Page restrictions work a little differently to global and space permissions. Pages are open for viewing or editing by default, but you can restrict either viewing or editing to certain users or groups if you need to. Page restrictions can be applied to published or unpublished pages and blog posts (drafts).
Don't forget, every page in Confluence lives within a space, and space permissions allow the space admin to revoke permission to view content for the whole space. Even the ability to apply restrictions to pages is controlled by the 'restrict pages' space permission.

For full details, check out Page Restrictions.

How do permissions and restrictions interact?

You can restrict viewing of a page or blog post to certain users or groups, so that even if someone has the 'view' permission for the space, they won't be able to view the content of the page or blog post.

If someone is a space admin and you’ve used page restrictions to prevent them viewing a page, they won't be able to see the page when they navigate to it. As a space admin though, they can see a list of restricted pages in the space and remove the restrictions.

Check who can view a page

To check who can view a page, go to More options *** > People who can view. This will show a list of people, including administrators, who have space permission to see the space, and are not prevented by page restrictions from seeing the page. See Check who can view a page for more information.

The diagram below shows the points at which someone could be prevented from viewing a page.

- **Site** - they don't have permission to log in to Confluence.
- **Space** - they don't have permission to view the space.
- **Parent page** - the current page has a view restriction preventing them from viewing.
- **Child page** - the current page is inheriting a view restriction from another page higher up in the page hierarchy, preventing them from viewing.

What about links?

Space permissions and page restrictions affect how links between Confluence pages are displayed.

- If someone doesn't have 'View' space permission, links to pages in that space will be visible, but they'll get a "page not found" message. The space key is not revealed in the link URL.
- If someone has the "View" space permission, but the page has view restrictions, the link will be visible but they'll get an "access denied" message when they click the link.

Links to attachments are also affected. If the visitor doesn't have permission to view the page the attachment lives on, the link won't be rendered.
Confluence Groups

Grouping users in Confluence is a great way to cut down the work required when managing permissions and restrictions.

If you’re a space admin, you can assign a set of space permissions to a group rather than to each individual user. And as a page creator with ‘Add /Delete Restrictions’ permission, you can also add and remove page restrictions for groups.

Default Confluence groups

There are two default groups in every Confluence instance and, beyond that, Confluence administrators are free to set up and edit groups in any way they see fit.

The two default groups in Confluence are:

- **confluence-users** - this is the default group into which all new users are usually assigned. In most sites this is the group that provides the permission to log in to Confluence.
- **confluence-administrators** – this super group grants the highest level of administrator permissions. Members of this can view all pages, including restricted pages. While they can’t edit existing pages, they can add, delete, comment, restore page history, and administer the space. They can also access the admin console and perform all administrative tasks.

Overlapping permissions

Space permissions are additive. If a user is granted permissions as an individual or as a member of one or more groups, Confluence will combine these permissions together. This is sometimes known as their effective permissions.

Sasha is a member of the confluence-users group and the developers group. The confluence-users group has ‘export’ permission, but does not have ‘restrict’ permission. The developers group has ‘restrict’ permission but does not have ‘export’ permission.

By being a member of these two groups, Sasha can restrict and export content. The permissions do not conflict, they combine to determine what Sasha is allowed to do in this space.

Anonymous users

People who don’t log in when they access Confluence are known as ‘anonymous’ users. By default, anonymous users don’t have access to view or change any content in your Confluence site, but Confluence admins can assign permissions to anonymous users if it’s required.

Unlicensed users from linked applications

If you’re using Confluence as a knowledge base for Jira Service Management, your Jira Service Management administrator can choose to allow all active users and customers (that is logged in users who do not have a Confluence license) to view specific spaces.

These users have very limited access, and cannot be granted permissions in the same way as an individual or group. However, it’s important to note that this permission overrides all existing space permissions, so any logged in Confluence user will also be able to see the space (regardless of their group membership). This is due to the way Confluence inherits permissions.
Check who can view a page

Confluence is open by default, however because of the layers of space permissions and page restrictions that can be applied, it isn't always obvious who can see your page.

If you want to share a page with someone in a different team, for example, it's useful to know whether they have adequate permissions to see it before you share.

Check who can view a page

To check who can view a page:

1. Go to More options ••• > People who can view.
2. A list of all the people who can view the page will appear.
3. Start typing a name to filter the list.
People who can view this page

5 people can view this page. Restrictions can affect who can view.

<table>
<thead>
<tr>
<th>Full name</th>
<th>Username</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rach Admin</td>
<td>admin</td>
</tr>
<tr>
<td>Fran Perez</td>
<td>fran</td>
</tr>
<tr>
<td>Jane Rotanson</td>
<td>jane</td>
</tr>
<tr>
<td>Jie Yang Song</td>
<td>jie</td>
</tr>
<tr>
<td>Omar Darboe</td>
<td>omar</td>
</tr>
</tbody>
</table>

Why can these people view?

The list includes everyone who:

- is allowed to view the space, via space permissions, and
- is not prevented from viewing the page by page restrictions.

The list also includes members of the confluence-administrators super group, who can always see all spaces and pages. This means that even if you restrict a page to yourself, it's possible that at least one other person can see it.

What should I do if someone can't see my page?

If you want to share your page with a person, and they're not listed, you'll need to work out what is preventing them from viewing the page.

If you restricted the page, add them to the page restrictions, and then check the People who can view list again.

If they still aren't listed, it's likely they don't have permission to see the space. You'll need to contact a space admin to help with this. Go to Space Tools > Overview for a list of space admins.

How do I make my page completely private?

The short answer is, you can't. Confluence is designed to be open. It's for sharing work with your team. While you can restrict a page to yourself, it's important to note that:

- Space administrators always have the ability to remove page restrictions, even from pages they can't see.
People with Confluence Administrator and System Administrator global permissions can't see your pages by default, but they can grant themselves space administrator permission to the space.

Members of the confluence-administrators super group can see all spaces and pages. This group grants the highest possible permission in Confluence. Some organisations use this group heavily, while others don't use this group at all.

**Disable the People who can view option**

People with Confluence Administrator or System Administrator permissions can disable the **People who can view** option, if they don't want people to be able to see a list of user's names.

To disable the People who can view option:

1. Go to `<base-url>/admin/plugins/gatekeeper-plugin/global/configuration.action`
2. Deselect **Show 'People who can view' option** and save the change.
Inspect permissions

Confluence is open by default, but because of the layers of group, individual and anonymous permissions that can be applied, it can be challenging to find out exactly who can do what.

Inspect permissions helps you:

- troubleshoot permissions problems
- audit who can do what in your site
- apply the permissions granted to a user or group in one space to multiple spaces.

It reveals a person's effective permissions, combining everything we know about their permissions in a way that can be easily interpreted.

Troubleshoot permissions problems

Often you will need to find out why someone can or can't do something in Confluence. By inspecting permissions you can drill right down to the root of the problem.

For example, someone reports to you that a teammate can see a space they shouldn't be able see. By inspecting permissions you can work out exactly what group memberships, for example, might be contributing.

Inspect permissions via space administration

You need space admin permissions for the space you want to troubleshoot.

To find out why someone can or can't view this space:

1. Go to the space and choose Space tools > Permissions from the bottom of the sidebar
2. Go to the Inspect permissions tab
3. Enter the person's name or username.
4. Leave the Page field blank (unless you need to investigate a specific page in this space).
5. Choose Show.

A table showing the person's effective permissions in this space will appear. Click one of the icons to go to the detail view, and find out exactly why they do or don't have that permission.

If you choose to specify a particular page, the permissions explanations will also include information about any page restrictions. The icons will represent just that page, not the user's permissions for the entire space.

Related pages:

- Permissions and restrictions
- Global Permissions Overview
- Space Permissions Overview

Troubleshooting and known issues

- General cache problems
- Export options limited in Internet Explorer 11
- Inspect permissions for a group only shows direct permissions
- Excluding spaces with no permissions can take a long time in large sites

On this page:

- Troubleshoot permissions problems
  - Inspect permissions via space administration
  - Inspect permissions via the Global administration
  - Inspect permissions for a group
  - Permissions explanations
- Audit permissions
- Bulk apply permissions
  - Bulk apply permissions for a group
  - Bulk apply permissions for a user
- Troubleshooting and known issues
  - General cache problems
  - Export options limited in Internet Explorer 11
  - Inspect permissions for a group only shows direct permissions
  - Excluding spaces with no permissions can take a long time in large sites

Inspect permissions is an advanced permissions feature, and is only available in Confluence Data Center.
Inspect permissions via the Global administration

You need Confluence Administrator or System Administrator global permission to do this. You don’t need to have permission to view the space itself.

To find out why someone can or can’t view this space:

1. Go to Administration > General Configuration > Inspect permissions.
2. Enter the person’s name or username.
3. Enter the spaces you want to view.
4. Choose Show.

A table showing the users and spaces you searched for will appear. Click the link to see the detailed view, then click the icons to find out exactly why they do or don’t have that permission.
Inspect permissions in Global administration showing permissions for two users and three spaces.

Animation: Inspect permissions in Global administration showing searching for all spaces containing the word "project" and then viewing permissions explanations for a user.

Inspect permissions for a group
You can also inspect permissions for a specific group. This can only be done via the global administration.

To inspect permissions for a group:

1. Go to Administration > General Configuration > Inspect permissions.
2. Choose the Groups tab
3. Enter the group name.
4. Enter the spaces you want to view.
5. Choose Show.

A table showing the groups and spaces you searched for will appear. Click the link to see the detailed view.

When inspecting permissions for a group, be aware:

- We don't indicate when a group does not have the Can Use global permission, as we do for users.
- We don't show effective permissions for the group, as we do for users. We only show permissions directly granted to that group (not granted via membership of a parent group. This is only an issue if your external user directory has nested groups).

### Using wildcards in your search

When searching for users, groups, or spaces, you can use * as a wildcard. For example if you wanted to search for all spaces that contain the word project in their title, type *project and select Search for *project from the suggestions dropdown.

### Permissions explanations

The detail view shows the effective permissions for a single user or group in a space. Click each icon to see a detailed explanation, as shown here.

**Icons** - icons indicate whether the user or group can or can't do this action.

**Explanation** - explains why the user can or can't do this action.

**Good to know information** - provides additional information that may become relevant, for example that space administrators can grant themselves permissions they don’t currently have.

The purpose of these explanations is to provide a simple reason why someone can or can't do something in a space. The messages are designed to be short, and present the most relevant information first.

The table below contains a more detailed explanation of every message, including the conditions that trigger the message.

### Explanations about users

<table>
<thead>
<tr>
<th>Explanation</th>
<th>Message appears when...</th>
</tr>
</thead>
</table>

Created in 2023 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Permission granted as an individual</th>
<th>The user is listed in the space permissions for that space.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Permission granted as a member of:</td>
<td>The user is a member of a group, that is listed in the space permissions for that space. If the user is a member of multiple groups that are listed in the space permissions, we will list all of them.</td>
</tr>
<tr>
<td>Permission granted as an individual and as a member of:</td>
<td>The user is listed in the space permissions for that space, and is also a member of a group that is listed in the space permissions for that space.</td>
</tr>
<tr>
<td>Permission granted to <strong>anonymous users</strong>, which means everyone will get this permission by default, including people who are not logged in.</td>
<td>The permission is granted to anonymous users in this space, and your site is public (you have granted anonymous users the Can use global permission). Logged in users can't have fewer permissions than anonymous users.</td>
</tr>
<tr>
<td>Permission granted to <strong>anonymous users</strong>, which means everyone who is logged in will get this permission by default.</td>
<td>The permission is granted to anonymous users in this space, but your site is not public (anonymous users do not have the Can use global permission). Logged in users can't have fewer permissions than anonymous users. This is sometimes used as a shortcut way to provide 'everyone' with space permission, without making the site itself public.</td>
</tr>
<tr>
<td>No permission granted as an individual or as a member of a group.</td>
<td>The user isn't listed in the space permissions for that space, they are not a member of a group that is listed in the space permissions for that space, and anonymous has not been granted any permissions.</td>
</tr>
<tr>
<td>This person doesn't have the <strong>Can use</strong> global permission, so they can't log in to Confluence.</td>
<td>This user exists in the user directory, but doesn't have a Confluence license seat. They are not a member of confluence-users or another group that has the 'Can use' global permission.</td>
</tr>
<tr>
<td>This person is a <strong>Confluence administrator</strong> so could grant themselves this permission.</td>
<td>The user, or a group they're user is a member of, has Confluence Administrator global permission. This means they can recover permissions for a space they don't have permission to see, and then change the permissions for that space. Unlike members of the confluence-administrators super group, they can't see the space by default.</td>
</tr>
<tr>
<td>This person is a <strong>space admin</strong>, so could grant themselves this permission.</td>
<td>The user has space admin permissions in this space. This means they can modify permissions for this space, and could grant themselves any permissions they don't currently have.</td>
</tr>
<tr>
<td>This person is a <strong>space admin</strong>, so can edit restrictions. They can also remove all restrictions from pages they don't have permission to edit or view.</td>
<td>The user has space admin permissions in the space. This means they can always change page restrictions (even if they don't have the Restrict permission), and can access a list of all restricted pages in the space, and remove all restrictions from these pages.</td>
</tr>
<tr>
<td>This person has <strong>Delete own permission</strong> so can delete their own pages, blog posts, comments, and attachments.</td>
<td>The user can delete pages, blog posts, comments, and attached files that they have created. They can't delete pages, blog posts, comments, and attached files created by other users unless they also have Delete permission in the space. For example the user can delete a page they created, but they cannot delete a page their team mate created unless they also have the Delete Page space permission.</td>
</tr>
</tbody>
</table>
To add and delete restrictions this person also needs the **Add page permission**.

This person is a member of the **confluence-administrators super group**. This means they can view all pages, including restricted pages. While they can't edit existing pages, they can add, delete, comment, restore page history, and administer the space.

This person can't log in because their **account is disabled**.

Restrictions on `<page title>` prevent this person from viewing the page.

Restrictions on `<page title>` allow this person to view and edit the page.

Restrictions on `<page title>` allow this person to view the page.

**Explanations about groups**

These messages appear when you select a group as the entity to inspect. You need to be a Confluence Administrator to inspect permissions for groups.

<table>
<thead>
<tr>
<th>Permission explanation</th>
<th>Message appears when...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Permission granted to all members of this group.</td>
<td>The group is listed in the space permissions for that space.</td>
</tr>
<tr>
<td>Permission granted to <strong>anonymous users</strong>, which means everyone will get this permission by default, including people who are not logged in.</td>
<td>The permission is granted to anonymous users in this space, and your site is public (you have granted anonymous users the Can use global permission). Logged in users can't have fewer permissions than anonymous users.</td>
</tr>
<tr>
<td>Permission granted to <strong>anonymous users</strong>, which means everyone who is logged in will get this permission by default.</td>
<td>The permission is granted to anonymous users in this space, but your site is not public (anonymous users do not have the Can use global permission). Logged in users can't have fewer permissions than anonymous users. This is sometimes used as a shortcut way to provide 'everyone' with space permission, without making the site itself public.</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>No permission granted to this group.</td>
<td>The group isn't listed in the space permissions for that space, and anonymous has not been granted any permissions.</td>
</tr>
<tr>
<td>This group doesn't have the <strong>Can use</strong> global permission, so people in this group may not be able to log in to Confluence.</td>
<td>This group exists but does not have the 'Can use' global permission. This is very common. Often one group, such as confluence-users is used to grant a Confluence license seat, and additional groups used only to manage space permissions. This is only an issue if a user is not a member of another group that grant them Can use permission.</td>
</tr>
<tr>
<td>Members of this group are <strong>space admins</strong>, so could grant themselves this permission.</td>
<td>The group has space admin permissions in this space. This means members of this group can modify permissions for this space, and could grant themselves or this group any permissions they don't currently have.</td>
</tr>
<tr>
<td>Members of this group are <strong>space admins</strong>, so can edit restrictions. They can also remove all restrictions from pages they don't have permission to edit or view.</td>
<td>The group has space admin permissions in the space. This means members of this group can always change page restrictions (even if they don't have the Restrict permission), and can access a list of all restricted pages in the space, and remove all restrictions from these pages.</td>
</tr>
<tr>
<td>Members of this group have <strong>Delete own</strong> permission so can delete their own pages, blog posts, comments, and attachments.</td>
<td>Members of this group can delete pages, blog posts, comments, and attached files that they have created. They can't delete pages, blog posts, comments, and attached files created by other users unless they also have Delete permission in the space. For example the user can delete a page they created, but they cannot delete a page their team mate created unless they also have the Delete Page space permission.</td>
</tr>
<tr>
<td><strong>confluence-administrators</strong> is a <strong>super group</strong>. Members of this group can view all pages, including restricted pages. While they can't edit existing pages, they can add, delete, comment, restore page history, and administer the space.</td>
<td>This is a default group that has significant privileges in Confluence, beyond that provided by the Confluence Administrator or System Administrator global permission.</td>
</tr>
<tr>
<td><strong>To add and delete restrictions people in this group also need the Add page permission.</strong></td>
<td>The group has Restrict permission, but does not have the Add page permission. Applying a page restriction is considered editing the page, so both permissions are required.</td>
</tr>
<tr>
<td><strong>Delete own</strong> is only available to members of this group who have logged in.</td>
<td>This message appears when Delete Own permission is granted to a group that doesn't have Can use global permission. It is just a reminder that people must be able to log in to delete their own content.</td>
</tr>
<tr>
<td>This permission information may be incomplete because this group is a member of one or more parent groups. Permissions granted to parent groups are not shown here.</td>
<td>This message appears when the group is nested, that is, it's a member of another group. This hierarchy of groups comes from your external user directory. We don't show any permissions that a group is inheriting from a parent group. You'll need to inspect these parent groups seperately.</td>
</tr>
</tbody>
</table>
Explanations about anonymous

These messages appear when you select Anonymous as the entity to inspect. Anonymous in this instance means people who have not logged in to Confluence.

<table>
<thead>
<tr>
<th>Permission explanation</th>
<th>Message appears when...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Permission granted to anonymous users.</td>
<td>Permission granted to the anonymous entity listed in the space permissions for that space.</td>
</tr>
<tr>
<td>No permission granted to anonymous users</td>
<td>No permission granted to the anonymous entity listed in the space permissions for that space.</td>
</tr>
<tr>
<td>Anonymous users don't have Can use global permission. People must log in to use Confluence. All logged in users will inherit this permission by default.</td>
<td>The permission is granted to anonymous users in this space, but your site is not public (anonymous users do not have the Can use global permission). Logged in users can't have fewer permissions than anonymous users. This is sometimes used as a shortcut way to provide 'everyone' with space permission, without making the site itself public.</td>
</tr>
<tr>
<td>Although Delete own permission can be granted to anonymous users, it has no effect.</td>
<td>The Delete Own permission is assigned to anonymous users. Because you need to be logged in for us to know who you are, and what you have created, Delete Own is never available to anonymous users, even when granted.</td>
</tr>
<tr>
<td>Restrictions on &lt;page title&gt; prevent anonymous users from viewing the page.</td>
<td>A page restriction has been applied to the page. Anonymous users have 'no access'. This message only appears when you inspect permissions for a specific page in a space.</td>
</tr>
<tr>
<td>Restrictions on &lt;page title&gt; allow anonymous users to view, but prevent them from editing the page.</td>
<td>A page restriction has been applied to the page. In the page restrictions dialog, everyone can view, but only specific users or groups can edit. This message only appears when you inspect permissions for a specific page in a space.</td>
</tr>
<tr>
<td>This permission can't be granted to anonymous users.</td>
<td>This is a reminder that some permissions, such as Space Admin, and Restrict are never available to anonymous users.</td>
</tr>
<tr>
<td>Anonymous access is enabled globally.</td>
<td>This is a reminder that your site is public. Because you have granted anonymous users the Can use global permission, people do not need to log in to access Confluence.</td>
</tr>
</tbody>
</table>

Audit permissions

If you need to regularly check who can do what in your site, for example for compliance or regulatory reasons, you can inspect permissions to conduct an audit.

To export permissions information for all users and all spaces in your site:

1. Go to Administration > General Configuration > Inspect permissions.
2. Choose your search criteria - you can search for particular users, groups, or spaces, include disabled accounts, or exclude users who have no permissions.
3. Choose Show. This will give you an idea of how large your query is.
4. Choose Export.
5. Keep the default separator. Comma separated is great for opening in most spreadsheet applications.
6. Choose how you want spaces to be listed. This depends on how much information you want to include. You can include just the space key, or the title and description too.

7. Choose Export.

The CSV file will be immediately downloaded in your browser. This can take a few minutes, depending on the size of your query.

This file can be extremely large in sites with many users and spaces. You could use the wildcard search feature to limit the number of users to be included in each export.

1. **Wildcard search** - use a wildcard to narrow your search.
2. **Export** - export the results to CSV for auditing or further analysis.

This example shows the output for one user, and three spaces.

- A row will be created for each of the 14 space permissions that can be granted.
- A column will be created for each space in your query. These are identified by space key, but you can choose to include the space name and description in the export if you require it.
- T and F indicates whether the user has this permission (true) or they do not have this permission (false)

<table>
<thead>
<tr>
<th>Username</th>
<th>Display Name</th>
<th>Permission</th>
<th>SPACE1</th>
<th>SPACE2</th>
<th>SPACE3</th>
</tr>
</thead>
<tbody>
<tr>
<td>user1</td>
<td>Sample User 1</td>
<td>view-space</td>
<td>T</td>
<td>T</td>
<td>F</td>
</tr>
<tr>
<td>user1</td>
<td>Sample User 1</td>
<td>remove-own</td>
<td>T</td>
<td>T</td>
<td>F</td>
</tr>
<tr>
<td>user1</td>
<td>Sample User 1</td>
<td>page-add</td>
<td>T</td>
<td>T</td>
<td>F</td>
</tr>
<tr>
<td>user1</td>
<td>Sample User 1</td>
<td>page-remove</td>
<td>T</td>
<td>F</td>
<td>F</td>
</tr>
<tr>
<td>user1</td>
<td>Sample User 1</td>
<td>blog-add</td>
<td>T</td>
<td>F</td>
<td>F</td>
</tr>
</tbody>
</table>
In this example Sample User 1:

- Can do everything, including administer Space1
- Can view, add, and delete their own content in Space2
- Can't view Space 3 at all.

### Bulk apply permissions

Bulk applying permissions is useful when:

- You create a new group, and want to give that group permissions to a number of existing spaces.
- You need to grant someone permissions as an individual for a number of existing spaces.
- You have just created several new spaces, and want to use permissions from an existing space as a template.

We recommend using groups as an efficient way to manage permissions in your site. When someone new starts on your team, we would recommend making them a member of appropriate groups, over using the bulk add permission options to grant them permissions to all their spaces as an individual.

#### Bulk apply permissions for a group

You need Confluence Administrator or System Administrator global permissions to do this.

To give a group the same permissions in multiple spaces:

1. Go to Administration > General Configuration > Inspect permissions.
2. Go to the Groups tab.
3. Enter the name of the group.
4. Enter the name of the space that you want to use as a starting point.
5. Choose Show, then click to see the detailed view.
6. Choose Edit.
7. Make sure the correct permissions are selected. These are the permissions you'll be copying.
8. Enter the names of the spaces you want to copy these same permissions to. You can add as many spaces as you like.
9. Choose Apply.
10. Check the confirmation dialog to make sure all spaces were successfully updated.
Bulk apply permissions for a user

Before you do this, we recommend you inspect permissions to find out what permissions the user already has for the spaces you plan to update, paying particular attention to how the permissions are granted (individually, or via a group). In many cases the best approach is to change the user’s group membership, or the space permissions granted to a group, rather than bulk applying changes to the individual.

You need Confluence Administrator or System Administrator global permissions to do this.

To give a user permissions in multiple spaces:

1. Go to Administration > General Configuration > Inspect permissions.
2. Enter the name of the user.
3. Enter the name of the space that you want to use as a starting point.
4. Choose Show, then click to see the detailed view.
5. The user’s effective permissions are shown. These permissions are a combination of any individual and group permissions. Choose Edit.
6. Make sure the correct permissions are selected. These are the permissions you’ll be copying.
7. Enter the names of the spaces you want to copy these same permissions to. You can add as many spaces as you like.
8. Choose Apply.
9. Check the confirmation dialog to make sure all spaces were successfully updated.

As a general rule, we recommend managing permissions using groups. If you do decide to bulk apply permissions for a user, there are some things to be aware of:

- Permissions can only be granted to the user as an individual using this method.
- Any permissions the user has as a member of a group will be unchanged. For example if they are a member of a group that has Export permission, and you bulk apply permissions that do not have Export permission, they will still have Export permission. Changing their individual permissions can’t override their group permissions.
- The checkboxes, when you click Edit, reflect the user’s current effective permissions - that is the combination of all the permissions they already have as an individual or member of a group. When you click Apply, you’ll apply these exact permissions as an individual. You may actually be doubling up on permissions the user already has, as a member of a group.

Troubleshooting and known issues
General cache problems

Confluence caches permissions information, which helps to make sure results are returned quickly when you check who can view a page, or inspect permissions. We continually update the cache as people and permissions change. However, we know of two scenarios where the cache is not correctly updated - when you import a site, and when you add, disable, or change the order of your user directories.

If this happens, the best way to force Confluence to rebuild the cache is to disable the Inspect permissions - gatekeeper plugin, then re-enable it. Alternatively, you can restart Confluence, as the cache is built on startup.

Export options limited in Internet Explorer 11

There's a known issue with the export dialog in Internet Explorer 11. The dialog is known to intermittently freeze if you select either of the dropdown menus. As a workaround, use the default values for the Separator and List spaces by fields, or use another browser to complete the export.

Inspect permissions for a group only shows direct permissions

If your external directory has nested groups (a group is a member of another group), and you inspect permissions for a group, you'll only see permissions granted directly to that group (not effectively granted by being a member of a parent group). If you search for a user, we'll always show the effective permissions, including those granted by parent groups.

Excluding spaces with no permissions can take a long time in large sites

In the global Inspect Permissions screen, if you select "Don't show spaces that have no permissions for selected users" and don't specify any other filters (such as specifying users, groups, or spaces), the query can take several minutes to return any results. This is particularly true in sites with a very large number of users and spaces.
Permissions best practices

There are several different strategies you can use for managing permissions in your site. The larger your site grows, the more important it is to make sure that your permissions strategy can scale with your organisation.

Granting permission to a space on an individual by individual basis may work well for small teams, but rapidly becomes unwieldy when your user base grows to thousands of people.

On this page, we provide our recommendations for the best ways to manage common permissions scenarios. Most of the advice boils down to:

- Keep Confluence as open as possible, it's designed to be open by default.
- Use groups over individual permissions wherever possible, to avoid headaches in the future.

Give people access

I want everyone in my organisation to be able to log into Confluence

The best way to achieve this is to make everyone a member of a group that has permission to log in to Confluence, such as the default confluence-users group.

See Adding or Removing Users in Groups for information on how to add people to groups.

When new people join your organisation, add them to this group to grant permission to use Confluence.
If you don't want to use an existing group, you can create a new one. The process is much the same, but you will need to explicitly grant this group global permission to use Confluence.

To change the global permissions for a group:

1. Go to Administration > General Configuration > Global permissions.
2. Choose Edit Permissions.
3. Enter your new group name in the Grant browse permission to field.
4. Make sure the Can use checkbox is selected.
5. Save your changes.

I want everyone in my organisation to be able to view a space

The best way to do this is to grant space permissions to a group that all users are a member of, such as the default confluence-users group.

If your site is not public (anonymous users do not have the 'Can Use' global permission, everyone must log in to use Confluence), you can also use the anonymous permission as an 'everyone' shortcut. This is useful if your groups setup is complex, and there isn't a single group that everyone is a member of. If you plan to make your site public in future however, it's best to avoid this workaround.

I want to give people in my team access to our space

Think about whether your space really needs to be private. If not, you can grant permission to a group that all users are a member of, such as confluence-users.

If it does need to be private, and your team is only going to be using this one space, it might be appropriate to grant permissions as individuals. That way you don't need to ask a Confluence Administrator to add people to groups. See Assign Space Permissions.

However, if your team needs access to multiple spaces, using a group is definitely the way to go, as it will save you a lot of time in future when people join or leave your team. See Adding or Removing Users in Groups.

I want to give my team access to all our project spaces

The best way to do this is to create a group, and grant that group permissions in each project space. When people join or leave your team, you only need to change the group membership, you don't need to edit the space permissions for multiple spaces. See Adding or Removing Users in Groups for more information.

It might be more work to set up now, but it will help you in the long term.

I want all the spaces in my site to have the same permissions

First, you should change the default space permissions, so that when a new space is created, it automatically gets your desired permissions.

To change the default space permissions:

1. Go to Administration > General Configuration > Space permissions.
2. Choose Edit permissions.
3. Add groups, and grant permissions in the usual way then save your changes.

Any new spaces created will get these permissions by default.

For existing spaces, it is a little more laborious. You'll need to go to the space permissions screen in each space, and set your desired permissions manually.

If you have Confluence Data Center you can slightly speed up this process by applying the permissions from one space to multiple spaces. This is done on a group by group or user by user basis. There is no way to copy an entire set of permissions from one space to another. See Inspect permissions.
I want to give external people access to my space

If you don't want to make your site public, but you need to give people outside your company, such as a customer or contractor, access to your site, you will need to create user accounts for these people. We recommend creating a group specifically for these people, so that it is easy to remove their access later when it is no longer needed.

Your company is hosting a huge event, and you want to be able to collaborate with staff at Super Events, an external events company, in Confluence, rather than relying on email.

1. Create a group called super-events-staff
2. Grant this group the Can use global permission.
3. Create a user account for each Super Events person you'll be working with.
4. Add these users to the super-events-staff group only. Remove them from confluence-users, and any other default group to make sure they don't see any spaces they shouldn't. They should only be a member of super-events-staff.
5. Create a space for the event, and set the permissions for your internal staff.
6. Give the super-events-staff group permission to add pages, comments, and attachments only.
7. Send the space URL and usernames to your contacts at Super Events, and start collaborating.

By confining these users to a single group, they won't see any spaces, or other content that they don't have permission to see, such as Confluence Questions. However, they will be able to see things like the people directory.

Lock things down

I want to check what a person can access in Confluence

In Confluence Data Center, you can Inspect Permissions to find out what a user can view.

I need to prevent someone from accessing Confluence

The best way to do this is to disable the person's user account. They will not be able to log in. See Delete or Disable Users to find out how to do this.

I need to prevent specific people from viewing a space

If you have Confluence Data Center, Inspect permissions for the person and the space, to find out exactly how they are being granted permission.

If their permission was granted as an individual, simply go to the space permissions and change their permissions. If their permission was granted via a group, you'll need to decide whether to remove them from the group, or to change the whole group's permissions.

I want to prevent people from seeing my work in progress

First, check who can view your page. It may be that only you, or your team can see the page due to space permissions.

If you do need to lock it down further, the simplest way to do this is restrict the page, so that only you, or your team, can view it. See Page Restrictions to find out how to do this.

Once you're ready to share your work, remove the restrictions. A notification won't be sent when you remove the restrictions. Notifications are only sent at the point you publish the page (this means that if you restrict a page to yourself, and publish it, anyone who is watching the space for new pages won't ever get a notification).

I want to prevent people seeing part of a space

The simplest way to do this is to use Page Restrictions. This is particularly useful when the pages are a work in progress, and will eventually be opened up for more people to view at a later date.
In this example, a user wants to keep all the pages relating to a sensitive new project private, until the information can be shared with the whole organisation.

Here’s what they would do:

1. Create a page called "Secret project" and restrict it to just the people working on the project.
2. Create or move any pages relating to the project to be a child of "Secret project". The view restriction will be inherited.

This approach is not foolproof. It requires people to remember to create future sensitive pages under the restricted parent page, and to avoid moving pages to a parent that is unrestricted. If the content is sensitive, and will always be restricted, consider moving it to a different space, and use space permissions to control who can see the pages.

I want to share one page but keep the rest of the space private

This can be tricky, and introduces complexity that may be a problem later, because you are forcing Confluence to work in a way that is opposite to the way it is intended to be used.

Essentially you would need to organise your page hierarchy so that all pages are restricted, except the one you want to share. You would then change the space permissions to open up the space. You can then check who can view a page to make sure you’ve achieved the desired result.

In this example, a user wants to keep the work in their personal space private, but make their "What I’m working on" page available for their manager and team to view.

Here’s what they would do:

1. Create a page called "Private work" and restrict this page to themselves. Only they can see this page.
2. Move all the pages in the space that should remain private to be a child of "Private work".
3. Create a page called "Open work". Move the "What I’m working on" page to be a child of this page.
4. Change the space permissions so that their manager and team can view the space.

Important things to note:

- This approach is not foolproof. It requires the user to remember to create future sensitive pages under the restricted parent page, and to avoid moving pages to a parent that is unrestricted.
- Any blog posts or other non-page content created in the space would be visible, because the page restrictions only apply to pages that are a child of "Private work".

Delegate administration tasks

I want to delegate space administration to a specific group of people

The best way to do this is to create a specific space administrators group. The benefit of using a group is that you can easily add and remove members, without needing to touch the space permissions for the spaces themselves.

If you need to create a sensitive space, that these people shouldn’t be able to view or administer, simply edit the space permissions for that space, and remove the group’s permissions.

- Create a group, and give it a recognisable name like space-administrators.
- Add the people you want to be space admins as members of this group.
- Grant this group space admin permissions in the default space permissions, so all new spaces will be created with this permission.
- Go to every existing space and manually grant this group space admin permissions. If you have Confluence Data Center you can use Inspect permissions to speed up this step.

I want to control who can create spaces

You can set which groups or individuals can create spaces in Global Permissions.
If you choose to limit who can create spaces, we recommend granting this permission to a group of champions, who can handle requests, create the spaces, and work with stakeholders to set up their space permissions in the most appropriate way for your organisation. These people don’t need to be Confluence Administrators, they just need the Create Space global permission.

The big questions

What permissions should I give people?

This is going to depend on your organisation, and the type of work you are doing in Confluence. If collaboration is your goal, we recommend giving people full Add, Delete, and Restrict permissions, and granting Space Admin permissions to a handful of people, who can act as champions in the space, to perform tasks like creating templates, or customising the view.

In some industries you may need to prevent people from deleting or restricting content, for auditing or compliance reasons. If this is the case for your organisation, consider updating the default space permissions so that all new spaces are created with your ideal permissions.

The main use-case for your Confluence site also has an impact on how you will structure your permissions. Find out about using confluence for Technical Documentation, Knowledge Base articles, your Intranet, or Software Teams.

What should I do when someone leaves my team?

If most spaces in your site are open, chances are you don’t need to do anything. However it’s good practice to change the person’s group memberships to match their new role. This might happen automatically, via your external user directory, or you may need to search for the user, and change their group memberships manually.

Once you’ve changed their group memberships, if you’re a Confluence administrator and you have Confluence Data Center you can inspect permissions to check what spaces the person still has access to, then edit their permissions for each space on the fly, to remove any individual permissions.

What should I do when someone leaves my organisation?

If someone leaves your organisation, usually you would disable their user account, either in Confluence, or in your external user directory.

You may want to tidy up any individual permissions they’ve been granted (just to reduce the number of people listed in your space permissions screens), but unfortunately there’s no easy way to do this. If you’re a Confluence administrator, and you have Confluence Data Center, you can inspect permissions to check what spaces the person still has access to, then edit their permissions for each space on the fly, to remove any individual permissions.
Team Calendars

Team Calendars provides one place for fast-moving teams working in Confluence to connect their schedules of leave, Jira projects and events, or whatever use case your team has.

- Team Calendars Quick Tour
- Create, Add, and Edit Calendars
- Restrict a Calendar
- Watch a Calendar
- Share Calendars
- Export Team Calendars Content to Other Calendars
- Delete or Remove a Calendar

Create, organize, and find events easily. Team Calendars offers great tools for planning and managing your events, whether they're travel, conferences, birthdays, or JIRA issues and sprints.

- Add Events
- Add Jira Events
- Event Types
- Custom Event Types
- Reminders
- Embed Calendars on Confluence Pages

Calendar subscriptions provide a simple and effective way to stay up to date with holidays, conferences, and more.

You can subscribe to team calendars from many of your your favourite third-party calendar apps:

- Subscribe to Team Calendars from Microsoft Outlook
- Subscribe to Team Calendars from Outlook on the web
- Subscribe to Team Calendars from Apple Calendar
- Subscribe to Team Calendars from Apple iOS Calendar
- Subscribe to Team Calendars from Google Calendar
- Subscribe to Team Calendars from Android Calendar
- Subscribe to Team Calendars from Thunderbird

Alternatively, subscribe to a third-party calendar in Team Calendars:

- Subscribe to Outlook Calendar from Team Calendars
- Subscribe to Apple Calendar from Team Calendars
- Subscribe to Google Calendar from Team Calendars
- Subscribe to Opsgenie Calendars from Team Calendars
- Subscribe to PagerDuty Schedules from Team Calendars
- Subscribe to Teamup Calendars from Team Calendars

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Team Calendars Quick Tour

Team Calendars allows you to create calendars for yourself and your team, and view other calendars from your organization, all in one place. This page provides you a few essential steps to get started.

Open Team Calendars

There are two places you can view and work with Team Calendars – in a Confluence space, or on your 'My Calendars' page. The My Calendars page presents a roll-up of all of the Team Calendars you're currently subscribed to.

- If you're looking for your team's calendar, or you'd like to create a calendar for your team, go to your team's Confluence space and choose Calendars in the sidebar.
- If you'd like to create a calendar for yourself, or subscribe to your Google Calendar, choose Calendars in the Confluence header to open your 'My Calendars' page.

The My Calendars page

Calendars in a space sidebar
Create and add Calendars

To get started, you'll need to create a calendar or add an existing one. Select **Add Calendar** to quickly create a new calendar, or select **More options** next to Add Calendar to add an existing calendar in the following ways:

- **Add Existing Calendar** – to subscribe to another calendar in your Confluence instance.
- **Import Calendar** – to import an ICS file.
- **Subscribe by URL** – to Subscribe to Third-Party Calendars from Team Calendars.

See [Create, Add, and Edit Calendars](#) to learn more.

Add events to a calendar

To add an event to the calendar, you can do any of the following:

- **Choose Add Event**
- **Click a date on the calendar in either the month or week view (or click and drag to choose a date range)**
- **Double-click on the Timeline view**

You'll be prompted to enter a title, time and other details. Once you've added the details, choose **OK** to add the event to the calendar. If there are multiple calendars on your My Calendars page, you'll need to select the calendar you're adding the event to.

You can also click and drag on the calendar to select a range of days in the month and week views. Learn more by reading [Add Events](#).

Choose your view

You can view your events in four different ways: month, week, list, and timeline. Team Calendars remembers your last selected view, so you don't need to choose it again next time you come back.

Embed calendars on Confluence pages

You can embed a calendar on any page in Confluence, ensuring you and your teams are always up-to-date. Take a look at [Embed Calendars on Confluence Pages](#) for more information.

**Team Calendars for Confluence is now part of Confluence Data Center**

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can't upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Create, Add, and Edit Calendars

You can create new calendars or add existing calendars in any Confluence space or your My Calendars page. Existing calendars can be other calendars from your Confluence site, or third-party calendars.

Create a calendar

To create a brand new calendar:

1. Do either of the following:
   - **Create a calendar in a space** – Hit Create from template in the Confluence header, then choose Calendars in the create dialog (choose the right space too, if you're not already there)
   - **Create a calendar in My Calendars** – Choose Calendars in the Confluence header to go to your My Calendars page, then hit Add Calendar at the top-right of the page
2. Choose **Add New Calendar**
3. Enter a **Name** for your calendar

   ![](image)

   If you're in My Calendars, you'll also need to enter a Related space. The calendar will appear in that space once you've created it.

4. Choose **OK**

Add other calendars

To add other calendars from your Confluence instance, or from third-party calendars, select **More options** to the right of Add Calendar, then pick any of the following:

- **Add Existing Calendar** – to subscribe to another calendar in your Confluence instance.
- **Subscribe by URL** – to Subscribe to Third-Party Calendars from Team Calendars.

Did you know you can add a calendar to a Confluence page? See Embed Calendars on Confluence Pages.
Import a calendar

Import a calendar from an iCalendar (ICS) file. You can import the file to a new calendar, or add the events to an existing team calendar.

To import an ICS file as a new calendar:

1. Select More options *** to the right of Add Calendar
2. Select Import Calendar
3. Enter a name for your new calendar
4. Locate and select the .ics file you saved and follow the prompts to import it.

To import an ICS file into an existing calendar:

1. Choose *** to the right of the destination calendar and choose Import iCalendar
2. Locate and select the .ics file you saved and follow the prompts to import it.

Edit a Calendar

If you want to change the name of a calendar, hide certain event types, or move the calendar to another space, you can edit the calendar provided you have sufficient permissions. You can also add custom event types and hide default event types to tailor the calendar to your needs.

1. Choose Calendars in the Confluence header or space sidebar
2. Choose More options *** to the right of the calendar name, then choose Edit
3. Change the calendar’s name or move it to another space in the General tab, or hide events in the Event Types tab
Team Calendars for Confluence is now part of Confluence Data Center
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details
Restrict a Calendar

Calendars respect the view permissions of their related space. When you create a calendar in a space, or add a related space to an existing calendar, only people with permission to view the space will be able to see the calendar.

If a calendar contains sensitive information, or shouldn’t be edited by just anyone, you can further limit who can or edit it by adding restrictions. Restrictions in Team Calendars work in much the same way they do in Confluence, you can restrict a calendar to individual people or Confluence groups.

Change who can view a calendar

If no view restrictions are added, everyone who can view the space can view the calendar.

To restrict who can view a calendar:

1. Select Calendars in the Confluence header or space sidebar.
2. Select More options *** to the right of a calendar’s name, then choose Restrictions.
3. Select the Add view restriction radio button.
4. Search for and select a user, or choose the Group button and search for and select a Confluence group. Repeat this for all people and groups you want to be able to see the calendar.
5. Select OK.

Only the people listed under These people can view this calendar in the restrictions dialog, and the calendar’s creator, will be able to see the calendar. Remember, people also need view permissions for the space associated with this calendar to be able to see the calendar.

Change who can edit a calendar
If no edit restrictions are added, everyone who can view the calendar can edit the calendar.

To restrict who can edit a calendar:

1. Select Calendars in the Confluence header or space sidebar.
2. Select More options *** to the right of a calendar's name, then choose Restrictions.
3. Select the Add edit restriction radio button.
4. Search for and select a user, or choose the Group button and search for and select a Confluence group. Repeat this for all people and groups you want to be able to edit the calendar.
5. Select OK.

Only the people listed under These people can edit this calendar in the restrictions dialog, the calendar's creator, and any space administrators (who can see the calendar), will be able to edit the calendar, including adding events, editing existing events, and changing the restrictions.
Add Events

You can quickly add events to your calendars and categorize them into different event types for easier viewing and management.

Add an Event

1. Do any of the following:
   - Choose Add Event
   - Click a date on the calendar in either the month or week view
   - Double-click on the Timeline view
2. Select the type of event you’d like to add from the Event Type drop-down
3. Complete the other details for your event and choose Add

Event Types

Each calendar includes a standard set of event types, which you can use to classify the different events in the calendar. You can also create custom event types to capture events that don’t fit into the standard event types.

Repeat options

You can choose to repeat your event daily, weekly, monthly or yearly.

Delete an Event

To delete an event, select the event and choose Delete from the inline dialog.
If you don’t see the **Delete** option, the reason is usually:

- You don’t have **edit permissions** on the calendar
- The event you’re trying to edit is a JIRA event (sprint, version or issue). If this is the case, the change to the JIRA item has to happen in JIRA.

**Team Calendars for Confluence is now part of Confluence Data Center**
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Add Jira Events

Jira events enable you to visualize versions, issues or sprint dates from Jira applications. To use this feature, Confluence and Jira need to be connected by an application link. If, after connecting Confluence to Jira you’re still not able to add Jira events to a Team Calendar, make sure the Jira iCalendar Plugin is enabled in your JIRA site. This is bundled with Jira, but may have been disabled by an administrator.

Add JIRA events

When you create an event, there are multiple JIRA event types you can choose from. These are:

- **JIRA Issue Dates** – Embed a single JIRA issue date or the duration between any two issue dates. For example, embed due dates for JIRA issues, or, if you have custom fields, embed a scheduled deployment date.
  What if you want to see the duration for a particular issue? You may have fields like 'Deployment Start Date' and 'Deployment End Date' or 'Issue Start' and 'Issue End Date'. Team Calendars allows you to visualize the duration between any two dates.

- **JIRA Software Sprints** – If your team is using JIRA Software to plan their work, you can also embed your Sprints inside your Team Calendar. This helps you see the duration of your sprint and how your team’s availability or other team events could impact the sprint.

- **JIRA Project Releases** – JIRA versions help you define a release for your projects. You can embed and visualize your JIRA project versions to see how your releases are progressing.

Update JIRA events in Team Calendars

From Team Calendars, you can:
- Update JIRA project version dates
- Update Issue dates

Drag-and-drop the event or update its date, and it will automatically update in your JIRA application. Currently, you can't update your JIRA Software sprint dates.

**Add JIRA issue dates**

You can embed virtually any issue date in Team Calendars from your JIRA application. Embed JIRA issue dates as:

- A single date
- A duration between two specified dates

When adding JIRA issue dates, you'll be presented with the following display options:

- **Project** – A quick and easy way to map out project issues on a calendar
- **Saved filter** – For more advanced filtering as well as support for multiple projects.
- **JQL** – Power users can use JQL to create a JIRA calendar.

> If you select **Saved filter** or **JQL**, Team Calendars will render all available date fields that are available for all projects selected in your filter. If there are dates that are only available to one project, and not another in the filter, they will not render in the list of possible fields to show.

Upon selecting a Project, Saved Filter or JQL, you'll be presented with all possible dates that can be rendered in Team Calendars. For those of you with Jira Software, Team Calendars can also embed your JIRA Software sprint durations right on your JIRA Calendars.

Once you've entered a JQL query, choose the dates you'd like to display in Team Calendars.

Upon selecting a Project, Saved Filter or JQL, you'll be presented with all possible dates that can be rendered in Team Calendars. For those of you with Jira Software, Team Calendars can also embed your JIRA Software sprint durations right on your JIRA Calendars.

Once you've entered a JQL query, choose the dates you'd like to display in Team Calendars.

Once the calendar is created, depending on what you've selected, you can see:

- Issue dates
- JIRA project version due dates
- JIRA Software sprint durations

**Examples:**
Issue dates

Project release (shows release date)

Software sprint (shows start and end dates)
Notes

- You can't add content to JIRA calendars as they source all of their date information from the JIRA system. To add issues and version deadlines, add them in the JIRA application's interface.
- You can drag-and-drop your JIRA issue dates and project versions to re-schedule them right from Team Calendars.
- When you create a JIRA calendar, all users in your system can see the calendar name in Confluence. The actual calendar events (issues, versions, sprints), however, automatically respect your JIRA application permissions, so it's possible for users to be subscribed to a JIRA calendar and not see all events.
- In order to make sure calendars load quickly, JIRA events are cached. You can configure the cache expiry (time to live) in Team Calendars > Global settings - decrease the cache expiry time for more accuracy.

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can't upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details
Event Types

Each calendar includes a standard set of event types, which you can use to classify the different events in the calendar. You can also create custom event types to capture events that don't fit into the standard event types.

Standard event types

Plan your people

- **Leave** – For tracking holidays and breaks. Who is out of the office and when.
- **Travel** – For tracking your team's travel plans.
- **Birthdays** – To help you celebrate those special moments with your team members.
- **Events** – A generic event type where you can create any type of event.

Plan your projects

Team Calendars integrates with JIRA applications and allows you to plan your JIRA projects and see how your team's availability may impact them. You can create JIRA project events for:

- **JIRA Versions** – To plan your releases.
- **JIRA Software Sprints** – Visualize your team's Agile Sprints inside your calendar to see how your team's leave could impact your project.
- **JIRA Issue Dates**

Learn more about JIRA events

If you don't want to use any of the standard event types, hide them by choosing the calendar's drop-down menu, then select **Edit > Event Types**. Choose the minus icon to hide the event type.

Color-code event types

All events are color-coded according to the event type they belong to. To change the color of events in a particular event type:

1. Hover over the event type and click the More options that appears to the right
2. Choose the appropriate color for the event type

Changing event type colors changes the appearance of its events for you, but not for other viewers of the calendar. Each person viewing the calendar is free to set their preferred color scheme.
Filter events

If you've got a lot of events on your Team Calendar, you may want to show or hide certain event types or calendars to reduce clutter. Click on an event type to show or hide its events, or hit More options *** next to a calendar and choose Hide events to hide all events in that calendar.

Team Calendars for Confluence is now part of Confluence Data Center
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details
Custom Event Types

Event types allow you to categorize your events, making them easier to view and manage; custom event types take this a step further by giving you complete freedom to track any kind of event you can think of – so if you need to create events for training, email campaigns, outages, or anything else, Team Calendars is up to it.

Add a custom event type

To add a custom event type:

1. Choose More options to the right of the calendar’s name, then choose Edit
2. Choose Event Types on the left, then choose Add new event type
3. Enter the Event Name, select an Event Icon, then choose Save.

That’s it! Your new event type won’t appear in the sidebar immediately, but it’ll show up as soon as you add an event of that type.

You’ll need editing privileges for the calendar to add custom event types.

To quickly add a new custom event type, choose Add Event, then choose Add new event type from the Event Type menu.

On this page:
- Add a custom event type
- Delete a custom event type

Related pages:
- Event Types
- Add Events
Delete a custom event type

If you no longer need a custom event type, you can delete it by choosing Edit > Event Types, then choose the icon to the right of the event type.

Deleting a custom event type will delete all events within that event type, so, if there are any events you want to keep, make sure you move them to another event type before deleting.

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Reminders

There are some events that are just too important to miss, and you wouldn't want anyone in your team to miss them either. If you have edit permission for a calendar, you can set reminders for each event type so that anyone who's added the calendar to their 'My Calendars' page will receive an email at your chosen time.

Add reminders to event types

To add a reminder to an event type:

1. Choose More options ••• > Edit
2. Choose Event Types
3. Choose the pencil 🖋 icon to edit an event type
4. Add your reminder time and choose Save
   Repeat steps 3 and 4 for each event type you're adding a reminder to.
5. Choose OK

If you only want to add reminders to one event type, choose the More options ••• to the right of the event type, then choose Add a reminder.

From a reminder email you can click to view the event, or turn off reminders for the event type if you don't need them. To remove reminders for an event type, follow the above procedure and set the reminder time to 'None'.

Remember, when you change reminders for an event type, you're changing reminders for anyone who's added the calendar to their My Calendars page.

Turn reminder emails on or off
You can decide whether or not you want to receive reminder emails for each event type on your My Calendars page. This isn't about adding or removing reminders for an event type; it's essentially opting-in to or opting-out of the reminder emails.

To turn reminders on or off:

1. Choose **Calendars** in the Confluence header
2. Choose the **More options *** to the right of an event type
3. Select ‘Turn on reminders’ or ‘Turn off reminders’

If it says ‘Add a reminder’ when you get to step 3, it means there’s no reminder set for the event type. Only choose that option if you want to **set** reminders for the event type, which will be sent to everyone who’s added the calendar to their ‘My Calendars’ page.

You can also opt-out of reminder emails for an event type by clicking the ‘Stop reminding me’ link in the reminder email

**Team Calendars for Confluence is now part of Confluence Data Center**

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). **See our FAQ for all the details**
**Embed Calendars on Confluence Pages**

You can embed a calendar on any page in Confluence, making it easy to track and manage events. When you embed a calendar on a page, the calendar will also appear in the **Calendars** section of the space the page is in.

Below are a few ways of embedding a calendar on a Confluence page.

**Paste the calendar's link**

1. Choose **Calendars** in the Confluence header or space sidebar
2. Hit the **More options** • • • to the right of the calendar name
3. Choose **Embed**
4. Copy the calendar link provided
5. Paste the link on any page in Confluence

![Calendar embedding options](image)

**Add the Team Calendar macro**

1. While editing a page, choose **Insert > Team Calendar**
2. Select **Add Existing Calendar**
3. Search for and select the calendar and choose **Add**

See **Team Calendar Macro** for more information about using this macro.

**On this page:**

- Paste the calendar's link
- Add the Team Calendar macro

**Related pages:**

- Subscribe to Team Calendars from Third-Party Calendars
- Create, Add, and Edit Calendars

**Team Calendars for Confluence is now part of Confluence Data Center**

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Watch a Calendar

Watching a calendar is a great way to stay up-to-date on changes made in the calendar, without necessarily adding it to your My Calendars page. When you watch a calendar, you'll be sent an email notification when any of the following events occur:

- A new event is created
- An existing event is edited
- An event is deleted
- The entire calendar is deleted

When you watch a Confluence space it includes watching all calendars in that space, so there's no need to manually watch calendars for your team or project.

Watch a calendar

To watch a calendar, choose More options and select Watch. Notifications will be sent to your email address.

Stop watching a Calendar

You can also stop watching a calendar, if you no longer want to receive email notifications about changes to the calendar.

To stop watching a calendar, choose More options to the right of the calendar name and select Stop Watching.

If the menu says 'Watching', you're watching the calendar because you're either watching a page the calendar is embedded on or you're watching the related space for the calendar. To stop watching in this case, you'd need to stop watching the relevant page or space containing the calendar.

Administrators can limit notifications to only people directly watching a calendar. Go to Administration > General Configuration > Team Calendars and choose Don’t notify space or page watchers.

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Share Calendars

When viewing space calendars (all calendars in a particular Confluence space) or a single calendar from a space, use the Share button to email anyone a link to space calendars or a single calendar. You can either copy the Share link from the share dialog, or enter a Confluence user, group or email address. The option to add people is only available if your site has a mail server configured.

Share space calendars

1. Go to the space and select **Calendars** in the sidebar.
2. Select **Share** at the top right of the page.
3. Enter a username, group or email address, and select the appropriate user, group or email address from the list of suggestions.
   - Repeat this process to add multiple recipients to the list (or use the trash icons to remove people from the list).
4. Enter an optional message.
5. Select **Share** to send the link via email.

Share a single calendar from a space

If a space has multiple calendars, but you only want to share one of them, follow the steps below to get to the calendar’s details page and share it.

1. Go to the space and choose **Calendars** in the sidebar.
2. Select the name of the calendar you want to share. You’ll be taken to the detail page for the calendar – it’s just a page with that single calendar on it.
3. Select **Share** at the top right of the page.
4. Enter a username, group or email address, and select the appropriate user, group or email address from the list of suggestions.
   - Repeat this process to add multiple recipients to the list (or use the trash icons to remove people from the list).
5. Enter an optional message.
6. Select **Share** to send the link via email.
Team Calendars for Confluence is now part of Confluence Data Center
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Subscribe to Team Calendars from Third-Party Calendars

Subscribing to Team Calendars from your favourite third-party calendar app is a great way to view your Team Calendars events when you’re not in Confluence.

There are two ways to synchronize a Team Calendar with your calendar app:

- Two-way sync (CalDAV) - allows you to view and update Team Calendars events in your app.
- One-way sync (iCal) - allows you to view, but not update, Team Calendars events in your app.

Not all calendar apps support two-way sync, so check the table below to find out if your app supports it.

<table>
<thead>
<tr>
<th>Calendar app</th>
<th>Sync options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Outlook (Windows desktop)</td>
<td>One-way and two-way sync</td>
</tr>
<tr>
<td>Microsoft Outlook (browser)</td>
<td>One way sync</td>
</tr>
<tr>
<td>Apple Calendar (MacOS)</td>
<td>One-way and two-way sync</td>
</tr>
<tr>
<td>Apple Calendar (iOS)</td>
<td>One-way and two-way sync</td>
</tr>
<tr>
<td>Google Calendar (browser)</td>
<td>One way sync</td>
</tr>
<tr>
<td>Google Calendar (Android)</td>
<td>One-way and two-way sync</td>
</tr>
<tr>
<td>Thunderbird</td>
<td>One-way and two-way sync</td>
</tr>
</tbody>
</table>

You can also Subscribe to Third-Party Calendars from Team Calendars.

Other calendar apps

If the calendar app you use isn't listed above, you may still be able to subscribe to Team Calendars. Check your app's documentation to find out whether it supports the iCal or CalDAV standard. If it supports iCal, then you should be able to set up one-way synchronization. If it supports CalDAV, you should be able to set up two-way synchronization.

To subscribe to a calendar app that's not listed above:

In Confluence:

1. Choose the Subscribe button at the top of your calendar.
2. Select either iCal or CalDAV from the Calendar app dropdown (check your calendar app’s documentation to find out which standard it supports).
3. Copy the Calendar URL.

Then, in your Calendar app, follow the steps in your app’s documentation to add or subscribe to the calendar.

Timezones

Timezones can be confusing! Here’s how we decide what time to display.

- We display the time of an event in Confluence using the timezone set in your Confluence profile - find out how to update this.
- We display the time of an event in your calendar app using the timezone set in your app or device.
- We store events using the timezone defined in the Team Calendar itself, and then convert them to the appropriate timezone when you view the event.

You should always see the correct time, but if you change locations, make sure you update your Confluence profile so you don’t see a discrepancy between your calendar app and Confluence.

Confluence context path

CalDav uses Confluence’s root URL as it’s well-known URL. If you've configured Confluence with a context path, for example www.yoursite.com/confluence, your calendar app will not be able to connect to your Team Calendars.

There are two ways to resolve this issue. You can either:

- Configure your proxy so that any URL that does not end with /confluence (or whatever your context path is) or with /synchrony (if you’re using collaborative editing) always redirects to /confluence. This option is only suitable if Confluence is the only application accessed via that domain.
- Configure your proxy to redirect the following calls to your URL, with context path. In the examples below our context path is /confluence.

<table>
<thead>
<tr>
<th>Apache</th>
</tr>
</thead>
<tbody>
<tr>
<td>RewriteRule ^/.well-known/(.*)$ /confluence/.well-known/$1 [R=301,NC,L]</td>
</tr>
<tr>
<td>RewriteRule ^/plugins/servlet/team-calendars/caldav/(.*)$ /confluence/plugins/servlet/team-calendars /caldav/$1 [R=301,NC,L]</td>
</tr>
</tbody>
</table>

The order of directives is important in Apache. These rewrites should be placed before the Synchrony and Confluence location blocks. See Using Apache with mod_proxy for general information about configuring your proxy.

<table>
<thead>
<tr>
<th>Nginx</th>
</tr>
</thead>
<tbody>
<tr>
<td>rewrite ^/.well-known/(.*)$ /confluence/.well-known/$1;</td>
</tr>
<tr>
<td>rewrite ^/plugins/servlet/team-calendars/caldav/(.*)$ /confluence/plugins/servlet/team-calendars /caldav/$1;</td>
</tr>
</tbody>
</table>

While order is not as important in Nginx, we tested this config with the rewrites before the Synchrony and Confluence location blocks. See Running Confluence behind NGINX with SSL for general information about configuring your proxy.

Reverse Proxies

If you are using NGINX or Apache HTTPD, don’t forget to enable support for DAV methods on them, else, synchronisation may fail due to the following error:
405 Error
</p>

<h2 class="content-subhead">Method not allowed!</h2>

<p>
The REPORT method is not allowed for the requested URL.
</p>

<h2 class="content-subhead">Error 405</h2>

<p>
The REPORT method is not allowed for the requested URL.
</p>

Server is named <a href="/">confluence-atlas.atlassian.com</a>.

Webserver program <code>Apache/2.4.29 (atlassian@atlassian.com - CEL 7.x) OpenSSL/1.1.0f mod_fcgid/2.3.9</code> served the request with unique id <code>W1idbjAGhETV97vZN7bzyAAAWU</code> from <code>64.103.79.190:3443</code> socket on <code>Wed Jul 25 16:55:26 2018</code>.

</p>

Modules:

For NGINX - <a>Link</a>

For HTTPD - <a>Link</a>

Troubleshooting

If you have problems adding a Team Calendar to your calendar app, you should check the documentation for your particular app. Here's some issues we know about:

- You can't subscribe to a Team Calendar on Outlook.com if your Confluence site is not accessible outside your network.
- If your Confluence site isn't accessible outside your network, you may need to be connected to your network when you add the subscription, and to sync event data.
- If your calendar app supports calendar discovery, your calendar must be listed on your My Calendars screen, so it is available to sync. To add a calendar to My Calendars choose Calendars on the header > Add Calendar > Add existing calendar. We'll also prompt you in the subscribe dialog, if the calendar is not listed on My Calendars.
- If you're unable to connect to your calendar, and your site has a context path (for example, you access it from www.mysite.com/confluence) your admin may need to make some changes to the proxy configuration. See Confluence context path above.
- You can always enable more logging from CalDavSynchronizer as listed here for more logging and troubleshooting aid.

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Subscribe to Team Calendars from Microsoft Outlook

Outlook support

Subscribing to Team Calendars from Microsoft Outlook has been tested and works with Outlook 2010, 2013, and 2016 on Windows.

The Outlook for Mac 2011/2016 desktop applications don’t provide the ability to subscribe to an internet calendar, but there is a workaround that may work for you.

On this page:

- Outlook support
- Subscribe to a Team Calendar from Outlook (Windows)
  - Subscribe with two-way synchronization (CalDAV)
  - Subscribe with one-way synchronization (iCal)
- Subscribe to a Team Calendar from Outlook (Mac OS)

Subscribe to a Team Calendar from Outlook (Windows)

There are two ways to synchronize your calendar in Outlook:

- **Two-way sync** (CalDAV) - allows you to view and update Team Calendars events in Outlook. This option requires a free CalDAV Synchronization plugin for Outlook, and is only available for Windows users.
- **One-way sync** (iCal) - allows you to view, but not update, Team Calendars events in Outlook.

Subscribe with two-way synchronization (CalDAV)

Two-way synchronization is only available for people using the Microsoft Outlook desktop application on Windows, with the CalDAV Synchronization plugin installed.

1. Download and install the CalDAV Synchronization plugin

Before you begin:

1. Download a CalDAV plugin for Outlook. We used CalDAV Synchronizer, which is free. Other plugins may be available.
2. Install the plugin. You may need to talk to your admin if you don't have permission to install applications on your PC.

2. Grab your Team Calendars URL

In Confluence:

1. Choose the **Subscribe** button at the top of your calendar.
2. Select **Outlook** from the Calendar app dropdown.

![Subscribe to calendar](image)

3. If prompted, add the calendar to **My Calendars**.
4. Copy the **Calendar URL**. Because the CalDAV Synchronization plugin supports calendar discovery, this will be your Confluence URL, not the URL of an individual calendar. You'll be able to choose which calendar (that you've added to My Calendars) to sync in Outlook.

3. Subscribe to the calendar in Outlook
In your Outlook desktop application:

1. Choose **CalDAV Synchronizer** from the ribbon / toolbar.
2. Choose **Synchronization profiles**.

3. Click the + button to add a new profile.

4. Choose **Generic CalDAV / CardDAV** from the **Profile type** screen.
5. Give your profile a name, for example **Confluence Team Calendars**
6. Select an existing **calendar folder**, or create a new one.

7. Enter the **Confluence URL** you copied earlier in the **DAV URL** field.
8. Enter your Confluence **username** and **password**.
9. Click the **Test or discover settings** button to connect to Team Calendars.
10. If the test is successful you’ll see a list of resources. Choose the calendar you want to subscribe to.

11. Choose how often you want Outlook to sync back to Team Calendars. The default is every 30 minutes, but you may want to sync your calendar more often.
12. Click **OK** to save your new profile.
13. Back on the **CalDAV Synchronizer** tab, choose **Synchronize now** to sync the calendar for the first time.
14. If your calendar doesn’t appear, you may need to select it from the **My Calendars** list.

Seeing something different? These instructions are specific to the CalDAV Synchronizer plugin. If you’re using a different plugin, check its documentation to find out how to do this step.

**Subscribe with one-way synchronization (iCal)**

One-way synchronization means that you can view, but not update, Team Calendars events in Outlook. This option is best for people who are not able to install the CalDAV Synchronization plugin.

1. **Grab your Team Calendars URL**
   1. Choose **More options** to the right of the calendar name, then choose **Subscribe**.
   2. Select **iCal** from the **Calendar app** dropdown (don’t choose Outlook for one-way sync).
   3. Copy the **Calendar URL**.

2. **Subscribe to the calendar in Outlook**
   1. Choose **Calendar** at the bottom left of the app.
   2. Choose **Open Calendar > From Internet** in the ribbon.

3. Paste the calendar address and choose **OK**.

Depending on your authentication setup in Confluence, you may be prompted to enter your Confluence username and password.

**Subscribe to a Team Calendar from Outlook (Mac OS)**

Outlook for Mac 2011/2016 desktop applications don’t provide the ability to subscribe to an internet calendar.
If you have access to Outlook Web Access (OWA), you may be able to open an Internet Calendar, and have it appear in your Outlook client.

Team Calendars for Confluence is now part of Confluence Data Center
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Subscribe to Team Calendars from Outlook on the web

These instructions apply to Office 365, Outlook.com and Outlook on the web. If you are using the Outlook desktop app, head to Subscribe to Team Calendars from Microsoft Outlook to find out how to subscribe.

Subscribe to Team Calendars from Outlook on the web

Only one-way sync (iCal) is available for Outlook on the web. This means you can view, but not update, Team Calendars events in Outlook in your browser.

Subscribe with one-way synchronization (iCal)

These instructions are for Outlook.com (as at March 2018). Your version may differ slightly.

1. Grab your Team Calendars URL

In Confluence:

1. Choose the **Subscribe** button at the top of your calendar.
2. Select **Outlook (browser)** from the **Calendar app** dropdown.

![Subscribe to calendar](image)

3. Copy the **Calendar URL**.

2. **Subscribe to the calendar in Outlook on the web**

In Outlook calendar in your browser:

1. Choose **Add Calendars** > **From Internet**.
2. Enter the Team Calendar URL you copied above.
3. Give your calendar a name. This is how it will appear in the calendar list.

You can now view, but not edit, Team Calendar events in Outlook on the web.

⚠️ If your Confluence site is not accessible from outside your network, for example if you need to use a VPN to access it from outside your office, you won't be able to subscribe to your Team Calendars in Outlook on the web. Outlook will return a "Couldn't open calendar. Calendar address isn't formatted correctly" error.

**Team Calendars for Confluence is now part of Confluence Data Center**

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can't upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Subscribe to Team Calendars from Apple Calendar

If you want your Team Calendars events to appear in the built-in Calendar app on your Mac, you can subscribe to Team Calendars in a few easy steps.

Subscribe to Team Calendars from Apple Calendar

There are two ways to synchronize your calendar in Apple Calendar:

- **Two-way sync** (CalDAV) - allows you to view and update Team Calendars events in Apple Calendar.
- **One-way sync** (iCal) - allows you to view, but not update, Team Calendars events in Apple Calendar.

Subscribe with two-way synchronization (CalDAV)

Two-way synchronization allows you to view and update Team Calendars events in macOS.

These instructions are for Apple Calendar 10.0 on MacOS High Sierra. Your version may differ slightly.

1. **Grab your Team Calendars URL**

   In Confluence:
   
   1. Choose the **Subscribe** button at the top of your calendar.
   2. Select **Apple Calendar (macOS)** from the Calendar app dropdown.
   
   ![Subscribe to calendar](image)

   3. If prompted, add the calendar to **My Calendars**.
   4. Make a note of the **Calendar URL**.

      Because Apple Calendar supports calendar discovery, this will be your Confluence URL, not the URL of an individual calendar. You'll be able to choose which calendars (that you've added to My Calendars) to sync in the app.

2. **Add the calendar account in Apple Calendar**

   In the Calendar app on your Mac:
   
   1. Choose **Calendar > Add Account**.
   2. Choose **Other CalDAV account**.
   3. Select **Manual** from the Account Type drop down.
   4. Enter your Confluence **username** and **password**.
   5. Enter your **Confluence URL**.
      Apple Calendar supports calendar discovery, so you don't need the URL of a specific calendar.
   6. Click **Sign in**.

   All available calendars will be listed under your Confluence URL. Deselect any calendars you don't want to see.

   You can rename the calendar group. Head to **Calendar > Accounts** and edit the account listing.
Subscribe with one-way synchronization (iCal format)
These instructions are for Apple Calendar 10.0 on MacOS High Sierra. Your version may differ slightly.

1. **Grab your Team Calendars URL**
   In Confluence:
   1. Choose **More options** to the right of a calendar name, then choose **Subscribe**.
   2. Select **iCal** from the **Calendar app** dropdown (don’t choose Apple Calendar for one-way sync).
   3. Copy the calendar’s URL.

2. **Subscribe to the calendar in Apple Calendar**

   In the Calendar app on your Mac:
   1. Choose **File > New Calendar Subscription**...
   2. Paste the calendar URL and choose **Subscribe**.
   3. Configure any other calendar information and choose **Save**.

You can now view, but not edit, Team Calendar events in Apple Calendar.

---

**Team Calendars for Confluence is now part of Confluence Data Center**
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Subscribe to Team Calendars from Apple iOS Calendar

You can subscribe to Team Calendars from your iPhone or iPad device using the built-in iOS Calendar.

Subscribe to a Team Calendar from iOS

There are two ways to synchronize your calendar in iOS:

- **Two-way sync** (CalDAV) - allows you to view and update Team Calendars events in iOS.
- **One-way sync** (iCal) - allows you to view, but not update, Team Calendars events in iOS.

Subscribe with two-way synchronization (CalDAV)

Two-way synchronization allows you to view and update Team Calendars events in iOS.

These instructions are for iPhone, running iOS 11. Your version may differ slightly.

1. **Grab your Team Calendars URL**

In Confluence:

1. Choose the **Subscribe** button at the top of your calendar.
2. Select **Apple Calendar (iOS)** from the **Calendar app** dropdown.

   ![Subscribe to calendar interface](image)

3. If prompted, add the calendar to **My Calendars**.
4. Make a note of the **Calendar URL**.
   Because the iOS app supports calendar discovery, this will be your Confluence URL, not the URL of an individual calendar. You'll be able to choose which calendar (that you've added to My Calendars) to sync in the app.

2. **Subscribe to the calendar in the iOS Calendar app**

On your iOS device:

1. Go to **Settings > Accounts and passwords > Add account**.
2. Choose **Other > Add CalDAV account**.
3. Enter the **Confluence URL** you copied earlier in the **Server** field.
4. Enter your Confluence **username** and **password** and follow the prompts to add the account.
5. In the Calendar app, choose **Calendars** and select the calendars you want to show.

Subscribe with one-way synchronization (iCal)

One-way synchronization means that you can view, but not update, Team Calendars events in your app.

1. **Grab your Team Calendars URL**

   1. Choose **More options** to the right of the calendar name, then choose **Subscribe**.
   2. Select **iCal** from the **Calendar app** dropdown (don't choose Apple Calendar for one-way sync).
   3. Copy the **Calendar URL**.

2. **Subscribe to the calendar in the iOS Calendar app**

On your iOS device:
1. Go to Settings > Accounts and passwords > Add account.
2. Choose Other > Add Subscribed Calendar.
3. Paste the calendar URL and choose Next.
4. Enter any other required information and choose Save.

You can now view, but not edit, Team Calendar events in Apple Calendar for iOS.

Troubleshooting

Firewall or VPN issues

If your Confluence site isn't accessible outside your network (for example, you need to use a VPN to access it when you're out of the office), you will need to be connected to your network when you create the account. Your calendar will also only successfully sync when you're connected to your network. This means you may not see updates to events until the next time you are connected to your network or VPN.

SSL error

We have seen that iOS occasionally throws an SSL error when you attempt to add the Team Calendars account. If this happens, we recommend removing the account, and trying again. This often fixes the problem.

Calendars don't appear

It can take a few minutes for your calendars to appear in the Calendar app, after you've added the account. Tap the Calendars link at the bottom of the Calendar app to see the list of calendars from each account, and pull down to refresh the list.

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can't upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Subscribe to Team Calendars from Google Calendar

Integrating Team Calendars with your Google Calendar is a great way to keep track of your team's leave, travel, rosters, and projects, all in one place.

Only one-way sync (iCal) is available for Google Calendar. This means you can view, but not update, Team Calendars events in Google calendar in your browser.

Subscript with one-way synchronization (iCal)

These instructions are for Google G Suite Calendar (as at March 2018). Your version may differ slightly.

1. **Grab your Team Calendars URL**

   In Confluence:
   
   1. Choose the **Subscribe** button at the top of your calendar.
   2. Select **Google calendar** from the **Calendar app** dropdown.

   ![Subscribe to calendar](image)

   3. Copy the **Calendar URL**.

2. **Subscribe to the calendar in Google Calendars**

   In Google calendar in your browser:

   1. Choose **Add other calendars** > **From URL**.

   ![Add other calendars](image)

   2. Paste your Team Calendars URL.
   3. Choose **Add Calendar**.

The Calendar will be listed under Other Calendars, usually by URL. To rename the calendar Go to **Settings** > **Settings for other calendars**, select your Team Calendar and edit the calendar name.

![Other calendars](image)
Known Issues and Limitations

Known issues with Team Calendars and Google Calendars integration. These limitations are due to different issues in Google Calendar.

- There is currently a known issue with Google Calendar where a calendar subscription can't be added, or does not display events [CONFSERVER-53690 CLOSED].
- Subscribed Team Calendars names are truncated if they have a space in the title (More information: TEAMCAL-455).
- Google Calendar refresh times are delayed. They range from 3 hours to 24 hours. (More information: TEAMCAL-458).
- Subscriptions are read-only (you cannot modify events from Google Calendar, as it does not provide a CalDAV option).

Troubleshooting

Adding a calendar to Google Calendars may give you this error: "Could not fetch the url because robots.txt prevents us from crawling the url.". This means your server administrator is disallowing search engines from indexing your servers. A server administrator will need to modify your robots.txt to allow Google to index Team Calendars. In your robots.txt file, add the following line:

```python
User-agent: *
...
Allow: /rest/calendar-services/1.0/calendar/export/subcalendar/private/*
```

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can't upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details
Subscribe to Team Calendars from Android Calendar

You can subscribe to Team Calendars from your phone or tablet using the built-in Google Calendar on Android devices.

Subscribe to a Team Calendar from Google Calendar on Android

There are two ways to synchronize your calendar in Android device:

- **Two-way sync** (CalDAV) - allows you to view and update Team Calendars events in Google Calendar. Requires a CalDav synchronization app.
- **One-way sync** (iCal) - allows you to view, but not update, Team Calendars events in Google Calendar.

**Subscribe with two-way synchronization (CalDAV)**

Two-way synchronization allows you to view and update Team Calendars events in Google Calendar on Android. It requires a CalDav synchronization app. We've tested Team Calendars with DAVdroid, an open source app which is available from the [Play Store](https://play.google.com/store) (paid) or via [F-Droid](https://f-droid.org) (free).

These instructions are for Android 7.0 Nougat, with DAVdroid 1.10. Your version may differ slightly.

1. **Install the DAVdroid app on your device**

   Before you begin install a CalDAV synchronization app for Android.

   We used DAVdroid which you can install from the [Play Store](https://play.google.com/store) (paid) or via [F-Droid](https://f-droid.org) (free). Other plugins may be available.

2. **Grab your Team Calendars URL**

   In Confluence:

   1. Choose the **Subscribe** button at the top of your calendar.
   2. Select **Google Calendar (Android)** from the **Calendar app** dropdown.

      ![Subscribe to calendar](image)

      View your calendar and edit events in your favourite calendar app.

      **Calendar**: Holiday

      **Calendar app**: Choose your app

   3. If prompted, add the calendar to **My Calendars**.
   4. Make a note of the **Calendar URL**.

      Because DAVdroid supports calendar discovery, this will be your Confluence URL, not the URL of an individual calendar. You'll be able to choose which calendars (that you've added to My Calendars) to sync in the app.

3. **Subscribe to the calendar in the DAVdroid app**

   On your Android device:

   1. In DAVdroid, go to **Add account > Login with URL and user name**.
   2. Enter the **Confluence URL** you copied earlier.
3. Enter your Confluence username and password.

4. Follow the prompts to name your account.

5. Select the calendars you want to display in the Android Calendar app.

6. Open the Calendar app on your device. Your Team Calendars will be listed under the account name.

**Subscribe with one-way synchronization (iCal format)**

One-way synchronization means that you can view, but not update, Team Calendars events in your app.

You can't subscribe to an iCal calendar directly on your device. Instead you will need to subscribe to Team Calendars from Google Calendar in your browser. Events from your Team Calendar will then be visible in the Android calendar app automatically.

**Team Calendars for Confluence is now part of Confluence Data Center**

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Subscribe to Team Calendars from Thunderbird

If you want your Team Calendars events to appear in Thunderbird, you can subscribe to Team Calendars in a few easy steps.

Subscribe to Team Calendars from Thunderbird

There are two ways to synchronize your calendar in Thunderbird:

- **Two-way sync** (CalDAV) - allows you to view and update Team Calendars events in Thunderbird.
- **One-way sync** (iCal) - allows you to view, but not update, Team Calendars events in Thunderbird.

Subscribe with two-way synchronization (CalDAV)

Two-way synchronization allows you to view and update Team Calendars events in iOS.

These instructions are for Thunderbird 52 on MacOS High Sierra. Your version may differ slightly.

1. **Grab your Team Calendars URL**

   In Confluence:
   
   1. Choose the **Subscribe** button at the top of your calendar.
   2. Select **Thunderbird** from the **Calendar app** dropdown.

2. **Add the calendar in Thunderbird**

   In Thunderbird:
   
   1. From the **Home** tab, choose **Create a new calendar > On the network**.
   2. Choose **CalDAV**.
3. Paste the **Calendar URL** you copied earlier in the **Location** field.

4. Name the calendar - this is the name that will appear in the Thunderbird calendar list.

5. Enter your Confluence **username** and **password**.

Repeat this process for any other Team Calendars you want to add.

**Subscribe with one-way synchronization (iCal)**

These instructions are for Thunderbird 52 on MacOS High Sierra. Your version may differ slightly.

1. **Grab your Team Calendars URL**

   In Confluence:

   1. Choose the **Subscribe** button at the top of your calendar.
   2. Select **iCal** from the **Calendar app** dropdown (don't select Thunderbird for one-way sync).
   3. Copy the calendar URL.

2. **Add the calendar in Thunderbird**

   In Thunderbird:

   1. From the **Home** tab, choose **Create a new calendar > On the network**.
   2. Choose **iCalendar (ICS)**.
   3. Paste the **Calendar URL** you copied earlier in the **Location** field.
   4. Name the calendar. This is the name that will appear in the Thunderbird calendar list.
   5. Enter your Confluence **username** and **password**.

You can now view, but not edit, Team Calendar events in Thunderbird.

---

**Team Calendars for Confluence is now part of Confluence Data Center**

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). [See our FAQ for all the details](#)
Subscribe to Third-Party Calendars from Team Calendars

Subscribing to your favourite third-party calendar app from Team Calendars is a great way to view important events in Confluence.

There is only one way to synchronize a third-party calendar with Team Calendars:

- One-way sync (iCal) - allows you to view, but not update, third-party calendar events in Team Calendars.

You can subscribe to these third-party calendars from Team Calendars:

- Outlook
- Apple
- Google
- Opsgenie
- PagerDuty
- Teamup

You can also Subscribe to Team Calendars from Third-Party Calendars.

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details
Subscribe to Outlook Calendar from Team Calendars

Subscribing to Outlook Calendar in Team Calendars is a great way to see events, appointments, and meetings in Confluence.

In your Outlook.com account:
1. Go to Settings > View all Outlook settings.
2. Select Calendar > Shared Calendars.
3. Under Publish a Calendar, Select a calendar, Select permissions, then Publish.
4. Copy the ICS link.

In Confluence:
1. Select Calendars from the Confluence header or space sidebar (to add the calendar in a space).
2. Select More options *** next to Add Calendar and choose Subscribe By URL.
3. Enter the Name of the calendar and the ICS link you copied. If necessary, enter your username and password credentials for the calendar. Then select Subscribe.

Team Calendars for Confluence is now part of Confluence Data Center
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details
Subscribe to Apple Calendar from Team Calendars

You can view iCloud calendar events from Team Calendars in a few easy steps.

Subscribe to Apple Calendar from Team Calendars

Set up iCloud on your Mac to subscribe to iCloud calendars. In Apple Calendar on your Mac:

1. From the Calendars list, select a calendar under iCloud.
2. Select the Share Calendar button.
3. Copy the URL (it will only appear if Public Calendar is selected).

In Confluence:

1. Select Calendars from the Confluence header or space sidebar (to add the calendar in a space).
2. Select More options next to Add Calendar and choose Subscribe By URL.
3. Enter the Name of the calendar and the URL you copied. You will need to change webcal to http or https at the beginning of the link. If necessary, enter your username and password credentials for the calendar. Then select Subscribe.

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Subscribe to Google Calendar from Team Calendars

Subscribing to Google Calendar in Team Calendars is a convenient way to see all your events in one place, meaning you don’t need to leave Confluence just to check your appointments.

Subscribe to Google Calendar from Team Calendars

In Google Calendar:

1. From My Calendars, hover over a calendar and select Options (three vertical dots) > Settings and sharing.
2. From Settings for my Calendars, select Integrate Calendar.
3. Copy the URL listed under Secret address in iCal format. If your calendar is made available to the public, you can copy the URL listed under Public address in iCal format.

In Confluence:

1. Select Calendars from the Confluence header or space sidebar (to add the calendar in a space).
2. Select More options *** next to Add Calendar and choose Subscribe By URL.
3. Enter the Name of the calendar and the calendar URL you copied. If necessary, enter your username and password credentials for the calendar. Then select Subscribe.

Events from your Google Calendar will now appear in Team Calendars.

- Team Calendar reads Google’s calendars and caches them for an hour by default. Currently, there’s no way to configure the synchronization frequency or interval via the UI. The feature request is tracked here:
  - CONFSERVER-50112 - Make Google Calendar to Team Calendars synchronisation frequency or interval to be configurable [GATHERING INTEREST]
  
  and there’s a workaround available in the report.
- Subscriptions are read-only (you can’t modify events from Team Calendars)
  - CONFSERVER-61240 - CalDAV support [CLOSED]

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details
Subscribe to Opsgenie Calendars from Team Calendars

Subscribing to Opsgenie Calendars in Team Calendars is a great way to see Your on-call schedules and Who is on-call schedules in Confluence.

Subscribe to Your on-call schedules from Team Calendars

In Opsgenie:

1. Go to Settings > Your on-call schedule.
2. Select the Open calendar link icon (it will appear after you hover over the calendar).
3. Select the Copy calendar link to clipboard link icon (it will appear to the left of the Open calendar icon).

In Confluence:

1. Select Calendars from the Confluence header or space sidebar (to add the calendar in a space).
2. Select More options *** next to Add Calendar and choose Subscribe By URL.
3. Enter the Name of the calendar and the calendar link you copied. If necessary, enter your username and password credentials for the calendar. Then select Subscribe.

Subscribe to Who is on-call schedules from Team Calendars

In Opsgenie:

1. Select Who is on-call from the header.
2. Select a schedule name to view the schedule.
3. Select the Open calendar link icon (it will appear after you hover over the calendar).
4. Select the Copy calendar link to clipboard link icon (it will appear to the left of the Open calendar icon).

In Confluence:

1. Select Calendars from the Confluence header or space sidebar (to add the calendar in a space).
2. Select More options *** next to Add Calendar and choose Subscribe By URL.
3. Enter the Name of the calendar and the calendar link you copied. You will need to change webcal to http or https at the beginning of the link. If necessary, enter your username and password credentials for the calendar. Then select Subscribe.

Team Calendars for Confluence is now part of Confluence Data Center
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details
Subscribe to PagerDuty Schedules from Team Calendars

Subscribing to PagerDuty schedules in Team Calendars is an easy way to see all your on-call shifts in Confluence.

Subscribe to All Schedules from Team Calendars

In PagerDuty:

1. Go to My Profile in the drop-down menu from your avatar.
2. Select the User Settings tab.
3. Under Calendar settings, select WebCal feed and copy the link.

In Confluence:

1. Select Calendars from the Confluence header or space sidebar (to add the calendar in a space).
2. Select More options *** next to Add Calendar and choose Subscribe By URL.
3. Enter the Name of the calendar and the WebCal feed link you copied. You will need to change webcal to http or https at the beginning of the link. If necessary, enter your username and password credentials for the calendar. Then select Subscribe.

All of your personal on-call schedules from PagerDuty will now appear in Team Calendars.

Subscribe to a Single Schedule from Team Calendars

To subscribe to only your on-call shifts, in PagerDuty:

1. Go to Configuration > Schedules.
2. Next to a calendar select Export > Just My Calendar and copy the calendar URL.

In Confluence:

1. Select Calendars from the Confluence header or space sidebar (to add the calendar in a space).
2. Select More options *** next to Add Calendar and choose Subscribe By URL.
3. Enter the Name of the calendar and the calendar URL you copied. You will need to change webcal to http or https at the beginning of the URL. If necessary, enter your username and password credentials for the calendar. Then select Subscribe.

To subscribe to an entire Schedule (everyone’s shifts), in PagerDuty:

1. Go to Configuration > Schedules.
2. Next to a calendar select Export > Everyone and copy the calendar URL.

In Confluence: same as instructions above.

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details
Subscribe to Teamup Calendars from Team Calendars

Subscribing to Teamup Calendars in Team Calendars is an efficient way to help groups manage shared time and resources.

Subscribe to Teamup Calendars from Team Calendars

In Teamup:

1. Select 📅 in the top right and go to Preferences > iCalendar feeds.
2. Find your desired calendar on the list or scroll to the bottom of the list for All Calendars. Select Copy to the right of the feed URL.

In Confluence:

1. Select Calendars from the Confluence header or space sidebar (to add the calendar in a space).
2. Select More options *** next to Add Calendar and choose Subscribe By URL.
3. Enter the Name of the calendar and the feed URL you copied. If necessary, enter your username and password credentials for the calendar. Then select Subscribe.

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details
Export Team Calendars Content to Other Calendars

Team Calendars allows you to quickly export calendar data so you can open it in other calendar apps like Google Calendar, Apple Calendar, Microsoft Outlook, or any application that supports importing .ics files.

Google Calendar

These instructions are for Google G Suite Calendar (as at March 2018). Your version may differ slightly.

1. Choose More options to the right of the calendar and choose Export to iCalendar
2. Save the .ics file to your computer
3. Open Google Calendar, and choose Add other calendars > Import.
4. Locate and select the .ics file you saved and follow the prompts to import it.

Outlook

These instructions are for Outlook 2016, your version may differ.

1. Choose More options to the right of the calendar and choose Export to iCalendar
2. Save the .ics file to your computer
3. Open Outlook and choose File > Open & Export > Import / Export
4. Choose Import an iCalendar (.ics) or vCalendar file (.vcs)
5. Locate and select the .ics file you saved and follow the prompts to import it.

Apple Calendar

These instructions are for Apple Calendar 10, your version may differ.

1. Choose More options to the right of the calendar and choose Export to iCalendar
2. Save the .ics file to your computer
3. Open the Calendar app on your Mac and choose File > Import
4. Locate and select the .ics file you saved and choose Import
5. Choose the calendar you want to import the events into or choose New Calendar, then choose OK

Another team calendar
You can also choose to import events from one team calendar into another team calendar.

1. Choose More options ••• to the right of the calendar and choose Export to iCalendar
2. Save the .ics file to your computer
3. Choose More options ••• to the right of the destination calendar and choose Import iCalendar
4. Locate and select the .ics file you saved and follow the prompts to import it.

This process can be used to merge multiple team calendars into one calendar. Once you've confirmed the events were imported successfully, you can delete the original calendar.

Using another calendar app?

Many calendar apps support importing iCal files. Check the documentation for your app to find out how to import.

The information you import into your chosen calendar app is no longer connected to Team Calendars and won't be updated when you update Team Calendars. If you'd like your calendar app to be synchronised with Team Calendars, see Subscribe to Team Calendars from Third-Party Calendars.

Team Calendars for Confluence is now part of Confluence Data Center

To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can't upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Delete or Remove a Calendar

If you don’t want to see a calendar in a space or on your My Calendars page any more, there are two ways you can remove it. How you proceed depends upon whether you’re just hiding the calendar from your view, or deleting it completely.

Remove a Calendar

To remove a Calendar from a space or your My Calendars page:

1. Find the calendar in a space or on your My Calendars page
2. Choose More options *** to the right of the calendar name and select Remove...
   You’ll be asked if you want to delete the calendar or remove it from your list.
3. Choose the appropriate option:
   - In a space – Remove this calendar from space calendar view
   - In your My Calendars page – Remove this calendar from my calendar view

Delete a Calendar

⚠️ Be Careful! This action is permanent, and will delete the calendar for all users.

To permanently delete a Calendar for all users:

1. Find the calendar in a space or on your My Calendars page
2. Choose More options *** to the right of the calendar name and select Remove...
3. You’ll be asked if you want to delete the calendar or remove it from your list.
4. Select Permanently delete this calendar for all users
If you're using Confluence Cloud, and you'd like Atlassian Cloud site admins to be able to delete calendars, in addition to the calendar's owner, you can enable that option in your Team Calendars settings. Type **Team Calendars** in the Confluence quick search to get to your Team Calendars settings, then tick **Allow site administrators to manage calendars**.

**Team Calendars for Confluence is now part of Confluence Data Center**
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details.
Team Calendars FAQ

Get answers to your Team Calendars for Confluence questions. Click any of the questions below to view the answer.

Team Calendars is part of Confluence Data Center. Upgrade to Confluence Data Center 7.11 or later to use Team Calendars.
Yes you can. Learn more about this here:
- Subscribe to Team Calendars from Google Calendar
- Subscribe to Google Calendar from Team Calendars

Yes you can! See Add Jira Events to find out more.
Maybe! It depends whether you have a calendar app that supports iCal or CalDAV. See Subscribe to Team Calendars from Third-Party Calendars to find out how to get set up.
Yes you can. Just add multiple names in the people field.
Team Calendars is available in English and many of the the bundled Confluence languages. See Choosing a Default Language for a list of languages available in Confluence.
The date format is dependent on your language settings and automatically adjusts accordingly - this is a Confluence user and global setting. An admin can set the site default language (see Choosing a Default Language) and you can also set your preference (see Edit Your User Settings).
Team Calendars uses the language set in each user's profile to determine which day of the week should be the first day in the calendar. For example, if a user has selected US English, Sunday will be the first day of the week. If they select UK English, Monday will be the first day of the week.

If you want to override the default for all users, regardless of their profile setting, go to Administration > General Configuration > Team Calendars and choose a specific day of the week.
Currently, it's not possible to subscribe to Google Calendar from Team Calendars using Public URL to this Calendar from Google. This is a known issue with Google Calendar; it appears that Google Calendar Public URL doesn't contain the data/event that can be read by Team Calendars to display events. You can subscribe to Google Calendar from Team Calendars using these links:
  - Secret address in iCal format
  - Public address in iCal format (if your calendar is made available to the public)

Events from JIRA and external calendars are cached to help your calendars load more quickly. The cache expiry (time to live) defaults to 10 minutes, and is configurable. Go to Team Calendars > General Settings and decrease the Cache expiry time if you want these events to update more frequently.

Team Calendars for Confluence is now part of Confluence Data Center
To get access to the features described on this page upgrade to Confluence Data Center 7.11 or later. Can’t upgrade yet? Depending on your current Data Center version, you can access these features by installing the latest version of the app (at no cost). See our FAQ for all the details
Add-ons and integrations

Confluence has a wide range of features on its own, but you can also extend those features with Marketplace apps, and by integrating Confluence with other applications. Integrating with Jira applications can really take your Confluence experience to the next level by improving the way your teams track vital work, and plan and release new products.

If there's an extra piece of functionality you need, the Atlassian Marketplace is the place to look for useful Confluence apps. Whether you need to create diagrams, like the ones you can create with Gliffy, or you want to make awesome mockups and wireframes with Balsamiq, there are heaps of great apps in the marketplace. You may even find a really useful app you never knew you needed, but now can't live without.

In this section:

- Use Jira applications and Confluence together
- Request Marketplace Apps
- Use a WebDAV Client to Work with Pages
- Mail Archives
- Gadgets

Related pages:

- Use Jira applications and Confluence together
- Use a WebDAV Client to Work with Pages
- Gadgets
- Request Marketplace Apps
Use Jira applications and Confluence together

Confluence and Jira are like bacon and eggs; coffee and cake; Simon and Garfunkel. Separately, they’re great, but together, they’re amazing!

If your Confluence and Jira sites are connected using Application Links, you can display and create Jira issues and more from within Confluence.

What you can do with Confluence and Jira depends on the Jira application, version, and how it is hosted. Find out about the required applications and versions later in this page.

On this page:

- For every project or team
  - Display issues on a page
  - Create reports and charts
  - Create issues from inside Confluence
  - Move between Jira and Confluence
    - Link to pages from Jira
- For software teams
  - Define your requirements
  - Manage your sprints
- For service teams
  - Provide self help resources for your customers
  - Create knowledge base articles
  - Allow any active user to see knowledge base spaces
- Jira applications required

Want to learn how to integrate Confluence Cloud and Jira Software Cloud? Check out this guide.

For every project or team

Display issues on a page

You can display Jira issues on a Confluence page using the Jira Issues macro. Display a single issue, a list of issues, or show the total number of issues.

The simplest way to add a Jira issue to Confluence is to paste a Jira URL on a Confluence page.

- `<yourjirasite.com>/browse/CONF-1234` will insert the Jira Issues macro and display a single issue.
- `<yourjirasite.com>/issues/?filter=56789` will insert the Jira Issues macro and display a list of issues matching the saved filter.
- `<yourjirasite.com>/issues/?jql=project%20%3D%20CONF` will insert the Jira Issues macro and display a list of issues matching the Jira search.

Alternatively, you can add the Jira Issues Macro to the page and search for issues directly:

1. In the editor choose Insert > Jira Issue.
2. Follow the prompts in the macro browser to choose a project and search for an issue – you can even use JIRA Query Language (JQL).

Once you’ve added the macro, you can customize how the issue or list of issues appears on the page, including how much information to display, how many issues, and more.
Create reports and charts

Reporting on information stored in Jira is simple in Confluence. In addition to the Jira Issues Macro, you can use the Jira Report blueprint or Jira Chart macro to show information from your Jira application visually. It's the best way to give your stakeholders a snapshot of your team or project's progress.

You can:

- Use the **JIRA Report blueprint** to create a Change Log or Status report.
- Use the **Jira Chart Macro** to display data as a chart, including pie charts, created vs resolved, and two dimensional charts.
- Use JIRA **Gadgets** to display detailed Jira reports and charts on pages.

Create issues from inside Confluence

You can create issues while viewing a page or from the within the editor. This is really useful if you use Confluence for planning and gathering requirements.

**To create an issue when viewing a page:**

1. Highlight some text on your page and choose the ![Create Jira issue](icon) icon that appears above the highlighted text.
2. Enter your server (if you have multiple Jira sites connected to Confluence), project, issue type and description. Your highlighted text will populate the issue summary automatically.
3. Choose Create.

The issue will be created in Jira and added to your page. If your text is in a table, you'll have the option to create multiple issues using text from the same column.

If you don’t see a popup when you highlight text, check that Text Select is enabled in your profile settings.

**To create an issue in the editor:**

1. In the editor choose **Insert > Jira Issue > Create new issue**.
2. Enter your server (if you have multiple Jira sites connected to Confluence), project, issue type, summary, and description.
3. Choose Insert.

The issue will be created in Jira and added to your page.

There are some limitations when creating Jira issues from Confluence. The Jira Issues macro or Create Jira Issue dialog will notify you if it's unable to create an issue in the selected project. You can find out more in the Jira Issues Macro page.

Move between Jira and Confluence
Whenever you add a link to JIRA issues in Confluence, or link to a Confluence page from your Jira application, the **Jira Links** button appears at the top of the Confluence page. This makes it really easy to jump from Confluence to Jira and vice versa, speeding up your workflow.

The number on the Jira Links button indicates the total number of issues, epics, and sprints connected to that page, regardless of whether you have permission to view them. The dropdown, however, will only show details of issues, epics, and sprints that you have Jira permissions to view.

The button doesn’t detect links from issues displayed in the Jira Issues macro in table format.

![Jira Links button example](image)

---

**Link to pages from Jira**

When viewing an issue in Jira, you can link it to a relevant Confluence page.

How you do this depends on your Jira application, but there will be a Link option that will allow you to search for a Confluence page, or enter a URL.

If you use a Jira Cloud application, the option to search for a Confluence Data Center page is only available in sites that do not have Confluence Cloud. This is because Jira defaults to search Confluence Cloud, over any other linked Jira applications.

**For software teams**

Here’s some suggestions to help you get the most out of Confluence and Jira Software and unleash the potential in your agile development team.

**Define your requirements**

Confluence is the perfect place to start defining your requirements. You can use the **Product Requirements Blueprint** to capture your requirements, then create your Jira epic and other issues right from the requirements page in Confluence.

Here’s how it works:

1. Create a Confluence page using the **Product Requirements Blueprint**.
2. Choose the placeholder text ‘Link to Jira epic or feature’ and choose **Create new issue** to create your epic in Jira.
3. Collaborate with your team to define your stories and save the page.
4. Highlight text on your requirements page and choose the **Create Jira issue** link to create stories in Jira, and automatically link them to your epic.
5. Track the progress of the stories from the Confluence page or from within Jira.
The tight integration between Confluence and Jira Software means you can easily access issues from the Confluence page and see their status at a glance, and from within Jira Software you can see links to related Confluence pages. All the information you need is right there.

If you have Jira Software Cloud, the option to automatically link issues created in Confluence to your epic is only available in Classic projects.

**Manage your sprints**

There's often a lot of material in Confluence that provides useful context for your team during a sprint. These might be requirements documents, designs, tech specs, customer research and more. By linking these pages to epics, you make them easy for your team to find during the sprint.

Here's how you can use Confluence to support your sprint from within Jira Agile:

- In Jira Software, create a Confluence page to plan your sprint. The page is created using the Meeting Notes Blueprint — a handy template that helps capture the details you need — and is automatically linked to the sprint.
- In an epic, link to useful Confluence pages, including requirements, designs, and more.
- Report on your progress to stakeholders using the JIRA Report blueprint in Confluence.
- Use the Retrospective Blueprint in Confluence at the end of your sprint to take stock of what went well and not so well.

For people who work mostly in Jira Software, the integration means that useful Confluence pages are only a click away.

If you have Jira Software Cloud, the option to create pages from your sprint is only available in Classic projects.

For service teams

Available for Jira Service Management (formerly Jira Service Desk) Data Center and Server only. If you use Jira Service Management Cloud, you can't connect your project to a knowledge base space on a Confluence Server or Data Center site. You can only connect to a Confluence Cloud site. Read about how to migrate from Confluence Server to Cloud.

**Provide self help resources for your customers**

If you use Jira Service Management, you can help your customers resolve their issues without creating a request by connecting your service project to a knowledge base in Confluence. You’ll need Confluence 5.10 or later.

In Jira Service Management, head to Project settings > Knowledge base to connect or create a Confluence space.
When customers search in the Customer Portal, pages in the linked knowledge base space will be suggested, allowing customers to help themselves.

Create knowledge base articles

The Knowledge Base space blueprint, along with templates for how-to and troubleshooting articles make creating new knowledge base articles super simple for your agents.

The templates used in the how-to and troubleshooting blueprints are completely customizable too. Set up the template with all your standard information and let your agents take it from there.

Allow any active user to see knowledge base spaces

If your Confluence instance is not public, you can still make a knowledge base space available via the customer portal.

When you link your service project to a Confluence space, you can choose to allow all active users and customers to see pages in the linked space, even if they don’t have a Confluence license. These people get very limited Confluence access.

Unlicensed users can:

- View pages via the customer portal.
- Follow a URL to a page and then navigate within the linked space.

Unlicensed users can’t:

- Like, comment on or edit pages (or be granted permission to do this).
- See the dashboard, user profiles, the people directory or space directory.
- Search the whole site.

This permission can only be enabled via Jira Service Management, but you can revoke access to the whole site or to particular spaces via Confluence's global permissions or space permissions.

Allowing all active users and customers to view a space will override all existing space permissions, so any logged in, licensed Confluence user will also be able to see the space (regardless of their group membership). This is due to the way Confluence inherits permissions.

Jira applications required

As you’ve seen, Confluence has many integration points, some of which are only available in particular Jira applications or versions.

This matrix outlines the specific Jira applications you'll need for each feature. We've also included:

- The minimum legacy Jira Server version (plus any add-ons) that you'll need if you're not using the latest Jira Server or Data Center applications.
- The minimum cloud plan required, and whether there are any limitations on the project type or apps in your site (for example, some integrations won't be available if you also have a Confluence Cloud site).
<table>
<thead>
<tr>
<th>Feature</th>
<th>Jira Core</th>
<th>Jira Software</th>
<th>Jira Service Management (formerly Jira Service Desk)</th>
<th>Minimum legacy version</th>
<th>Jira Cloud plan</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display issues using Jira issues macro</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>Jira 4.3</td>
<td>✔️ Any</td>
</tr>
<tr>
<td>Display issue and project information using Jira chart macro</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>Jira 5.0</td>
<td>✔️ Any</td>
</tr>
<tr>
<td>Display issue and project information using the Jira Report blueprint</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>Jira 5.0</td>
<td>✔️ Any</td>
</tr>
<tr>
<td>Create an issue from Jira issues macro</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>Jira 4.3</td>
<td>✔️ Any</td>
</tr>
<tr>
<td>Create issues by highlighting text on a Confluence page</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>Jira 6.3.1</td>
<td>✔️ Any</td>
</tr>
<tr>
<td>Create issue by highlighting text on a Confluence page and automatically link issues to an epic</td>
<td>✗</td>
<td>✔️</td>
<td>✗</td>
<td>Jira 6.3.1 and Jira Agile 6.3.5</td>
<td>Class projects only</td>
</tr>
<tr>
<td>Link and create Confluence pages from epics and sprints</td>
<td>✗</td>
<td>✔️</td>
<td>✗</td>
<td>Jira 6.3.1 and Jira Agile 6.3.5</td>
<td>Jira-only sites, Class projects only</td>
</tr>
<tr>
<td>View linked issues with the Jira links button in Confluence</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>Jira 6.3.1</td>
<td>✔️ Any</td>
</tr>
<tr>
<td>Create a space using the Software Project space blueprint</td>
<td>✗</td>
<td>✔️</td>
<td>✗</td>
<td>Jira Software 7.0</td>
<td>✔️ Any</td>
</tr>
<tr>
<td>Use a Confluence space as a knowledge base in the customer portal</td>
<td>✗</td>
<td>✗</td>
<td>✔️</td>
<td>Jira 5.2 and Jira Service Desk 1.0</td>
<td>✗</td>
</tr>
<tr>
<td>Allow Service Management customers to view knowledge base articles without a Confluence license</td>
<td>✗</td>
<td>✗</td>
<td>✔️</td>
<td>Jira Service Desk 3.1</td>
<td>✗</td>
</tr>
<tr>
<td>Search for an existing Confluence page within the Jira link dialog</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>Jira 4.3</td>
<td>Jira-only sites</td>
</tr>
<tr>
<td>Delegate user management to Jira</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>Jira 4.3</td>
<td>✗</td>
</tr>
<tr>
<td>Add a Jira gadget to a Confluence page</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>Jira 4.3</td>
<td>✔️ Any</td>
</tr>
</tbody>
</table>

That's it? Time to jump into Confluence and give some of these great features a try with your team or project.

Want to find out more about how to connect your Jira application to Confluence? Check out Integrating Jira and Confluence.
Request Marketplace Apps

The Atlassian Marketplace website offers hundreds of apps that the administrator of your Atlassian application can install to enhance and extend Confluence. If the app request feature is enabled for your Confluence instance, you can submit requests for apps from the Marketplace to your Confluence administrator.

The ‘Atlassian Marketplace for Confluence’ page provides an integrated view of the Atlassian Marketplace from within your Confluence instance. The page offers the same features as the Marketplace website, such as searching and category filtering, but tailors the browsing experience to Confluence.

This in-product view of the Marketplace gives day-to-day users of the Atlassian applications, not just administrators, an easy way to discover the apps that can help them work. When you find an app of interest, you can submit a request with just a few clicks.

Submit an app request

To browse for add-ons in the Atlassian Marketplace, follow these steps:

1. Choose your profile picture at top right of the screen, then choose Atlassian Marketplace.
2. In the Atlassian Marketplace page, use the search box to find apps or use the category menus to browse or filter by type, popularity, price or other criteria. You can see what your fellow users have requested by choosing the Most Requested filter.
3. When you find an app that interests you, click Request to generate a request for your administrator.
4. Optionally, type a personal message to your administrators in the text box. This message is visible to administrators in the details view for the app.
5. When ready, click Submit Request.
6. Click Close to dismiss the ‘Success!’ message dialog box.

At this point, a notification appears in the interface your administrators use to administer apps. Also your request message will appear in the app details view, visible from the administrator’s ‘Find New Apps’ page. From there, your administrator can purchase the app, try it out or dismiss requests.

Update an app request

After submitting the request, you can update your message at any time. Click the Update Request button next to the listing in the Atlassian Marketplace page to modify the message to your administrator.

The administrator is not notified of the update. However, your updated message will appear as you have modified it in the details view for the app immediately.
Use a WebDAV Client to Work with Pages

Create, move and delete pages and attachments in Confluence using a file manager like Finder (OS X), Explorer (Windows) or Dolphin (Linux) or other WebDav compatible local client like CyberDuck.

For example, if you need to delete a lot of pages you can bulk delete them in your local file manager (like Finder or Explorer), rather than one by one in your browser.

Access to Confluence through a native client is provided by the WebDav plugin. Your administrator may have disabled the WebDav plugin, or may have restricted the actions that you can perform using a local client. See Configuring a WebDAV client for Confluence for more information on how to set it up.

Manage pages and files in a native client

Accessing Confluence through a native client is useful for performing bulk actions. Before you can start creating and moving things around, it's useful to understand how the content is organized.

The hierarchy in the file system looks like this:

- Type of space (global or personal)
  - Space (folder name is the spacekey)
    - Homepage (and other top level pages)
    - Child pages (folder name is the name of the page)
    - Attachments (filename of the attachment)

Essentially the file structure is the same as the page tree in your space. Here's how the Confluence demonstration space looks in Finder.

Here’s some things you might choose to do in a local client, rather than in your browser:

- Move pages to another space
  Select the page folders, and drag them into the other space’s folder (drag them from Space A to Space B)
- Delete multiple pages
  Select all the page folders you want to delete and delete them.
- Delete multiple attachments from a page
  Navigate down to the page folder, select the attachments you want to delete and delete them.
- Upload multiple attachments
  Navigate to the page folder, and drag the files into the folder (note you can attach multiple files through the insert dialog as well).
Mail Archives

Confluence allows you to collect and archive mail within each space. It's useful for storing the email messages that relate to a particular project – you can put them in the same Confluence space as the content for that project.

You can download mail from one or more POP or IMAP accounts, or import mail from an mbox file on your local system or on the Confluence server.

You need space administration permissions to manage the mail archives.

Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a system app. To activate mail archiving features in Confluence, enable the app – go to Administration > Manage apps then choose System in the drop down, and enable the Confluence Mail Archiving Plugin.

To see archived mail:

- Go to a space and choose Space tools > Integrations > Mail
- Choose a message to see its contents, or choose Next, Previous and other options to navigate around the mail archives.

Manage mail archives:

- Add a Mail Account
- Delete and Restore Mail
- Import Mail from an mbox
- Create content with email

Screenshot: Viewing a message in the mail archive

Notes

- Only site spaces – not personal spaces – can store mail archives. See Spaces for information on site and personal spaces.
- You can also search the mail messages and their attachments. See Search.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a system app. To activate mail archiving features in Confluence, enable the app – go to Administration > Manage apps then choose System in the drop down, and enable the Confluence Mail Archiving Plugin.
Add a Mail Account

When you add a mail account, you're configuring Confluence to download mail from that account and archive it within the space.

You need space administration permissions to add a mail account. See Space Permissions Overview.

⚠️ Note: Confluence will remove email messages from an email account when it transfers them to the mail archive. You must therefore configure Confluence to poll a clone email account rather than the actual account. For example, to archive the actual account sales@company.com to your Confluence Sales space, you must first create a clone account such as conf-sales@company.com that contains the same email content.

Add a mail account

Step 1. Create a clone email account on the mail server

1. Add a new email account on the mail server with the clone email address.
2. Copy all existing email messages from the actual account to the clone account.
3. Set up the actual account to bcc sent email messages to the clone account.
4. Set up the actual account to forward received email messages to the clone account.

Step 2. Configure Confluence to archive the clone account

1. Go to the space and choose Space tools > Integrations from the bottom of the sidebar.
2. Choose Mail Accounts > Add mail account.
3. Enter configuration details for the account:
   - **Account Name**: Enter a name for this account by which it will be known in Confluence.
   - **Description**: Provide a description for this account (optional).
   - **Protocol**: Choose from POP, IMAP, POPS or IMAPS.
   - **Hostname**: Enter the host name of the mail server on which the account resides.
   - **Port**: Don't edit this field. The mail server's port number will be displayed by default.
   - **Authentication**: By default, this is set to basic authentication. To select a different authentication method like OAuth 2.0, you'll need to first configure an outgoing link with your service provider.
   - **Username**: Enter a username that has permission to retrieve mail from this account.
   - **Password**: Enter the account's password.
4. Choose Test Connection to verify the details.
5. Choose Create to add the account to Confluence.
For each mail account you add, you can perform these actions in the **Mail Accounts** tab:

- **Edit**: Change the configuration settings for the mail account.
- **Remove**: Remove the account permanently.
- **Disable/Enable**: Temporarily disable the account, or enable a disabled account.

**Fetching Mail**

Confluence automatically fetches mail from the server once every 30 minutes. You can manually retrieve new mail from the configured mail accounts by selecting the **Mail** tab and choosing **Fetch new mail**.

ℹ️ You need to be a space administrator to manually retrieve mail. See **Space Permissions**.

**Notes**

- Only **site spaces** – not personal spaces – can store mail archives. See **Spaces** for information on site and personal spaces.
- Confluence mail archiving is an optional feature. This means that the ‘Mail’ options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a system app. To activate mail archiving features in Confluence, enable the app – go to **Administration** > **Manage apps** then choose **System** in the drop down, and enable the **Confluence Mail Archiving Plugin**.
- Once mail is fetched it will be removed from the server.
Delete and Restore Mail

To delete mail from a space, you need 'Delete Mail' permission.

ℹ️ Only a space administrator can delete all email messages in the space simultaneously.

To delete mail from a space:

1. Go to a space and choose Space tools > Integrations > Mail
   A list of email messages in the space is displayed in reverse chronological order.
2. Do either of the following:
   - Delete an individual email message by choosing the trash icon beside it.
   - Delete all email messages within the space by choosing Delete All.

⚠️ Email messages deleted using the 'Delete All' option can't be restored.

Space administrators can restore deleted email messages, provided they were deleted individually.

To restore deleted mail:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Trash
   You'll see a list of email messages and other content deleted from the space.
3. Choose Restore beside the email message you want to restore.
Import Mail from an mbox

Confluence allows you to import mail from mbox files located either on your local system or in a specified location on the Confluence server. Confluence will store the imported email messages in the space's mail archive.

You need to be a space administrator to import mail for a space. See Space Permissions.

NB: You may need to enable the Confluence Mail Archiving Plugin as it is disabled by default.

To import mail from an mbox file:

1. Go to the space and choose Space tools > Integrations from the bottom of the sidebar.
2. Choose Mailbox Import.
   - To import from a location on your file system: Browse to the location of the mbox file, select the file and then choose Import.
   - To import from the Confluence server: Enter the location of the mbox file on the server, then choose Import.

Notes

- Only site spaces can store mail archives. Personal spaces cannot. See Spaces for an explanation of site spaces and personal spaces.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a system app. To activate mail archiving features in Confluence, enable the app – go to Administration > Manage apps then choose System in the drop down, and enable the Confluence Mail Archiving Plugin.
- For security reasons mail can only be imported from a specified location in the Confluence server's file system. We recommend administrators create a folder in their Confluence home directory, add the system property confluence.mbox.directory and specify the location for mailboxes to be imported from. Mail cannot be imported from the server until this system property is set. See Configuring System Properties.
Create content with email

Use email to create new pages and reply to comments even when you can't access your Confluence instance. Whether you’re offsite, on mobile, or have lost network connection to your instance, these apps allow you to continue collaborating and creating content with flexibility and less disruption:

- Confluence Email Gateway
- Confluence Email to Page
- Confluence Reply to Email

⚠️ These apps are considered experimental and only allow you to create content within your personal space. They are disabled by default with your Confluence installation.

On this page, you’ll learn how to configure each of these apps and what they do.

Before you begin, you will need to:

- configure an outgoing link to allow Confluence to be an OAuth client
- configure a Server for Outgoing Mail to allow Confluence to send email messages
- configure a Server for Incoming Mail to allow Confluence to receive email messages

Email Gateway

The Email Gateway app allows users to create content by sending an email to Confluence.

To enable the app:

You need to be a Confluence admin to perform these steps.

1. Go to Administration > Manage apps
2. Change the filter to All apps
3. Search for “Email”
4. In the results, expand Confluence Email Gateway
5. Select Enable

Screenshot: Confluence admin email gateway configuration
Email to page

The Email to Page app allows users to create pages in their personal space by sending emails to a configured email address.

**To enable the app:**

You need to be a Confluence admin to perform these steps.

Ensure you have enabled the Email Gateway for this to work. See above

1. Go to Administration > Manage apps
2. Set the filter to All apps
3. Search for 'Email'
4. In the results, expand Confluence Email to Page
5. Select Enable
6. Go to Administration > General Configuration > Create by page
7. Check the box next to Create pages by email
8. Select the incoming mail server (this is the mail account users will email to create a page)
9. Select Save

**Check your space:**

Users will be able to see the app has been enabled in their personal space (see screenshot below).

1. Go to your personal space
2. Select Space tools > Integrations
3. Select the tab Create By Email
4. You should see Create pages by email listed with details of the inbox that’s been configured. Email this address with the content of a new page, and you’ll receive an email reply with a ‘Create page’ link to create the page in your personal space.

**Reply to Email**

The Reply to Email app allows users to publish comments in their personal space by replying to email notifications.
To enable the app:

You need to be a Confluence admin to perform these steps.

Ensure you have enabled the Email Gateway app for this to work. See above

Go to Administration > Manage apps

1. Set the filter to All apps
2. Search for “Email”
3. In the results, expand Confluence Reply to Email
4. Select Enable
5. Go to Administration > General Configuration > Create by page
6. Check the box next to Reply to comments by email
7. Select the incoming mail server (this is the mail account users will reply to to create a comment)
8. Select Save

Check your space:

Users will be able to see the app has been enabled in their personal space (see screenshot below).

1. Go to your personal space
2. Select Space tools > Integrations
3. Select the tab Create By Email
4. You should see Reply to comments by email listed

Screenshot: When (1) Email to Page and (2) Reply to Email apps are enabled, the user will see this in their space integrations menu, and can email admin@companyname.com to create content.
Gadgets

Gadgets allow you to add dynamic content to a Confluence page or Jira application dashboard. Confluence can display gadgets that support the OpenSocial specification, including third party gadgets.

For more information about Atlassian gadgets, see the introduction to Atlassian gadgets and the big list of Atlassian gadgets.

To see a list of available gadgets in your Confluence site go to Help > Available Gadgets.

Add a Confluence gadget to a page

We ended support for the following Confluence gadgets in Confluence 7.0:

- Confluence Page Gadget
- Activity Stream Gadget
- Confluence QuickNav Gadget

These gadgets no longer appear in the macro browser and can't be added to a page. Any gadget already on a page, or used in another application like Jira, will still work.

The Confluence News gadget was removed entirely in Confluence 7.0. This gadget displayed news from Atlassian and hadn't been working for some time.

If you're wanting to display information within Confluence, we recommend using the following macros as an alternative:

- Include Page macro
- Recently Updated macro
- Livesearch macro

Add a Jira gadget to a page

For displaying basic Jira information, such as issues and charts, we recommend using the Jira Issues Macro and Jira Chart Macro as these macros have better performance and are easier to configure than gadgets.

If the Jira information you want to display is not available from either of these macros a gadget will likely do the trick.

To add a Jira Gadget to a Confluence page:

- In the editor go to Insert > Other Macros.
- Select the gadget you wish to add, and use the preview area to configure the gadget.
- Choose Insert.

If you don't see any Jira Gadgets in the macro browser, ask your Confluence administrator to add the Jira Gadget urls to the list of authorized external gadgets in Confluence, and check that the application link between Confluence and your Jira application is configured correctly.

Add a Confluence gadget to your Jira application dashboard

To add a Confluence gadget to your Jira dashboard:
1. Go to the dashboard by selecting the **Dashboard** link in the header.
2. On the dashboard, Click **Add Gadget**.
3. Use the gadget wizard to choose the gadgets you want to add.

If you don't see any Confluence gadgets in the Jira gadget directory, ask your Jira administrator to add the gadget URLs as follows.

To add a Confluence gadget to your Jira application's gadget directory:

1. In Confluence, go to **Help > Available Gadgets** and copy the gadget URL for the gadget you want to make available in Jira.
2. In Jira, go to the dashboard and choose **Add Gadget**.
3. Choose **Manage Gadgets** or **Add Gadget to Directory** (depending on your Jira application and version)
4. Paste in the Confluence gadget URL and choose **Add Gadget**.

The gadget will now be available from the Jira Gadget Directory.
Activity Stream Gadget

⚠️ We ended support for this gadget in Confluence 7.0
The gadget no longer appears in the macro browser and can't be added to a page.
Any gadget already on a page, or used in another application like Jira, will still work.

The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.

In addition to showing a list of most recently changed content, the activity stream gadget also groups activities by separate date, and provides an RSS feed link to its content in the top-right corner.

Activity Stream Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

These properties are located in the preview panel in the macro browser.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Yes</td>
<td>None</td>
<td>Adds a title to the top of the Activity Stream.</td>
</tr>
<tr>
<td>Global filters</td>
<td>No</td>
<td>None</td>
<td>Allows you to add filters to the gadget including:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• space</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• username</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• update date</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Jira issue key (if your Confluence instance is integrated with a Jira application)</td>
</tr>
<tr>
<td>Available streams</td>
<td>Yes</td>
<td>All</td>
<td>If you have application links to other sites, Jira or another Confluence site, you can choose to include activity from those streams also.</td>
</tr>
<tr>
<td>Display options: limit</td>
<td>No</td>
<td>10</td>
<td>Specify the maximum number of results to be displayed. A maximum of 10 results will be displayed by default. The maximum value that this property can accept is 100.</td>
</tr>
<tr>
<td>Display options: Refresh Interval</td>
<td>No</td>
<td>Never /false</td>
<td>Specify the time interval between each 'refresh' action undertaken by the activity stream gadget. A refresh makes the activity stream gadget reflect any new activity that has been conducted on the Confluence site.</td>
</tr>
</tbody>
</table>
Confluence Page Gadget

We ended support for this gadget in Confluence 7.0
The gadget no longer appears in the macro browser and can't be added to a page. Any gadget already on a page, or used in another application like Jira, will still work.

The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.

On this page:
- Confluence Page Gadget Properties
- Working Macros

Macros that work with the page gadget
Please note, not all macros work with the page gadget. Please refer to the Working Macros section below for more information.

Screenshot: The Confluence page gadget displaying a sample page

Sample Page

Two penguins find themselves together on an ice floe, drifting helplessly into warmer waters. The penguins are very fond of each other. Suddenly, the ice flow splits in half, right between the penguins. As they drift apart, one penguin sadly waves a flipper and calls out “Chocolate milk!”

Confluence Page Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>No</td>
<td>None</td>
<td>Specify the space that your desired page is located in. Suggestions will display in a dropdown when you start typing. (Note, this property is only used to make searching for pages easier. It is not required.)</td>
</tr>
<tr>
<td>Page</td>
<td>Yes</td>
<td>None</td>
<td>Specify the page that you want to display in your gadget. Suggestions will display in a dropdown when you start typing.</td>
</tr>
<tr>
<td>Show View Link</td>
<td>No</td>
<td>Yes</td>
<td>Select whether to display a link to view the page on your Confluence site. Clicking the link will open the page in Confluence.</td>
</tr>
</tbody>
</table>

682
Working Macros

The Confluence page gadget will only render a subset of the macros that are used in Confluence correctly. Refer to the table below for the list of macros that work and do not work with the page gadget and known limitations.

Some of the issues with macros in the page gadget can be worked around, if you are comfortable developing in Confluence. Please see Troubleshooting Macros in the Page Gadget for more information.

Key:
- ✔ Works with the page gadget
- * Partially works with the page gadget
- ✗ Does not work with the page gadget

<table>
<thead>
<tr>
<th>Macro</th>
<th>Works with page gadget?</th>
<th>Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Stream</td>
<td>✗</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Anchor (within a page)</td>
<td>✔ *</td>
<td>Opens in a new page</td>
</tr>
<tr>
<td>Attachments</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Blog Posts</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Chart</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Children Display</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By Label</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By User</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Excerpt</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Gallery</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Include Page</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Info</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Labels List</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Function</td>
<td>Status</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Livesearch</td>
<td>✗</td>
<td>N/A</td>
</tr>
<tr>
<td>Note</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata Summary</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree Search</td>
<td>✗</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Panel</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Quick Nav</td>
<td>✗</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget.</td>
</tr>
<tr>
<td>Recently Updated</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>RSS Feed</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Section &amp; Column</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Spaces List</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>✔</td>
<td>Works, however links will be opened in a new browser window when clicked.</td>
</tr>
<tr>
<td>Team Calendars for Confluence Server</td>
<td>✗</td>
<td>See here for the Improvement Request: <a href="#">CONFSERVER-51407</a> - Make Team Calendars display in a Confluence Page Gadget, for use on a JIRA Dashboard. GATHERING INTEREST</td>
</tr>
<tr>
<td>View File (PDF or PPT)</td>
<td>✔</td>
<td>Works, but you may need to refresh the gadget the first time (see CONF-19932).</td>
</tr>
</tbody>
</table>
| Widget Connector                 | ✔      | Only works for some content:  
  - **Works:** blip.tv, Episodic, Flickr, Google Calendar, presentations on Google Docs, MySpace Video, Scribd, Skitch.com, SlideRocket, SlideShare, Viddler, Vimeo, YouTube, Dailymotion, Metacafe, FriendFeed, Yahoo Video, Wufoo HTML Form Builder  
  - **Does not work:** FriendFeed, Google Gadgets, Google Video (consumer service discontinued), Twitter, Widgetbox, DabbleDB, BackType |
Confluence QuickNav Gadget

**We ended support for this gadget in Confluence 7.0**
The gadget no longer appears in the macro browser and can't be added to a page. Any gadget already on a page, or used in another application like Jira, will still work.

The QuickNav Gadget allows you to add the quick navigation functionality to search your Confluence site. To search Confluence using a QuickNav Gadget, type the name of a page, blog post, person, file, or space into the search box, and choose from the list of results displayed.

If you don't immediately see what you need, hit **Enter** or choose the 'Search for' option at the bottom of the search results to go to the advanced search page. Learn more about searching Confluence.

**Screenshot: Using the QuickNav Gadget**

More information about the QuickNav Gadget:

- The QuickNav Gadget returns matches based on the title only, not the content of the page or file.
- Matching items are grouped by type, so that you can quickly find the type you want. Confluence shows a maximum of 3 admin options, 6 pages and/or blog posts, 2 attachments, 3 people and 2 spaces.
- Items are ordered with the most recently updated first.
- Permissions determine the admin options that appear in the search results. You'll only see the options you have permission to perform.

**Confluence QuickNav Gadget Properties**

This gadget has no properties and cannot be customized.
Confluence use-cases

This section describes some specific use cases for Confluence.

- **Using Confluence for technical documentation**
  A technical communicator’s guide to using Confluence – see Develop Technical Documentation in Confluence.

- **Setting up a knowledge base**
  A support engineer’s guide to using Confluence as a knowledge base – see Use Confluence as a Knowledge Base.

- **Setting up an intranet**
  A quick guide to setting up an intranet – see Use Confluence as your Intranet.

- **Confluence for software teams**
  A series of blog posts to help your agile team get the most out of Confluence. See Confluence for Software Teams.
Develop Technical Documentation in Confluence

Confluence is a flexible platform with a range of features and Marketplace apps that can help you capture, distribute, and update your technical documentation. Below are some tips to help you get your technical documentation site started, and to save you time and effort managing your documentation's life cycle.

For another great overview of how you can use Confluence for documentation check out Rock the Docs from our solution partner, K15t.

Create your Documentation Space

Creating spaces in Confluence is quick and easy. All you need to do to get your documentation started is choose **Spaces > Create space** from the Confluence header. To make things even easier, choose the 'Documentation Space' option in the create space dialog; it'll give you a custom home page with a search box (the *livesearch macro*) to search just your documentation space, a *recently updated macro*, and a few other goodies.

Give your space a name, and Confluence will automatically create the home page and space key for it (change the space key if you're not happy with the one Confluence chooses for you). Feel free to customize the home page at any time; what it looks like is completely up to you!

Save time by re-using content

If there's something you're going to use multiple times in your documentation space – whether it's a word, sentence or paragraph; an image; a product version number; or anything else – you can create it once and include it on as many pages as you like (or use it in the header and/or footer). Inclusions not only save you typing the same thing many times, they also make it easier when things change – it's much better to update the info in one place, than 47!

There are 3 macros that allow you to re-use content:

- The **Excerpt macro** to define a re-usable section, or 'excerpt', on a page – add content inside this macro, and you can reuse it on as many pages as you like.
- The **Excerpt Include macro** (excerpt-include) to include the contents of an excerpt on another page.
- The **Include Page macro** (include) to include the entire content of a page on another page.

For example, let's say you create release notes for each major release of your product, and you want to include the intro from each release notes page on a 'what's new' page. Place each release notes intro in an **Excerpt macro**, then add an **Excerpt Include macro** for each set of release notes to the what's new page. Your intros will magically appear on the what's new page, and if you update the release notes it'll automatically update the what's new.
1. **Excerpts**: the intros to these pages are in excerpt macros.
2. **Excerpt include**: these are excerpt include macros.

Another example is one of the ways we use the Include Page macro. Whenever the ellipsis (More options ...) appears in our documentation – for example, go to More options ... > Copy – it's actually an Include Page macro. We have a page with just that image on it, so we can include it whenever we need an ellipsis.

Why do we do use an Include Page macro for one tiny image? Well, just in case that UI element is ever changed. If we attach the image to every page, there might be 50 pages we need to update when things change; if we use an Include Page macro, we update once and it's changed everywhere. Doing it this way also allows us to know how many pages we're using the image on. By going to More options ... > Page Information, we can see how many incoming links there are to this page, and that tells us how many pages use the image.

**Create an inclusions library (optional)**

You can include content from any Confluence page, but you may want to create an 'inclusions library' to hold content that's specifically for re-use. The inclusions library isn't a specific feature of Confluence; the pages in the inclusions library are just like any other Confluence page. This is just a technique you can use if you want a place to store content that's specifically for re-use.

To create your inclusions library:

1. Choose Create and create a new page in your space
2. Enter a suitable title. We use '_ConfluenceInclusions' (the underscore before the title helps to let people know this page is special)
3. Enter some content and save the page
   - We enter text explaining the purpose of the inclusions library and how to re-use the content
4. Choose Space tools > Reorder pages and drag your new page above the space homepage
5. Go to your new inclusions page and choose Create to add child pages containing your re-usable content

Because you've moved the pages to the root of the space, they won't appear in the page tree in the sidebar. The pages will be picked up by other searches though, as they're normal Confluence pages.
1. **Inclusions library location:** drag your inclusions library here, above the rest of your documentation.

---

### Use page templates

Creating one or more page templates can be a real time-saver if you're creating a lot of pages with the same layout. If you're constantly adding the same macros, like panels and table of contents, save yourself from RSI and put them into a template – you can start with one, but make as many as you need to maximize your efficiency.

To create a page template that's available in all spaces:

1. Go to Administration > General Configuration
2. Select Global Templates and Blueprints from the list on the left
3. Choose the Add global page template button at the top-right
4. Create your template page and choose Save

For detailed info on page templates, see Create a Template.

---

### Draft your work

When you're creating a new page in your documentation, you'll likely want to do it over time, saving as you go, and have a select few people review it to provide feedback. A loose description of this workflow is 'draft, review, publish'.

You don't want any half-finished pages being seen by your users, and most documentation needs to be reviewed before it's finalized, so here's a technique for drafting pages and allowing for review:

1. Create a page and restrict its permissions
   - For example, you might restrict viewing to a group of people such as your team, or a few select individuals. On a public site, you might restrict viewing to staff members, so that the general public can't see the page.
2. Write your page content
3. Share the page with your reviewers and ask them for feedback (make sure you haven't restricted them from seeing the page!)
   - The reviewers can add comments to the bottom of the page or highlight text to add a comment inline.
   - If you give them permission, they can also edit the page content directly.
4. Publish the page when ready, by doing the following:
   a. Delete any comments on the page
   b. Remove page restrictions so that your audience can see it

You've now published your page. The space permissions and site permissions now determine who can see and/or update the page.

---

### Use links and anchors

#### Add links

In any documentation site, it's essential to be able to link from one page to another, and often to specific sections on a page. You can add any URL to a Confluence page and Confluence will automatically detect it and turn it into a link.
If you paste the URL for another page in your Confluence site, Confluence will display the link text as the page name and turn it into a relative link, meaning if the name of the page changes, Confluence will adjust the link so it doesn't break.

**Add and link to anchors**

The anchor macro allows you to create anchors in your documentation, which can be linked to from anywhere. I've added an anchor at the top of this page so you can click to go back to the top.

**To add a macro and link to it from the same page:**

1. Type `@anchor` in the editor, select the anchor macro and give your anchor a name (top in my example)
2. Select the text that'll link to the macro and hit Ctrl+K (Windows) or Cmd+K (Mac) (this opens the link dialog)
3. Choose Advanced from the options on the left and type `#` followed by your anchor name (#top in my example)

Check out our documentation for links and anchors to get the full rundown on linking to anchors on other pages and other anchor goodness.

**Useful macros**

Confluence ships with a great range of macros, and there are a few that are particularly useful in technical documentation. Here's a few:

**Table of contents macro**

The Table of Contents macro helps people navigate lengthy pages by summarizing the content structure and providing links to headings used on the page. The best part is, you don't need to do anything except add the macro; once you've added it, it’ll automatically detect headings and add them to the table of contents.

**Tip, Note, Info, Warning, and Panel macros**

Often when creating documentation, there are elements of a page that you want to highlight or draw the the viewers' attention to. Confluence ships with the Tip, Info, Warning, Note and Panel macros, which will help you focus a viewer's attention on a particular part of your content.

**Keep track of page updates**

In Confluence, it's quite usual for a number of different people to update a single page. Technical writers need to know what happens to our documents, both during review and after publication.

**Watch pages or the space**

So that you know when changes are made, it's a good idea to watch pages or even the entire space. That way, when changes are made to pages you're watching, or someone comments on them, you'll get an email notification letting you know who changed what.

Whenever you're on a page in your documentation space, choose the Watch button at the top-right of the page. From there, you can choose to watch just that page, or all pages in the space.
View page history

Confluence creates a new version of the page every time someone edits the page. The page history shows all the versions, with date, author, and any comments made on the update.

To view page history, go to the page and choose More options ⋮ ⋮ > Page History

On the page history view, you can:

- View the content of a specific version of the page.
- Revert to (restore) a specific version.
- Select any two versions and ask for a comparison, to see what has changed between those two versions.

Take a look at Page History and Page Comparison Views for a detailed explanation.

Show a list of contributors

If you want to see at a glance who's updated a page or pages, you can add the contributors macro. This macro displays a customizable list of people who've contributed by creating, editing, or, optionally, commenting on the page.

Customize PDF export

If you're planning to provide a PDF version of your documentation – whether it be for email, download, print, or any other form of delivery – you can customize the look of the PDF by adding a title page, header, and footer.

The process you take depends on whether you're trying to customize the PDF export for one space or for your whole site, so, if you're keen to make these changes, take a look at our page on Customize Exports to PDF for more detailed instructions.

Other useful tools and apps

Confluence is already a great tool for technical documentation, but you can still add to it depending on your documentation and workflow needs. Here are some useful apps available on the Atlassian Marketplace, most of which we use ourselves, which can extend the functionality of Confluence.

New apps are hitting the marketplace all the time. This is by no means an exhaustive list!

Scroll Versions (supported by vendor)

Scroll Versions, by K15t, allows you to tie versions of your documentation to versions of your product, so that when a new version of your product ships you can publish that version of your documentation. Create as many versions of your documentation as you like, make the changes you need to, and keep them up your sleeve until release time. You can even publish different variations of your documentation – like if you have versions of your documentation for different operating systems – to different spaces or Confluence instances.

Copy Space (unsupported)

The Copy Space add-on, by Atlassian Labs, does what its name suggests; it allows a space administrator to copy a space, including the pages within the space. Great for when you want a space template that you can copy to create other spaces.

This app is also useful when you need to archive a copy of a current space at a particular point in time, like when you're moving from one version of your product to the next – copy the space, give it a new name, and keep it wherever you like, all without losing the existing space.
At this point this plugin won't copy page history, blog posts and email.

**Scroll PDF Exporter (supported by vendor)**

If you're going to produce a PDF of your documentation space, wouldn't you like it to be professionally formatted? The **Scroll PDF Exporter**, by K15t, lets you style single pages or whole spaces for export, using handy PDF templates.

**Gliffy (supported by vendor)**

Create diagrams, wireframes, flowcharts and more with **Gliffy**. Gliffy features a highly intuitive drag-and-drop interface, and allows you to export your diagrams in multiple formats, including: JPEG, PNG and SVG. Add Gliffy flowcharts, UI wireframes, and network diagrams directly to your Confluence pages to communicate your ideas visually, making them easy to understand and faster to spread through your team.

**Lucidchart (supported by vendor)**

Lucidchart is available in versions for **Cloud** and **Data Center**, and allows you to create and insert diagrams within your Confluence Cloud environment. Quickly draw flowcharts, wireframes, UML diagrams, mind maps, and more inside our feature-rich editor.

The Data Center version also comes with a free Visio viewer, so you can view Microsoft Visio (.vsd) files, Visio stencils (.vss) and it also supports exporting back to Visio.

**Documentation theme (discontinued)**

Confluence historically provided a theme specifically for documentation. This theme was removed in Confluence 6.0.

A number of the original Documentation theme features, such as headers, footers and the ability to add custom content to the sidebar, are available in Confluence's more modern default theme, which make it a great choice for your documentation space.
Use Confluence as a Knowledge Base

A knowledge base is a repository for how-to and troubleshooting information. Knowledge Bases are commonly used by IT Support teams, but can be useful for procedural and troubleshooting information in any organization or team.

Learn more about how a knowledge base helps your team work smarter

What do people want out of a knowledge base? Using an IT Support team as an example:

- Customers want fast access to a solution, and relevant search results.
- Help desk staff want to be able to create new articles quickly.
- Help Desk team leads want the space to be self curating, and do not want to spend a lot of time manually organizing content.
- Everyone wants a way to be notified when articles they are interested in have been updated or important notices are added.

Create a knowledge base space

⚠️ You'll need the Create Space global permission to do this.

To create your knowledge base space:

1. Choose Spaces > Create space > Knowledge base space
2. Choose Space Tools > Permissions to set permissions for the space, including anonymous access
3. Choose Create > How-to or Troubleshooting and follow the prompts to create your first knowledge base article

The knowledge base space blueprint includes everything you need to get started, including article templates, and a pre-configured homepage with Livesearch and Content By Label macros.

Page labels are essential in knowledge base spaces. These are used to add topics to your articles, and allows your knowledge base to become self-organizing over time.

Users will generally find articles by searching, and using the topic navigation on the homepage and end of each article, rather than navigating through a tree-like page hierarchy.

When starting off your knowledge base space, it's a good idea to brainstorm a few topics to get started.

Customize your knowledge base space

⚠️ You’ll need Space Admin permissions to do this.

To make it easy for your users to create knowledge base articles, such as your help desk or support team, we recommend customizing the how-to and troubleshooting article templates to make them relevant for your organization. The more guidance and structure you can put in your template, the faster it will be for your team to create great articles.

To edit the article templates:

1. Go to Space Admin > Content Tools > Templates.
2. Edit the How-to or Troubleshooting article templates.
3. Add headings and instructional text (choose Template > Instructional Text).

You can also add additional templates, such as a policy or procedure page templates.

We also recommend customizing the look and feel of your space. Simple changes like a space logo and welcome message can make a huge difference.

To change the look and feel:
• Add a space logo and useful shortcuts to the sidebar (choose Space Tools > Configure Sidebar)
• Edit the homepage to add a custom welcome message.
• Edit the color scheme (choose Space Tools > Look and Feel > Color Scheme).

Provide communication and notification options

Channels of communication with your audience, internal or external, are essential in a good knowledge base. Here are some out-of-the-box options:

• **Blog** - blog updates and important notices, and encourage people to watch for new blogs in your space.
• **Watch** - encourage people to watch pages that interest them, or watch the entire space.
• **Comments** - allow logged in users (or even anonymous users) to comment on knowledge base articles. This is a simple way to connect with your end users.
• **RSS** - create an RSS feed and add the link to your knowledge base homepage (choose Help > Feed Builder). Alternatively encourage users to create their own feed - useful if they want to keep up with particular topics (labels), rather than receive notifications for the whole space.

Integrating your knowledge base with other Atlassian products

If your Confluence site is connected to another Atlassian product (via an application link), you can make use of these great integration features:

• **If you use any Jira application** - add a JIRA Issues macro to your troubleshooting article to provide quick access to known issues. This has the added advantage of automatically updating when an issue is resolved or its status changes. One simple way to do this would be to add some labels to Jira to indicate the issue should appear in the knowledge base (for example 'printer-kb'), and then add a Jira Issues macro with a query like 'label = 'printer-kb and status <> resolved'' on all articles with the printer topic.
• **If you use Jira Service Management** - link a Confluence space to be used as a knowledge base. Users (including those without a Confluence license) can search your knowledge base directly from within the customer portal. You can connect Jira Service Management with Confluence 5.10 or later.
• **If you use Questions for Confluence Server** - add a Questions list macro to troubleshooting articles, to highlight the top questions with the same topic as the article, and an Ask a Question button to the knowledge base homepage.

Extending your knowledge base with Marketplace apps

The Atlassian Marketplace has a large number of apps for Confluence. A common addition to Knowledge Base spaces is a survey or form tool, which enables you to get feedback on the usefulness or usability of your knowledge base articles.

Search for 'knowledge base' on Marketplace and see if there is an app that's right for your knowledge base.
Use Confluence as your Intranet

Your intranet is the hub of your organization. When choosing your intranet platform, you need to ensure that the system is simple enough for non-technical users, information and content can be shared easily, and access is restricted to those within your organization.

Confluence has a host of great out-of-the-box features that allow you to share and collaborate with your colleagues, while keeping your information secure. Share things like procedures, specifications and important files – or organize company events and functions – and get your teams working together. It’s one place to share, find, and collaborate to get work done.

Create your community

It’s quick and easy to add users to your Confluence site. Allow people to add themselves as users of the site; invite people to sign up by sending them an invitation link; add new users manually; or use an existing directory – like an LDAP directory – for authentication and to manage users and groups.

Whichever way you choose, you can quickly build a community of Confluence users and give them access to your intranet; you’ll also have a ready-made people directory.

Match your company branding

Upload your company logo, and Confluence’s auto look and feel will change the color scheme to match. It'll make your intranet feel more familiar to your colleagues, and help with adoption.

A space for everything, and everything in its space

A Confluence space is essentially a container for a group of pages and blog posts with related content.

When you’re starting out with Confluence, the easiest way to organize things is to create a space for each team or department within your organization. Each team’s space is then a place for them to create and share pages, blog posts, meeting notes, files, and much more – and becomes the place to go for team members to get the information they need.

Just choose Spaces > Create space from the header, and Confluence provides a list of space blueprints to help get you started.

Each space can have its own color scheme and has a customizable home page, which you can edit to suit your purpose – like displaying and tracking team goals and displaying a list of team members. Use the built-in 'Team Space' template to automatically add all members of the team to the homepage, to help everyone get to know each other.

You can set permissions for each space, so if there’s sensitive information that should only been seen by certain users or groups, it’s easy to secure it with Confluence.
Don’t feel restricted to creating spaces for teams though; you can also create spaces for projects (large or small), events, and anything else where you want to collect information under a common heading or permissions structure.

Once you have some spaces set up, create some pages and blog posts to give your colleagues an example of how Confluence can be used, then invite them to create their own pages and blogs.

**Add a personal space**

Every Confluence user, including you, can also create their own personal space; it can be a place to keep your own work, add shortcuts to your most used content, and you even get your own blog for sharing your ideas and opinions with the rest of your organization (or just those that you want to see them).

**Create pages, meeting notes and more**

You can create pages for anything you want in Confluence - meeting notes, project plans, decisions, and more. Pages are editable so others can contribute and keep them up to date after you create them. Choose Create from the Confluence header and choose a blank page, or use a template to get you started.

Type your page, change its layout, add images and links, and do it all without any specialist skills or training. You can also attach files – allowing everyone in a team access to assets that are critical to the project – like mockups and requirements. You and your colleagues can like the page, and comment on it to start a conversation about the content.

Confluence also offers a series of useful built-in page blueprints, which help you with the content and formatting of the page. The meeting notes and decisions blueprints are two that can be really useful when others need to be in-the-know about what happened, and why it happened.

**Avoid the reply-all and blog about it**

Each space you create in Confluence has its own blog, where you and your teams can share news and events, discuss important projects and developments, or congratulate a teammate for a special effort; blogging is a great way to foster company culture and celebrate achievements across your organization.

You can watch any blog to make sure you get updated when there’s a new post. Blog posts are automatically organized by date, and grouped by year and month, so they’re also easy to find.

**Share stuff that matters**

If you need to be sure that the right people see a page or blog post, Confluence offers a range of ways to make sure you can get their attention. Type the @ symbol and the name of a Confluence user to mention them in a page, blog post, or comment. They’ll get an email notification that you’ve mentioned them, with a link to the page, post or comment.

There’s also a Share button at the top right of every page. Type the name or email address of a user or group and send them a short message with a link to the content you’re sharing.

**Watch and learn**

Don’t miss out on important updates. Watching spaces, pages, and blogs is a great way to stay up-to-date with what’s happening in your own team, or any other team or person you need to keep up with. When you watch something, you’ll get email updates when changes are made or a comment is added.

The Confluence dashboard also has a recent activity feed, which allows you and your team to see what’s trending throughout the company or in your network.
Confluence for Software Teams

Welcome to the Software Team’s guide to using Confluence.

Check out the articles in this collection:

- How to write product requirements
- How to build a release planning page
- Creating insightful customer interview pages
- Create sprint retrospective and demo pages (like a BOSS)
- How to make better decisions as a development team
- How to document releases and share release notes
- Use blogs to share your development team’s progress
- How to create technical and onboarding documentation

Like what you see? Start creating these pages and more in Confluence!

Try it for free