DyNet Plugin for Cytoscape 3.2+

Visualization and Analysis of Dynamic Molecular Interaction Networks

Ivan H. Goenawan\textsuperscript{1,2}, Kenneth Bryan\textsuperscript{2} and David J. Lynn\textsuperscript{2,3,*}

\textsuperscript{1}Department of Medical Biotechnology, Flinders University, Bedford Park, SA 5042, Australia, \textsuperscript{2}South Australian Health and Medical Research Institute (SAHMRI), North Terrace, Adelaide, SA 5000, Australia. \textsuperscript{3}School of Medicine, Flinders University, Bedford Park, SA 5042, Australia.

*To whom correspondence should be addressed.

Contact: David.Lynn@sahmri.com

Abstract

The ability to experimentally determine molecular interactions on an almost proteome-wide scale under different conditions is enabling researchers to move from static to dynamic network analysis, uncovering new insights into how interaction networks are physically rewired in response to different stimuli and in disease. Dynamic interaction data presents a special challenge in network biology. Here, we present DyNet, a Cytoscape application that provides a range of functionalities for the visualization, real-time synchronization, and analysis of large multi-state dynamic molecular interaction networks enabling users to quickly identify and analyze the most ‘rewired’ nodes across many network states.

Availability

The latest version of DyNet can be downloaded from the Cytoscape App Store (http://apps.cytoscape.org/). Source codes along with a digital copy of this user document can be found at this repository (https://bitbucket.org/dynetteam/dynet).
Introduction

DyNet is a Cytoscape plug-in that visualizes differences among multiple networks. It can be used for analysing how networks change over time or across multiple conditions (dynamic networks). DyNet utilizes Cytoscape’s own built-in network data structure, so there is no need for a specialized file format. Users can just import multiple networks separately as they would normally do and quickly use DyNet to highlight and identify differences that are present. In addition, DyNet also introduces a new method to highlight nodes that are most ‘rewired’. It takes into account actual changes in nodes’ connectivity (their connections to each neighbour separately). Therefore this method can identify a node that is more strongly connected to different neighbours in different networks, even if its degree or the sum of its edge weights stays the same.

List of features:

- Import multiple network files at once.
- Live synchronisation of network layouts (can be turned off manually in slower computers).
- Highlight differences between two networks (based on node/edge presence or specific attribute).
- Highlight most varying nodes/edges across multiple networks (based on node/edge presence or specific attribute).
- Highlight most varying nodes in terms of their edge connections (most rewired nodes) across multiple networks.
- Complex filtering criteria (e.g. show edges present in network A and B, but not C or D)
- Create a networks vs edges heatmap, with hierarchical clustering on both axes (cluster edges that evolve similarly across multiple networks and cluster networks that contain similar connections).

Sample Dataset Used in this Document

Sample dataset containing the Epidermal Growth Factor Receptor (EGFR) pathway PPI networks in 6 different tissues is used in this document to showcase DyNet’s different features. These networks were generated by integrating public PPI data for members of the EGFR pathway with protein abundance data from the recently published Human Protein Atlas (Uhlen et al., 2015). The 6 networks were randomly selected from a larger dataset containing PPINs for 47 different tissues. The complete dataset along with further details on how it was prepared are available at this address (https://bitbucket.org/dynetteam/dynet).

Initialization

1. Import multiple networks separately using Cytoscape’s own importing mechanism (Click ‘File -> Import -> Network -> File’), or alternatively use DyNet’s new importing mechanism which allows users to import multiple networks at once (Click ‘Apps -> DyNet Network Importer’). When using Cytoscape’s own importer, make sure that all networks are imported into separate network collections.

2. Make sure that all networks have unique names and that the node/edge attributes that will be compared across networks have the same names in all networks. If they don’t, simply rename the attributes on the Cytoscape Table Panel.

3. Click ‘Apps -> DyNet Analyzer’. A popup initialization dialog will appear:

   ![DyNet Initialization Dialog]

4. Select the networks that will be included in the analysis (using Ctrl+click), the initial layout to use (can be changed later), and whether to treat the networks as directed or undirected networks. If networks are treated as directed networks, then edges that connect the same two nodes but in opposing directions in different networks will be considered as separate edges in subsequent analyses.

5. Click on the ‘Advanced options’ to expand the advanced options panel:

   ![DyNet Advanced Options Panel]

   Two sets of checkboxes will appear. DyNet will use all selected attributes to determine whether nodes/edges in different networks correspond to each other and therefore should be treated as a single node/edge.

   Example:
   - Suppose we have protein networks which contain proteins (as nodes) from different species and we want to consider them separately (we’re not comparing between
species). We can do this by ticking the ‘species’ attribute in addition to ‘name’. Nodes that have different ‘species’ attribute in different networks will subsequently be treated as separate nodes even if they have the same ‘name’ attribute.

- Similarly if we don’t want to compare edges with different ‘interaction’ attributes and just prefer to keep them separate, we can tick ‘interaction’ under the ‘Find corresponding edges by’ section. Edges with a different ‘interaction’ attribute will then be considered as separate edges in subsequent analyses, even if they connect the same two nodes.

Note:

Please make sure that there is only one unique node/edge in each network which has the same combination of values for all attributes that have been selected in the ‘Find corresponding nodes/edges by’ section. For example, if only ‘name’ is selected for nodes, then there cannot be two nodes with identical names in one network. If both ‘name’ and ‘species’ is selected, then two nodes with identical names are permitted, as long as they have different species attribute. Only edges which connect the same two nodes need to be unique. This requirement is needed because DyNet will store a one-to-one mapping of corresponding nodes and edges in the different networks.

6. Click ‘OK’. DyNet will generate a new reference network containing the union of all network states while also keeping the original networks. All networks will be laid out the same way, making it easy to identify corresponding nodes and edges. Furthermore, if the user selects or moves one or multiple nodes in one of the networks (including applying a new layout algorithm), the action will be synchronised to all the other networks. By default, if only 2 networks are being analysed, DyNet will highlight differences between the two networks. Otherwise, if more networks are present, nodes with most varying connectivity will be highlighted. These features will be explained more fully later. DyNet will also automatically add and open a new tab called ‘DyNet’ on the Cytoscape Control Panel on the left side of the screen. This provides the menus for doing further analyses with the app.

7. If the network is large, click ‘View -> Show Graphics Details’ to force Cytoscape to always display all edges and node labels even when the network is zoomed out. This can make analysing large networks easier but Cytoscape might become less responsive, especially on older computers.
Pairwise Network Comparison

This feature allows users to identify differences between two networks. One network will be associated with the colour red and the other one green. Users can choose to compare the presence or absence of nodes and edges, or alternatively a Boolean or numeric node/edge attribute can also be compared. In the central reference network, nodes/edges that have higher values in the red or green network will be coloured accordingly. In addition, if a numeric attribute has been selected, node size and/or edge thickness will be mapped to the log₂-fold-change difference between the two networks. The resulting log₂-fold-change values will be made available as a regular node/edge attribute in the Cytoscape’s node/edge table so users can use them to do further analyses (with other Cytoscape apps, for instance). In the two individual networks, nodes/edges unique to the green network will be coloured green and likewise with nodes/edges unique to the red network. If a numeric attribute has been selected, node size and/or edge thickness will be mapped to the attribute value that each node/edge has.

Notes:

- Since DyNet uses the log₂-fold-change calculation, only attributes containing NON-NEGATIVE numbers can be used (besides Boolean attributes). It does not work with string attributes.
- If a node/edge is not present or is missing a particular attribute value in a network, then it will be assigned the value 0. Therefore, node/edge colour highlighting will only make sense for attributes for which higher value means stronger/better/more significant (farther from absence). Please transform p-values or similar metrics using the negative log or another appropriate method first.
- When mapping log₂-fold-change values in the reference network, nodes/edges with the largest and smallest log₂-fold-change values that are within two Standard Deviation from the mean will be mapped to the largest and smallest node size / edge thickness. Only the magnitudes of the log₂-fold-change values (and not the sign) are considered. Node size ranges from 15 to 45, while edge thickness ranges from 1 to 5 (in Cytoscape unit). Values that are more than two Standard Deviation away from the mean will also be given maximum or minimum size/thickness. Other nodes/edges’ size/thickness will be scaled linearly according to their log₂-fold-change values.
- Numeric attribute values are mapped in a similar manner in the two individual networks. However, the mean and standard deviation is calculated from the union of all values found in both networks. Nodes/edges with the same size/thickness in the two networks thus have the same values.
- There is an option to only highlight nodes/edges common to both networks (in the central reference network) so that users can easily identify only changes in actual node/edge attribute values, not changes in node/edge presence.
Procedures:

1. Select the networks that will be associated with the colour red and green

2. Tick the checkbox ‘Highlight node changes’ or ‘Highlight edge changes’ to turn on pairwise network comparison for nodes or edges.

3. Select the node/edge attribute that will be compared. Choose the attribute ‘present’ to compare only node/edge presence.

4. If we are only interested in comparing differences in attribute values but not node/edge presence and absence, tick the checkbox ‘Only highlight common but attribute-varying nodes/edges’. Nodes and edges that are not present in both networks will no longer be highlighted. Alternatively, use the filter to display only nodes and edges that are present in both networks (described later in the manual).

5. Use DyNet’s filter to display only nodes/edges with the largest fold-changes. The filtering feature will be described later in the manual.

6. Alternatively, we can right-click on a single node and choose ‘Apps -> DyNet Node Analyser’ to quickly analyse a single node. Only the analysed node, its edges, and its direct neighbours will be kept fully visible, while other components will be made transparent. In addition, DyNet will show extra information about the currently analysed node and its edges on the left side of the screen (e.g. the original attribute value in the two networks, the calculated fold-change, etc.). To exit this mode, click the ‘Exit Node Analyzer’ button on the extra information panel on the left.
Variance analysis (based on a node/edge attribute)

This feature allows users to highlight nodes/edges that have the highest variance in a particular attribute across multiple networks. This feature makes it especially easy for users to quickly identify nodes and edges that have undergone the greatest amount of changes when analysing a large number of networks. Since different nodes/edges might have widely varying attribute values, normalization is performed by dividing each value with the average across all networks (for each node/edge separately) before variance is calculated. However, only non-zero values are included in the average calculation.

Example: an edge with weight values of 3.0, 2.0, and 4.0 in three different networks will have its values normalized to 1.0, 0.67, and 1.33 (divided by the mean of 3.0), giving a variance of 0.11. This way, the analysis is not biased towards identifying edges with large average values. Instead, the method will more accurately reflect the degree to which a node/edge’s values across networks deviate from the mean.

Nodes/edges will be coloured with different shades of red according to the magnitude of their variance in the chosen attribute. Results from the variance calculations will also be made available as a regular node/edge attribute in the Cytoscape’s node/edge table so users can use them to do further analyses (with other Cytoscape apps, for instance).

Note:

- This feature only works with NON-NEGATIVE numeric attributes or Boolean attributes. If both positive and negative values are present, the resulting mean can be close to 0. Since we will normalize values by dividing them with the mean, this can result in misleadingly large variance.
- If a node/edge is not present or is missing a particular attribute value in a network, then it will be assigned the value 0. Therefore, node/edge colour highlighting will only make sense for attributes for which higher value means stronger/better/more significant (farther from absence). Please transform p-values or similar metrics using the negative log or another appropriate methods first.
Normalization is performed using the average of only non-zero values. This prevents nodes/edges who are absent or have zero values in many networks from producing a misleadingly large variance (because the average is small).

One of the consequences of the normalisation is that the distance to node/edge absence or node/edge with zero attribute-value is always considered the same. Example: an edge with weight values of 0, 10, and 10 will have the same variance as another edge with weight values of 0, 1000, and 1000, because those three values will be the same when normalized.

Node colour is varied from white (low variance) to red (high variance), while edge colour is varied from grey to red. The nodes/edges with the smallest and largest variance that are within two standard deviation from the mean (across all nodes/edges) will be assigned white/grey and red respectively. Likewise, nodes/edges whose variance values are more than two standard deviation away from the mean will also be assigned either of the two extreme end of the colour range. The colour for the rest of the nodes/edges will be scaled linearly according to their variance value.

Procedures:

1. In the ‘Multiple Network Analysis’ section, select the networks that will be included in the analysis using Ctrl+click.

2. Tick the checkbox ‘Highlight most varying nodes’ or ‘Highlight most varying edges’ to turn on variance analysis for nodes or edges.

3. Select the node/edge attribute that will be used for the analysis (under the ‘Node property’ or the ‘Edge property’ label). For nodes, there is a special attribute called ‘DyNet REWIRING’ which can be used to identify most varying nodes based not on a regular node attribute, but changes in their edge connections. This special mode will be explained in a later section.

4. Use DyNet’s filtering capability to show only nodes/edges with the highest variance. This is especially useful if the networks are very dense. The filtering feature will be explained in a later section.

5. Alternatively, we can right-click on a single node and choose ‘Apps -> DyNet Node Analyser’ to quickly analyse a single node. Only the analysed node, its edges, and its direct neighbours will be kept fully visible, while other components will be made transparent. In addition, DyNet will show extra information about the currently analysed node and its edges on the left side.
of the screen (e.g. individual attribute values in each network, the calculated variance, etc.). To exit this mode, click the ‘Exit node analyser’ button on the information panel on the left.

**Node Rewiring Analysis (Dn-score)**

This feature allows users to highlight nodes with most varying edge connections. It therefore helps users to quickly identify nodes that have undergone the most ‘rewiring’. It is especially useful when analysing a large number of networks. Internally, DyNet represents each node in each network as a vector where each component of the vector represents an edge attribute/weight. It then calculates how much the vector for each node varies across all networks (Dn-score or dynamic neighbourhood score). This method captures actual changes in nodes’ connectivity (their connections to each neighbour separately). It does NOT simply compare node degree or the sum of edge weights. Therefore this method will still successfully identify a node that is more strongly connected to different neighbours in different networks, even if its degree number or the sum of its edge weights stays the same.

Users are able to choose which edge attribute to use as edge weight or alternatively comparison can be done based only on edge absence/presence. Nodes will be coloured with different shades of red according to the magnitude of their variance. Results from the variance calculations will also be made available as a regular node attribute in the Cytoscape’s node table so users can use them to do further analyses (with other Cytoscape apps, for instance).

The Dn-score rewiring metric works by calculating the ‘variance’ of the vectors representing a particular node in different networks. Just as scalar variance provides a measure of spread in one dimension, this metric measures the spread of the vectors in in multi-dimensional space. The resulting formula is identical to the regular variance, except that the mean in this case is the centroid point of the vectors. We calculate 'distance from mean' (the $x - \bar{x}$ in scalar variance) simply by measuring the Euclidean distance from individual vector to the 'mean' (centroid). Normalization is also performed as described in the previous section for regular scalar variance (Variance Analysis). All edge values are first divided by the average (of only non-zero values) across all networks before calculations are performed. The formula (not including the normalisation step) used for calculating the Dn-score of each node is given below:

$$D_{n-score} = \frac{\sum_{i=1}^{n}[distance(V_i, centroid)]^2}{n - 1}$$

where $V_i$ is each vector representing a node in each particular network and $n$ is the number the number of networks being analysed.

Note:
- If edge weights are supplied, the edge attribute chosen as weight has to be NON-NEGATIVE and higher values have to represent stronger/better/more significant (farther from absence)
because absent edges or edges with missing weight will be assigned 0. Please transform p-values or similar metrics using the negative log or another appropriate method first.

- Nodes with higher degrees (in the central reference network) will tend to have higher $D_n$-score (more dimensions can only increase distance to centroid, but not reduce it). Therefore this method will preferentially highlight hub nodes. However, degree-corrected $D_n$-score values are also provided to users as an additional node attribute.
- Node colour is varied from white (low $D_n$-score) to red (high $D_n$-score). The nodes with the smallest and largest scores that are within two standard deviation from the mean (average $D_n$-score across all nodes) will be assigned white and red respectively. Likewise, nodes whose scores are more than two standard deviation away from the mean will also be assigned either of the two extreme end of the colour range. The colour for the rest of the nodes will be scaled linearly according to their score.

Procedures:

1. In the ‘Multiple Network Analysis’ section, select the networks that will be included in the analysis using Ctrl+click.
2. Tick the checkbox ‘Highlight most varying nodes’.
3. Choose ‘DyNet REWIRING’ for node property.
4. Choose the edge attribute that will be used as the edge weight. If weight is not supplied, just choose the attribute ‘present’ to do the analysis based only on edge presence/absence.
5. Use DyNet’s filtering capability to show only the most varying nodes. This is especially useful if the networks are very dense. The filtering feature will be explained in a later section.
6. Alternatively, we can right-click on a single node and choose ‘Apps -> DyNet node analyser’ to quickly analyse a single node. Only the analysed node, its edges, and its direct neighbours will be kept fully visible, while other components will be made transparent. In addition, DyNet will show extra information about the currently analysed node and its edges on the left side of the screen (e.g. individual attribute values in each network, the calculated variance, etc.). To exit this mode, click the ‘Exit node analyzer’ button on the information panel on the left.
Node Rewiring Analysis. The ‘Node Rewiring Analysis’ feature makes it easy to identify nodes that have widely varying connectivity in two or more networks such as the one shown above (the red-coloured hub). In the picture above, node colour is mapped to $D_n$-score (with only 2 networks selected), while edge colour and thickness are mapped to differences in weight values between the two networks. We can see that the node with high $D_n$-score found above is connected to many different neighbours in the two networks being examined. Furthermore, even for neighbours that are present in both networks, the connections are mainly stronger in the ‘heart muscle’ network.
Complex Filtering

The filtering option allows users to filter the networks based on node/edge attributes using complex logic (e.g. show only edges present in network A and B, but not C or D). The filter also provides shortcut methods to filter all networks at once using the same criteria. Nodes/edges that do not meet the filtering criteria will immediately be hidden. This is much quicker than using Cytoscape’s own filtering mechanism (after applying the filter, user still needs to invert the selection then hide the selected nodes/edges).

There are 3 types of filters available (for both nodes and edges):

- Filters that begin with a network’s name such as ‘Node: Network1_present’ or ‘Edge: Network2_weight’ will be applied only to the corresponding network. However, all such filters will also be applied to the central reference network. The central reference network thus plays the role of showing the final filtering result when we use complex filtering logic that spans multiple networks. To illustrate the point, suppose we’re analysing 2 networks called ‘kidney’ and ‘heart muscle’ and the following two filters are active: ‘Node: kidney_tissueExpression’ above 10 and ‘Node: heat muscle_tissueExpression’ under 10. In the ‘kidney’ network, nodes with ‘tissueExpression’ attribute above 10 will be shown. Likewise, nodes with ‘tissueExpression’ attribute below 10 will be shown in the ‘heart muscle’ network. However, in the central reference network, only nodes which satisfy both requirements (tissueExpression above 10 in ‘kidney’ but under 10 in ‘heart muscle’) will be shown.

- Filters that begin with ‘ALL’ such as ‘Node: ALL_Expression’ or ‘Edge: ALL_present’ will filter all networks separately using the same criteria. However, it will only show a node or an edge in the central reference network if the criteria is fulfilled in ALL networks. This is therefore equivalent to setting the same filters manually for each network and joining them with the ‘AND’ operator. A useful case example for this type of filter is to show only nodes or edges that are present in all networks: simply activate the ‘Node: ALL_present’ or the ‘Edge: ALL_present’ filter.
• Filters that begin with ‘EACH’ such as ‘Node: EACH_Expression’ or ‘Edge: EACH_Weight’ will filter all networks separately using the same criteria, similar to the ‘ALL’ filters explained previously. However, unlike the ‘ALL’ filters, nodes and edges only need to satisfy the filtering criteria in one of the networks for it to be shown in the central reference network. This is therefore equivalent to manually setting the same filters for each network and joining them with the ‘OR’ operator. This kind of filter is useful for when we simply want to exclude nodes or edges that do not meet certain criteria, while keeping the central reference network showing the union of all the networks (without the excluded nodes and edges).

Notes:

• Nodes and edges that are currently filtered out (hidden) are still included in the calculations for pairwise network comparison, variance, and rewiring analysis. If, for example, there is an outlier node with extraordinarily high variance that is skewing the colour mapping and we want to exclude it from the analysis, then use the ‘Delete Filtered Components’ button on the filter UI. Nodes and edges that are currently filtered out will be deleted from DyNet and therefore not included in future analyses. The deletion can later be undone using Cytoscape’s menu ‘Edit -> Undo’ which can be triggered with the keyboard shortcut Ctrl+Z (remember to turn off the filter to see them again).

• We can also filter nodes/edges based on the fold-change, variance, or Dn-score values calculated for the Pairwise Network Comparison, Variance Analysis, or Node Rewiring Analysis. This allows us to easily find nodes/edges that are most significantly different or varying. Simply set up a filter using the ‘DyNet Pairwise Comparison’, ‘DyNet Variance’, or ‘DyNet Rewiring (Dn-Score)’ attribute (either for nodes or edges). These attributes will be filled with the results from the latest calculation. If, for example, we change the attribute that is used for Pairwise Network Comparison or Variance Analysis, then results from the new calculations will overwrite the old ones.

• The “^” button on the top line of the filter tree can be used to move the whole tree down one level, making it easy to ‘AND’ or to ‘OR’ all the existing filters with a new clause without having to redo everything again from scratch.
**Heatmap**

This feature allows users to generate heatmaps with edges occupying the y-axis and networks on the x-axis. Furthermore, users will have the ability to cluster heatmaps on both axes, thus allowing them to identify similar edges (edges whose values fluctuate in similar manners across multiple networks) and similar networks (networks whose edge compositions are similar). Users can choose which edge attribute to use in the heatmap. They are also free to choose which networks and which edges to include. The resulting heatmap is interactive. When users select rows in the heatmap, the corresponding edges will also be selected in the network (and vice versa), making it possible for users to identify which edges correspond to which lines on the heatmap. Users can therefore easily check if certain interesting patterns on the heatmap correspond to any particular structure in the network.

**Notes:**

- Boolean and numeric attributes can be used. For Boolean attributes, true and false will be coloured red and white respectively. With numeric attributes, negative values will be coloured green while positive values will be coloured red. The intensity of the colour will be scaled relative to the maximum absolute edge value for edges that are included in the heatmap.
- Edges that are not present or are missing some values in some networks will be given the default value of 0. Therefore, it only makes sense to use an attribute where higher value represents stronger/better/more significant (farther from absence). Please transform p-values or similar metrics using the negative log or another appropriate method first.
- Bottom up hierarchical clustering is used, meaning that at each step the two most similar branches are joined and averaged. Similarities are calculated using cosine similarity.
- For now, the resulting dendograms only show which edge/network are more closely related, but not their relative distances (similar to a cladogram).
- There is an extra option that allows users to cluster edges in the heatmap based not on their values, but based on their actual spatial distances in the central reference network (measured from their mid-points). The resulting heatmap will therefore reflects node positioning on the network (the layout algorithm being used). This is especially useful when a layout algorithm that performs some kind of clustering has been applied. Since edges in a cluster are more likely to be located closer together, they will also be located closer together in the heatmap. Users can therefore easily identify whether or not edges in certain network clusters have any remarkable characteristics.

**Procedures:**

1. Choose which networks to include using Ctrl+click.
2. To exclude some edges, use the filter to hide unwanted edges. The heatmap will only include edges that are visible (not filtered out). Note that clustering can be very slow once the number of edges exceeds a few thousands.
3. Choose the edge property to use.
4. Choose whether to cluster edges based on their values (the default) or based on their spatial proximities in the central reference network (as explained previously).
5. Choose whether or not to cluster the x-axis (the networks) too.
6. Click ‘Generate’. The heatmap will be generated in a new window.
7. The size of the heatmap window and the width of columns in the heatmap can be freely adjusted.

8. Select a row or multiple rows in the heatmap using Ctrl+click to quickly identify which edges they correspond to in the network (they will be selected). Similarly, selecting edges in the network will cause the corresponding rows on the heatmap to be selected.

9. The actual numeric values in the heatmap can be obtained by selecting some rows in the heatmap, copying the values (Ctrl+C), then pasting them somewhere else (Ctrl+V).
Synchronisation Settings

- Synchronisation of network pan/zoom, node location, and node/edge selections can be turned on or off independently for each network. In older computers, it is recommended that synchronisation is turned off if it slows down the program too much.